Sign in to follow this  
ErichB

P3D crashes when trying to save a scenario

Recommended Posts

Unrelated to the new v3.2 install is that I cannot seem to save a scenario any longer.  P3D crashes every time I select the Scenario/Save option.

 

I also cannot load a scenario. On trying to load any scenario P3D asks whether I'm sure I want to exit P3D...

 

I thought these issues might have been eliminated with the latest upgrade, but they haven't been.

 

I've also tried a new p3d.cfg - no difference.

 

Any thoughts?

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Having exact same issues . I can't load a previously saved flight or save a new scenario . I get a CTD . I did have this problem back in 3.0 and found that I had added a folder(containing some AI aircraft) to my simobjects.cfg file and when I deleted it from the simobjects.cfg file my loading and saving scenarios problem was gone . In 3.2 the only thing I have added to the simobjects.cfg was My Traffic and it as worked fine until recently . I too deleted the Prepar3D.cfg and it regenerated another but still unable to save or load Scenarios . I'm at a loss now . Hoping someone will come up with a solution . In the meantime if I find anything that works I'll pass it on .

 

Rich

Share this post


Link to post

Found the problem , at least in my particular case . I remember reading in another forum (can't remember exactly where) possibly at P3D's about some AI aircraft being placed directly into the SimObjects/Airplanes folder causing problems . I decided to look into my simObjects/Airplanes and found I had placed 7 or 8 AI aircraft that came with a couple different sceneries I had loaded so I removed them . I am now able to load previously saved scenarios and save new ones . The P3D SimObjects folder must be pretty picky . I hope this helps .

 

Rich

Share this post


Link to post

Are you using the Migration Tool? I have the same issue but if you Disable the tool then you are able to save.

Share this post


Link to post

Anyone any more info on this problem - tried all suggested and no joy. Using 3.2 - why does this happen with the menus.

Denis B

Share this post


Link to post

I have no problem saving a scenario but when I try to load a scenario it does crash to the desktop.

Share this post


Link to post

Thanks Samaritano - mine dos it on load and save. and the menus in the scenario do different things - press save and it wants to exit etc.

Share this post


Link to post

A friend of mine had a problem with loading or saving scenarios that he figured out after much effort to be an entry in simobjects that P3D apparently did not like.  The simobject was not an aircraft involved in the scenario, but one installed by posky. Hope this helps.

Share this post


Link to post

Well I took your friends advice and tested my airplanes folde by splitting in half and found when one half was loaded - no menu faults. Tested other half an fault occurred with menus. I only have 38 plane folders due to the way I fly in my airplanes folder. After going down list I found the culprit - MD80 by mad dog.

I had purchased this for. FSX a few years ago and after googling thought I would install in p3d as a test- it works and doesn't work but left it installed.

When p3d 3.4 came out - I updated with client and found my Concordex needed upgrade so I followed instructions from FSlabs to update. I found I could not save my scenarios etc because I decided to do new ones for Concordex.

After a couple of days I had vas warnings with 3.4 and decided to go back to 3.2 - still faulty menus but went back ok.

Found yesterday after a lot of searching it could be a plane Installation and Dan has more or less confirmed it.

If I want to fly MD80 I just drop the whole folder in and fly with it - I remove it after to fly with others and no menu errors. I nearly was going to do a complete reinstall Windows etc.

Anyway thanks to anyone that contributed when searching and l would never have believed a plane install would make the errors I had.

All the best

Denis B

  • Upvote 1

Share this post


Link to post

I am having the same issue, cant save or laod flights.

 

If I ever work out what addon aircraft has caused it and I manage to get back to being able to save and load flights I will start keeping an addon install  dairy so I can more easily find the culprit.

 

Thanks to every one for the bits of info hope it helps to find the cause.

Share this post


Link to post

I hate to jump in late but I thought I'd give a bump to this thread. I had the same issue. Turns out a few older POSKY models (in my case the CRJ-900 and The 767-400) were the culprit! Pulled them from my simobjects folder and poof!! issue was gone.

Share this post


Link to post

Can I make a suggestion which I had previously posted in response to a similar topic.

 

If you find a saved flight causes problems when trying to reload it, the place to look for clues is the save config file. This will be in Documents / P3D files.

 

Each saved flight will have 2 files. One is the weather WX file and the other is the save config file. Open the config file in Notepad and compare it with the config file for the P3D default flight. It should have a similar size and content. If it has any additional information then that is something to investigate. 

 

It should end with the line SIMBASE DOCUMENT. Any script after this should not be there and will probably cause a problem. If you find it, try deleting it. This solved the issue for me. In my case it was specific to a particular aircraft. As a guide, after deleting the unwanted entries, all my saved flight configs are around 47Kb, same as default.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this