Sign in to follow this  
Forkboy2

Major blurry issues

Recommended Posts

HiI know blurries have beed discussed a million times here before, but I did a search and couldn't find any post that described my exact problem.I've just given my PC a major upgrade. the past couple of weeks I've been flying GA and everything's been fine. Today I decided to fly a bit further afield, so I took my PMDG 737 for a flight.However, I had some problems. After about 40-50 minutes, every time I switched to spot view all the textures went very blurry - both in flight and at airports - at airports all tectures, AI, airport scenery, ground textures etc go blurry.It seems to happen when the aircraft textures are loading - when I switch to Spot view everything's fine for a second, until the aircraft textures load then everything goes blurry. After that, it seems like FS stops loading textures - so I also end with a half-textured 737 with the wings usually untextured. I have a key assigned to 'refresh scenery', and once this is done, everything goes back to being sharp. If i stay in spot view, evertyhing stays sharp, and within the first few minutes of reloading the textures, it's possible to switch views without blurries. But then the cycle starts again.What's really annoying is that exactly the same setup is fine for flying at 300kts+ through photographic scenery with no blurries!So naturally I'm confused. At the moment I've only had this problem with the PMDG 737, but that's also the only airliner I've flown so far in FS, so it may happen with others. I will try flying others as time allows. So far I've tried to delete my FS9.cfg and allow a new one to be created, but it made no difference. This problem occurs everywhere - even where there is no add-on scenery installed.I'm extremely annoyed that my new setup has these issues - any help would be much appreciated.MikeMy system:AM Athlon64 3000+GeForce 6600GT1GB RAMi don't really know what else I should be putting here!!

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hmmm, well the only blurries I have are with one plane, and it's my own repaint no less! :-lolI have the same video card. Well, it's a 6600GT, anyway, but mine is AGP. If yours is too then it's the same :) I know they offered a PCI-X version also.Have you tried any of the tricks mentioned in the hardware forum, like disabling page files and the like? I don't remember the details, but I think I read somewhere (haha how's that for accuracy?) that with 1GB of RAM or more, disabling the paging file actually increases performance by keeping more in system memory. Heck I'm talking outta my rear end now, as I can't even remember if I read that here or not now. Anyone? Alcott, where are you bro? :)-Jeremy BurchThe Ozark Dogfighter http://forums.avsim.net/images/wedge.gifHappy Flying!Engine Failure: A condition which occurs when all fuel tanks mysteriously become filled with air.Firewall: Section of the aircraft specially designed to let heat and smoke enter the cockpit.Lean Mixture: Nonalcoholic beer

Share this post


Link to post
Share on other sites

Do NOT disable your pagefile. Even with a lot of ram it can still cause many problems. I recently got rid of most of my blurries with this configuration tweak. Make sure you backup any files before modifying. The change I made was posted by Cole (1st reply in the thread)http://www.simforums.com/forums/forum_posts.asp?TID=12229Also, search "blurries" here on Avsim, and you will find lots of helpful threads on the issue.

Share this post


Link to post
Share on other sites

Hithanks for your help.I've tried some of the fixes posted, and it doesn't make much difference. It seems to me that those fixes fix persistent blurries, but the problem I have, as posted above, is intermittent, and seems to be directly associated with loading of aircraft textures.Any more help would still be appreciated!!

Share this post


Link to post
Share on other sites

Last time I had this problem, it was a result of setting Antialiasing on in the nVidia driver rather than using the setting in FS...I set the nVidia to "application controlled" and turned it on in the FS display config, and the blurries went away.Using an AGP 6800 Ultra here.RegardsBob ScottATP IMEL Gulfstream II-III-IV-V L-300Santiago de Chile

Share this post


Link to post
Share on other sites

HiI'm still not sure that people realise quite what issue I'm having - so I took some screenshots to illustrate. After having flown for a while, especially over a reasonably long distance, this happens:In the first picture, I've just switched views, and textures are loading - note how the ones that have loaded are in focushttp://www.geocities.com/pikey_mikey2003/i...s/image2981.jpgNow the aircraft textures start loading, and everything goes very blurryhttp://www.geocities.com/pikey_mikey2003/i...s/image3111.jpgNo amount of zooming, or waiting around, will cause these tectures to focus. This doesn't happen when I first load FS, but only after I've been flying a whileAny suggestions?

Share this post


Link to post
Share on other sites

Blurries......Causes:Textures of AI and other aircraft not the same format, ie;DXT1 or DXT3 or all 32 bit.Frames set too high.... set them back to around 20 to 25. Blurries are caused by a rescource shortage. by lowering the frames you give the sim time to work and the textures will show. In the case of the textures not being the same format, it's trying to load, like, apples and oranges. If they are the compressed type, DXT1 or DXT3 they will load faster and use less resources.I hope this helpsJoe W.http://home.comcast.net/~raptor67/Joe_W/Joe_sig.jpg

Share this post


Link to post
Share on other sites

I've had very similar, most commonly at the bigger airports with lots of AI. Reducing the traffic seems to have cured it.Joe's comments about AI textures not being the same format makes a lot of sense. Most of my AI aircraft are from PAI. I was using GA Traffic for a while, but have stopped due to its resource demands.Alastair

Share this post


Link to post
Share on other sites

For me tha answer has been to change 32-bit textures on my own airplane to DXT3.

Share this post


Link to post
Share on other sites

Check in your system properties that resources are set at "programs" and not "system cache" I had that problem when the settings are at system cache and fixed it once i set it back to programs You find the settings by right cliking my computerthen select:propertiesadvanced Tab Performance Settings Tab AdvancedHope this helps Jamie

Share this post


Link to post
Share on other sites

Looking at the pictures, you definitely are experiencing video memory starvation (as a few others have pointed out). Steve Lacey talks about it in this blog post (read the comments)http://www.steve-lacey.com/blogarchives/20..._blurries.shtmlAs a side note, he also talks about stutters here:http://www.steve-lacey.com/blogarchives/20..._stutters.shtmlIt seems pretty obvious though...You've got a ton of third party add-ons in that scene. All those individual jets? That's a *LOT* of texture my friend. BIG textures too. Lots and lots of vertices as well. Do all those add-ons have LODs? I wonder...Cheers,Jason

Share this post


Link to post
Share on other sites

>However, I had some problems. After about 40-50 minutes, every>time I switched to spot view all the textures went very blurry>- both in flight and at airports - at airports all tectures,>AI, airport scenery, ground textures etc go blurry.>It seems to happen when the aircraft textures are loading ->when I switch to Spot view everything's fine for a second,>until the aircraft textures load then everything goes blurry.>After that, it seems like FS stops loading textures - so I>also end with a half-textured 737 with the wings usually>untextured.Probably I have a workaround for you.The same thing used to happen to me, but with an ATI radeon (not an nVidia) video card.It's caused by some kind of memory management problem by (most likely) FS, leading to both texture and video memory dropping to zero.Do these 2 things:1) Enter BIOS and increase your AGP aperture size to 256MB at least. This does not remove the problem completely, but delays its appearing;2) Download one of those tweaking tools for videocards:http://downloads.guru3d.com/download.php?id=13 I use ATI tray tools, but you can pick one suitable for nVidia cards, then install it.Make sure the tool you use has the option "Reload display drivers", and if possible assign it to a key-combination (one that is not used by FS!).Every time the problem appears while you're flying, do a "Reload display drivers". It frees up again all texture and video memory, and the problem should be gone.Marco

Share this post


Link to post
Share on other sites

>Check in your system properties that resources are set at>"programs" and not "system cache" I had that problem when the>settings are at system cache and fixed it once i set it back>to programs >>You find the settings by right cliking my computer>then select:>properties>advanced Tab >Performance Settings Tab >Advanced>>Hope this helps >>>Jamie I would highly recommend NOT doing this. I seem to remember that there have been many reports by people who have tried this and it completely destroyed their Windows installation to the point where they had to reinstall Windows.Matt

Share this post


Link to post
Share on other sites

>>Check in your system properties that resources are set at>>"programs" and not "system cache" I had that problem when>the>>settings are at system cache and fixed it once i set it back>>to programs >>>>You find the settings by right cliking my computer>>then select:>>properties>>advanced Tab >>Performance Settings Tab >>Advanced>>>>Hope this helps >>>>>>Jamie >>I would highly recommend NOT doing this. I seem to remember>that there have been many reports by people who have tried>this and it completely destroyed their Windows installation to>the point where they had to reinstall Windows.>>Matt>>Matt! For the record, Jamie has it right!! The safest way is to set your system memory usage to programs. When it is set to system cache, it caches your system code and data in memory during operation, this can increase performance of your system, however you run a higher risk that if your system crashes, or you lose power, it may leave the O/S in an unstable state, since data in memory cache never gets written back to disk, and can potentially leave it unbootable.

Share this post


Link to post
Share on other sites

Brad......Open the FS9.cfg and look for the {main} section and paste this in:AVE_FRAME_RATE_DISPLAY=1Start the sim and ALT+Z till you get the frame rate. At the end of that line is a V:xx.x% display, Thats the varation in frames. Play witth the frame rate untill you have a V: of around 1.0 or less. I have mine set to 15 frames and am getting 14.6 to 14.9 frames with a varation of .08 to .03. It really smooth and more important... nothings blurrie anywhere. It's important to get it less than 1.0.Another thing you might do is to convert all the textures of addon sceneries that have been added to either DXT1 or DXT3. This will reduce the resource load on the vid card.I'm running a vVidia 5700le with 128 mgs of ram in a Asus P4 P800se with a gig of ram. and all is smooth.Joe W.http://home.comcast.net/~raptor67/Joe_W/Joe_sig.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this