Sign in to follow this  
joemiller

Bummer: 4K Monitor- Not what I thought

Recommended Posts

Well, last night I purchased a Curved 65 inch Samsung 4K  TV for my simulator. As a TV it's impressive; however, the bad news came for my P3D sim. I have an EVGA 970 card, CPU 6700k.  Setting my card's resolution at the TV's  'Native Resolution' of 3840 x 2160, my fps drops from 29fps to around 12fps.. and the lag is significant.  Why? And this is settings  P3D's inner resolution at around 1920x1080

 

 

In order to get back to a near 25-30 fps and smoothness, I need to lower  the Nvidia 970 card's resolution to around 1920 x 1080. Increasing or decreasing  P3D's resolution makes no difference other than: the higher above 1080x (), will consume more VAS.  So, then I'm disappointed that  I am unable to use it's high resolution for my sim. 

 

What am I doing wrong?  Is it (1) I can only use a low TV resolution set by Nvidia card?

 

                                               (2) or is the problem my card? Maybe I need to get a stronger card?  (if yes, which one?

                                                

                                               (30 Do I need to remove any Anti Aliasing I have set on Nvidia Inspector? (or what setting should I use?)

 

By-the-way, regardless of any resolution I select with my Nvidia card, I only see a 30hz refresh option- nothing higher. (Is this normal or ok?)

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

A 970 is going to struggle at that resolution for a number of reasons. For one things its being forced to push out a lot more pixels to the screen at that res. If you end up getting a new card, I would start at a 1070 and work up from there, depending on your budget

 

Share this post


Link to post
Share on other sites

P3D will only run at the resolution that you set it to if you are running in fullscreen. Running in windowed it will always run at whatever your desktop resolution is set to or the size of the window. As for your lagging, a drop in FPS that extreme usually is a sign of insufficient VRAM. Running antialiasing along with 4K resolution is a very VRAM-intensive combination. What is your VRAM usage when running the sim at 4K?

Share this post


Link to post
Share on other sites

P3D will only run at the resolution that you set it to if you are running in fullscreen. Running in windowed it will always run at whatever your desktop resolution is set to or the size of the window. As for your lagging, a drop in FPS that extreme usually is a sign of insufficient VRAM. Running antialiasing along with 4K resolution is a very VRAM-intensive combination. What is your VRAM usage when running the sim at 4K?

 

Pardon my lack of knowledge. How do I check this VRAM? 

 

And yes, I use PD3 in Full Screen mode; however, due to VAS issues in some areas like California of New York, I'm forced to reduce P3D to 1080 along with removing traffic, and decreasing several settings.   In other less congested scenery, I can max it out to highest resolution.   (VAS is now THE bottleneck for us simmers) 

 

So it looks like with this new monitor, if I want to use the computer/ monitor resolution @ or near 4K resolution, I will very likely need to get an EVGA of maybe...... 1070 (+)

Share this post


Link to post
Share on other sites

I am using a 780Ti with a 4K screen in P3D and almost always have 30 FPS. Of course I had to tune down some settings, but still - it is possible to run older cards in 4K

 

Thomas

Share this post


Link to post
Share on other sites

Display Port cable? HDMI cable can also be a bit of a bottle kneck...

Share this post


Link to post
Share on other sites

What are your AA settings?  After moving to 4K, I was able to reduce, and inmy case, eliminate all AA while retaining good image quality.

 

I have a 3770K with a GTX970 and have no problem maintaining 30 fps in nearly all cases except for extreme weather.

-Rich

Share this post


Link to post
Share on other sites

I have GTX970 in 4K with very good performance.  (FSL A320-X in Aerosoft EGLL at 25 FPS NGX 30 FPS at least)

 

In Overcast AS2016 4 layers  i use my SLI setup. (Still 25-30FPS solution no problemo)

 

Regarding your 4K@30HZ option you should check the manual. HDMI 1.4 or 2.0(a) HDMI1.4 is only 10GB/S while 2.0 is 18GB/s (henze 60HZ possible)

 

Sometimes only a few dedicated HDMI ports on a 4K can run it at 60HZ.

 

I run mostly 1XGTX970 on 4k@25HZ or 30HZ VSYNC ON,UNLIMITED FPS because its very very smooth .

 

Try only 2x MSAA (4xMSAA sometimes work also) but NO SGSS in NI

 

 

Window mode or fullscreen doesnt change anything on my side btw.

 

 

Michael Moe

Share this post


Link to post
Share on other sites

Display Port cable? HDMI cable can also be a bit of a bottle kneck...

 

Yes, I'm connected via an HDMI cable. 

I have GTX970 in 4K with very good performance.  (FSL A320-X in Aerosoft EGLL at 25 FPS NGX 30 FPS at least)

 

In Overcast AS2016 4 layers  i use my SLI setup. (Still 25-30FPS solution no problemo)

 

Regarding your 4K@30HZ option you should check the manual. HDMI 1.4 or 2.0(a) HDMI1.4 is only 10GB/S while 2.0 is 18GB/s (henze 60HZ possible)

 

Sometimes only a few dedicated HDMI ports on a 4K can run it at 60HZ.

 

I run mostly 1XGTX970 on 4k@25HZ or 30HZ VSYNC ON,UNLIMITED FPS because its very very smooth .

 

Try only 2x MSAA (4xMSAA sometimes work also) but NO SGSS in NI

 

 

Window mode or fullscreen doesnt change anything on my side btw.

 

 

Michael Moe

 

Hi Michael.. so the HDMI 2.0 is based off the Monitor itself not the cable, correct? 

Share this post


Link to post
Share on other sites

I have the same monitor as you, Samsung curved 65", and it is a known fact (check Guru3D.com forums) that no current single card can run 4k perfectly at high frame rates. I have a gtx 1080 and have to use 2K for most games. 

 

I am running P3D at 4K and getting about 25 to 35 fps at Pago Pago Gate B1 with 747 in cockpit mode. For games such as GTA5 and Project Cars I have to use 2k.

 

If you want to run P3D at true 1080p again you need to set Nvidia resolution section to 1920x1080. I have to do that for Sony Vegas and HitFlim programs for video work.

 

You  also should have your refresh rates set at 60 in the Nvidia Resolution section and use "RGB" in the color format box with "Full" set in the dynamic output box.

 

Here is a link on how to set up your exact tv as a monitor for games and sims.

https://hardforum.com/threads/2015-samsung-4k-tv-as-a-monitor-set-up-guide.1869675/

Share this post


Link to post
Share on other sites

Yes, I'm connected via an HDMI cable. 

 

Hi Michael.. so the HDMI 2.0 is based off the Monitor itself not the cable, correct? 

Both Monitor and Cable should be 2.0 (18GB/S important)

 

Not all Monitor´s HDMI ports can provide 4K@60HZ(2.0 18GB/S) Sometimes only port 3+4 for instance

 

 

BUT if you choose to run P3D at 4K@30HZ anyway then you should be able to use the older 1.4 cables anyway

 

I just sometimes need 4K for Project CARS at 60HZ so why not just get those 2.0 cables 

 

 

Michael Moe

Share this post


Link to post
Share on other sites

I dont use NV inspector anymore with my 4K TV as its not needed. Also did you update your video driver and also read your TV manual for certain settings that aren't available or noticeable unless you turn different settings things on. Also make a new cfg file and clear your shaders.  I had a 970 card and upgraded to a 10 series card as they are better for 4k.  Josh

Share this post


Link to post
Share on other sites

I have the same monitor as you, Samsung curved 65", and it is a known fact (check Guru3D.com forums) that no current single card can run 4k perfectly at high frame rates. I have a gtx 1080 and have to use 2K for most games. 

 

I am running P3D at 4K and getting about 25 to 35 fps at Pago Pago Gate B1 with 747 in cockpit mode. For games such as GTA5 and Project Cars I have to use 2k.

 

If you want to run P3D at true 1080p again you need to set Nvidia resolution section to 1920x1080. I have to do that for Sony Vegas and HitFlim programs for video work.

 

You  also should have your refresh rates set at 60 in the Nvidia Resolution section and use "RGB" in the color format box with "Full" set in the dynamic output box.

 

Here is a link on how to set up your exact tv as a monitor for games and sims.

https://hardforum.com/threads/2015-samsung-4k-tv-as-a-monitor-set-up-guide.1869675/

 

 

Yep, I had to select RGB to get the 60mhz refresh rate. I also removed all external Anti Aliasing through NI, and reduced P3D's to 2X. It is much , better. I'm now getting around 25fps and the sim is more fluid. And this is using the monitor's native resolution. If I bring the monitor's resolution 2 steps lower from 'native's', the sim looks horrible.

 

And 2  more thing I discovered, I need to use  the sim in windowed mode.. Full Mode will go back to bad performance. I'm yet to try other settings, look into that 2.0 HDMI cable, and of course will likely get a better card, as well.  The other thing I did was to turn off my Anti-virus completely; yes it's risky but that factored in/ in getting improved performance. 

I dont use NV inspector anymore with my 4K TV as its not needed. Also did you update your video driver and also read your TV manual for certain settings that aren't available or noticeable unless you turn different settings things on. Also make a new cfg file and clear your shaders.  I had a 970 card and upgraded to a 10 series card as they are better for 4k.  Josh

 

Hi Josh,  thanks for the input-  Yes I have the latest graphics drivers.  I will also clear the Shaders, haven't done that. 

Share this post


Link to post
Share on other sites

Be sure to follow that guide I linked that shows  you how to setup your exact TV as a game monitor.

Share this post


Link to post
Share on other sites

This is exactly why, despite the fact that it's the current trend, that 2K might be a better monitor choice for many, over 4K

  • Upvote 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this