Jump to content

Sign in to follow this  
captain420

How to stop annoying "black" texture popping in P3D v4?

Recommended Posts

There's a texture command that you can put in the cfg file to fix this, I forgot what it was. Does anyone know? It's really annoying when you pan around to look at something and then pan back to see your textures black and have to reload. What's the cause of this? The 3rd party airports/scenery? Because I would think that going 64bit would fix these issues. I think the 3rd party developers need to update their addon scenery?

  • Upvote 2

ASUS ROG Maximus Hero XII ▪︎ Intel i9-10900K ▪︎ NVIDIA RTX 3090 FE ▪︎ 64GB Corsair Vengeance RGB Pro ▪︎ Windows 10 Pro (20H2) ▪︎ Samsung 970 EVO Pro 1TB NVME SSD (OS Drive) ▪︎ Samsung 860 EVO 2TB SATA SSD ▪︎ Seagate 4TB SATA HDD ▪︎ Corsair RMx 850W PSU

Share this post


Link to post

I think you mean TEXTUREMAXLOAD=30 (the default is around 3 I think)

That sped up my texture loading enormously.

Edit to add: Put it in the [Display] part of the cfg file..

Share this post


Link to post

I don't think we will ever get rid of that until LM fix it.  Once you fly away from an area that scenery is unloaded.  This was made like this on purpose to save on VAS.  Now that VAS isn't an issue LM "should" be able to just leave the scenery loaded in.


--Sean Hart

Share this post


Link to post

My Prepar3D.cfg shows TEXTURE_MAX_LOAD=1024... 


Ed Wilson

Mindstar Aviation
My Playland - I69

Share this post


Link to post
1 minute ago, WarpD said:

My Prepar3D.cfg shows TEXTURE_MAX_LOAD=1024... 

That's something different. That is just how big of a texture size the game can load. 

 

TextureMaxLoad is a different entry, under [DISPLAY], which can be set to 30 to alleviate "black texture" problems. There's also TEXTURE_BANDWIDTH_MULT, which you can set to something like 120. That should significantly decrease the problem.


8700K Delid @ 5GHz | G.Skill 32GB DDR4 @ 3600MHz | MSI 1080 Ti Sea Hawk X | Windows 10 Pro (2004) | Monitors: LG 27UK650 / Acer XB270HU

Share this post


Link to post
3 minutes ago, WarpD said:

My Prepar3D.cfg shows TEXTURE_MAX_LOAD=1024... 

TextureMaxLoad not TEXTURE_MAX_LOAD


--Sean Hart

Share this post


Link to post

I had black AI when I finally got my install done. What I did was install TextureMaxLoad=30 and my problems went away. Try what S_D said.


"I am the Master of the Fist!" -Akuma
 

Share this post


Link to post

texturemaxload=12 could fix it too. 30 is really high and might be a drag on your system.

You can try texture bandwidth multiplayer higher than 30 I changed mine to fsx steam's setting of 160 and that got rid of the slow texture loading and I did not need to add texturemaxload

  • Upvote 1

Share this post


Link to post

Thanks, this seem to have fixed the problem for me! Awesome!


ASUS ROG Maximus Hero XII ▪︎ Intel i9-10900K ▪︎ NVIDIA RTX 3090 FE ▪︎ 64GB Corsair Vengeance RGB Pro ▪︎ Windows 10 Pro (20H2) ▪︎ Samsung 970 EVO Pro 1TB NVME SSD (OS Drive) ▪︎ Samsung 860 EVO 2TB SATA SSD ▪︎ Seagate 4TB SATA HDD ▪︎ Corsair RMx 850W PSU

Share this post


Link to post
49 minutes ago, captain420 said:

Thanks, this seem to have fixed the problem for me! Awesome!

Did you use TEXTURE_BANDWIDTH_MULT or texturemaxload?


Intel Core i7-6700k CPU Overclocked to 4.50GHz - 16GB RAM, Nvidia Geforce GTX980ti 6GB, Windows 10 Home 64-bit

Share this post


Link to post

My Prepar3D.cfg shows TEXTURE_MAX_LOAD=4096 and is in the [GRAPHICS] section of prepar3d v4.1.  Are you saying I should change it to 30?  I don't think so!   lol

Share this post


Link to post
2 hours ago, Mark Niebauer said:

My Prepar3D.cfg shows TEXTURE_MAX_LOAD=4096 and is in the [GRAPHICS] section of prepar3d v4.1.  Are you saying I should change it to 30?  I don't think so!   lol

Really!!

I think you need to read the topic again before jumping to wrong conclusions.

TEXTURE_MAX_LOAD and TextureMaxLoad are two different entries.

A crystal clear version below just for you.

 [DISPLAY]

TextureMaxLoad=xx

[GRAPHICS]

TEXTURE_MAX_LOAD=xxxx

 

  • Upvote 3

David Murden.  MSFS2020 • M20  CJ4WT       DCS  A10CII  AV-8B  F-14A/B  F-16C  F/A-18C 

10900K@4.9 All Cores HT ON  Asus ROG Strix Z490-E  32GB DDR4 CL14 3200MHz RTX 3080  Corsair iCUE H150i Pro XT 360mm 

Corsair HX850i Platinum Plus 2x 1TB Samsung EVO Plus M.2  Phanteks Enthoo Evolo X Case  Thrustmaster Warthog HOTAS & TPR 

TrackIR • Samsung G7 32" 1440p 240Hz • Internet BT 75 Mbps Unlimited 
 

Share this post


Link to post
6 hours ago, Mark Niebauer said:

My Prepar3D.cfg shows TEXTURE_MAX_LOAD=4096 and is in the [GRAPHICS] section of prepar3d v4.1.  Are you saying I should change it to 30?  I don't think so!   lol

Why can't people read the entire topic before berating others and making himself look a fool.


- Dean

P3Dv4 & XP11

space

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    42%
    $10,690.00 of $25,000.00 Donate Now
×
×
  • Create New...