Sign in to follow this  
RancidViper

Heavy stuttering with Chaseplane when panning!

Recommended Posts

So I just bought Chaseplane and installed it. First tried out v4, at first I couldn't pan around, but when I set basic controls it panned but was stuttering heavily.

Fired up v3 and same problem. Downloaded a preset but it's still there. Any help? This doesn't happen without Chaseplane.

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Do you have Pan View in the sim set to the same control?

e.g. Chaseplane pan X and Y and the sim (P3D) controls pan view both set to the same hat on your joystick.

  • Upvote 1

Share this post


Link to post

Unfortunately, Chaseplane's panning view is very juddery in my experience. Both the stock view system and Ezdok is miles better in that regard. Especially when you're in low framerate scenarios, Chaseplane does significantly worse. However, you can turn down the inertia setting, which does seem to improve it a bit. You can also go a bit further and disable the "advanced features", which seems to make the camera work more like the default system. 

You also want to make sure you give Chaseplane access to as many CPU cores as possible, don't lock it into a single core that's also processing the sim. Because Chaseplane's movement can get really bad under a high CPU load environment. 

And as mentioned above, make sure you don't have double-bindings with the sim's default controls. 

But overall, Chaseplane is the least smooth camera option available, in my experience, though the one with the most features, best UI and best support. 

  • Upvote 1

Share this post


Link to post

I use default P3D hat switch pan with Chaseplane, no problems here.

Share this post


Link to post

I removed the default key binding for the hat switch and that improved it a little bit. I was locked at 30fps and bang on so it wasn't really an fps issue, I will try and play around with the settings a bit today. 

I guess I should look at this as an investment since it's still in Alpha, and hope that they sort these issues out soon. They definitely have the right idea, now it's about fine tuning the execution. :)

  • Upvote 1

Share this post


Link to post

Quite a while back I had some stuttering when panning, there is a place in Chaseplane where you can speed it up, and that fixed it for me ( I remember that was when I was locked at 30 also)

Share this post


Link to post

Are you using Windows 10 game mode with Prepar3D V4 ? I suggest you to disable it. 

  • Upvote 1

Share this post


Link to post
1 hour ago, PlaysK said:

Are you using Windows 10 game mode with Prepar3D V4 ? I suggest you to disable it. 

Mate! That was it right there! Thank you so much! Absolutely zero stuttering now. Can't wait to set up my fleet! :)

Share this post


Link to post
2 hours ago, RancidViper said:

Mate! That was it right there! Thank you so much! Absolutely zero stuttering now. Can't wait to set up my fleet! :)

You're welcome. I was in the same situation when setting up P3D V4 and found the culprit.
Windows 10 enables the game mode in P3D v4  even if you have done nothing wrong because it's the same executable (prepar3D.exe) as P3D v3.4 (for which I tried to play with it for my fps). Thanks to Keven Menard for pointing the right solution in a post on the chaseplane forum. :)

  • Upvote 1

Share this post


Link to post

This is a fantastic tip, and thanks for highlighting it.

Share this post


Link to post

Hi I am using P3d V4.3 and now 4.4 with Chaseplane latest experimental version, and using FSUIPC exclusively to assign controllers,  and have the same issue with very juddery panning in the cockpit. Also when it gets to the final position it almost seems to vibrate back and forth a bit before settling down. I am not using game mode. I have the HAT switch assigned in Chaseplane to P0 P90 P180 P270 and do not have any assignments in FSUIPC that overlap as far as I can see. This does not happen during transitions from one preset to another.

I am not sure what "Chaseplane setting to speed things up" mentioned above  refers to, but I did try altering the master controller settings with no benefit.

Maybe this is just a limitation of my rig.

 

Greg

Share this post


Link to post

Sorry for this double post to here and  Chaseplane forum as well. I thought this thread which I googled was in the Chaseplane forum, not P3d. Will await an answer over there.

 

Greg

Share this post


Link to post
On 6/17/2017 at 1:56 AM, PlaysK said:

Are you using Windows 10 game mode with Prepar3D V4 ? I suggest you to disable it. 

 

On 6/17/2017 at 3:17 AM, RancidViper said:

Mate! That was it right there! Thank you so much! Absolutely zero stuttering now. Can't wait to set up my fleet! 🙂

Hello, was this found in the Settings > Gaming > Game Mode page to disable it or somewhere else? I seem to be experiencing the same the issues with P3Dv4.4 and Chasplane when I move my camera around.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this