sparkie66

GPU pegged at 99% p3d 4.1 no matter what

Recommended Posts

Does anyone have some light to shed on this, or has the same?

My gpu 980ti evga OC is pegged at 99% no matter what I do or change. I run 4790k at 4.8 ghz, and 4k res. (this isnt it, when i change to 1080p it still sits at 99%)

FPS as a result fluctuates a great deal, and sim is not smooth. I usually run at 30 hz and it was smooth as butter before 4.1. I dont go crazy with the settings eiter, but changing them doesnt do a thing, still 99% all the time, no fluctuations, just 99%. (Vram is 40% used)

edit: addons: UT live, chaseplane, GSX, FSUIPC 5. NGX and FSLabs A320 (+spotlights)

Aj7phqw.jpg

IUaVwsR.jpg

 

thx,

 

Roland

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

My experience. If you select unlimited as a target frame rate it will use as much of the GPU as possible at all times. I use around 30 FPS and that give the GPU some breathing room with a smoother performance.

Share this post


Link to post

Hi pine,

I tried limit 30 and 20, doesnt change a thing. Still 99%.

Share this post


Link to post

Maybe try lowering lighting and autogen settings? I know Dynamic Lights can be a real performance killer with high AA. Water quality also makes a big difference at airports surrounded by water. 

Share this post


Link to post

Hmmm.... not that this is going to help as it's a mystery to me. I have generally higher settings than you and my GPU rarely hits more than 50% or so. I do have FPS limited to 30, which I know on my system results in a massive reduction in both GPU and CPU workload. I suggest you revisit those settings and see if something 'didn't take' when you tested before.

Share this post


Link to post

Go into task manager and what ever else your running with your Sim e.g. ASv4/ASCA... kick them off core 0 and 1

It will help.

Share this post


Link to post
6 minutes ago, Nyxx said:

Go into task manager and what ever else your running with your Sim e.g. ASv4/ASCA... kick them off core 0 and 1

It will help.

How will kicking addons off core 0 and 1 of Cpu help Gpu load?

Share this post


Link to post

Did no one notice the video card?  980Ti.  Didn't mention how much VRAM, but they're typically 4GB which a bit low for P3D v4.  I'd say it's time for a better video card.  Just my thoughts.

Share this post


Link to post

To Ed's point, check your VRAM usage. If it's maxing out, a couple of judicious setting reductions could bring you below the line, then your FPS limiter might actually free up some GPU cycles.

Before a recent upgrade, I used a 980 (non ti) with P3D v4 in 4K without issues, by keeping a few critical settings in check.

Share this post


Link to post

This may or may not be relevant, but I'm running a GTX 1070 with "Use high resolution terrain textures" selected and I my VRAM usage never gets to 4GB.

Roland, it is not specifically listed, but do you use Active Sky weather with ASCA? If so, one option would be to use lower resolution cloud textures. In ASCA set all cloud quality to 512x512. When I did that, I saw no difference in cloud texture quality.

Share this post


Link to post

Maybe you already tried this but ...

1. Delete the Shaders folder in %localappdata%\Lockheed Martin\Prepar3D v4

2. Delete the prepar3d.cfg in %appdata%\Lockheed Martin\Prepar3D v4

Make backups if you feel the need but both will be rebuilt next time you start P3Dv4.

Share this post


Link to post
1 hour ago, WarpD said:

Did no one notice the video card?  980Ti.  Didn't mention how much VRAM, but they're typically 4GB which a bit low for P3D v4.  I'd say it's time for a better video card.  Just my thoughts.

its a 6 gb card

Share this post


Link to post

Could be a function of AA. Restore/Apply your Nvidia Control Panel profiles might help.

Share this post


Link to post

I did a re install of p3d. Now slowly adding the addons.

I know a 1080ti would be better, but the thing is that from v3.5 onward and also 4.0 was running nicely with 4k and 30hz. I dont mind somewhat low fps, but the stutters were really bad.

I will use some suggestions made her with the new setup. I also changed my main monitor back to a 1080p one and save the 4k for when I get the 1080ti. Locked the fps to 28 and used fftf 0.15. Now the GPU is at 40 - 50 % and frames more stable. (my 1080p monitor doesnt support 30 hz)

edit: I also reverted back to some old nvidia drivers, not sure if that helps. (clean install with DDU). Are there still drivers to avoid?

Share this post


Link to post
2 hours ago, WarpD said:

Did no one notice the video card?  980Ti.  Didn't mention how much VRAM, but they're typically 4GB which a bit low for P3D v4.  I'd say it's time for a better video card.  Just my thoughts.

Guess also "no one" noticed he already sad in the OP vram was at only 40% :biggrin:

 

Also, 980Ti is an awesome card... on par with the 1070s.... Wouldn't use it for 4K, but still not the problem since he already stated he tied other resolutions too...

 

Maybe drivers issue.

  • Upvote 1

Share this post


Link to post
4 hours ago, sparkie66 said:

I also changed my main monitor back to a 1080p one

Something was off in your system configuration Sparkie. I am running a 4k monitor at 30hz on a 3770k with only a 3gb VRAM 780 gtx and my graphics settings are higher than yours. Sounds like you got it sorted with the reinstall of P3D. I also just installed the latest Nvidia drivers 2 days ago and they are working fine for me. Just wanted to let you know that you could probably retry the 4k monitor again after your reinstall of P3D. If you do change video drivers and/or monitor I would also delete both the P3D.cfg and shaders files to let them rebuild fresh as was suggested above.  

Ted

Share this post


Link to post

Thanks Ted, will try.

Im still investigating atm. Gpu usage is now normal (low even) with fps cap in p3d, but it stutters more.

I checked xp11 and that stutters more also. Im thinking maybe a w10 update changed something with their mandatory pushed update system.

Going back to 1080p isnt all that either, when you are used to 4k. Imho 4k is not a problem as long as you have vram enough. With 4k i hardly use aa where at 1080p i have to use 4 to 8x ssaa, which in my mind is near the same as 4k with little (2x msaa) aa.

But i stand to be corrected on that.

Maybe time to get a 1080ti, gi back to win7...or both..sigh.

-roland

Edit: i also removed my OC, didnt get a chance to test that yet.

Share this post


Link to post
On 10/25/2017 at 3:44 AM, PepeBiondi said:

Also, 980Ti is an awesome card... on par with the 1070s.... Wouldn't use it for 4K, but still not the problem since he already stated he tied other resolutions too...

Yes the 980ti has much the same performance as a 1070 and works every well in 4K heck I used to run my old 770 card in 4K (with FSX maybe not P3D)!  My  980ti  GPU usage is typically 30 - 50 % with the usual high end addons more in heavy weather. 

Bruceb

Share this post


Link to post

Last update:

I reflashed bios after random ide boot errors. Not sure if related.

Complete re install of w10 and sim

Put back 4k monitor for use with 30hz / vsync 

Installed 1080ti (1. tbh my 980ti ran nicely, albeit with some lower settings than the 1080ti. Before the problems began that is)

Smooth as butter again with ngx and ut live. (Not with fslabs a320. This one is too demanding and i hangared it) (2. Even DL seems ok now with 2x msaa (all i need in 4k)

Thanks for the help

Edited by sparkie66
additions see 1. and 2.

Share this post


Link to post

Glad to hear you got it sorted and thanks for reporting back for the benefit of others.

Ted

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now