dmarques69

TEXTURE_SIZE_EXP=10 gives me out of memory

Recommended Posts

I was having the slow loading textures/autogen issue in V4 and i thought i would give a try on this tweak, what i noticed was a huge difference, the autogen goes beyond what i can see... magic, however the loading time increases a lot and 50% of the time i get an out of memory in that loading, im talking about a out of memory from windows 10, but i still have at least 5 gb of free ram in 16gb total so i guess this is windows related. TEXTURE_SIZE_EXP=9 reduces loading time, the autogen is still far, but with a good zoom i can see it popping, no out memory with this value.

Any thoughts on this? anyone having this also?

My specs below.

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Is it possible that you're running out of VRAM? I know you have a 1080 Ti wil, 11 GB but I've seen them have their VRAM usage pinned at 100% with that tweak. The new Windows 10 update brought GPU monitoring into task manager so if you have the update, have it open while you are experiencing the OOM and see what the available VRAM is sitting at. HardwareMonitor and MSI Afterburner are good alternatives if you don't have the update.

Share this post


Link to post
21 minutes ago, Milton Waddams said:

Is it possible that you're running out of VRAM? I know you have a 1080 Ti wil, 11 GB but I've seen them have their VRAM usage pinned at 100% with that tweak. The new Windows 10 update brought GPU monitoring into task manager so if you have the update, have it open while you are experiencing the OOM and see what the available VRAM is sitting at. HardwareMonitor and MSI Afterburner are good alternatives if you don't have the update.

 

Thank you Milton, i dont belive is a vram issue, but i have Afterburner installed, going to check that later on!

Share this post


Link to post

As it happens I did a test last evening with this value and max out my settings , VRAM on the 1080ti went to 7.3gb.

Also default weather and max AI

PC similar to yours. 

Share this post


Link to post
5 minutes ago, onebob said:

As it happens I did a test last evening with this value and max out my settings , VRAM on the 1080ti went to 7.3gb.

Also default weather and max AI

PC similar to yours. 

Thank you onebob, i also have pretty much everything max out, i believe is something windows related, and it's RAM that is complaining not VRAM. Nevertheless doenst happen always, it depends on the place im loading, for example EGLC in middle of London is error for sure.

Share this post


Link to post

I have it running with exp=10 and no problems. 

Windows 10, 1080ti and 32 gb RAM. 

Share this post


Link to post
1 minute ago, swiesma said:

I have it running with exp=10 and no problems. 

Windows 10, 1080ti and 32 gb RAM. 

swiesma thank you, but you have double the ram i have ;) if you can do me a favour, load EGLC and tell me what ram its being used i appreciated!!

Share this post


Link to post

Strange you should get an OOM in 64 bit. Have you disabled the windows swapfile or made it really small?

Do you have other programs or addons running which are 32 bit?   Because as you are by now aware each 32 bit program will be run independently and be able to access it's own 4GB address space. If you had P3D running Those could potentially try to allocate more memory than you have remaining.

Also another potential problem is that with some ways of programming ( even in 64 bit) a program could try to allocate a contiguous block of memory -  that means it needs an uninterrupted block of memory that isn't scattered all over. (memory fragmentation) If it can't get the requested block of memory, it will trigger an OOM. Maybe with such a large texture settings it could trigger an OOM?

It would help if you can use the snipping tool and post the exact error that pops up.  Also maybe pull up event viewer and find the error on there and give details from that.

Share this post


Link to post

Thank you Richard and Slayer.

Problem found, i had no pagefile in my system, vram max was 7800 mb around london. But i guess im going to use 9 instead of 10, the load is just to long in 10.

No i have another problem, freezes/stutters with a stable 30 fps that i have to solve ahhhhh not easy this simmer live.

Share this post


Link to post
11 minutes ago, odourboy said:

Interesting indeed. Hardly seems to be worth doing if it results in such extended load times and memory requirements.

I came to the same conclusion after watching those screenshots and reading the article.

Share this post


Link to post

With only a 1070 I have not tried 10, but when flying high above 10,000 to 38000, the difference with 9 from default if truly amazing from what v3 looked like.

With PTA I truly don’t think I need a bigger LOD. Would like to see what 10 looks like from 30000 

Share this post


Link to post

Feeling very frustrated here, the TEXTURE_SIZE_EXP didnt solve my loading autogen problem after all, so i made the one thing i love to do :p full reinstall, out of the box 4.1 no Orbx no nothing craping autogen loading times, autogen almost below my plane whatever settings i put on there, i pause the simulator and it takes a few good seconds to load everything around me. what da hell is this!? Dont know what to do now :(

Share this post


Link to post

Sometimes i ask my self why i dont find another hobby, this one gives me so much troubles... another turn and i think i solved all my issues with 2 simple things, changed the HT, it was off with P3d V3 and V4 and for some weird reason in 4.1 my system prefers HT on now, and i locked the frames to 30, another mistery to add to my list of "why as to be like that now!?" im playing in 4k@30hz and before i had the best results with my frames unlocked and vsync on!??

So my tests until now with TEXTURE_SIZE_EXP at 9 and 10 no slow auto gen and no stutters and fluid like it has to be, the loading time is in average twice the time from 9 to 10, but i only installed FTX global so far, i dont have the strength to install OpenLC today, going to give a kiss to my son and im going to bed dreaming that im falling from a stair stuttering all the way down!!!

 

Share this post


Link to post

16GB is not enough for exp 10. With other programs open. IE chrome or tons of others. 

Share this post


Link to post
16 hours ago, dmarques69 said:

I was having the slow loading textures/autogen issue in V4 and i thought i would give a try on this tweak, what i noticed was a huge difference, the autogen goes beyond what i can see... magic, however the loading time increases a lot and 50% of the time i get an out of memory in that loading, im talking about a out of memory from windows 10, but i still have at least 5 gb of free ram in 16gb total so i guess this is windows related. TEXTURE_SIZE_EXP=9 reduces loading time, the autogen is still far, but with a good zoom i can see it popping, no out memory with this value.

Any thoughts on this? anyone having this also?

My specs below.

That 'tweak' shouldn't do a thing regarding autogen, it increases the resolution of your textures.

Share this post


Link to post

I would suggest you start with no tweaks of any kind, no locked FPS, no HT, no Vsync, certainly no texture size exp stuff.

Also start with rather low to mid settings in P3D and then slowly start increasing your settings one by one giving you a chance to monitor the result and hopefully isolate what is causing your issues.

I don't think it's caused by any add-on but rather a tweak or setting.

Share this post


Link to post

 

4 hours ago, adyfoot said:

That 'tweak' shouldn't do a thing regarding autogen, it increases the resolution of your textures.

In theory thats whats LM states regarding this tweak, but in my system the difference is huge, and from what i read so far, im not the only one.

 

4 hours ago, WebMaximus said:

I would suggest you start with no tweaks of any kind, no locked FPS, no HT, no Vsync, certainly no texture size exp stuff.

Also start with rather low to mid settings in P3D and then slowly start increasing your settings one by one giving you a chance to monitor the result and hopefully isolate what is causing your issues.

I don't think it's caused by any add-on but rather a tweak or setting.

I reinstalled the thing my friend, my first test was as clean as i can get, and as i stated before, the one thing that solved the autogen loading, was locking FPS's at 30, HT on and exp at 9 or 10. why? i have no F****** idea!

Share this post


Link to post
21 hours ago, dmarques69 said:

im talking about a out of memory from windows 10, but i still have at least 5 gb of free ram in 16gb total so i guess this is windows related. TEXTURE_SIZE_EXP=9 reduces loading time, the autogen is still far, but with a good zoom i can see it popping, no out memory with this value.

Any thoughts on this? anyone having this also?

There is a similar post further down about problems with 4k screens and stutters etc, I am not smart enough to link to that however I am firm believer on the VRAM issue after hitting the Vram wall with a GTX980Ti, now, if you play with Texture exp this is what I measured and posted in that response:

~~~~~~~~~~~~~~~~~~~~

To press the point I made earlier I just ran a test 3 times with both exp = 9 and 10 .

On runway 16L at YSSY 1400 hrs in the NGX 737 800 The important thing regardless of my spec is the only thing I changed was EXP 10 back to 9 and I did that test back and forth 3 times.My settings are all maxxed or as close as can be. ( I forgot to mention that I did not disable my 2k screen as that is always running for me whilst running v4 on the 4k monitor)

Started up in the Virtual cockpit stuck my head out and spun around the same way each time:

The result of 3 runs with each

VRAM average EXP10 = 8534MBs

VRAM average EXP 9  = 4579MBs

Try it for yourselves easy enough to monitor in the Afterburner graphs (and log if need be).

~~~~~~~~~~~~~~~~~~~~~

I would also add that in response to this topic I found if I upped the autogen vegetation level from the default 4 to 6 IIRC the memory/ram went from about 12 GBs used to 17.5GBs so as has been said many times before still easy to make even a powerful pc  slow down.

Some people have complained about loading times with EXP=10, certainly is longer but the eye candy and all the 0 & 1s are worth it in my book on my screen.

 

Share this post


Link to post
3 minutes ago, Uteman said:

There is a similar post further down about problems with 4k screens and stutters etc, I am not smart enough to link to that however I am firm believer on the VRAM issue after hitting the Vram wall with a GTX980Ti, now, if you play with Texture exp this is what I measured and posted in that response:

~~~~~~~~~~~~~~~~~~~~

To press the point I made earlier I just ran a test 3 times with both exp = 9 and 10 .

On runway 16L at YSSY 1400 hrs in the NGX 737 800 The important thing regardless of my spec is the only thing I changed was EXP 10 back to 9 and I did that test back and forth 3 times.My settings are all maxxed or as close as can be. ( I forgot to mention that I did not disable my 2k screen as that is always running for me whilst running v4 on the 4k monitor)

Started up in the Virtual cockpit stuck my head out and spun around the same way each time:

The result of 3 runs with each

VRAM average EXP10 = 8534MBs

VRAM average EXP 9  = 4579MBs

Try it for yourselves easy enough to monitor in the Afterburner graphs (and log if need be).

~~~~~~~~~~~~~~~~~~~~~

I would also add that in response to this topic I found if I upped the autogen vegetation level from the default 4 to 6 IIRC the memory/ram went from about 12 GBs used to 17.5GBs so as has been said many times before still easy to make even a powerful pc  slow down.

Some people have complained about loading times with EXP=10, certainly is longer but the eye candy and all the 0 & 1s are worth it in my book on my screen.

 

A few posts below ;)

14 hours ago, dmarques69 said:

Thank you Richard and Slayer.

Problem found, i had no pagefile in my system, vram max was 7800 mb around london. But i guess im going to use 9 instead of 10, the load is just to long in 10.

No i have another problem, freezes/stutters with a stable 30 fps that i have to solve ahhhhh not easy this simmer live.

 

Share this post


Link to post
35 minutes ago, dmarques69 said:

I reinstalled the thing my friend, my first test was as clean as i can get, and as i stated before, the one thing that solved the autogen loading, was locking FPS's at 30, HT on and exp at 9 or 10. why? i have no F****** idea!

Now that is really odd how you would get less stuttering by increasing the workload on your system.

Well, hope you get your issue(s) sorted one way or the other and can spend some time enjoying things soon again rather than troubleshooting.

Share this post


Link to post
9 hours ago, WebMaximus said:

Now that is really odd how you would get less stuttering by increasing the workload on your system.

Well, hope you get your issue(s) sorted one way or the other and can spend some time enjoying things soon again rather than troubleshooting.

I have used that odd thing quite a few times with P3D, FSX also. There have been times when I was having stutters (or skipped frames) and I upped the load a bit (usually something like shadows) and it would smooth out the frames.

Share this post


Link to post

Now that you are using the pagefile I suggest that the stuttering may be a result of swapping out memory to the pagefile. Might need to go up to 32 GB. Just a guess.

Share this post


Link to post
11 hours ago, WebMaximus said:

Now that is really odd how you would get less stuttering by increasing the workload on your system.

Well, hope you get your issue(s) sorted one way or the other and can spend some time enjoying things soon again rather than troubleshooting.

Thank you mate, i think i solved the thing, im installing as we speak, and for each little thing i install i fire the simulator to check if is still smooth. FTX Global, ASCA, REX, OPENLC, some planes and things look ok :)

 

2 hours ago, Slayer said:

Now that you are using the pagefile I suggest that the stuttering may be a result of swapping out memory to the pagefile. Might need to go up to 32 GB. Just a guess.

And that makes sense my friend, swapping can cause stutters, i had it in the past, but it's not the case, since for now things look ok.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now