DModjo

FSX Smoothness Configuration

Recommended Posts

Hi FSXers,

I don't think I've ever posted a topic on the forums here (long time lurker) but I wanted to share a really fantastic combination of settings which I found through trial and error give me some outstanding smoothness/performance in FSX. I'm running the steam edition but I'm guessing this may be beneficial for standard boxed FSX too. Flying into AI filled payware airports with the PMDGs is improved tremendously. Stutter is literally gone.

FSX.CFG:
Add to [Main]:
FIBER_FRAME_TIME_FRACTION=0.01

FSX Settings:
Frame Rate Limit: 30FPS

Nvidia Inspector:
Frame Rate Limiter: 30FPS
Frame Rate Limiter Mode: Limiter V2 Force Off
Maximum Pre-Rendered frames: 5
Preferred Refresh Rate: Highest available
Tripple Buffering: On
Vertical Sync: Half Refresh Rate
Vertical Sync Smooth AFR behaviour: ON
Vertical Sync Tear Control: Adaptive

Note: You must set frame limit to 30FPS inside FSX otherwise you'll get a lot of blurry textures due to the low Fiber Frame Time Fraction tweak. Also this will only work if your monitor is @60Hz (most are).

Give it a go and see if you notice an improvement. I can't guarantee it will work on your system but I'm using an i7 3.4Ghz iMac with absolutely no complaints.

David

 

 

  • Upvote 2

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

There are many configurations based on various computer setups.  I assume the rest of your settings are the same as those in the AVSIM FSX Configuration Guide?  Default?  Those settings are very important too as they affect "the blurries" and performance too.

Best regards,

Jim

Share this post


Link to post
Share on other sites

Is Bufferpools set to 0 and Highmemfix=1 not needed anymore in the fsx.cfg? (for FSX-SE)

Share this post


Link to post
Share on other sites

HighMemFix=1 was "fixed" in FSX-SE.  Still required for the boxed version.  Should never use BufferPools.  Worst tweak on Planet Earth... (IMHO).

Share this post


Link to post
Share on other sites

David, I too am running FSX:SE, but when I go to open the the FSX.CFG file it is FSXSEConfig.exe.  I cannot open it. I get the typical "Do you want to allow this app to make changes to your device?"  I click yes and nothing happens.  I cannot access the FSX:CFG file.  That is the only .cfg I have.  How can I make the change?

Share this post


Link to post
Share on other sites
2 hours ago, Jim Young said:

Should never use BufferPools.  Worst tweak on Planet Earth... (IMHO).

+1

Just caused me loads of problems when I experimented with it. But, as we always say, every PC build and installation is different.

Rupert

Share this post


Link to post
Share on other sites
8 hours ago, DModjo said:

I can't guarantee it will work on your system

True that but glad you've found your FSX sweet spot. However, beyond tweaking fsx.cfg and nVidia Inspector, performance is heavily impacted by cpu/gpu capacity, many other settings within FSX, and the level of scenery and aircraft complexity during any given flight. It's a witch's brew of factors.

At the top of my fsx.cfg file I have well over 100 commented lines noting changes I've made over the past 6 years in search of the holy grail of performance. I'm still not satisfied that I've found it but now I spend way more time just enjoying the sim and way less time fussing with it. 

  • Upvote 1

Share this post


Link to post
Share on other sites

Ok, so here is my situation.  I have FSX:SE on my D:.  I found the FSX.CFG file on the C: in app data and FSX.  I made the change.  Then made the changes in Nvidia Inspector.  Flew a short 35 minute flight and the closer I got to my destination the longer the stutters got.  A couple lasted between 10 -15 seconds.  Thought it was going to crash.  Oh well, just didn't work on my system.  So, I'll be going back to my previous settings.  Appreciate the information though.  

Share this post


Link to post
Share on other sites
6 hours ago, Jim Young said:

 Should never use BufferPools.  Worst tweak on Planet Earth... (IMHO).

I understand this is your opinion but I have been using BufferPools=0 , first on my i7-2700k with GTX 680, and now with a GTX 1070ti and it has been absolutely awesome since about 2011 or 12.

The only tweaks I use for my FSX SE DX10 fixer is FFTF=.10 and BP=0 (as well as inspector settings)

I have never had an issue, always crisp clear and 90% of the time 30fps 

what issues was it causing you if you don’t mind me asking?

 

Share this post


Link to post
Share on other sites
9 minutes ago, ziggy said:

I understand this is your opinion but I have been using BufferPools=0

The ancient tweak used for pre-i7 systems might work but it is known to produce a lot of crashes where the individual will remove the tweak or comment it out so it won't load and crashes gone.  If it works for you, great!  That's what this hobby is all about, enjoying flight simulation and becoming educated in the aspects of flight.  As stated in the AVSIM CTD Guide, it is not recommended.  NickN, a computer guru over at another website does not recommend too since anything above an i7 2600K should run FSX/P3D well.  But, if you decide to throw in a lot of autogen and have high settings, then you will need something to try to make it run smooth.  My i7 7700K OC'd to 4.5GHz and the GTX 1080TI with a 34 inch monitor run FSX and P3D well without tweaks.  I had an i7 2600K when it first came out and it was a game-buster in that it dramatically improved the performance of FSX.  It was like the holy grail of all technology and many members here were touting the massive improvements over the core2 technology!  Me likes i7 technology.  The major problem with most of us is the fact we think putting all sliders to the max is the only way to go and that's not the case with FSX (or P3D).  It's old technology that is mostly GPU dependent (programmed for the GPU) and that's good but it is not taking full advantage of the improvements in technology.

  • Upvote 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now