Mungo Spencer

Seemingly Unfixable Micro Stutters

Recommended Posts

Hi all, 

I've spent the last few days battling with my P3D and consistently failing. For about 4 days now I've been experiencing micro stutters in my sim, I didn't change anything in my sim but they just started randomly occurring. 

I've tried almost everything I could think of which includes deleting scenery.cfg, changing my monitor's refresh rate and so on. It got to the point of re-installing my sim completely yesterday but still, they have come back. Up until now I've had a perfectly running P3D v4 and this issue is driving me up the wall. 

I keep thinking I've fixed it but still everything I try seems to do nothing to this issue. 

If anyone has any advice on what I could try to fix this I would be highly appreciative. 

My specs are as follows: 

ntel Core i7 6700K (4.0GHz overclocked to 4.4GHz),

ASUS MAXIMUS VIII HERO,

16GB HyperX Fury,

NVIDIA GEFORCE GTX1080,

2TB SEAGATE 3.5" SSHD,

480GB KINGSTON V300 2.5" SSD,

128GB SAMSUNG SM951 M.2,

Corsair H100i GTX Hydro Cooler,

CORSAIR 750W CS SERIES.

 

 

 

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Have you tried to backup your Prepar3D.CFG file, delete it from its location, re-start the sim and let it build a new one?. Sometimes this helps.

Good luck.

Cheers, Ed

Share this post


Link to post

Any new program, e.g. virus scanner that's running in the background? 

Share this post


Link to post
43 minutes ago, edpatino said:

Have you tried to backup your Prepar3D.CFG file, delete it from its location, re-start the sim and let it build a new one?. Sometimes this helps.

Good luck.

Cheers, Ed

Yeah I've tried that to no avail unfortunately. 

Share this post


Link to post
37 minutes ago, J35OE said:

Any new program, e.g. virus scanner that's running in the background? 

Nah nothing that I can recall. 

Share this post


Link to post

You don't mention about it, but if you're running W10, make sure there's nothing new with a recent update.

Cheers, Ed

Share this post


Link to post

Maybe check which Nvidia drivers you are currently using. The new 411.70 drivers were released a few days ago, and a few people (but not all) have been reporting some problems in P3Dv4 with them. Win 10 will at times helpfully update your video drivers for you, without you knowing about it.

The people effected reported the problems were solved by rolling back to their previous Nvidia drivers.

Just a thought.

-Bob

 

 

Share this post


Link to post

Have you tried Vsync off and locking FPS at 20?

 

Edited by pracines

Share this post


Link to post
1 hour ago, edpatino said:

You don't mention about it, but if you're running W10, make sure there's nothing new with a recent update.

Cheers, Ed

Hi ed, 

Havent updated my windows for quite some time. 

Share this post


Link to post
23 minutes ago, pracines said:

Have you tried Vsync off and locking FPS at 20?

 

Just tried it, didn't really notice much improvement, thanks for the suggestion though. 

Share this post


Link to post

Are you locking your frames externally, or are you running unlimited frames?

Edited by exeodus

Share this post


Link to post

I have the same issue, especially whilst in lock spot view panning 

just completely jittery 

haven’t installed any new scenery etc

tried everything, except reinstalling  v4.3

i think it may be a win10 update 

that caused the issue.

 

input guys?

thanks

mike

 

Share this post


Link to post

So many suggestions, some may work, some may not. Here is my penny's worth, I suggest rebuilding your cfg file and then add to the [MAIN] section FIBER_FRAME_TIME_FRACTION=0.01. This will provide a smoother flying experience by prioritising framerate in lieu of scenery loading (keep your eye on this) Then I would suggest, you keep all graphics settings in P3D and not use any external app such as Nvidia Inspector. Ensure you set no higher than 4SSAA (could try 8MSAA also) in anti aliasing. Here comes the important thing, if you can lock your monitor's refresh rate to 30Hz then do so, then lock your framerate in P3d to 31 tick Vsync. Try and establish if you have any background programs running as these can affect things a lot. However, in my experience things running in the background have a more obvious effect than micro stutters. I suspect somewhere along the line it is more to do with your P3d settings or cfg. Set road traffic to no higher than 8 and AI traffic no higher than 25. Keep us all informed of your progress.  😉

Share this post


Link to post
Posted (edited)

FSUIPC? If so, turn off autosave

 

 

Edited by andreh
  • Like 1

Share this post


Link to post

I had micro-stutters along with hundreds of others because my FSUIPC was out of date.  Updated to the latest and they were gone.  If that does not fix, I would go along with others and rebuild the p3d.cfg and disable all of the add-on scenery by moving all of the xml's in the Documents/P3DV4 Add-on Folder to a temporary directory.  That would return your P3D configuration to the default.  If it continues, then, you have a hardware problem as there should be absolutely no stutters with the default config with no add-ons.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now