Riah069

Anything under unlimited or 60FPS Stutters

Recommended Posts

I have had this problem for a while and it is starting to become annoying because i do not know how to fix it.

If i run P3D with anything under 60FPS or unlimited it becomes very stuttery. For instance if i set FPS to 59fps it stutters if i leave it at 60 or unliited it is buttery smooth. As this is annoying i would like to cap P3D out at 30-31 fps.

Having VSync or triple buffering on or off does not help.

The monitor i am using is a Acer XB321HK i also have a Acer X34 same results on both monitors 😞

Nvidia driver is 416.34

Appreciate any help

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

17 minutes ago, Riah069 said:

I have had this problem for a while and it is starting to become annoying because i do not know how to fix it.

If i run P3D with anything under 60FPS or unlimited it becomes very stuttery. For instance if i set FPS to 59fps it stutters if i leave it at 60 or unliited it is buttery smooth. As this is annoying i would like to cap P3D out at 30-31 fps.

Having VSync or triple buffering on or off does not help.

The monitor i am using is a Acer XB321HK i also have a Acer X34 same results on both monitors 😞

Nvidia driver is 416.34

Appreciate any help

Go into the Nvidia control panel and create a custom resolution.  Set it for 30hz.  If your monitor will support it.  In P3D options turn on vsync and triple buffering and set frame rate to 33.

  • Like 1

Share this post


Link to post

Hmmm

Tried youre tip and as soon as i switched to 30hz on my monitor i got a very laggy mouse and a stuttery desktop. Upon entering P3D no change if anything a very ghosty panning around in the cockpit 😞

Share this post


Link to post

disable hyperthreading in your bios

Share this post


Link to post

Each system is different, which I'm sure you have heard a mulititude of times, but that is the case. Different settings will create different loads and combined with your AM and other cfg settings, will affect smoothness. However, as Matt suggested earlier, the biggest way of easing stutters is to match your framerate with that of the monitor's refresh rate. If possible, set the monitor's refresh rate to 30Hz and lock framerate in P3D to 30, maybe 31, 32. I have ticked Vsync which also helps. The Vsync will have an impact on fps, but it should help provide a smooth flying experience. EDIT: I've just seen your reply regarding setting your monitor to 30Hz and your experience of no improvement, I suspect, you're overloading the sim elsewhere. Something as simple as overloading your AI setting will cause stutters, regardless of any other settings anywhere else! What you have said so far regarding the refresh rate and Vsync not helping at all, suggests to me that you have incorrect settings in P3d or you have been tweaking the cfg file? Please post your P3d settings. 

Edited by Rockliffe

Share this post


Link to post

Try driver 397.93 but remove actual driver before. 

Share this post


Link to post

My bet: some other apps blocking the main threads of P3D.

I would try an AM of 60 with HT disabled

Share this post


Link to post
2 hours ago, Riah069 said:

Hmmm

Tried youre tip and as soon as i switched to 30hz on my monitor i got a very laggy mouse and a stuttery desktop. Upon entering P3D no change if anything a very ghosty panning around in the cockpit 😞

If u set your monitor to 30hz and u maintain 30 FPS it will be very smooth.  I suspect u have something set incorrectly.  

  • Like 1

Share this post


Link to post
2 hours ago, zwenna said:

Try driver 397.93 but remove actual driver before. 

Voodoo driver magic does not exist.

Share this post


Link to post

Tied all suggestions to no avail. Maybe this is a Win10 issue. I seem to recall before i went to Win10 and was running a GTX970 there was not this problem 😞

Could it be a Display port issue? Maybe running a HDMI cable would work?

Frustrating.

Share this post


Link to post

Some points to check: Windows Game Mode activated (a crook)? Some energy saving things activated?

Share this post


Link to post
On ‎11‎/‎15‎/‎2018 at 1:26 AM, Riah069 said:

If i run P3D with anything under 60FPS or unlimited it becomes very stuttery. For instance if i set FPS to 59fps it stutters if i leave it at 60 or unliited it is buttery smooth. As this is annoying i would like to cap P3D out at 30-31 fps.

Having VSync or triple buffering on or off does not help.

Hi,  You are not alone, I am experiencing the exact same behavior. The problem comes from the refresh rate of our monitor. My solution is to choose P3D settings to be able to stay above 60 FPS, Vsync and Triple Buffering enabled.

Flying above big cities is not a smooth ride.

Mike

Edited by Mikelab6

Share this post


Link to post

I would try limiting FPS via NVidia Inspector to 30 FPS. As long as you can keep 30 FPS you should be good.

In order to not create autogen and/or blurriness set the internal FPS lock to 33 or 35 (YMMV).

Share this post


Link to post

OK so I was looking into this the other day turns out that when P3D is set to unlimited frames it disables fiberframetime. Which is default set to .33 when a frame lock is set.  If you lock your frames and add the FiberFrameTime tweak ie set it to .1 then your stutters should go away

Share this post


Link to post

Set FPS within P3D to 30 and add this to main in your config

[Main]
FIBER_FRAME_TIME_FRACTION=0.01

When you drop below unlimited your making P3D use 

FIBER_FRAME_TIME_FRACTION=0.33

FIBER_FRAME_TIME_FRACTION=0.01 is the same as setting unlimited 

 

It's the only weak I use.

 

Edited by Nyxx

Share this post


Link to post

Strangely, I’ve started experiencing stutters as well which I haven’t had since the FSX days.  I tried everything and settled on locking FPS in sim to 30, forgoing vsync and triple buffering.  Seems to have done the trick for me.  Test after test revealed that the in sim vsync was the culprit on my system.  

 

Something certainly has changed, not sure what it is though.  Really don’t have the time as I used to to test out theories.  But my system has been smooth for a long time up until a month or two ago.  I run Win 7 64 with an I7 6700k @ 4.6GHZ (no HT) 16 Gig ram,  1080ti 11gig vram and a 1080p monitor 144hz.  I can run my monitor at a customized 30HZ but introduces screen tearing/lag if I Pan to fast. Process lasso being run as well.  

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now