JerseySeven

Any fix for flickering after Win10 1809?

Recommended Posts

The "October" update just crapped onto my machine late last week.  P3Dv4.4 was running fine until then.  Since then I've experienced the flickering screen reported by others on this forum.  Setting vsync On and triple buffering in the P3D config helps slightly but does not eliminate it.  I tried rolling back to P3Dv4.3 and the flickering was still present.

At this point I'm seriously considering rolling back to Win10 1803 unless someone here has found a better solution. BTW, my gpu is Geforce 1080ti. I've tried geforce drivers 41616 and 417.35 (latest) and neither one helps.

Thanks folks.  It was in searching this forum that I realized that the problem was related to the windows update. I'd updated all manner of things trying to find a possible cause and was getting frustrated.

 

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

I've had 1809 since October and I never had any problems with flicker.

Try increasing your P3D graphic settings??

Share this post


Link to post
1 hour ago, JerseySeven said:

The "October" update just crapped onto my machine late last week.  P3Dv4.4 was running fine until then.  Since then I've experienced the flickering screen reported by others on this forum.  Setting vsync On and triple buffering in the P3D config helps slightly but does not eliminate it.  I tried rolling back to P3Dv4.3 and the flickering was still present.

At this point I'm seriously considering rolling back to Win10 1803 unless someone here has found a better solution. BTW, my gpu is Geforce 1080ti. I've tried geforce drivers 41616 and 417.35 (latest) and neither one helps.

Thanks folks.  It was in searching this forum that I realized that the problem was related to the windows update. I'd updated all manner of things trying to find a possible cause and was getting frustrated.

 

Have you tired disabling full screen optimization in P3D. Its been mentioned a few times. Fix my flicker problem. By the way, if you have the FSLabs it will uncheck the disabling full screen optimization. They will fix it on the next update.

  • Right-click your P3D.exe
  • Properties / Compatibility 
  • Check: 'Disable Fullscreen Optimizations'
Edited by Wise87
  • Like 1
  • Upvote 1

Share this post


Link to post

@Wise87:  You live up to your user name!  That did the trick.  This never came up on my google search.  Works great.  This is the first time I've ever had to check "Disable Fullscreen Optimizations" for anything.

@pracines:  I'm already running at 2160p with many settings maxed.  What settings specifically did you have in mind?

 

Share this post


Link to post
13 minutes ago, JerseySeven said:

@Wise87:  You live up to your user name!  That did the trick.  This never came up on my google search.  Works great.  This is the first time I've ever had to check "Disable Fullscreen Optimizations" for anything.

@pracines:  I'm already running at 2160p with many settings maxed.  What settings specifically did you have in mind?

 

JS

I can't take credit for the fix. I was having the same issues with the latest version of Windows 10 and searched Avsim and P3D forums and found the fix. Glad it's working for you. 

Dan

Share this post


Link to post
11 hours ago, JerseySeven said:

The "October" update just crapped onto my machine late last week.  P3Dv4.4 was running fine until then.  Since then I've experienced the flickering screen reported by others on this forum.  Setting vsync On and triple buffering in the P3D config helps slightly but does not eliminate it.  I tried rolling back to P3Dv4.3 and the flickering was still present.

At this point I'm seriously considering rolling back to Win10 1803 unless someone here has found a better solution. BTW, my gpu is Geforce 1080ti. I've tried geforce drivers 41616 and 417.35 (latest) and neither one helps.

Thanks folks.  It was in searching this forum that I realized that the problem was related to the windows update. I'd updated all manner of things trying to find a possible cause and was getting frustrated.

 

Damm, the first time ever I could have helped someone and I’m 7 hours too late!! 😂

Had a thread on exactly the same subject a few days ago. Disabling full screen optimisation solved it for me as well.

Regards

Alan

Share this post


Link to post

I had the same issue last week the below fixed it.  If you rename the fslabsconfig Programe it will not change it back 

5 hours ago, Gandalf said:

Damm, the first time ever I could have helped someone and I’m 7 hours too late!! 😂

Had a thread on exactly the same subject a few days ago. Disabling full screen optimisation solved it for me as well.

Regards

Alan

 

Share this post


Link to post

Windows update 1809 break g-synk too...

and it is'nt fixed by disabling full screen optimisation...flickering yes.

Share this post


Link to post
2 hours ago, tooting said:

I had the same issue last week the below fixed it.  If you rename the fslabsconfig Programe it will not change it back 

 

I did not know this. Now maybe I can reinstall the labs again without having to wait for the update. Do you know the exact file name?

Thanks

Edited by Wise87

Share this post


Link to post

Limiting the frame rate to 60 or less is another simpler cure.

Share this post


Link to post

This (disable fullscreen opt.) fixes the flickering but causes other issues. Like one cannot use fixed refreshrates anymore. Things like 1/2 refresh-rate. And like mentioned other functions in the sync section wont work too anymore.

Sadly there is no fix that doesnt have unwanted side-effects, noone seems to care about this enough. There are hundres of posts in forum and everyone accepts the very first answer: "disable fullscreen optimizations or "use vsync". Theres exactly 1 group of ppl who are the ones who probably wont have this problem. The ones without any addons installed and able to fly in over 60 fps vsynced...Or the ones that accept immense microstutters....

Edited by Bytehunter

Share this post


Link to post
3 hours ago, Bytehunter said:

This (disable fullscreen opt.) fixes the flickering but causes other issues. Like one cannot use fixed refreshrates anymore. Things like 1/2 refresh-rate. And like mentioned other functions in the sync section wont work too anymore.

Sadly there is no fix that doesnt have unwanted side-effects, noone seems to care about this enough. There are hundres of posts in forum and everyone accepts the very first answer: "disable fullscreen optimizations or "use vsync". Theres exactly 1 group of ppl who are the ones who probably wont have this problem. The ones without any addons installed and able to fly in over 60 fps vsynced...Or the ones that accept immense microstutters....

I run on a 4K TV and have it set to 30Hz for smooth performance. I run my mine unlimited on the slider for smoothness. No one else that I know that is running disable fullscreen options are having refresh rate issues. 

Share this post


Link to post

I limit my frames in NI to 28, and that eliminated my flickering.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now