GSalden

V4.5 : what has happened to Locked framerate ?

Recommended Posts

It doesn’t matter if all sliders are set to the left and Locked framerate at 10 , core 0 ( main thread ) has  100% load.

Using Unlimited shows a 92%  load with very high settings and 95+  fos, while with Vsync on ( 25 hertz / 2 4K displays in NVSurround with Distortion correction ) load drops to 67%.

As Uimited + Vsync still show some jumping up fps ( 50/100/ back to 25 ) , in V4.4 I also used Locked at 30 to avoid that.

When doing that with V4.5 because of the Locked framerate too there is this 100% load .

Therefore I started to test with my 2 pc’s and found out that with Locked framerate , regardless of the settings , the main core shows a load of 100% which causes micro stutters ..

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

This was the case with V4.4. as well as best I recall.

Share this post


Link to post

With V4.4 I used Uimited + Vsync + Locked at 26. Load 67-95% depending on the scenery .

I use HardwareMonitor for this.

A look ahead buffer should not cause this...

Imho this is a bug but before posting this at the LM forum I wanted to know first how you guys experience this ..

Share this post


Link to post
Posted (edited)
14 minutes ago, GSalden said:

With V4.4 I used Uimited + Vsync + Locked at 26. Load 67-95% depending on the scenery .

I use HardwareMonitor for this.

A look ahead buffer should not cause this...

Imho this is a bug but before posting this at the LM forum I wanted to know first how you guys experience this ..

Hi Gerard. I can confirm this. I´m using the latest P3D Build (4.5 incl. HF), Unlimited, VSync and in NCP set 30hz on my 4K monitor. Locked Framerate at 23, 25, 29, 30 or whatever I set, doesn´t reduce the load on my 8700k OC to 5.1 GhZ. Also switching to VR doesn´t change anything (I did not expect this behavior but thought it might be interesting that VR/no VR doens´t influence anything). 

 

BR Marcus

Edited by mpo910

Share this post


Link to post

Do you use an AM setting (i think i recall you do)?

Remove it, just for a test. Since 4.4 i see an kind of smoother experience without pushing P3D to cores.

Share this post


Link to post

There isn't anything wrong with fully loading the first core from what I understand. Core 0 is mainly just offloading jobs to the other cores and you want it to be fully busy doing that. Microstutters are possibly not because core zero is fully utilized, but that something in the system is interrupting core zero from doing its job  (so therefore use affinity mask). Locking frames shouldn't reduce core zero's purpose of offloading jobs to the other cores. If core zero is not fully loaded, that is actually a bad sign because it means that the CPU is generally under utilised because core 0 can't find jobs to allocate (when it always should). 100% load in task manager doesn't even mean that the core is fully utilized. Only the core temperature tells you what the actual load of the core really is. The only way to overload core zero is if you are using too many cores for it to allocate jobs or there is another setting that is too over zealous like LOD where core zero can't keep up with the job scheduling load any more because there is too much scenery being pushed out from the CPU to the GPU.

I could be wrong but this is my understanding after a long time of reading SteveW.

Best wishes with this. It is complicated and I could be wrong.

Share this post


Link to post

You are correct ; I use an AM. But also without AM this Locked franerate bug is there...

BTW : as I use a 14 core 7940X I oy use the 8 fastest cores for Fs and the others for multiple addons. 

Share this post


Link to post

With the main core continuesly at 100% , also in easy scenery , you will experience stutters when flying over detailed scenery and a large AG has to be loaded ( eg : True Earth series )

  • Like 1

Share this post


Link to post

I am on 4.5, hotfix not yet installed and I never monitor the CPU load. All I can say: I use an AM entry that restricts P3D to the "real" cores only (I have HT active) and .bat files that move all addons off core0 and I do not see microstutters or something like that with a frame limit of 30. As soon as I remove the AM or put "unlimited", I have a stutterfest.

  • Like 1

Share this post


Link to post

There was information about this in another thread a while back.

Something about calculating look ahead frames and keeping it loaded to prevent any throttling which could induce stutters

Share this post


Link to post
Posted (edited)

Did a test with my 9900k , have a saved testflight in P3D V4.5 HF1 . tested only cpu usage same gpu 2080TI same settings in P3D at 4.8ghz 100% at 5.5ghz approx 90% 

9900k is working best for now, have x299 and 2x cpus 7920X 12cores and 7980XE 18cores both do 5.0ghz HToff

Edited by westman
  • Upvote 1

Share this post


Link to post
3 minutes ago, westman said:

Did a test with my 9900k , have a saved testflight in P3D V4.5 HF1 . tested only cpu usage same gpu 2080TI same settings in P3D at 4.8ghz 100% at 5.5ghz approx 90% 

5.5? Congrats, can't get mine beyond 5.1 ATM

Share this post


Link to post
Posted (edited)
7 minutes ago, JoeFackel said:

5.5? Congrats, can't get mine beyond 5.1 ATM

its a binned chip, not from siliconlottery , on AIO cooling 360rad HToff

Edited by westman

Share this post


Link to post
Posted (edited)
2 hours ago, glider1 said:

There isn't anything wrong with fully loading the first core from what I understand.

Have my doubts about that. Don't no about V4.5 or V4.4 but with V4.3  there are a few combinations of refresh rate, VSync and frame rate that peg the CPU at 100% all the time, even with the sim paused. CPU temp is higher and performance (smoothness) is worse than other combinations giving a lower CPU usage and a logical drop in CPU usage when paused. Of course any combination can go to 100% given the right situation but if you are the only plane in a blue sky featureless desert and the sim is still running 100% paused you have to wonder what's going on.

gb.

Edited by gboz

Share this post


Link to post

Steve W is going to test this and will let me know. I will post the conclusion then in this thread...

  • Like 2

Share this post


Link to post

Is this thread about CPU load or locked fps?

Share this post


Link to post
7 minutes ago, GSalden said:

Steve W is going to test this and will let me know. I will post the conclusion then in this thread...

If one can shed light on this subject then its Steve!

Share this post


Link to post
1 hour ago, DJJose said:

Is this thread about CPU load or locked fps?

This is about getting 100% main core load on the cpu when using a Locked Framerate.

Even with all settings to the left + Locked at 10 fps the main thread core has a 100% load 

  • Upvote 1

Share this post


Link to post
7 hours ago, GSalden said:

A look ahead buffer should not cause this...

Why not?  It requires CPU cycles.

Greg

  • Upvote 1

Share this post


Link to post
41 minutes ago, GSalden said:

This is about getting 100% main core load on the cpu when using a Locked Framerate.

Even with all settings to the left + Locked at 10 fps the main thread core has a 100% load 

That's incredible. That can't be good for our OC CPUs.

Share this post


Link to post

Confirmed,

With or without AM setting. 

Process Lasso can't do a thing about it either. With or without PL, same result.

It appears something got broken in the quest for better performance/FPS. 

No doubt, 4.5 w/Hotfix I'm getting about 5-10 more FPS over 4.4 - obviously at a cost. I hope this can be fixed w/o the sacrifice of the extra FPS 4.5 brought me. 

I have all the latest drivers and windows updates installed as of today.

 

Share this post


Link to post

Hmm so far as i am reading your findings makes me wanna stay a little bit more on 4.4. Thanks for sharing your experience. 

I am still on rather old drivers but they do the job in 4.4

Will kill the time in the FSL A320 a bit. 

Michael Moe 

  • Upvote 1

Share this post


Link to post

Same here - as of 4.5 HF CPU 0 is constantly close or at 100%. 

Unlimited frames in P3D but 1/2 adaptive refresh rate and 30 frames set in NVI.

Before, CPU 0 was within a comfortable  65-95% range...

Share this post


Link to post
 
 
1
3 minutes ago, Michael Moe said:

Hmm so far as i am reading your findings makes me wanna stay a little bit more on 4.4. Thanks for sharing your experience. 

I am still on rather old drivers but they do the job in 4.4

Will kill the time in the FSL A320 a bit. 

Michael Moe 

Me to Michael, glad am still on 4.4. At this rate, it will stay like that way. FSL has confirmed the new update will be fine with 4.4. I don't see anything in 4.5 that makes me want to upgrade and if the small increase in FPS is at the cost of core 0 at 100% all the time then....no thanks.

Thanks, guys for finding and sharing this info.

  • Upvote 1

Share this post


Link to post
Posted (edited)
10 hours ago, GSalden said:

It doesn’t matter if all sliders are set to the left and Locked framerate at 10 , core 0 ( main thread ) has  100% load.

Using Unlimited shows a 92%  load with very high settings and 95+  fos, while with Vsync on ( 25 hertz / 2 4K displays in NVSurround with Distortion correction ) load drops to 67%.

As Uimited + Vsync still show some jumping up fps ( 50/100/ back to 25 ) , in V4.4 I also used Locked at 30 to avoid that.

When doing that with V4.5 because of the Locked framerate too there is this 100% load .

Therefore I started to test with my 2 pc’s and found out that with Locked framerate , regardless of the settings , the main core shows a load of 100% which causes micro stutters ..

Please cross post to the P3D forum. At the very least, it gives them a heads up on this potential issue.

Edited by B777ER

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now