Jump to content

heavy1216

Autogen Popping P3D v4.5

Recommended Posts

Can anybody help with my Autogen Popping problem? Here is a video example of what I am experiencing. I am running an Intel i7 8700K at 4.6Ghx, GTX 1080ti, 16GB of RAM. Both Level of Detail Radius and Autogen and Scenery Draw Distance are at Max

 

Share this post


Link to post
29 minutes ago, heavy1216 said:

Can anybody help with my Autogen Popping problem? Here is a video example of what I am experiencing. I am running an Intel i7 8700K at 4.6Ghx, GTX 1080ti, 16GB of RAM.

Same cpu and vidcard that I have.  Now see below:

 

29 minutes ago, heavy1216 said:

Both Level of Detail Radius and Autogen and Scenery Draw Distance are at Max

Likely, those settings are too high for your given location (your popping is what I see when I'm set too high).  I don't run that high except maybe in rural areas.

My typical urban config has AG radius at med, and AG Veg at Dense and AG Buildings at Norm.  It is a give-and-take though -- you may have other settings, like Special Effects sliders or AI, that are eating cpu cycles, preventing you from running the AG settings you want.

Share this post


Link to post

That's one of my favorite enemies. I (and others) have reported it at the Prepar3d forum numerious times, including two video clips in the San Francisoc Bay area I made which are still available there. There have also been a number of threads here at AVSIM on the topic.

It is NOT a performance issue. It starts as soon as you dial Autogen+Scenery slider beyond "Medium". According to my experience, it is independent on any other settings, as low as they may be to help with performance, and I tried a lot of them. I also didn't get rid of it by limiting fps internally or externally, as long as that slider is above "Medium".

After following it from 4.0 until the most recent version, I doubt we will get rid of it over the 4.x run. Maybe in 5.0. Maybe.

Kind regards, Michael

  • Like 2

Share this post


Link to post

I too thought I could crank up those setting after building recently a new rig. Unpleasantly surprised when dialling in "very dense" on those settings, I had fps in the high teens only flying out of major hubs with all the FTX and wx addons...and had to dial it down 😕

 

Share this post


Link to post

Scenery draw distance is the major contributor to this kind of behaviour. Set frames to 30 locked and set scenery draw distance to medium, set the rest of sliders appropriately to the scenery you are flying in and popping is likely to no longer be seen.

Share this post


Link to post
10 minutes ago, Rockliffe said:

Scenery draw distance is the major contributor to this kind of behaviour. Set frames to 30 locked and set scenery draw distance to medium, set the rest of sliders appropriately to the scenery you are flying in and popping is likely to no longer be seen.

Agreed. Unfortunately, the "Medium" setting is just the autogen radius we had in the 3.x series which is quite small and has been citized at that time. Accordingly, it was extended by LM in the 4.X. At the cost of popping beyond that radius.😥

Kind regards, Michael

  • Like 1

Share this post


Link to post

Some resource heavy addons, aircraft & weather in your video, time of day dusk and dawn transition can also add more resource burden (transition textures in-play). Lowering the sliders a  tad in dense city scapes is a good idea even though you have a powerful rig.

Initially thought you had some artifacting on the engine cowl, until I realised it was rain. (no issues there)

Something else to think about, you seem to have quite a lot open on your taskbar, do you normally run your sim with so many open programs, or was it just for this vid capture. One of the heavier resource hitters could be the chrome browser. Only run things you need for simming and of course exclude your Sim folders and files from being scanned by your Antivirus.

Share this post


Link to post
10 hours ago, heavy1216 said:

Can anybody help with my Autogen Popping problem? Here is a video example of what I am experiencing. I am running an Intel i7 8700K at 4.6Ghx, GTX 1080ti, 16GB of RAM. Both Level of Detail Radius and Autogen and Scenery Draw Distance are at Max

What night lighting product are you using? Does this also happen with your autogen building/vegetation during daylight?

Share this post


Link to post

That was my solution, but first:

 

Do you run Nvidia Inspector? Texture filtering in Nvidia Inspector?

Share this post


Link to post
3 hours ago, Jethro said:

Some resource heavy addons, aircraft & weather in your video, time of day dusk and dawn transition can also add more resource burden (transition textures in-play). Lowering the sliders a  tad in dense city scapes is a good idea even though you have a powerful rig.

Initially thought you had some artifacting on the engine cowl, until I realised it was rain. (no issues there)

Something else to think about, you seem to have quite a lot open on your taskbar, do you normally run your sim with so many open programs, or was it just for this vid capture. One of the heavier resource hitters could be the chrome browser. Only run things you need for simming and of course exclude your Sim folders and files from being scanned by your Antivirus.

I'm in the process of moving everything to a Network Configuration so for the moment, everything runs on my main system. 

Share this post


Link to post
1 hour ago, Urmel81 said:

That was my solution, but first:

 

Do you run Nvidia Inspector? Texture filtering in Nvidia Inspector?

 

I don't Nvidia Inspector. Stopped some time ago when people were saying it wasn't needed for v4 

Share this post


Link to post
Posted (edited)
3 hours ago, Flic1 said:

What night lighting product are you using? Does this also happen with your autogen building/vegetation during daylight?

I'm using "unmentionables" for night lighting and I just tested again and the same problem occurred. 

Edited by heavy1216

Share this post


Link to post
Just now, heavy1216 said:

 

I don't Nvidia Inspector. Stopped some time ago when people were saying it wasn't needed for v4 

I had this slow loading / poping Autogen with Nvidia Inspector Texture filtering. I used High Performance but this was the cause of the issue. Qualtiy is for me working best. Had really big issues with High Performance.

Maybe you wan't to try if it works.

Share this post


Link to post
6 minutes ago, Urmel81 said:

I had this slow loading / poping Autogen with Nvidia Inspector Texture filtering. I used High Performance but this was the cause of the issue. Qualtiy is for me working best. Had really big issues with High Performance.

Maybe you wan't to try if it works.

 

I'll give it a try right now

Share this post


Link to post
On 5/20/2019 at 12:04 PM, heavy1216 said:

 

I'll give it a try right now

Did this ever solve your problem? 

Share this post


Link to post

The issue still exists. I really just gave up and accepted it. I installed P3D over again and it still did the same thing with Orbx Lights and the unmentionable lights both tested. Frames locked at 30fps and it's still there.  

Share this post


Link to post

Aa I use AG radius at medium I am able to use both AG sliders ar very dense without poping up issues...

Share this post


Link to post

I have noticed that the people who seem to have "solved" the autogen popping issue have very powerful processors and graphics cards. The people (like me) complaining of the problem have relatively modest systems. Maybe that simply is the answer?

Share this post


Link to post
21 minutes ago, AviatorMan said:

I have noticed that the people who seem to have "solved" the autogen popping issue have very powerful processors and graphics cards. The people (like me) complaining of the problem have relatively modest systems. Maybe that simply is the answer?

No. I've done numerous tests taking all load from the CPU and/or GPU lowering several sliders from LOD to Tesselation, Autogen Bulding density etc. on several machines over time, but the popping is still there. At the end of the day it's exactly as Gerard says:

Autogen slider <= Medium: No Autogen Popping

Autogen slider > Medium: Autogen Popping

Nothing else matters. As far as I can tell, all people claiming they don't see the issue are masking it by using short-range visibility, flying in narrow valleys etc.

Kind regards, Michael

Share this post


Link to post

This certainly has an influence, yes. But also the fact (sorry to say), that many simmers stubbornly stick to FPS numbers and as such use combinations in their settings that further provoke autogen loading in batches. Using "unlimited" inside P3D together with generally high settings overloading the CPU and yet insisting that the sim is otherwise a choppy mess is one of those stubborn attitudes you constantly see here in the forums.

Why am I that strict: because over at the ORBX forums, you find the proof of it. Due to the fact that TrueEarth products are the most demanding addons ever, many people complain about blurries, batchy or no autogen loading, stutters and general performance issues and in more than 90% of the cases those issues are fully or at least partially resolved by using the suggested setup for TE products by ORBX. And guess what? This includes an internal frame limit as most important setting...

Now, of course you will hear instantly those claiming that with a FPS limit of 30, they only get 20-22FPS in some scenarios while they would have more than 30FPS in the same scenario when using "unlimited". Those users you should then ask the question: "why do you think that your computer provides you 20-30% more FPS with one setting vs. the other WITHOUT any trade-off?"

If your computer is capable of "only" 20-22FPS when using a frame limiter of 30 vs. more than 30FPS when using "unlimited", you should not blame P3D for "doing something" wrong but accept that obviously your rig is not capable of generating more than 20-22FPS in such a heavy load scenario. And consequently, a setting that "miracously" provides 20-30% FPS in the same scenario MUST result in drawbacks somewhere else. And yes, blurries and autogen popping IS this "somewhere else".

Means: if you put your sliders and settings as such as your rig is capable of running the sim at acceptable frame rates, you will get rid of most of the performance issues constantly popping up here and in other P3D related forums. And the first step for this is: accept that more or less constant 25-30FPS results in a more fluid and smooth sim experience compared to an average of 35FPS with fluctuations from 20 to 60...

PS: if you do not believe me, you can test this "hypothesis" easily. Put your FPS slider on "unlimited" with your current settings and note the average FPS number. Then lower demanding settings at least two notches and check the FPS number again. Now, put a frame limit that is representative of the lowest FPS number you got in the "test" with low settings. Surprise, surprise: your simulator will now run 99.9% with exactly this FPS number. You will not see any FPS loss anymore, you will not see anymore 20-30% lower FPS in your test scenario. Guess why? Because your FPS limit is set as such that your hardware is capable of reaching this FPS number in 99.9% of the cases.

Now in the ideal world, you should "test" your sim according this approach until you find the "sweetspot", I would call the "sweetspot" those settings that result just exactly in the FPS number your hardware can still maintain. Or, like in my case, the settings that you get your desired FPS number (30 for me) in 80-90% of the scenarios, which is perfectly fine. As I am a fan of high graphic settings, I accept 20-25FPS on huge hubs like EGLL, EHAM, EDDF etc. for the sake of a 30FPS limit that basically totally eliminated blurries, autogen popping and stutters in my case.

Of course, and then my way too long text is over, many additional influences make finding this "sweetspot" pretty hard and cumbersome. In my case, when using my "normal" settings, FPS suffer like hell in overcast conditions (due to the 4xSSAA) and then I should basically dial back my settings a notch. Currently, I just reduce the AA down to 4xMSAA, as this can be done on the fly without interrupting the sim session.

EDIT: Michael is scientifically absolutely right. However, I really hardly ever notice autogen popping, not even when flying in nice weather conditions that allow the sight until the end of the autogen drawing. The heavier the destination scenario, the more likely I still see some autogen popping in the far distance, of course. But then, basically above returns into place, for approaches into heavy scenarios, I might still use settings that are a notch too high for my hardware...

  • Like 2
  • Upvote 1

Share this post


Link to post

@AnkH Interested read. Thanks. It is amazing that with your powerful rig you still need to do some compromises in some situations.

Share this post


Link to post
Posted (edited)
22 minutes ago, AnkH said:

This certainly has an influence, yes. But also the fact (sorry to say), that many simmers stubbornly stick to FPS numbers and as such use combinations in their settings that further provoke autogen loading in batches. Using "unlimited" inside P3D together with generally high settings overloading the CPU and yet insisting that the sim is otherwise a choppy mess is one of those stubborn attitudes you constantly see here in the forums.

Why am I that strict: because over at the ORBX forums, you find the proof of it. Due to the fact that TrueEarth products are the most demanding addons ever, many people complain about blurries, batchy or no autogen loading, stutters and general performance issues and in more than 90% of the cases those issues are fully or at least partially resolved by using the suggested setup for TE products by ORBX. And guess what? This includes an internal frame limit as most important setting...

Now, of course you will hear instantly those claiming that with a FPS limit of 30, they only get 20-22FPS in some scenarios while they would have more than 30FPS in the same scenario when using "unlimited". Those users you should then ask the question: "why do you think that your computer provides you 20-30% more FPS with one setting vs. the other WITHOUT any trade-off?"

If your computer is capable of "only" 20-22FPS when using a frame limiter of 30 vs. more than 30FPS when using "unlimited", you should not blame P3D for "doing something" wrong but accept that obviously your rig is not capable of generating more than 20-22FPS in such a heavy load scenario. And consequently, a setting that "miracously" provides 20-30% FPS in the same scenario MUST result in drawbacks somewhere else. And yes, blurries and autogen popping IS this "somewhere else".

Means: if you put your sliders and settings as such as your rig is capable of running the sim at acceptable frame rates, you will get rid of most of the performance issues constantly popping up here and in other P3D related forums. And the first step for this is: accept that more or less constant 25-30FPS results in a more fluid and smooth sim experience compared to an average of 35FPS with fluctuations from 20 to 60...

PS: if you do not believe me, you can test this "hypothesis" easily. Put your FPS slider on "unlimited" with your current settings and note the average FPS number. Then lower demanding settings at least two notches and check the FPS number again. Now, put a frame limit that is representative of the lowest FPS number you got in the "test" with low settings. Surprise, surprise: your simulator will now run 99.9% with exactly this FPS number. You will not see any FPS loss anymore, you will not see anymore 20-30% lower FPS in your test scenario. Guess why? Because your FPS limit is set as such that your hardware is capable of reaching this FPS number in 99.9% of the cases.

Now in the ideal world, you should "test" your sim according this approach until you find the "sweetspot", I would call the "sweetspot" those settings that result just exactly in the FPS number your hardware can still maintain. Or, like in my case, the settings that you get your desired FPS number (30 for me) in 80-90% of the scenarios, which is perfectly fine. As I am a fan of high graphic settings, I accept 20-25FPS on huge hubs like EGLL, EHAM, EDDF etc. for the sake of a 30FPS limit that basically totally eliminated blurries, autogen popping and stutters in my case.

Of course, and then my way too long text is over, many additional influences make finding this "sweetspot" pretty hard and cumbersome. In my case, when using my "normal" settings, FPS suffer like hell in overcast conditions (due to the 4xSSAA) and then I should basically dial back my settings a notch. Currently, I just reduce the AA down to 4xMSAA, as this can be done on the fly without interrupting the sim session.

EDIT: Michael is scientifically absolutely right. However, I really hardly ever notice autogen popping, not even when flying in nice weather conditions that allow the sight until the end of the autogen drawing. The heavier the destination scenario, the more likely I still see some autogen popping in the far distance, of course. But then, basically above returns into place, for approaches into heavy scenarios, I might still use settings that are a notch too high for my hardware...

Well described, Chris. After having set the FPS limit to unlimited and using a monitor refreshrate of 30 Hz for the last two years, I prefer now the internal limiter with my native monitor refresh rate (60 Hz). For "normal" areas I've set internal FPS @ 30 with high autogen settings. At more demanding scenery I've set FPS @ 22-24 with more moderate settings. This way, autogen popping is barely noticeable. Lowering FFTF to 0.10 or 0.05 helps to achieve my targeted frame rates. The only drawback compared to unlimited fps is that flying curves is a bit more stuttery now.

Edited by Nemo

Share this post


Link to post

I use a 30Hz monitor and fps unlimited, VSync and TB on. The simulator can keep those 30 fps in (nearly) all situations and gives me a very smooth experience.

I have a certain "autogen popping" test situation in the Silicon Valley area where there's a sea of houses to compare and which I know pretty well under several settings. I have tried limiting fps internally to 30fps or lower as well, but it didn't help me against autogen popping either and moreover doesn't provide the same smooth display.

After countless hours of experimenting, I got tired and just set autogen distance to medium.

Kind regards, Michael

  • Like 1
  • Upvote 2

Share this post


Link to post

Has anyone else noticed this problem getting worse in v4.5 compared to previous versions?

Even when using Dynamic FFTF with a setting of 1.0 above 5000 feet I still have issues. Didn't have them in 4.4.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...