Jump to content

Sign in to follow this  
dantaylor

Sudden Drop in Performance - P3Dv4.5

Recommended Posts

Hi everyone,

I'm hoping for some support here, as I'm honestly quite lost right now.

Up until a few days ago, I was flying around without any issues in P3D v4.5, all of my settings being unchanged for months and using all sorts of add-on planes, scenery, weather, shaders, textures, etc. Everything was looking beautiful and I was enjoying it a lot.

Without changing anything in the sim, I suddenly experienced a massive drop in FPS (to < 15) and blurry textures in scenarios that were no problem before. This issue unfortunately still persists, despite my desparate attempts to narrow it down.

This is what I've done since the problem appeared (in the following order and with reboots/tests in between):

  • Disabled VolFog and AA
  • Disabled all add-on scenery
  • Disabled all other add-ons (weather, GSX, SODE, FSUIPC, etc.)
  • Restored P3D's default shaders
  • Restored the default P3D.cfg
  • Removed all user generated files (as per LM's general debugging steps)
  • Reset all NVidiaProfileInspector settings to default
  • Installed a legacy P3D v4.4 client
  • Updated my graphics card driver
  • Installed an older graphics card driver again
  • Disabled my CPU and GPU overclocking

None of this solved my issue or caused even the slightest improvement. The only way I could get back to my old FPS performance was to dramatically reduce scenery complexity, LoD radius and draw distance through the settings (complexity sliders at "sparse" instead of "dense" or even "very dense", the latter of which I used for VFR flying without any issues a few days ago).

So, I decided to completely uninstall P3D and all of my add-ons, as I thought one of my many add-ons might have messed up the sim. Afterwards I set the CPU and GPU overclocking back on.

Today, I started testing with my fresh P3D v4.5 installation which I had downloaded again.

  • P3D default scenario, all settings unchanged = all fine (as expected due to low settings)
  • P3D default scenario, all settings back up to the low range of what I was using before = bad performance again (stuttering, low FPS)

This is with no add-ons enabled and a complete clean installation.

I locked my FPS to 30 via RivaTuner which took some load off the GPU, but the problems are still there, no matter if the GPU is working at 70% or 100%. Currently I am experiencing stutters again with GPU load at approx. 80% and the CPU at approx. 70%. This is flying from KVPS (P3D default) in the default F-22, using settings that would normally be fine for flying an add-on airliner out of Frankfurt with a complex weather scenario. Of course I was used to FPS going down in other cases before too, but not to the current level that really makes the Sim impossible to use, unless I fly virtually without any objects in the scenery.

I tried to rule out a hardware issue. So I performed a test via userbenchmark.com, which resulted in all of my components performing "as expected" or "way above expectations". Not sure if this is enough to rule out any issues here?

Right now, I'm completely lost and don't know what to try next. Any help would be greatly appreciated! Thank you in advance!

Let me know if I should post any further information and I'll gladly do so.

Best regards,
Daniel

tl;dr: My P3D v4.5 has become a complete FPS and stutter desaster out of nothing, even after a clean reinstall, with no changes made to the settings

My system specs:
CPU: Intel Core i5-7600K OC@4.4 GHz
GPU: Nvidia GTX 1060-6GB
SSD: Intel SSD 256GB
HDD: Seagate ST1000 1TB
RAM: G.SKILL Ripjaws 4 DDR4 3000 C15 4x4GB
MBD: Asrock Z270 Pro4
OS: Win 10 Home 64 Bit
Sim: P3D v4.5

Share this post


Link to post

I had the same problem with Aerosoft CRJ (I had 15FPS on ULTRA and LOW settings) and the only thing that fixed it was a full Windows 10 reinstall. It worked for a month and then I got the same problem. V5 runs perfectly fine!


I7-10700 (4.8 GHz with HT enabled)

2x8 DDR4 

Gigabyte RTX 2070 Super OC Gaming

Share this post


Link to post
On 5/7/2020 at 5:04 PM, Branimir said:

I had the same problem with Aerosoft CRJ (I had 15FPS on ULTRA and LOW settings) and the only thing that fixed it was a full Windows 10 reinstall. It worked for a month and then I got the same problem. V5 runs perfectly fine!

Ok, thanks. I'll go for a full reinstall now too. :-(

Share this post


Link to post
4 hours ago, dantaylor said:

Ok, thanks. I'll go for a full reinstall now too. 😞

On one person's experience for a low frame rate you're now going to reinstall your entire OS? Good Lord....

 

  • Like 3

Eric 

 

 

Share this post


Link to post
5 hours ago, dantaylor said:

Ok, thanks. I'll go for a full reinstall now too. 😞

What a painful thing to have to do....

Really (with the exception of the xml addon methon) the configuration of P3D is much the same as FSX.

And the first thing I do for troubleshooting FSX is to rename the config folders, that way new clean default configs are auto created at next start.

Note I said rename the folders, not delete, there is no point to removing the time already spent in setup if it can be easily saved.

If all is good then it's just a process of elimination to track down the problem.

  • C:\ProgramData\Lockheed Martin\Prepar3D v4
  • C:\Users\<account_name>\AppData\Local\Lockheed Martin\Prepar3D v4
  • C:\Users\<account_name>\AppData\Roaming\Lockheed Martin\Prepar3D v4
  • C:\Users\<account_name>\Documents\Prepar3D v4 Files
  • C:\Users\<account_name>\Documents\Prepar3D v4 Add-ons

P3D also has it's separate installers, e.g. need to re-install the cilent or just to test the latest version bump it's easy to uninstall the client (keeping P3D activated) and reinstall/rollback.

Windows 10 also has its own oddities.

https://devblogs.microsoft.com/directx/demystifying-full-screen-optimizations/

https://winaero.com/blog/disable-fullscreen-optimizations-windows-10/

Let's not forget outside of the sphere, like AV scanning or automatated backups - confirm your P3D antimalware exceptions and check the backup processes.

Lastly check how clean everything is, lots of dust means lack of cooling and potential throttling, I've even saw an instance where the fan has stopped.

  • Upvote 2

Ryzen 2700X clocked to 4.2 Ghz, 32 GB ram, Samsung 1 x 1 TB NVMe 970 and 2 x 1 TB SSD 850 Pro raided, Nvida 1070 Ti clocked to 2 Ghz

P3D 4.5.14, Orbx Global, Vector and more, lotsa planes too.

Catch my vids on Oz Sim Pilot, catch my screen pics @ Screenshots and Artwork

Share this post


Link to post

If P3D with all settings on default works fine and with your settings it doesn't, well, try to change settings one by one and see where the issue starts. This could give you some clues what might be wrong.

But if you have issues even with vanilla P3D (assuming you really did a clean install of P3D) then my bet would be on something else, like Windows 10, AV, hardware,.. don't get fixated on P3D, especially if you didn't do anything in P3D before this issue appeared.

Share this post


Link to post

Been having similar issues.  I almost exclusively use XP11 now and have for some time, but decided to fire up Prepar3d V4.5 H3 as I missed the good addons.  The performance is terrible all of the sudden.  I get huge lag spikes regardless of the aircraft I use.  My FPS will fluctuate between 50 and 20fps and makes the sim unflyable, and I've already reinstalled P3D and all addons


Mark Javornik

Share this post


Link to post

Hi guys,

Thanks for your replies!

I did a quick OS reinstall, not too much of an issue here, because I only use the PC for P3D and there is not much else on it. Then I installed P3D again, which was a 100% guaranteed clean version this time, after having formatted my drives beforehand. 😎

To rule out any hardware/temperature issues, I did some more benchmarking and took care of my overclocking settings. Now the PC was running faster than ever with a fresh OS installation and overclocking optimized. But to my horror, P3D was still performing awfully! The only way to get reasonable performance was by using very low settings.

Thanks to @Rogen's tip, I turned off fullscreen optimizations and all of a sudden, I could actually use P3D with decent settings again. The regular pattern of stutters and graphical FPS "spikes" (monitoring via RivaTuner) I was seeing, had disappeared. So now I will carefully reintroduce my add-ons one by one and hope everything stays as it is! My preliminary testing in P3D's default scenery world worked fine, even on ultra-high settings in areas like New York City.

I'll report back once the add-ons are back in the sim. Fingers crossed, the issue should be solved now.

Best regards,
Daniel

 

Share this post


Link to post
Posted (edited)

I'll try to turn off fullscreen optimizations and report back as well

Edited by markjj
shortened

Mark Javornik

Share this post


Link to post

Issue is still there even with disabling fullscreen optimization.  Interestingly, the FPS is stable so long as I don't move or pan the view.  Once I start rolling on the runway or moving the view around, the stuttering comes back

  • Upvote 1

Mark Javornik

Share this post


Link to post

Did you do a Windows update, or HF3 for P3Dv4.5? Obviously something changed. It can’t just go from fine to awful for absolutely no reason. 

Share this post


Link to post

There are many reasons for stuttering, mostly because the frame rate is either too low or there is an undesired level of fluctuation.

Items that can cause are,

  • Running out of vram (DX11 - maybe not so for DX12).
  • Maxing out the GPU.
  • Maxing out the CPU.
  • Running intensive and complex aircraft or addins that tend to keep the FPS lower.

General advice is to monitor the CPU/GPU usage while on a reproducable test flight and let the monitoring guide the settings.

For myself a 30 Hz capable monitor and running P3D @ unlimited with vsync enabled has resulted in the best tuning opportunites for highest detail and smoothest running.

From monitoring I now have built a number of custom Display/Profile configurations selectable from the P3D Display Global Settings options where I select the one most suitable for the type of flying I'm performing.

You might find the below links of use.

 

And here is a vid of Riva Tuner Statistics Server in action, note the frame rate counter on the RH bottom.

And here is my highly tuned P3D v 4.5 instance where I've tuned for the maximum detail use in combo for smoothest running. Tuning is not only the sliders, it also includes P3D config file and GFX drivers and GFX card as well as CPU (e.g. overclocking GPU and CPU). For the most part the sliders tend to affect GPU use apart from Scenery Complexity, Autogen Draw Distance and AI.

As usual what I use for settings may not be applicable for others, but the general idea of tuning does still apply.

 


Ryzen 2700X clocked to 4.2 Ghz, 32 GB ram, Samsung 1 x 1 TB NVMe 970 and 2 x 1 TB SSD 850 Pro raided, Nvida 1070 Ti clocked to 2 Ghz

P3D 4.5.14, Orbx Global, Vector and more, lotsa planes too.

Catch my vids on Oz Sim Pilot, catch my screen pics @ Screenshots and Artwork

Share this post


Link to post

The same question. I have reinstalled win10 and p3dv4 HF3, but the problem still exists. PMDG often dropped from 40 FPs to 2 FPS, lasting for several seconds or more. I haven't found a solution yet.

Share this post


Link to post
Posted (edited)
54 minutes ago, ljk811 said:

The same question. I have reinstalled win10 and p3dv4 HF3, but the problem still exists. PMDG often dropped from 40 FPs to 2 FPS, lasting for several seconds or more. I haven't found a solution yet.

Possible hardware dying??

 

mike

Edited by mikeymike

Share this post


Link to post
1 hour ago, mikeymike said:

Possible hardware dying??

 

mike

This should not be the reason. My hardware is 9900k + 2080ti, and the hard disk is m2 ssd, a computer that was assembled last year. It ’s been okay before, I guess it ’s getting too hot recently, and I ’m going to buy an air conditioner in my room to lower the temperature of my computer.XD

  • Like 1

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    28%
    $7,145.00 of $25,000.00 Donate Now
×
×
  • Create New...