Jump to content

Sign in to follow this  
MarkW

Decreasing FPS

Recommended Posts

Posted (edited)

@simbol

@Kaiii3

I ran the test for 35 Minutes now:

4K 32" monitor no VR of course unlimited frames vsync off

Date today 12:00 o´clock ASP3D on weather clear and stable.

EGLL

F22 at gate 300

EA=on

Airplane Traffic sliders 100%

Facing 270 (away from london city)

Located my viewpoint outside the plane at the beginning of the airport at the eastside right in between the two runways view all over the airport at about 300 feet high

Started with 23-24 FPS without dips below 21 decreased after 35 mintues to 20-22 FPS with dips below 18 fps(minimal decrease after 35minutes). Not one single frame at 24 anymore.

Strange is, the FPS counter is slowing down the FPS refresh frequency (like from 3 times a second to 2 times a second. 

It is still running. I will monitor if it is going below 20tis

EDIT AFTER 1 hour:

FPS went a little up again to 22-23 fps. So seems normal to me for 1 hour running with full traffic. Airport is fully loaded (Aerosoft EGLL) with planes. 

@simbol @Kaiii3

BUT: Turning off all traffic sliders to 0% my fps goes up to 55-60FPS!

So AIGAIM has a huge impact on FPS with 100% usage.

Here some numbers after playing with both sliders:

  • 0% = 55-60 FPS
  • 25% = 37-38 FPS
  • 50% = 26-28 FPS
  • 75% = 23-24 FPS
  • 100% = 20-21 FPS

Another thing I noticed: Setting all traffic sliders from 100% to 0% does following:

FPS goes directly up from 20 to 35-38FPS and it takes about 20 to 30 seconds to further increase from 35-38 to 55-65 FPS

Marcus

System specs

Prepar3D_v5_Academic_5.0.31.35253

Edition Windows 10 Home
Version 2004
Installed on 20200501
OS Build 19041.329
Experience Windows Feature Experience Pack 120.2202.130.0

Latest Nvidia Drivers

i9 10900K @ 5.1 Ghz | HT ON | 1.32V | AffinityMask=88061
Mainboard ASUS ROG Maximus XII Formula Z490
32 GB RAM 3600 Mhz Corsair Vengeance | 4x8GB
RTX Titan 24GB
32" Samsung UHD Monitor using 4k
Custom Water Cooling | 2x 360MM | 1x 240MM Radiator
HP Reverb v2 VR HMD | Steam VR

Main Addons

ASP3D | 7479 Open Beta
ChasePlane | Via ORBX
FSReborn Prof.
GSX 2
FSUIPC6
AIGAIM
SODE | Latest Version
MultiCrewExperience | Latest Version
Airbus A330 | Latest Version
PMDG 747/748 | Latest Version
QW787 | Latest Version
Navigraph Charts
ORBX Base
ORBX LC
ORBX TE NL
ORBX Regions
ORBX HD Buildings
ORBX HD Trees V1 & V2
REALTURB | All Continents
+200 Addon Aiports | via .xml method added
 

 

Edited by mpo910
  • Like 1

Share this post


Link to post
Posted (edited)

Not sure whether these are all the same issue with varying symptoms, or different issues.

My experience, which I've shared in the thread that @MarkW started on this subject a week or so ago, is that over time, my displayed framerate becomes more unstable and the practical implication is stutters, but nothing like what @MarkW described.  This occurs whether I am displaying traffic in the sim or not - and I say it that way because I use AIG-AIM only for installing models/liveries, I use PSXseeconTraffic to actually inject static and active aircraft into the sim, so I don't really use "AI" in the typical fashion.

I am setup for 30hz vsync and each scenario starts very fluid and smooth. After some time - sometimes 20 minutes, sometimes 100 minutes - I will notice my framerate bouncing through a wider range. It is 'normal' for it to be bouncing around between 27 and 33, and still be totally fluid and 'locked' at 30. However, when I notice it is getting into the 40s and the lower 20s, I know I've got the problem, which I can validate by panning around in spot view.

This is fixed easily by, as someone else also described, simply turning off EA momentarily and turning it back on, which is the fastest way to 'reset' the weather rendering. I hypothesized in the first thread on this subject that this is actually a weather engine issue as others saw this without EA.  I have been meaning to test whether restarting ASP3D has the same impact. This issue has persisted through the various versions of ASP3D as well as with both HF1 and HF2.

It might be useful to try and sort out whether these are different issues, or the same issue with different symptoms because of different configs/hardware.

@MarkW and others seeing this behavior, if you toggle EA, hit OK, then go back and toggle EA again to get back to your original config, does that alleviate the symptoms for you?

Also, Navigraph Simlink has always caused stutters for me unless I move to another core. In v4.5 I used ProcessLasso to move it off Core0 and that solved the problem. In v5, given all the anomalies, I haven't wanted to introduce anything outside the sim that might interfere, so I don't run it at all. But in any case, the simlink problem wasn't cumulative - it didn't get worse over time - just always interferes a little with the sim.

Edit: @mpo910, if you recycle EA off, hit ok, then back to settings EA on...do your framerates come back?

 

Edited by cwburnett

i5 9600K @ 5Ghz | MSI RTX 2070 | 32GB DDR4 3200 MHz | 2 x M.2 Gen 3x4 1TB SSDs + 1 x SATA 1TB SSD
Honeycomb Alpha Yoke | Saitek Throttle Quadrant | Saitek Rudder Pedals | Thrustmaster Warthog HOTAS

P3Dv5 HF2 | ASP3D | PSXseeconTraffic | AIG-OCI | Lorby AOM | Navigraph Charts | RXP GTN750 | FS2Crew UGCX
Leonardo Maddog X | Majestic Dash 8 | Aerosoft A318-A321+A330 (Beta Tester) | TFDi 717 (Beta Tester) | FSW Lear 35A+Falcon 50+MU-2B | Aerosoft DC-8 | Coolsky DC-9

Share this post


Link to post
2 minutes ago, cwburnett said:

Not sure whether these are all the same issue with varying symptoms, or different issues.

My experience, which I've shared in the thread that @MarkW started on this subject a week or so ago, is that over time, my displayed framerate becomes more unstable and the practical implication is stutters, but nothing like what @MarkW described.  This occurs whether I am displaying traffic in the sim or not - and I say it that way because I use AIG-AIM only for installing models/liveries, I use PSXseeconTraffic to actually inject static and active aircraft into the sim, so I don't really use "AI" in the typical fashion.

I am setup for 30hz vsync and each scenario starts very fluid and smooth. After some time - sometimes 20 minutes, sometimes 100 minutes - I will notice my framerate bouncing through a wider range. It is 'normal' for it to be bouncing around between 27 and 33, and still be totally fluid and 'locked' at 30. However, when I notice it is getting into the 40s and the lower 20s, I know I've got the problem, which I can validate by panning around in spot view.

This is fixed easily by, as someone else also described, simply turning off EA momentarily and turning it back on, which is the fastest way to 'reset' the weather rendering. I hypothesized in the first thread on this subject that this is actually a weather engine issue as others saw this without EA.  I have been meaning to test whether restarting ASP3D has the same impact. This issue has persisted through the various versions of ASP3D as well as with both HF1 and HF1.

It might be useful to try and sort out whether these are different issues, or the same issue with different symptoms because of different configs/hardware.

@MarkW and others seeing this behavior, if you toggle EA, hit OK, then go back and toggle EA again to get back to your original config, does that alleviate the symptoms for you?

Also, Navigraph Simlink has always caused stutters for me unless I move to another core. In v4.5 I used ProcessLasso to move it off Core0 and that solved the problem. In v5, given all the anomalies, I haven't wanted to introduce anything outside the sim that might interfere, so I don't run it at all. But in any case, the simlink problem wasn't cumulative - it didn't get worse over time - just always interferes a little with the sim.

Edit: @mpo910, if you recycle EA off, hit ok, then back to settings EA on...do your framerates come back?

 

I will check this. I knew about the ea fps decrease as I suuferedwith hf1 of this also. Ea off and on again also was my workaround to get fps back. I will check if this decrease in fps is again from ea mode on, or from something else. I will let the sim run till 1930 german time and then switch ea off and on again to see if the fps come back again

Share this post


Link to post
4 hours ago, simbol said:

Do you also get CPU going to 100%?

S.

Simbol,

I think I found my individual problem regarding FPS degradation.  I'll continue to experiment, but today I flew from Vegas to John Wayne with NO FPS degradation.  Very smooth flight.  I landed, and changed aircraft from Boeing 737 to Airbus 320 and flew back from John Wayne to Vegas.  In the past this would have been SURE to start FPS plummeting somewhere either on the way or definitely on the way back.  Absolutely smooth wonderful flights.

The only DIFFERENCE?   I disabled UT Live which was not a V5 program.  I moved it from V4 to V5 in my addons section.  I therefore believe Ultimate Traffic Live was the culprit in my situation.  As I said, I will continue to test, but it was a pleasure flying with no stutters or low frames. I love seeing other planes in the sky and at airports, but I guess I'll have to wait for a viable V5 Traffic program.

Stan

Share this post


Link to post
27 minutes ago, spilok said:

I love seeing other planes in the sky and at airports, but I guess I'll have to wait for a viable V5 Traffic program.

Not to derail this or rehash this if you've already looked at it, but I recently took the plunge with AIG-AIM OCI and found it to be easy to deploy and is v5 compatible.

  • Like 2

i5 9600K @ 5Ghz | MSI RTX 2070 | 32GB DDR4 3200 MHz | 2 x M.2 Gen 3x4 1TB SSDs + 1 x SATA 1TB SSD
Honeycomb Alpha Yoke | Saitek Throttle Quadrant | Saitek Rudder Pedals | Thrustmaster Warthog HOTAS

P3Dv5 HF2 | ASP3D | PSXseeconTraffic | AIG-OCI | Lorby AOM | Navigraph Charts | RXP GTN750 | FS2Crew UGCX
Leonardo Maddog X | Majestic Dash 8 | Aerosoft A318-A321+A330 (Beta Tester) | TFDi 717 (Beta Tester) | FSW Lear 35A+Falcon 50+MU-2B | Aerosoft DC-8 | Coolsky DC-9

Share this post


Link to post
1 hour ago, spilok said:

The only DIFFERENCE?   I disabled UT Live which was not a V5 program.  I moved it from V4 to V5 in my addons section.  I therefore believe Ultimate Traffic Live was the culprit in my situation.  As I said, I will continue to test, but it was a pleasure flying with no stutters or low frames. I love seeing other planes in the sky and at airports, but I guess I'll have to wait for a viable V5 Traffic program.

Stan

But, I use UTL and I don't have the issue.

In addition other users have different AI packages and have seen the problem.

Regards,

Simbol 

  • Like 1

Share this post


Link to post
1 hour ago, spilok said:

I disabled UT Live which was not a V5 program.  I moved it from V4 to V5 in my addons section.  I therefore believe Ultimate Traffic Live was the culprit in my situation.

 To be fair, it's really not a V4 program either as it doesn't actually run anything inside the sim. V4 or V5 compatible in many cases is just the installer knowing what entries to add to the relevant sim folders which you successfully circumvented yourself.


i7-8700K, 16gb DDR4 3200,  GTX1080Ti, Win 10, P3d V5x

Share this post


Link to post
1 hour ago, cwburnett said:

Not to derail this or rehash this if you've already looked at it, but I recently took the plunge with AIG-AIM OCI and found it to be easy to deploy and is v5 compatible.

I downloaded it, but for the life of me, I cannot get it to sync with V5.  I read the docs and I'm still not sure where to get it to link to the sim.

I must be getting old.

Stan

Share this post


Link to post
Posted (edited)
51 minutes ago, simbol said:

But, I use UTL and I don't have the issue.

In addition other users have different AI packages and have seen the problem.

Regards,

Simbol 

Did you just move it from your P3dv4 folder over to your P3dv5 folder?  That's what I did.

Maybe it was a fluke...but I'll keep testing the sim to see if I can replicate the FPS slow down.

Stan

Edited by spilok

Share this post


Link to post
25 minutes ago, spilok said:

I cannot get it to sync with V5.  I read the docs and I'm still not sure where to get it to link to the sim.

It is added as an Add On via the add-on.xml method. It creates an entry in the add-ons.cfg file pointing to its own add on directory and that's what introduces the models, liveries and traffic BGLs into the sim.  The initial setup can be a bit tedious while it downloads and adds the selected airlines. I don't want to derail this thread, but if you wanted to give it another go, since I just went through the process of figuring it out, feel free to PM me or if you post in the main AIG AI Manager thread, I and others would surely be happy to assist. 

 

  • Like 1

i5 9600K @ 5Ghz | MSI RTX 2070 | 32GB DDR4 3200 MHz | 2 x M.2 Gen 3x4 1TB SSDs + 1 x SATA 1TB SSD
Honeycomb Alpha Yoke | Saitek Throttle Quadrant | Saitek Rudder Pedals | Thrustmaster Warthog HOTAS

P3Dv5 HF2 | ASP3D | PSXseeconTraffic | AIG-OCI | Lorby AOM | Navigraph Charts | RXP GTN750 | FS2Crew UGCX
Leonardo Maddog X | Majestic Dash 8 | Aerosoft A318-A321+A330 (Beta Tester) | TFDi 717 (Beta Tester) | FSW Lear 35A+Falcon 50+MU-2B | Aerosoft DC-8 | Coolsky DC-9

Share this post


Link to post
1 hour ago, cwburnett said:

It is added as an Add On via the add-on.xml method. It creates an entry in the add-ons.cfg file pointing to its own add on directory and that's what introduces the models, liveries and traffic BGLs into the sim.  The initial setup can be a bit tedious while it downloads and adds the selected airlines. I don't want to derail this thread, but if you wanted to give it another go, since I just went through the process of figuring it out, feel free to PM me or if you post in the main AIG AI Manager thread, I and others would surely be happy to assist. 

 

Thanks.  I will post in the forum.  Appreciate it.

Stan

Share this post


Link to post
12 hours ago, spilok said:

Thanks.  I will post in the forum.  Appreciate it.

Stan

I totally agree it's well worth the effort - while the installer can be a tad tedious installing everything, its a hell of lot easier than trawling the interweb for it all yourelf and doing it manually!  Also, check out the forum link below, there is a spreadsheet on a post there which tells you exactly which traffic bgls you need to install for any particular country- saves a lot of time if you don't need the entire world 🙂

https://www.alpha-india.net/forums/index.php?topic=33878.msg336537#msg336537


Kevin Firth - i7-8700K @5.0; Asus Maximus X Hero; 32Gb Cas14 3200 DDR4; RTX2080Ti

Beta tester for: UK2000; JustFlight; VoxATC; FSReborn; //42

Share this post


Link to post
25 minutes ago, kevinfirth said:

I totally agree it's well worth the effort - while the installer can be a tad tedious installing everything, its a hell of lot easier than trawling the interweb for it all yourelf and doing it manually!  Also, check out the forum link below, there is a spreadsheet on a post there which tells you exactly which traffic bgls you need to install for any particular country- saves a lot of time if you don't need the entire world 🙂

https://www.alpha-india.net/forums/index.php?topic=33878.msg336537#msg336537

but please remember this file is not updated by AIG, so it might be have not all released flightplans

  • Like 1

AIGtechBanner_Kai_AVSIM.png

Share this post


Link to post
7 minutes ago, Kaiii3 said:

but please remember this file is not updated by AIG, so it might be have not all released flightplans

I still can't believe you produce this for free Kai, excellent work, the world still has capacity to astound me 🙂


Kevin Firth - i7-8700K @5.0; Asus Maximus X Hero; 32Gb Cas14 3200 DDR4; RTX2080Ti

Beta tester for: UK2000; JustFlight; VoxATC; FSReborn; //42

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    22%
    $5,550.00 of $25,000.00 Donate Now
×
×
  • Create New...