Jump to content

Search the Community

Showing results for tags 'AAO'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • New Member Forums
    • Welcome New Members!
    • Help Using the AVSIM Forums
    • Help Creating an AVSIM Account and Logging on to AVSIM
  • AVSIM Fixed Based Operations (FBO)!
    • Hangar Chat
    • Flight Planning
    • Virtual Reality (VR) Hardware and Games
    • Letters to the Editorial Staff of AVSIM
    • All About Us
    • Crash To Desktop (CTD) Forum
    • The Bargain Hunter's Shack
    • Classified Ads | Want Ads | Swap Meet
    • AVSIM's Round the World Race Forum
    • AVSIM Reviews Feedback
    • The File Library General Forum
    • Flight Sim & Aviation User Stories
    • In Memoriam of Tom Allensworth
    • In Memoriam
  • Microsoft Flight Simulator Forums
    • Microsoft Flight Simulator (2020)
    • MS FSX | FSX-SE Forum
    • The Microsoft Flight (2012) Forum
    • The FS2004 (FS9) Forum
    • Flight Simulator Tips and Tricks
    • Shared Cockpits | Multi-Player Forum for FSX | FSX-SE | P3D
    • MS FSX | FSX=SE | P3D Simconnect Forum
    • FSX | P3D Missions Forum - How To
    • FSX/FSX-SE Aircraft and Panel Design Forum - How To
    • FSX | FSX-SE Scenery Design Forum - How To
    • The Paint Shop - The Aircraft Painter's Forum - How To
    • Mesh Scenery Design - How To
    • TTools for MSFS Forum
    • Add On Developer's Forum
    • DX-10 Discussions, Hints and Help
  • The Prepar3D Forums
    • The Prepar3d Forum
    • Prepar3D Tips, Tricks and How To's
  • The X-Plane Forums
    • The X-Plane General Discussions Forum
    • X-Plane Tips and Tricks
  • The IPACS Aerofly Forums
    • IPACS AeroFly FS2
  • Helicopter and Rotor Head Forum
    • Rotor Head Archive
    • Rotory Winged & Helicopter Flying
  • Simulator Screen Shots, Real Aviation Photos, & Videos
    • The AVSIM Screen Shots Forum
    • Real Aviation Photos
    • Aviation and Flight Sim Video Forum
  • Hardware & Operating Systems Discussions
    • WIN11 OS Forum
    • WIN10 OS Forum
    • WIN8 OS Forum
    • The Win7 OS Forum
    • System Hardware: PC | MOBO | RAM | CPU | HDD | SSD | PSU etc
    • Video Hardware: Monitors | Multi-Monitors | Video Cards | Drivers etc
    • Hardware Controllers: Joysticks/Yokes | Throttle Quads | Rudder Pedals | Drivers etc
    • Networks | WIFI | Routers | Ethernet | DSL | Cable Modems
  • Commercial Support Forums (Hosted by AVSIM)
    • FS2Crew Support Forum
    • Mindstar Aviation Support Forum
    • The RealityXP Support Forum
    • The Official DX10 Scenery Fixer Support Forum
    • The Multi-Crew Experience (MCE) Support Forum
    • Lorby-SI Support Forum
    • Pilot2ATC Users Forum
    • The Carenado Support Forum
    • The Alabeo Support Forum
    • Aviasoft Remote CDU for Phone / Tablet Official Support Forum
    • Airline2Sim Support Forum
    • SX Airport Design Forum
    • SimSettingsManager Official Support Forum
    • simFDR General Support Forum
    • Blue Sky Star Simulations Support Forum
    • Capt. PERO Support Forum
    • Flysimware Forum
    • Mid-Atlantic Air Museum Simulations Support
    • FSReborn Series Support Forum
    • Desk Pilot - Shared Cockpits
    • PhotoSim Labs - Bahamas sceneries
    • Fulcrum Simulator Controls
    • The PILOT'S Support Forum
    • Stick and Rudder Studios
    • Honeycomb Aeronautical
    • SimFly Pad Support Forum
  • User-to-User Support Forums
  • Freeware Support Forums
  • Virtual Airlines News and Discussion
  • Home Cockpit Builders
  • Other Civil Aviation Simulators
  • International Language Forums
  • Other Forums

Categories

  • Articles
  • AVSIM News
  • File Library News
  • AVSIM Reviews
    • Hardware
    • Aircraft
    • Scenery
  • Product Announcements & Press Releases
  • What's New @ AVSIM
  • Interviews
  • AVSIM Editorials
  • Guest Editorials
  • Obituaries

Blogs

  • Tom Allensworth's Blog
  • Gaiiden's Scroll
  • Brandon's Blog
  • Jess B's X-plane blog thingy
  • Tom_Test's Blog
  • Alpha Floor's Logbook
  • GolfPilot
  • adi518's Blog
  • Chase's Blog
  • The Big Tour
  • Tales of a Wannabe Pilot
  • Farmer Looking Skyward

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


About Me


About Me

Found 14 results

  1. Hi I have just had to change my MotherBrd and CPU due to failure. I have installed MS2020 and XP12 and all work great on Windows 11. I then did a clean install of AAO and I can't find how to scan for my controls. ie In the manage Hardware changes screen you should have a "Scan Joystick" button but its gone. I have REPLACE, CLEAR and DELETE but no scan. What am I doing wrong. It all worked before OK or am I missing something, I have the downloads as per the installation instructions. In the left I have a list of devices including my controllers. How do i get them to the right side? Help please as it a fantastic program.
  2. I am looking for a SimVar or Sim event to bind a joystick button or a Midi button to trigger the "TICK ITEM" option in the InGame Checklists. Using the mouse to click this is bit cumbersome and tiring. Found this in the SDK. But no idea how to call these from AAO. My guess is this is possible as we can use "'SHOW_TOOLTIP|0|hello·there|1000|500'·(>L:AAO_COHERENT_TRIGGER,·String)" https://docs.flightsimulator.com/html/Programming_Tools/JavaScript/Coherent_Listeners/JS_LISTENER_CHECKLIST.htm Thanks.
  3. Hello, I am attaching pictures of my issue through my Reddit post (sorry for the quality). I just got a streamdeck pretty much exclusively for MSFS, besides for when I stream. I follow all installation instructions to a T, but when I’m watching others on YouTube install actual profiles, their WebAPI automatically goes to their selected port. Whether I do the default (9080) or custom (6080 and yes I updated it in AAO and the .js folders in the files), it doesn’t give me that option. It only shows enable WebAPIs and I’ve done it several times, restarted/reinstalled the app and restarted my computer several times. I have also done the custom firewall rules. I am really hoping this is some obvious issue I’m missing. When I load up into the A320 (this is the plug-in I’m first starting with), I can see the flight data like pressure, but no buttons work.
  4. Hallo ! Have had the software a couple of weeks and assigned some buttons on X-Touch mini for the Cessna 152/172 and JF Arrow. Yesterday I had some problems with getting the JF Arrow Lvar Autopilot_onoff to get working. Tested and experimenting with scripting, without knowing how to do it and without success. No local variables in the Arrow seems to be possible to assign without script. Is it intentional ? In the previous version of AAO I have assigned a couple off them so I could for instans remove the Efb/Ipad in the Arrow. But when starting the sim and AAO today every assignment was gone. Where did they go ? To clearify, when trying "Apply other config to this aircraft", the Dialog box is empty, I reinstalled the 2.04 version and of course running everything as admin and AAO is connected to the sim. Regards, Peter
  5. Greetings, In the "Change Web API address" settings window, the box to the left of the port address has a check. The box next to StreamDeck Plugin and Lorbysi-content-fippanel do not. Should they also have checks in their boxes? When I turn of and back on the checkbox to the left of the port address the two boxes for the StreamDeck Plugin and Lorbysi-content-fippanel will briefly become checked and then uncheck again. What is this behavior indicating? My Streamdeck is however working with aircraft. I also added lorbysi-atc-bridge to the community folder. Should I see it listed in the area with the other two entries, StreamDeck Plugin and Lorbysi-content-fippanel? It is not listed and did change the port to 9080 in AaoAtcBridge.js. AAO 3.00 b53 MSFS, com.lorbysi.aao.streamdeckplugin_18_01, ATC bridge downloaded 4/26/2023 Thanks
  6. Hi, Could you please give me some help here. I received my Bravo Throttle Quodrent last week and have spent many hours setting up profiles for various types of aircraft (twin engine piston and jet, single engine basic and complex etc etc). One of my favourite aircraft is the WT CJ4 citation jet. To setup this aircraft I purchased Lorby AAO. I am now planning to setup all my controls and buttons for all my favourite aircraft with this software. However before I proceed I have a number of questions. 1. Most important question is. If I mess it up can I resort back to the profiles I setup in MSFS 2020. 2. Is it necessary to unbind all axes and buttons in the profiles I have already setup within the simulator. I know I have to do it for WTCJ4, but not sure about the others.
  7. Once upgraded to the last versions of AAO and Stream Deck PlugIn, I noticed something wrong. Some commands start to be broken. Looking at the PlugIn fields I noticed that in the "Read Variable" field of toggle object, the variable is rewritten by the the PlugIn it self like the image linked (https://1drv.ms/u/s!AmStMhJnIz5Ci7coSaPaQKWGvwM1KQ). Nothing works after refilling the field, and the "Submit" button seems unuseful. Some of the previous toggle buttons do not work anymore. Some advices? Thanks! AAO Version: 2.26 b04 Stream Deck AAO Plugin Version: 9.02
  8. Being a huge fan of everything I can I do in AAO, I have finally gotten my Honeycomb Bravo working much better with the Kodiak / Floatiak after the latest update from SWS version 1.3.5. The idea was to have Forward Thrust from the idle detent 0% to 100%, and BETA and REVERSE in the correct reverse direction 0% to -25%. Because there is no axis on the Bravo in reverse I had to simulate it with buttons as best I could. This is what I did: 1. Create Axis Assignment "THROTTLE1_SET" and assign to the first throttle axis on the Bravo. (You can use whatever axis you like but note the button numbers below will be different.) 2. In the RPN Script Editor, create a script (I called It) "THROTTLE1_BETA" with the contents: 14·(>K:THROTTLE1_DECR) This will move the lever into BETA range approx 11% of reverse thrust. (This is what the animation displays if you hover over it in the sim.) 3. In the RPN Script Editor, create another script (I called It) "THROTTLE1_REVERSE" with the contents: 32·(>K:THROTTLE1_DECR) This will move the lever into REVERSE range approx 25%. (Also what is displayed hovering over throttle in sim.) 4. Create Button Assignment THROTTLE1_BETA to the reverse detent on the Bravo. It should read as Button 23. 5. Create Button Assignment THROTTLE1_REVERSE to the Go Around Button on the Bravo. It should read as Button 28. The GA Button on the Kodiak does not appear to have assignment, so I used it. You can use whatever button you like. If it is or does get used later, I can still use this method just give it a long button press of say 1 second. That should do it, works perfect for me. The BETA is really handy in the Float Version of the Kodiak, not sure it would be good to use full reverse there. Both work well in the Kodiak wheeled version too. Hope someone finds this useful. -HardCat
  9. Hi, this is possibly going to sound a bit pathetic, but, whatever. I saw a couple of articles about the Streamdeck, and thought it looked like a good idea, so have bought the XL version. I can see the basics of how it works but haven't played in depth with it yet. I have downloaded a bunch of basic profiles for the default MSFS aircraft (via FlightDeck) and I can see how that hangs together. I also saw lots of stuff about using AAO, both as a separate package for MSFS control and in conjunction with the Streamdeck. So I got a copy of this as well. I have watched a few videos but have not actually set up anything with AAO on the sim yet. My confusion is surrounding the relationship between the two products. How do they fit together? Do I have to have functions (buttons etc) assigned via AAO before I can use them in the SD? (I assume not but . . .). Perhaps if I state what I'd like to do, and it may be that I'm completely off-track anyway, in which case I'm happy to be told so. I'm not a complex (procedural) flyer. Very much a "ctrl-e"/give it some throttle/get in the air/fly around a bit as the mood takes me" kind of simmer. One of the reasons I never was attracted to all the button pressing and gauge wathing in the sim was the sheer awkwardness of finding all the right buttons and moving around in the cockpit, trying to get the mouse to work on the dials etc. So my first thoughts about the SD was that if I had a bunch of profiles with all the major buttons and functions set up I might be more inclined to learn how to actually fly some of these aircraft a bit more realistically. So, do I need AAO to be able to do this? My second thought, as I see that I can assign multiple functions to the SD buttons, is that it might be possible, and a good learning exercise for the aircraft concerned, to create a "start from cold" sequence for an aircraft by hooking together the correct set of functions, with appropriate pauses. Once done, I could then either use my customary ctrl-e quickstart or fire off the cold start macro and watch the whole process take place without having to remember the specific sequence for each aircraft (once I've set up the macro/SD button). And again, do I need AAO to do this (if it's even feasible) or if it's not actually necessary, would it improve the process for doing this? I've looked at a lot of videos, and they all seem to be about the mechanics of things like assigning a particular function to a particular controller axis, or assigning a function to a standard keypress or controller button, and I don't have any issues about how to do any of that stuff. I just don't really get the bigger picture of how it all hangs together. I'm more than happy to RTFM - I just can't find the RFM (right FM)! One final question re AAO. The info I have seen implies that I should remove the default MSFS settings for my controllers (CH Pro set, in my case), and use AAO to assign settings for my different aircraft. But like I said, I'm not a procedural flyer and I have dozens of aircraft addons that I'm only ever going to want to just ctrl-e and fly away in. Presumably I could just keep a default set of MSFS profiles and only switch in any AAO profiles on demand? Or will AAO drop back to an MSFS default if the current aircraft is not know to it? And if that's not even a realistic question, I apologise. That's the level of confusion I'm stuck at right now. Thanks for any advice or suggestions of appropriate reading. cheers, Andy
  10. dear Daniel, all as new AxisAndOhs Demo Version (2.27 b09) is out, have tried yesterday to connect my Knobster (siminnovations) to MSFS the Bridge is connecting fine to AAO main program, green light in the bridge. i can assign a button in AAO, select the required button, i turn the knobster, hardware is recognized. so far so good. see attached picture. (this was not the case with previous version, so one step further=. however there is no action in the MSFS aircraft at all ! also i see no green LED light in the main AAO program - assigned button main page when i turn the knobster. This cannot be correct ?! looks like AAO is not connecting to MSFS (installed properly with lorbysi-content-hooks in the community folder. have tried default C172 cessna to assign OBS and Kodiak 100 aircraft with various FMS commands, eg FMS knob or page zoom.no joy. no reaction at all. (what i need is the FMS knob in fact on the G1000 nxi WT, inner wheel, outer wheel and press button action for VR) any idea ? am i doing something wrong or is there still a bug in the software. many thanks Franz https://ibb.co/ZghW2LG https://ibb.co/cDLL7f8
  11. Hi, I'm new to AAO and just downloaded the Demo version for a trial for my X-touch Mini controlling the MSFS2020. Under the scripting, I was not able to see anything for "Watch simulation eventsor "Watch simulation variables" whenever I did some turning / clicking of MSFS. I suspect it's caused by the WebAPI. I've checked the Tools menu, the "Enable Web API on port 9080" was not able to be selected/enable. I've checked the port 9080 of my PC is okay and not blocked. Please advise any parameters need to set in order to "Watch simulation events" under "Scripting". My AAO Demo version is 2.81 b05 MSFS. I've checked the "port setting for the WEB" is 8080/9080 for WebFIP/WebAPI respectively. However, I could only see unchecked one module under "Set WebAPI for AAO Addons" as "Lorbysi-content-fippanel -> IP:localhost, Port:9080". I was not able to "Tick" the box of this module. However, the entire box is "Ticked" and have port 9080 set. (the "Set WebFIP for AAO Addons" is similar with only the "Lorbysi-content-fippanel -> IP:localhost, Port:8080" but not able to be cheched. Thanks BC
  12. Hi My Elagato Streamdeck is not working anymore with AAO. Pressing any Fenix button on Elgato does not work with MSFS 2020 Fenix function. WebAPI Port 8090 enabled under Tools menu item. (changed to 8090 because Logitech Hub has already 9080 in use) Verified port 8090 also in file settings.js in directory c:\Users\erathost\AppData\Roaming\Elgato\StreamDeck\Plugins\com.lorbysi.aao.sdPlugin\ What else could be the issue here? After updating to V 2.81 AAO I have this problem. Using: Axis and Oh MSFS V 2.81 b05 Plugin for Streamdeck Ellgato V 16.03 Thanks for any advice.
  13. Hello, Does anyone know of a beginner level tutorial that details the exact steps of the order in how add-ons and plugins, scripts need to be done in MSFS. Right now this is extremely difficult, because each author typically only deals with their piece of the puzzle. I'm looking for a complete 'HitchHikers Guide' that will simply describe each step, what needs to be done(assume nothing), before moving on to the next piece/file/action of software or configuration (typical) to get the desired results.... MSFS2020 > Adding a Stream Deck > Installing SD Plugins (AAO specifically) > Adding SD Profiles > Importing XML scripts, etc. I've managed to achieve some of the above, but I still fail on getting simpe AP altitude and headings to show up on any buttons, for any profile! What's needed is a clear and coherent written down approach to this so that simers like me, who don't fly real planes can understand clearly what is happening and can learn without chucking it all in frustration! I can't be the only one who would benefit from something like this. If anyone knows of such a thing whether free or for fee, please post links. The sophistication of MSFS is in a software league of itself. I love the software, its capabilities - of which I'm just scratching the surface. The first thing I wanted to do, was simply jump in a 152 and fly - perhaps a bit crudely at first. Simple instruments at first and then evolve to more complex operations. Not plot a flight plan and IFR flight somewhere. There's plenty of time for that. There needs to be some, either well-done text-based material, or better done videos that non-pilots can appreciate and learn from. ************************************* A few notes to those who produce YouTube videos on many of these topics... For the love of god, please try and exercise a little more constraint with moving the mouse pointer around. Slow it down. Give people time to follow. This fatal flaw is endemic in the You Tube industry today. I'm surprised almost no authors even recognize what's happening. Feedback is good, but some people won't be honest about a video, and therefore the producer of the content never knows what and how to improve. 1) Change the color of your mouse pointer to red, blue, some bright color that stands out so viewers can easily see where you are. I was watching a video the other day on LittleNav Maps. I have never in my life seen such a busy screen and fast movements. Anyone, unfamiliar with the software wouldn't be any better off after watching the video. I probably started and stopped it at least 100 times before I quit watching. And the sad part is, this kind of video does not help the author of the software attract more users. In fact, it will likely drive them away. Simply inexcusable IMO. 2) Move slower to menu options and hover for a few seconds so viewers can see where you are and more easily follow you. Especially on the tiny icons on most software and on multiple tool bars. I know it's second nature for all of us to zip our mouse across the screen and do something. But if the viewers can't begin to know what you just did - what's the point? Most of the instructional videos I've watched are horrid, because everything is moving to fast! NO ONE CAN KEEP UP. 3) Bring whatever microphone you use closer to your mouth, and articulate clearly. 4) Lower the resolution of your screen when producing videos, so that objects are LARGER and easier to see by the viewer. 1080p is fine for most videos. Please, don't use your 4K desktop to create instructional content. It's not needed. 5) Repeat multiple step sequences a second time for clarity (on hard to follow steps) and allow the viewer to catch up. 6) Some YT videos are done well, and better than others, but many simply don't realize the pain inflicted because of speed. Go back and watch some of your own videos! Judge for yourself. 7) YouTube is a marvelous thing, and there are a lot of wanta-be producers of instructional videos that are missing the mark. Rant over.
  14. Hello I am hoping someone can point me in the right direction to fix an issue with assigning the L/R brake axis. I just recently purchased AAO for Stream Deck functionality. Decided to assign aileron and elevator axis by AAO and liked it. Problem is when I assign the brake axis, when the aircraft reaches zero velocity I can’t move the aircraft again. By applying the park brake and releasing it the aircraft can now move once again until it reaches zero velocity. If I stop the aircraft with the parking brake and release the parking brake the aircraft can move. It is only when bringing the aircraft to a stop with the brakes that this is an issue. The brakes are not reversed. I have unassigned the brake axis in MSFS. I have looked for brake conflicts in all assigned devices. All animation look normal. This issue occurs on the aircraft I have tried so far, C172 classic, C172 G1000, CTL, C152, DC-6, CRJ. Regards Michael
×
×
  • Create New...