Archived

This topic is now archived and is closed to further replies.

McCrash

Flight1 Ultimate Traffic Ii

Recommended Posts

Help AVSIM continue to serve you!
Please donate today!

according to flight1, they were looking at a end of 2008 release. i would suspect that will not happen in the next 4 days, seeing as there has not been one peep about it in a month or so. i am holding out for this product but i hope i dont have to wait too long.Kyle

Share this post


Link to post
Share on other sites
What's wrong with SimConnect?
I cannot get my sim connect to work. cause I am told (now) that when I reinstalled everything, I had to install simconnect at SP1 and then once again at SP2. I found out about my problem when trying to AS to work which uses Sim connect Since I have not run the simconnect at SP1, I cannot go back to do it unless I do it all over again.Of course I had to do multiple installs in the first place because I was trying to get my SDK to work properly..which is again dancing on a pin head type install and I have got that to work finally (But really don't know what I did right to get that to work).Manny

Share this post


Link to post
Share on other sites
I cannot get my sim connect to work. cause I am told (now) that when I reinstalled everything, I had to install simconnect at SP1 and then once again at SP2. I found out about my problem when trying to AS to work which uses Sim connect Since I have not run the simconnect at SP1, I cannot go back to do it unless I do it all over again.Of course I had to do multiple installs in the first place because I was trying to get my SDK to work properly..which is again dancing on a pin head type install and I have got that to work finally (But really don't know what I did right to get that to work).Manny
You only have to reinstall the SDK... Not FSX itself.

Share this post


Link to post
Share on other sites
You only have to reinstall the SDK... Not FSX itself.
But I cannot just install the SDK from the acceleration box. It says, I need the previous version of the SDK, then when I go to install that, it tells me to uninstall Acceleration..and forces me to go backward. It has a spaghetti dependency. Unless all the stars are lined up properly, there is no guarantee everything will work. Thats what happened with my simconnect. I finally got the SDK all ligned up and after 4 months, I am finding out that my sim connect has its own install recipe. Now, I have so many paywares already installed, the thought of going back and redoing that is a nightmare...so I am now living without simconnect..and can't install anything that uses sim connect.. particularity the SP1 sim connect like AS.]Normally, I'd expect my latest and the greatest version of FSX and click repair something.If there is a recipe to rectify my sim connect without uninstalling any SDKs or my flight sim, I'd much appreciate it.Manny

Share this post


Link to post
Share on other sites
A preview for AI traffic that doesn't show any AI traffic? At the end of the day, UT and (especially) Trafficx look like garbage compared to the highly accurate AI models that it currently takes huge amounts of time to compile from various freeware sources. When you pair a hyper accurate airport with accurately modeled and liveried AI traffic, it is truely a sight to behold. As it is, today's top payware (and some freeware) airports really contrast with how terrible all of the payware AI traffic packages look compared to the top frewware AI.A pretty interface is all well and good, but show me how the traffic compares to AIAardark, EvolveAI, etc. Also, what about the flight plans? Accurate? Updateable?

Share this post


Link to post
Share on other sites

i agree with the above post, but i'm thinking they are not going to release too much because of what competitors do with stuff like that. i am holding off on buying a AI program until this comes out because i think this will top what is out there already o the payware side of things, keeping my fingers crossed.

Share this post


Link to post
Share on other sites
But I cannot just install the SDK from the acceleration box. It says, I need the previous version of the SDK, then when I go to install that, it tells me to uninstall Acceleration..and forces me to go backward. It has a spaghetti dependency. Unless all the stars are lined up properly, there is no guarantee everything will work. Thats what happened with my simconnect. I finally got the SDK all ligned up and after 4 months, I am finding out that my sim connect has its own install recipe. Now, I have so many paywares already installed, the thought of going back and redoing that is a nightmare...so I am now living without simconnect..and can't install anything that uses sim connect.. particularity the SP1 sim connect like AS.]Normally, I'd expect my latest and the greatest version of FSX and click repair something.If there is a recipe to rectify my sim connect without uninstalling any SDKs or my flight sim, I'd much appreciate it.Manny
Manny, do whatever it takes to get it working. I wish I could help you! ASA (if that's what you were talking about) is probably the most important purchase I have made for FSX. ASA really improves FS all the way around.

Share this post


Link to post
Share on other sites
awesome!
Interprocess Communications, the magic required for FS add-ons to "talk" to each other, will be provided by SimConnect now and in the future. You'll have to learn to love it. In any case, you need the SDK to write apps that will take advantage of SimConnect, but you certainly don't need the SDK to use programs written to take advantage of SimConnect. FSUIPC will not likely last forever.

Share this post


Link to post
Share on other sites
But I cannot just install the SDK from the acceleration box. It says, I need the previous version of the SDK, then when I go to install that, it tells me to uninstall Acceleration..and forces me to go backward. It has a spaghetti dependency. Unless all the stars are lined up properly, there is no guarantee everything will work. Thats what happened with my simconnect. I finally got the SDK all ligned up and after 4 months, I am finding out that my sim connect has its own install recipe. Now, I have so many paywares already installed, the thought of going back and redoing that is a nightmare...so I am now living without simconnect..and can't install anything that uses sim connect.. particularity the SP1 sim connect like AS.]Normally, I'd expect my latest and the greatest version of FSX and click repair something.If there is a recipe to rectify my sim connect without uninstalling any SDKs or my flight sim, I'd much appreciate it.Manny
Hi Manny,I can try to help with this. A few supertrafficboard customers had similar problems with the way SimConnect had deployed onto their PCs. You say the "previous version of the SDK"? Which SDK version is that exactly? I would start by ensuring all SDK versions are removed, and then install that from FSX disk 2. Following that SDK SP1a downloaded from FSInsider and finally Acceleration SDK. Maybe you tried that path already, but let me know.RegardsSimon
i agree with the above post, but i'm thinking they are not going to release too much because of what competitors do with stuff like that. i am holding off on buying a AI program until this comes out because i think this will top what is out there already o the payware side of things, keeping my fingers crossed.
I agree with the statement, but will posting screenshots of models and paints really affect their commercial position? They must have many models and paints done by now. I sincerly hope some are published soon, just as both Just Flight TrafficX and MyTrafficX have done prior to release.RegardsSimon

Share this post


Link to post
Share on other sites
Hi Manny,I can try to help with this. A few supertrafficboard customers had similar problems with the way SimConnect had deployed onto their PCs. You say the "previous version of the SDK"? Which SDK version is that exactly? I would start by ensuring all SDK versions are removed, and then install that from FSX disk 2. Following that SDK SP1a downloaded from FSInsider and finally Acceleration SDK. Maybe you tried that path already, but let me know.RegardsSimonI agree with the statement, but will posting screenshots of models and paints really affect their commercial position? They must have many models and paints done by now. I sincerly hope some are published soon, just as both Just Flight TrafficX and MyTrafficX have done prior to release.RegardsSimon
Simon.I did it exactly in the sequence you mention to get my SDK to work properly. When I mentioned "previous versions of sdk", at each of the three steps you mentioned, I installed SDKs.However, after each of three steps, I did not do anything with sim connect. But sim connect is unusable atleast for AS at the end. AS requires SP1 sim connect.Manny

Share this post


Link to post
Share on other sites
Simon.I did it exactly in the sequence you mention to get my SDK to work properly. When I mentioned "previous versions of sdk", at each of the three steps you mentioned, I installed SDKs.However, after each of three steps, I did not do anything with sim connect. But sim connect is unusable atleast for AS at the end. AS requires SP1 sim connect.Manny
Hi Manny,So as far as you know the SDK is installed to the acceleration level and that is working, but SimConnect is not as evidenced by Active Sky?FSX has the notion of side by side interfaces, meaning you can have multiple levels of the SimConnect interface installed (e.g. RTM, SP1, SP2). When an add-on targets a particular SimConnect version, it just uses that version even if it is not the latest. SuperTrafficBoard is desgined to look at all the side by side interfaces that are installed, and always use the most recent. FSUIPC can do the same, and I dare say there are others too. Sometimes the side by side interfaces don't get installed properly. I have no idea why, but a few STB customers endrf up in this situation and were all fixed by installing the Simconnect clients from the SDK. Normally these are intended to enable Simconnect on a remote PC (like FSUIPC WideFS), but they can be used to fix problems in deployment on the FSX PC too.Try installing these and see what happens. The latest version of the client corresponding to your SDK version may be found in:C:\Program Files\Microsoft Games\Microsoft Flight Simulator X SDK\SDK\Core Utilities Kit\SimConnect SDK\libOlder versions, such as those for SP1 that might help ASX out are in:C:\Program Files\Microsoft Games\Microsoft Flight Simulator X SDK\SDK\Core Utilities Kit\SimConnect SDK\LegacyInterfaces\FSX-SP1The installer is called SimConnect.msi in each case. When you install these they are very quiet, but they do get installed nonetheless.

Share this post


Link to post
Share on other sites
Hi Manny,....Try installing these and see what happens. The latest version of the client corresponding to your SDK version may be found in:C:\Program Files\Microsoft Games\Microsoft Flight Simulator X SDK\SDK\Core Utilities Kit\SimConnect SDK\libOlder versions, such as those for SP1 that might help ASX out are in:C:\Program Files\Microsoft Games\Microsoft Flight Simulator X SDK\SDK\Core Utilities Kit\SimConnect SDK\LegacyInterfaces\FSX-SP1The installer is called SimConnect.msi in each case. When you install these they are very quiet, but they do get installed nonetheless.
Simon,THANK YOU!That did it. I just had to install the SP1's sim connect. I didn't have to uninstall anything. Phew!THANK YOU THANK YOU.Manny

Share this post


Link to post
Share on other sites