Archived

This topic is now archived and is closed to further replies.

Guest Pres_Clinton

Stuttering Help

Recommended Posts

I am getting some stuttering still in FSX. I have tweaked it some with buffer pools and affinity mask. It happens mainly when I pan my view. Here are my specs does anyone with a simular system have any tips?[Display]Processor: AMD Phenom II X4 965 Processor (3399 MHz)Operating System: Windows 7 Ultimate, 64-bitDirectX version: 11.0 GPU processor: GeForce GTX 295Driver version: 191.07Stream processors: 240 Core clock: 576 MHz Shader clock: 1242 MHzMemory clock: 1008 MHz (2016 MHz data rate) Memory interface: 448-bit Total available graphics memory: 4095 MBDedicated video memory: 896 MBSystem video memory: 0 MBShared system memory: 3199 MBVideo BIOS version: 62.00.6C.00.01IRQ: 16Bus: PCI Express x8 Gen2GPU processor: GeForce GTX 295Driver version: 191.07Stream processors: 240 Core clock: 576 MHz Shader clock: 1242 MHzMemory clock: 1008 MHz (2016 MHz data rate) Memory interface: 448-bit Total available graphics memory: 4095 MBDedicated video memory: 896 MBSystem video memory: 0 MBShared system memory: 3199 MBVideo BIOS version: 62.00.6C.00.01IRQ: 16Bus: PCI Express x8 Gen2GPU processor: GeForce GTX 295Driver version: 191.07Stream processors: 240 Core clock: 576 MHz Shader clock: 1242 MHzMemory clock: 1008 MHz (2016 MHz data rate) Memory interface: 448-bit Total available graphics memory: 4095 MBDedicated video memory: 896 MBSystem video memory: 0 MBShared system memory: 3199 MBVideo BIOS version: 62.00.6C.00.02IRQ: 16Bus: PCI Express x8 Gen2GPU processor: GeForce GTX 295Driver version: 191.07Stream processors: 240 Core clock: 576 MHz Shader clock: 1242 MHzMemory clock: 1008 MHz (2016 MHz data rate) Memory interface: 448-bit Total available graphics memory: 4095 MBDedicated video memory: 896 MBSystem video memory: 0 MBShared system memory: 3199 MBVideo BIOS version: 62.00.6C.00.02IRQ: 16Bus: PCI Express x8 Gen2

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

One of the most common causes of stuttering is the texture bandwidth mult setting in the FSX.cfgWhat is yours set at?IAN

Share this post


Link to post
Share on other sites

295 is listed 4 times becuase I have 2 of them hooked up for quad SLI.

Share this post


Link to post
Share on other sites

Don't know what the correct setting should be when using SLI but 295 sounds high.I use 120 having experimented with many diffrent settings.Consensus says that 40 is nearer the mark otherwise stuttering will occur.IAN

Share this post


Link to post
Share on other sites

I have massive stuttering unless I change texturemaxload to 4096

Share this post


Link to post
Share on other sites

There are many ways to fix stutters , but two things that help a lot are this1 - Turn off Hyperthreading if you using i7, then increase your cpu speed.2- for quad core Set affinity mask to 14 in fsx.cfga good defrag also helps

Share this post


Link to post
Share on other sites
295 is listed 4 times becuase I have 2 of them hooked up for quad SLI.
that's overkill for FSX - I'm assuming you play other games?Some people have reported micro stutter issues when running SLI, but as you can read above, others have had no issues....

Share this post


Link to post
Share on other sites

Are your FPS locked or unlimited? Are you running DX9 or the DX10 preview?With my system, If I don't lock the FPS in DX9 I get terrible stutters, especially in turns and when panning the view. I suspect this is because the fps are fluctuating from 90 one moment to 20 the next. I have it locked at 25fps and it's generally smooth, though I stay the heck away from the complex airports.In DX10 preview mode it works much better to set the FPS to unlimited (go figure). I get better fps with DX10 in general, but it's also more ... ummm ... let's say idiosyncratic.

Share this post


Link to post
Share on other sites
GPU processor: GeForce GTX 295.
In my opinion, that's the problem. This card is not very good for FSX.. it has something to do with two cores... I'm not an expert but I read it several times.

Share this post


Link to post
Share on other sites

Quad SLI is not doing anything for you, FSX only addresses one (of your 4)GPUs, so I would disable sli (for FSX) and see what happens, frames may even improve.I also get stutters with frames unlocked that smooth out with frames locked, so that could do it as well.

Share this post


Link to post
Share on other sites
Are your FPS locked or unlimited? Are you running DX9 or the DX10 preview?With my system, If I don't lock the FPS in DX9 I get terrible stutters, especially in turns and when panning the view. I suspect this is because the fps are fluctuating from 90 one moment to 20 the next. I have it locked at 25fps and it's generally smooth, though I stay the heck away from the complex airports.In DX10 preview mode it works much better to set the FPS to unlimited (go figure). I get better fps with DX10 in general, but it's also more ... ummm ... let's say idiosyncratic.
I may have asked you before, but if not, have you tried FPSLimiter.exe? This has been a wonderful find for many, higher end Quad core P4's in particular, and I'm not sure about newer CPUs. But in any case, this is a frame lock that occurs BETWEEN FSX and your monitor, and lets you get the benefits of UNLIMITED frames (in FSX), but ameliorates the fluctuating frames responsible for frame surges n jerks that can happen in UNLIMITED mode. The benefits come from the fact that UNLIMITED in FSX seems to bring in some prioritizations/optimizations that you won't get when you lock frames in FSX. FPSLimiter.exe will allow to lock frames whereever you want, while running FSX in UNLIMITED mode. Plus, you can change the frame lock on the fly, which can be useful in certain situations. For example, when I set FPSLimiter to it's default 30 fps, I notice sometimes road traffic will run herky-jerky: but lowering the frame lock to 25 (incrementally using the F11 key) eliminates this issue with road traffic.Noel

Share this post


Link to post
Share on other sites

Having tried all of the above after a fresh install of FSX can anyone suggest a way to reduce stutters.I seem to get them quite a bit and they are becoming annoying, im not even at a busy airport either, so its not like im really testing my system.I may keep playing around with the texture bandwith, i have this set to 80 at the moment, but more tweaking is needed i feel.But in the short term does anyone have any quick fixes or things to try??ThanksTom

Share this post


Link to post
Share on other sites
Quick fix:Pay $ 2,000+ for the new i7 something and hardware to match!Or go here and read, read, read:http://205.252.250.26/cgi-bin/yabb2/YaBB.p...=1208959973/0#0http://www.simforums.com/forums/forum_posts.asp?TID=29041If you have FSX on W7 - TBM works best at 40 IMO...Good luck!
lol yeah that would be a quick fix.Well I have setup to nickn's guide and have been using that for a while but I seem to have gotten more stutters after my recent full reinstall.I have w7 tho so I will play around with the tbm and see how I go.Thanks for the info

Share this post


Link to post
Share on other sites

W wh wh when I I r r r ro ro ro rolled b b b b ba ba back m m m m my d d d d d dr dr driv drivers t t t t to to 1 1 1 1 1 1 1 18 18 18 f f f fi 5 p p p poin point f f f fi fi 5, m m m m my s s s s st st stt stut stutter stuttering s s s s st st stop stopped c c c co com com ple ple ple ly ly.S S S S St Step Stephen

Share this post


Link to post
Share on other sites
W wh wh when I I r r r ro ro ro rolled b b b b ba ba back m m m m my d d d d d dr dr driv drivers t t t t to to 1 1 1 1 1 1 1 18 18 18 f f f fi 5 p p p poin point f f f fi fi 5, m m m m my s s s s st st stt stut stutter stuttering s s s s st st stop stopped c c c co com com ple ple ple ly ly.S S S S St Step Stephen
:(

Share this post


Link to post
Share on other sites
W wh wh when I I r r r ro ro ro rolled b b b b ba ba back m m m m my d d d d d dr dr driv drivers t t t t to to 1 1 1 1 1 1 1 18 18 18 f f f fi 5 p p p poin point f f f fi fi 5, m m m m my s s s s st st stt stut stutter stuttering s s s s st st stop stopped c c c co com com ple ple ple ly ly.
That's exactly my experience too!

Share this post


Link to post
Share on other sites

I get a lot of stuttering when there are tons of trees around. For example in the grand canyon free addon there are a ton of trees there and my frame rate jumps from 80-10 constantly creating the jerks. Same with the orbx blue freebie and that airport they give you in there where there are a ton of trees around. Still haven't been able to figure out why trees are killing my frame rate to this day...

Share this post


Link to post
Share on other sites
There are many ways to fix stutters , but two things that help a lot are this1 - Turn off Hyperthreading if you using i7, then increase your cpu speed.2- for quad core Set affinity mask to 14 in fsx.cfga good defrag also helps
You can also leave hyperthreading ON and set the affinity mask to 85 in the config. Works great on my quad core i7.

Share this post


Link to post
Share on other sites
I get a lot of stuttering when there are tons of trees around. For example in the grand canyon free addon there are a ton of trees there and my frame rate jumps from 80-10 constantly creating the jerks. Same with the orbx blue freebie and that airport they give you in there where there are a ton of trees around. Still haven't been able to figure out why trees are killing my frame rate to this day...
You need to lower your frame rate lock. If I use 30 FPS lock in areas with alot of trees and autogen I get what you describe. If I set it to 24 or 26 problem is gone. Usually the surge issue where you see large swings in FPS means a frame lock set too high.

Share this post


Link to post
Share on other sites
I get a lot of stuttering when there are tons of trees around. For example in the grand canyon free addon there are a ton of trees there and my frame rate jumps from 80-10 constantly creating the jerks. Same with the orbx blue freebie and that airport they give you in there where there are a ton of trees around. Still haven't been able to figure out why trees are killing my frame rate to this day...
Since I bought GEX Europe I don't have "the tree problem" anymore! For my i7 Affinitymask=14 works best.

Share this post


Link to post
Share on other sites