Jump to content

Archived

This topic is now archived and is closed to further replies.

airhub

NGX Autopilot not engaging anymore

Recommended Posts

Hi, Not sure if i'm posting in the right place so forgive me if i'm not: My issue: After my first few flights in the excellent NGX my autopilot stopped engaging. I tried everything, making sure both flight directors were on, making sure aircraft was trimmed with no control inputs, cycling a/p on and off but no joy! So I re-installed fsuipc4, no change! I re-installed NGX and bingo...it started working again! Now after 3/4 flights it won't engage at all again. I've tried the exact same flights with when it was working, with fair weather, light load, balanaced trim...but no joy! Has anyone else experienced this? Can anyone tell me what might be wrong? Any help would be appreciated as this is killing the experience for me. [ps I have a v.modest system but I've managed to get an acceptable balance of settings that make successful flight v.enjoyable...thankyou PMDG + testers!] Many thanks,


Milton

FSX SP2 (no Acceleration)

Win XP Pro 32-bit / Intel Core 2 Duo E660@2.4 GHz / 4Gb DDR2 RAM / Nvidia GT 240 - 512Mb /

Share this post


Link to post
Share on other sites

Try reloading the plane. You might have broken something by violent maneuvers (it happened to me after I missed a landing and did a bit of roller-coastering while trying to adjust buttons). Henri


Henri Arsenault

Share this post


Link to post
Share on other sites

Hi Henri, Thanks for your suggestion I'll try it out. It's a weird issue since i tried it in fair weather several times to avoid any crazy inputs and for perfect trim, but no joy! Hope I don't have to resort to reinstalling everything :( Thanks for your help.


Milton

FSX SP2 (no Acceleration)

Win XP Pro 32-bit / Intel Core 2 Duo E660@2.4 GHz / 4Gb DDR2 RAM / Nvidia GT 240 - 512Mb /

Share this post


Link to post
Share on other sites

A few screen shots of the upper panel, FMS and main panel would be helpful as well as what modes your trying to engage.


George Morris

 

Boeing777_Banner_BetaTeam.jpg

Share this post


Link to post
Share on other sites

Hi George, thanks. I'll try it again in a bit and post the screen shots. many thanks


Milton

FSX SP2 (no Acceleration)

Win XP Pro 32-bit / Intel Core 2 Duo E660@2.4 GHz / 4Gb DDR2 RAM / Nvidia GT 240 - 512Mb /

Share this post


Link to post
Share on other sites

Pls find some screenshots below: have departed EDDK, VNAV and LNAV are armed, aircraft is ~15000ft and leveling off to make sure trim is set correctly - from around 1500ft AGL to this point I've tried engaging either CMD-A or CMD-B but the button just depresses with no autopilot engagement. I tried at several phases in the flight up to this point with no engagement of AP. (Weather set at fair weather (so little/no wind) - clouds by REX) Many thanks some more screenshots:There are a couple more but won't upload...bear with mesome FMS screens at same point in time (failed to engage any autopilot)Apologies for the duplicate images the uploader doesn't seem to like any images >1Mb


Milton

FSX SP2 (no Acceleration)

Win XP Pro 32-bit / Intel Core 2 Duo E660@2.4 GHz / 4Gb DDR2 RAM / Nvidia GT 240 - 512Mb /

Share this post


Link to post
Share on other sites

@Henri Tried reloading aircraft and got a Crash To Desktop :( Never mind, thankyou for the suggestion anyway :)


Milton

FSX SP2 (no Acceleration)

Win XP Pro 32-bit / Intel Core 2 Duo E660@2.4 GHz / 4Gb DDR2 RAM / Nvidia GT 240 - 512Mb /

Share this post


Link to post
Share on other sites

I notice in the photos that your FO's FD is the master !! Try turning both FD's off and then turning them back on..........Captains one first. Also your MCP is asking you to set a different altitude !! The plane wants to descend by the looks of it. Hope this helps.


Frederic Steiner.

B7382.jpg

Share this post


Link to post
Share on other sites

The AP won't engage issue happens to me all the time, although there might be other issues at the same time. I often have the EXACT active modes (as per FMA), but no (!) FD bars (already posted a seperate thread on this). Furthermore I can already anticipate this issue is coming when RTO won't arm on ground (everything set up perfectly) but immediately throws a DISARM light which won't come off as it usually should. This is one of the cases where AP would also not engage. Tried everything from disabling realistic AP engagement to check active failures, disable joystick and center controls via keyboard input, and so on. Usually you're doomed for the rest of the flight. Last time this happened to me, I decided to divert before reloading, shutting everything down, powering everything up again and see what the AP does. In fact it worked again, without reloading the whole aircraft. So there must be some awkward condition that leads the AP to this nasty behavior. Unfortunately I'm unable to reproduce. It just happens and I have no clue when. sig.gif

Share this post


Link to post
Share on other sites

A Short Term 'Dirty' Fix: Not ideal but at least can get fly again: Firstly thankyou all for your kind replys. @twinturbo99 - I checked and everything appeared to be off/not active under failures but I'll have to spend some more checking it out. It's v.useful to know about so thankyou for pointing me in that direction, it helped me find the temp. fix :) @RYR738 - thankyou too for pointing those out. I made the changes but unfortunately they didn't solve my particular issue. The 'Dirty' fix that has at least allowed me to engage the A/P on my first tests and therefore continue my flight. (Need to test more to see how it fully works): 1) goto FMC -> Menu -> PMDG SETUP2) select AIRCRAFT3) select EQUIPMENT4) select REALISTIC AP ENGAGEMENT to OFF (was set to on)5) enjoy your flight :) It's not an ideal solution but at least I can hopefully enjoy a few flights before going back to try and figure out what's really going on.My hunch is something to do with the controls as @Gerardius kindly pointed out. I'm using just mouse and keyboard with autorudder -> OFF.I'll have to do some test flights and use the SYS display to check actual flight surface positions. @badderjet - maybe this might help if you want to remove the stress of spending time setting up only for your flight to be ruined :| Again thankyou to everyone for your assistance. I hope this thread maybe of help to you if your face this or a similar issue. If I find the real cause I'll post back whenever that may be. Happy Flying to you!


Milton

FSX SP2 (no Acceleration)

Win XP Pro 32-bit / Intel Core 2 Duo E660@2.4 GHz / 4Gb DDR2 RAM / Nvidia GT 240 - 512Mb /

Share this post


Link to post
Share on other sites

This happens a lot with me as well, but only when using mouse/no auto rudder. I ve gotten so damn frustrated with it but im hoping that realistic A/P off works


800driver.jpg

Share this post


Link to post
Share on other sites

Guys,There is no "issue" with the AP not engaging. What there is an issue with are people's controllers being out of calibration, spiking etc. What the Realistic AP Engagement option actually means is that you need to have the controls completely neutral when you press the CMD button. If your stick is sending out any kind of signal at all to the sim, that's not neutral and it's not going to engage. If you've calibrated and still have the issue, turn off Realistic AP Engagement in the options and it should allow it to engage. The problem then though is that it may disengage due to thinking you're moving the controls. It has no way of knowing if an input is real or from bad calibration (how could it?).A for sure way to check for controller issues is to get in the air and then totally unplug or disable your joystick. If the AP engages fine while it's unplugged, you know for sure it's the controller doing it.


Ryan Maziarz
devteam.jpg

For fastest support, please submit a ticket at http://support.precisionmanuals.com

Share this post


Link to post
Share on other sites

Sorry to bring this back up, but I have been having some trouble with autopilot not being able to engage, for one reason or another, and it turns out the plane recognized it as a failure, (and if you have all failures turned off...this can come as a surprise to you not realizing it's recognized as such) so to fix it you can go into PMDG Setup > Aircraft > Failures. It should say Active: 1, hit LSK1, then "clear all" and that should bring bring CMD A/B back online.

Share this post


Link to post
Share on other sites

×
×
  • Create New...