Sign in to follow this  
Followers 0
cubs

FPS limiter bat file

91 posts in this topic

Hi all, FPS limiter I am running windows 7 on a 64 bit system. I have FSX located in C/FSX. When I run the exicutable to get the bat file, It does not create one. It looks like the directions want FSX located in program files(x86). Does this matter? Doug

0

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Yes, I am using java, that is how I was able to open it. Doug
you mean you cannot create a batch file ? If you are using java you open the FPS_limiter jar file and then search for fsx.exe and just click on create , the created batch file will be in you fsx directory fsx.exe.limited something like that.
0

Share this post


Link to post
Share on other sites
you mean you cannot create a batch file ? If you are using java you open the FPS_limiter jar file and then search for fsx.exe and just click on create , the created batch file will be in you fsx directory fsx.exe.limited something like that.
Thanks for the reply, yes, I use java to open the gui file, I get the small window where you locate the fsx.exe, it shows 30 fps, I click create bat, and nothing happens. I have fsx located in my C drive, C/fsx/fsx.exe. It shows fsx.exe in the name window and C:/FSX/fsx.exe in the path window. does that look right?
0

Share this post


Link to post
Share on other sites

This in all likelihood is a dumb @ss question... I noticed that you didn't mention that you clicked "browse" after you open the Jar file to locate FSX.EXE. This Jar file assumes FSX is in your programs directory and you must point it in the right direction. Also might sure you open the Jar file as an "administrator".

0

Share this post


Link to post
Share on other sites

Also I think the .bat file is created wherever you've placed the FPS Limiter program (and not in the FSX folder)... so look in that folder.

0

Share this post


Link to post
Share on other sites

Also, are you looking for the right file? You need a batch file, but it doesn't say .bat. The file you need is fsx.limited.exe.

0

Share this post


Link to post
Share on other sites

Nothing is supposed to happen when you click "create bat". It just silently creates a file called fsx.exe.limited.bat in the same folder that you ran the .jar file from.

0

Share this post


Link to post
Share on other sites
It should though.... It will say fsx.exe.limited.bat
If you went into it's properties, it would, but windows explorer does not show the final file extension.
0

Share this post


Link to post
Share on other sites
If you went into it's properties, it would, but windows explorer does not show the final file extension.
It will if you enable "show file extensions." Under Control Panel\All Control Panel Items\Folder Options
0

Share this post


Link to post
Share on other sites

Y'know - I've been mulling this darned limiter over for a while now. It is a worthwhile mod, as it does make a difference to almost everyone's frame rate, by pushing the frame rate limit off to the operating system, thus freeing up fsx to "work on other stuff".. The problem everyone runs into, is that Java GUI. How to run it, where to put, and so on.. The truth is - you don't need the jar. You can just delete the darned thing and make the bat file manually - it's quite easy once you get away from the 'magic' of Java.. Bare with me - I'm mainly making this for the guys that think they can't do this, or that it's too hard, but the fact is that there are hundreds of posts all from folks having trouble understanding this thing - including me. I must have downloaded 20 different versions of Java, trying to get it to work. And then the problem with Microsoft's "Where do I put the quotation marks?" "Why only one quotation mark?" - all pretty confusing. What I'm outlining below is what I found to be a more straight-forward way of getting it running.Basically - it's put the files in the FSX root, make a batch file on the desktop, name it, and then run it. The parameters in the file are fairly well known by now, and are in the readme.txt, but this is the part we can make a lot more simple by stating where FSX actually is with the dos "SET PATH=" command, instead of making error upon error because of those squirrely quotation marks.So... if you are still having issues making it run, try this.. 1). Make a new folder on your favorite "stuff" drive - not your fsx drive, and name it anything you want to, say "FPS_Limiter_Source_File. Put the zip file into it.2). Unzip the file inside that new folder.3). You will now have another new folder there called "FPS_Limiter_02".4). Inside that folder are seven files:- ......FPS_Limiter.exe......FPS_Limiter_GUI.jar......HookHelper.dll......Limiter_D3D8.dll......Limiter_D3D9.dll......Limiter_OGL.dll......Readme.txt 5). Copy everything inside the folder - except the readme and the jar files - over to the root folder of FSX. Now forget about that folder.6). Now leave Windows Explorer and then Rt-Clk anywhere on the desktop. Select 'New -> Text document'7). Rt-Clk on the icon and select "Edit"8). Notepad will open: Copy/paste the dos script below from between the two asterisk rows "*******" (don't copy the asterisks) into Notepad and then substitute your path to your FSX folder from what mine was. So... highlighting everything from CLS all the way to \fsx.exe..... ************CLS@ECHO OFFSET PATHF=F:\Flight SimulatorF:CD "%PATHF%"start .\FPS_Limiter.exe /r:D3D9 /f:30 /x:OFF /l:OFF "%PATHF%"\fsx.exe ************ For example your path might read:- SET PATHX=C:\Flight Simulator C:CD "%PATHX%"start .\FPS_Limiter.exe /r:D3D9 /f:30 /x:OFF /l:OFF "%PATHX%"\fsx.exe It might be: SET PATHX=C:\FSXC:CD "%PATHX%"start .\FPS_Limiter.exe /r:D3D9 /f:30 /x:OFF /l:OFF "%PATHX%"\fsx.exe What we've done is to substitute a parameter (PATHX) for the path to your FSX folder - a lot more simple than trying to figure where to put a quotation mark.. Once you're happy that everything looks good, spaces in the right spot, etc., click on 'save as' and name it "Limiter.bat"... or anything else, as long as it ends with ".bat".Lastly - open up your fsx.cfg and edit the [Display] section - and make UPPER_FRAMERATE_LIMIT=0. If you docant find or don't know how to manually do this, just start FSX as you normally do, and move the frame rate to 'unlimited, then exit fsx.Double-click on this batch file and FSX will start, and will be limited tp 30 frames per sec.. This will work every time. If you are using TripleHead2G - then make "/f:90" for the 3 screens. Also, too, note the "start" command - Following "start" is a space, and then a "." before the "\". If you copy\paste you won't have any trouble. I'm a retired old fart, so you can pm me if it's still as cloudy as before. At least you won't have to worry about java.....

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0