Jump to content

Archived

This topic is now archived and is closed to further replies.

Tom Wright

STILL Spiking!

Recommended Posts

Hi,I don't know why, but for a long time i've been plagued with autogen spiking/artifacting in areas of Dense or higher autogen. Particularly bad areas i've noticed recently are Orbx PNW near Darrington, and Earth Simulations Guernsey. When exit the virtual cockpit and pan the view around in Spot, the trees and buildings explode. It tends to occur not immediately, but 5-10 minutes into a session, often when I load up in a dense area, fly away and then return to it. This greatly removes the satisfaction of it to me. I've tried so many things to fix it. I even replaced the graphics card from a GTX 285 to a GTX 560 Ti, which has helped a little, but not enough. I've tried with a fresh, untweaked cfg, as well as different Bufferpools, nothing works. My PC is a fairly decent spec, 4GHz i7 920 and the GTX 560 Ti, and I get reasonable frame rates (20-30) even when it's spiking. I just don't know what else to do!Any help would be appreciated.

Share this post


Link to post
Share on other sites

Sounds like a memory problem, try adding at least another 2 gigs of RAM, 4 is a bit marginal.

Share this post


Link to post
Share on other sites

I've actually got 6Gb, but my motherboard has started only posting 4Gb. I've tried all sorts of things, taking them out and putting them back in one by one, changing OC settings, reseating the CPU...I think the board's had it.Any I thought FSX was only a 32 bit app so can't use more than 4Gb?I did wonder perhaps the timings might be off, since the overclock setting is all configured for 6Gb, but would that cause spiking? I thought it was video card related. And it passed stress testing.

Share this post


Link to post
Share on other sites

If you have 6 and the MB is only seeing 4 then yup, you got bigger problems. I have almost the same system as you and so far have never had a spiking issue, which I used to have before upgrading to this system.Win 7 uses almost 2 gigs of RAM all by itself so there isnt much left for other programs, especially if you have other stuff running in the background. I have my 920 oc'd to 3.8, it didnt like 4.0.But again, if your MB is only seeing 4 gigs and you have 6 installed, you have a bigger issue, either bad RAM or the MB is going south.

Share this post


Link to post
Share on other sites

Download Memtest, load it to something bootable, and then run the tests. I had OCZ Platinum with my oc'd 950, and they went bad, but only by running Memtest before the OS boots did I have evidence of memory issues.

Share this post


Link to post
Share on other sites
Sounds like a memory problem, try adding at least another 2 gigs of RAM, 4 is a bit marginal.
Not really.OP, are you using a frame rate limiter? What are you Inspector settings? Can you post you fsx.cfg

Share this post


Link to post
Share on other sites
Hi,I don't know why, but for a long time i've been plagued with autogen spiking/artifacting in areas of Dense or higher autogen. Particularly bad areas i've noticed recently are Orbx PNW near Darrington, and Earth Simulations Guernsey. When exit the virtual cockpit and pan the view around in Spot, the trees and buildings explode. It tends to occur not immediately, but 5-10 minutes into a session, often when I load up in a dense area, fly away and then return to it. This greatly removes the satisfaction of it to me. I've tried so many things to fix it. I even replaced the graphics card from a GTX 285 to a GTX 560 Ti, which has helped a little, but not enough. I've tried with a fresh, untweaked cfg, as well as different Bufferpools, nothing works. My PC is a fairly decent spec, 4GHz i7 920 and the GTX 560 Ti, and I get reasonable frame rates (20-30) even when it's spiking. I just don't know what else to do!Any help would be appreciated.
Tom this surely couldn't hurt to TRY -Backup your fsx config file and go here - let this program generate the fsx/config file for you and put it there, fire up FSX and test...http://www.venetubo.com/fsx.html

Share this post


Link to post
Share on other sites

The only time I get spikes is in Orbx land... with really high CFG settings. So, LOD of 6.5, max autogen and scenery. In a nutshell, there's too much stuff loaded and right after the spikes I normally get a OOM CTD.

Share this post


Link to post
Share on other sites

I'll try Memtest and see what comes up. At the moment i'm locking frames internally at 24fps. I've also tried unlocked (even worse) and locked externally using the Java limiter, the Antilag limiter and the new one included in nVidia Inspector. AA setting is 8xS with no multisampling. 16x AF - all set up according to NickN's handy guide. I've tried using Bojote's tweaking tool, but went back to a vanilla untweaked cfg as it was slightly more stable, though still with spikes. I don't get OOMs, but it sure does detract from the experience with constantly spiking trees and buildings. Do you think backing off my overclock might help? I never remember it being such an issue when I was running at 3.6GHz surprisingly.

Share this post


Link to post
Share on other sites
Do you think backing off my overclock might help? I never remember it being such an issue when I was running at 3.6GHz surprisingly.
As I said earlier, I have the same processor and it didnt like 4.0 but 3.8 is fine. However, again, if you have 6 gigs of RAM and the MB is only seeing 4, you have an issue that needs to be fixed before anything else. Fix that and chances are your spikes will dissapear.

Share this post


Link to post
Share on other sites
Guest firehawk44
I've actually got 6Gb, but my motherboard has started only posting 4Gb. I've tried all sorts of things, taking them out and putting them back in one by one, changing OC settings, reseating the CPU...I think the board's had it.Any I thought FSX was only a 32 bit app so can't use more than 4Gb?I did wonder perhaps the timings might be off, since the overclock setting is all configured for 6Gb, but would that cause spiking? I thought it was video card related. And it passed stress testing.
You're right about not seeing anything above 4GB. You have plenty of memory at 4GB. You really only need 3GB for FSX to run efficiently. You have a 64 bit OS which is good. You might want to make sure Microsoft dotnet 4 is up-to-date as one of it's functions is to manage memory for your applications. Use the Windows update program. Passing a stress test means nothing. I've passed several and I still had problems with FSX until I fixed the memory frequency, timings, and voltages for the installed memory. Spiking indicates memory starvation. You could have your sliders set too high or the memory timings need to be fixed. The settings should be based on what CPU-Z says under the SPD tab (one of the four columns). But I would lower several sliders first and see if that fixes the problem. If not, then it is more likely the memory BIOS settings. What MB do you have installed? Your system should handle the 4GHz OC but that should be looked at too. If it's at the max for the 920, then I would lower it and see if that fixes the problem. Another common problem is manually setting your virtual memory (page file) with max and min settings. If that's your case, I would return them to 'system managed size'. Hope this helps.Best regards,Jim

Share this post


Link to post
Share on other sites

I wonder too if you have that extra 2GB installed in the correct slot or is faulty as that processor needs a minimum 6GB of triple DDR3 RAM and only reporting 4 could mean that one of the RAM slots is faulty or not seated properly or the wrong slot is being used. To upgrade on this system you would need to go to 12GB of DDR3 RAM ie 3 x 4GB best or 6 x 2GB. If the machine is only running on 4GB it is running totally unbalanced.Please don't confuse the VAS (4 GB maximum for FSX SP2/Gold/Accel in a 64-bit OS) with RAM they have very little in common except they both need computers to work. RAM as long as you have enough and it is fast enough doesn't really come into the equation and 6 GB is ample.RegardsPeterH

Share this post


Link to post
Share on other sites

A lower fixed frame rate will also help prevent those spike artifacts. I run at 33 fps, internally fixed. There are dense autogen areas that if I fly unlimited fps always cause those nasty spikes. Also lower autogen gen and water settings can help.

Share this post


Link to post
Share on other sites

I do need to sort the RAM issue out. I have tried everything I can think of. Reseated all the sticks, switched them round. They're definitely in the right slots. It happened when I installed a new CPU cooler. I've checked the CPU socket for bent pins relating to the memory controller but found nothing. All I can think of now is to replace the whole board, and it's now out of warranty so this is going to cost! It's an Asus P6T Deluxe V2. Lower autogen slider helps the spiking, but to me it defeats the point because I would like to enjoy the detail of the scenery and feel I have an adequate spec PC to use at least 'Dense' autogen. I've not changed the page file. One weird thing is that CPU-Z shows that 6Gb RAM is installed, but the BIOS only POSTs 4Gb. When I was trying the slots it always seemed to be the middle orange DDR3 slot not working. All software is kept up to date - I religiously check for updates!

Share this post


Link to post
Share on other sites
Hi,I don't know why, but for a long time i've been plagued with autogen spiking/artifacting in areas of Dense or higher autogen. Particularly bad areas i've noticed recently are Orbx PNW near Darrington, and Earth Simulations Guernsey. When exit the virtual cockpit and pan the view around in Spot, the trees and buildings explode. It tends to occur not immediately, but 5-10 minutes into a session, often when I load up in a dense area, fly away and then return to it. This greatly removes the satisfaction of it to me. I've tried so many things to fix it. I even replaced the graphics card from a GTX 285 to a GTX 560 Ti, which has helped a little, but not enough. I've tried with a fresh, untweaked cfg, as well as different Bufferpools, nothing works. My PC is a fairly decent spec, 4GHz i7 920 and the GTX 560 Ti, and I get reasonable frame rates (20-30) even when it's spiking. I just don't know what else to do!Any help would be appreciated.
Have you tried using rejectthreshold instead of using a low bufferpools setting?

Share this post


Link to post
Share on other sites
Guest firehawk44

If the link I provided above does not help, a Google search of 'CPU-Z shows that 6Gb RAM is installed, but the BIOS only POSTs 4Gb' will provide you thousands of more links....Best regards,Jim

Share this post


Link to post
Share on other sites

Try the BP=0 tweak in your FSX.cfg. This fixed all spiking and stutters for me.

Share this post


Link to post
Share on other sites

I upgrade from a gts 520 to gtx 560, not ti, and I haven't seen any spikes since. I also have a i7 920 but I only overclocked to 2.8ghz. Have you tried lowering some of the settings?

Share this post


Link to post
Share on other sites

I have the same motherboard. If the ram timing is too aggresive for the voltage it will cause the under-reporting of ram. Try setting your ram speed to 1600 8-8-8-24 DRAM voltage 1.64v. External limiter locked at 30, HIGHMEMFIX, and AM=14 should fix the spiking.DaveIntel Core I7 975 Quadcore OC @ 3.75 Ghz (Air)Asus P6T DLX V2 X58 1366, BD Combo Plextor B310SA6GB (3x2GB) Corsair Dominator DDR3 1866C7GTHIS ATI 6950 2GB, Samsung 24", Saitek X-52 ProLogitech Z680 5.1 Speakers, G15 Keyboard, G5 MouseThermaltake Element S Case, Corsair 850HX PSUC: Intel 80GB SSD w/Windows 7 Home 64D: WD 300GB Velocity Raptor w/FSX+Accel+GEX, F4AFE: WD 1TB Caviar Black w/Data SH4

Share this post


Link to post
Share on other sites

Did you ever get your spiking fixed? I was going to say, try removing your bufferpools section and see if it still happens. That would be where I would start. Weird about your mb but I think you vc is maxed due to no bp.

 

ou812

Share this post


Link to post
Share on other sites

×
×
  • Create New...