Archived

This topic is now archived and is closed to further replies.

japangg

Giant spikes/needles in FSX

Recommended Posts

Dear All,

 

I have just returned to FSX world after quite a long hiatus (so long in fact that my AVSIM forum account was deleted), and have just installed FSX on a new machine.  When trying out the FSX after installing, I noticed several giant needles/spikes around the airport where I was flying.  I though at first that there may be errors in scenery data, but the occurance is quite persistent in other airports when I tried out the FSX. 

 

In addition to that, when I have flown for several minutes, a "wall" of single color appear from the ground and obstructed everything, until i "have flown through" that wall.  I cannot attached a screen capture as I have been traveling.

 

Can any of you help me solve this problem?  Is this related to hardware?

 

For reference, my system is as follows:

 

Win7 Home Premium 64bit

16GB RAM

i5 3570k (stock)

Radeon HD7950 boost

 

Thanks in advance.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I get the spikes when things get too easy for my system, like getting over 35 fps with a light resource hungry plane. Maybe try limiting your frame rate ti to 30 fps might help. Or check your display drivers

Share this post


Link to post
Share on other sites

Dear All,

 

I have just returned to FSX world after quite a long hiatus (so long in fact that my AVSIM forum account was deleted), and have just installed FSX on a new machine.  When trying out the FSX after installing, I noticed several giant needles/spikes around the airport where I was flying.  I though at first that there may be errors in scenery data, but the occurance is quite persistent in other airports when I tried out the FSX. 

 

In addition to that, when I have flown for several minutes, a "wall" of single color appear from the ground and obstructed everything, until i "have flown through" that wall.  I cannot attached a screen capture as I have been traveling.

 

Can any of you help me solve this problem?  Is this related to hardware?

 

For reference, my system is as follows:

 

Win7 Home Premium 64bit

16GB RAM

i5 3570k (stock)

Radeon HD7950 boost

 

Thanks in advance.

 

My first thought was certainly scenery corruption - the same effect can be introduced when scenery code hasn't got the correct return codes after plotting scenery objects. That same fault can nearly always be reproduced at the same scenery location.

 

If it is occurring in other sceneries I would suggest a graphics driver or graphics hardware hiccup can also be the culprit. A corrupted loading sequence could also cause the same effect.

 

Is it occurring in the default scenery - or is it an addon ?

 

If you have the disk space I'd move your scenery folders around to say, a 'Temp' folder which FSX cannot access and see if the effect re-occurs.

Try a small number of folders at a time to see if the problem clears.

 

Failing that, a graphics card driver update may be the only option.

 

Hope that helps

Regards

Bill

Share this post


Link to post
Share on other sites

Have you manually added the line

 

HIGHMEMFIX=1

 

to the [graphics] section of your fsx.cfg? (You should!)

 

 

 

What's the size of your fsx.exe when your issues happen? (Have your task manager running beside FSX with the processes tab selected.)

 

 

 

Did you install SP1 and SP2 of FSX? (Acceleration pack alternatively.)

Share this post


Link to post
Share on other sites

Dear All,

 

Thanks for the reply.

 

Have you manually added the line

 

HIGHMEMFIX=1

 

to the [graphics] section of your fsx.cfg? (You should!)

 

 

Thanks for the tip, I will add this to the config file.

 

 


Did you install SP1 and SP2 of FSX? (Acceleration pack alternatively.)

 

I have Acceleration pack installed.

 

 

My first thought was certainly scenery corruption - the same effect can be introduced when scenery code hasn't got the correct return codes after plotting scenery objects. That same fault can nearly always be reproduced at the same scenery location.

 

If it is occurring in other sceneries I would suggest a graphics driver or graphics hardware hiccup can also be the culprit. A corrupted loading sequence could also cause the same effect.

 

Is it occurring in the default scenery - or is it an addon ?

 

If you have the disk space I'd move your scenery folders around to say, a 'Temp' folder which FSX cannot access and see if the effect re-occurs.

Try a small number of folders at a time to see if the problem clears.

 

Failing that, a graphics card driver update may be the only option.

 

Hope that helps

Regards

Bill

Noted on moving the Scenery folder to a temporary folder.  The problems occurs both  in the default scenery and add-on scenery (I have several Aerosoft add-on airports installed).  I have also use the latest official ATI driver.

 

Thanks for the assistance.

Share this post


Link to post
Share on other sites

<p>I'm getting a similar issue when the FSX process gets to around 3 GB, then I start hearing Windows warning sounds shortly after and then it'll OOM if I fly much further. To be honest, I think my sim is totally messed up and needs a complete reinstall, I've got OOMs, microstutters, blurries, lotta. But putting on all my Horizon VFR X Scenery takes hours, then the tweaks, then all my tweaked addons etc *large sigh*</p>

<p> </p>

<p>And yes I have tweaked my FSX.cfg with Hihjmemfix=1, amongst other tweaks and I'm running Win 7 x64 on 8 GB of RAM so I wouldn't expect to be seeing these kind of issues until hitting more like 4 GB of FSX process usage - is there anything I can do make sure FSX really is using the full 4 GB of addressable space?</p>

Share this post


Link to post
Share on other sites

FSX - inclusing SP2 - can be very unreliable with its "4GB awareness". It should be able to run up to 4GB on a 64bit system, but I've seen OOM issues and OOM messages way earlier at times - even close to 3GB ...

 

That's why I suggested to run the task manager - maybe the size of the fsx.exe can help either to confirm or to exclude an OOM.

Share this post


Link to post
Share on other sites

Dear All,

 

Thank you for the replies.  I'm glad that I'm not the only one with this problem.

 

@Bill:

What is "4GB Awareness"?  and how do I prevent that or the OOM?

 

regards

Share this post


Link to post
Share on other sites

My name ain't Bill, but ##### ... why should I care?

 

FSX is 32bit and 32bit applications can use a maximum of 4GB RAM - the 'default' is, they are configured to use just about half of that (2GB).

 

So most 32bit applications need to be 'tweaked' in order to use the full (max) 4GB - this 'tweak' is applied to FSX via the 2nd servicepack (SP2). SP2 is included in the Xpack, so you're good to go in that respect, anyway.

 

4GB is the upper limit for any 32bit app - there is no way at all to make a single 32bit app use any tiny bit more of your 16GB RAM - not even with a W7 64bit OS.

 

This is where the OOMs happen: If the fsx.exe approaches the 4GB limit, you get weird graphics/spikes and maybe (maybe!) a FSX window pops up that wants you to reduce your scenery settings.

 

And that's exactly the fix: Reduce and balance your settings (graphics, textures, clouds, shadows, scenery in general, AI traffic) to stay below the 4GB limit.

 

But it would help a lot if you could confirm that your fsx.exe actually goes beyond the 3GB size, heading for those 4GB ...

Share this post


Link to post
Share on other sites

i used to see those black giant spikes around my plane too sometimes, when i panned the view. on top of every single spike is a tree or house (i am guessing the autogen objects) and they will "fall" down to their place, making the black spike disappear.

 

while i have the same OS, same CPU and half the RAM, i am running with a NVIDIA gpu, so i think the tweaking is different, but if your system is running normally (meaning: if your computer is clean and not packed with background tasks and stuff)

you should be able to deal with this problem.

 

for me it started when i tweaked around the FSX.CFG file. after i reduced

"FIBER_FRAME_TIME_FRACTION" to 0.2, in conjunction with "UsePools=0" and probably messing with "TEXTURE_BANDWIDTH_MULT" and also "TextureMaxLoad

" i started getting the scary black spikes in scenery i always had no problem with!

 

now for me it was just a matter of changing some of those options to the point they seem to work together perfectly with my CPU/GPU and i have not seen those spikes ever since (knock on wood!)

 

if your GPU has 2GB or more videoram you should try the usepools=0 and check your other options.

 

for me, at the moment, these settings work best:

 

[bufferPools]
UsePools=0

 

[Display]

TEXTURE_BANDWIDTH_MULT=120

 

[Main]

FIBER_FRAME_TIME_FRACTION=0.30

 

[Graphics]

HIGHMEMFIX=1

 

i think you can find good tutorials on tweaking the FSX.CFG right here on avsim.com and also searching google for "fsx tweak guide" will lead you to some excellent resources. be warned though, as my example shows, too much tweaking can mess up your experience!

 

good luck, i hope you can enjoy flying FSX again soon.

Share this post


Link to post
Share on other sites

The spiking can also come from an overloaded GPU, or overheating GPU...

 

Read the guide here on avsim, as to how to configure fsx via the fsx.cfg and so on most effectively for your hardware.

 

A

Share this post


Link to post
Share on other sites

My name ain't Bill, but ##### ... why should I care?

 

FSX is 32bit and 32bit applications can use a maximum of 4GB RAM - the 'default' is...

 

Hi Olli4740, sorry for the mixed up....i though I saw your siggy with Bill something on that, but I was mistaken.  Terribly sorry for this.  Thanks for the explanation.  I will keep this in mind and will monitor the size of fsx.exe when I am back from my business trip.  It's a bit ironic isn'it...my fairly capable gaming rig has to run a relatively old application at a reduced setting.

 

tofupete and aentwis: thanks for the tips.

@tofupete: i'd wager that you like tofu? :rolleyes:

 

regards

Share this post


Link to post
Share on other sites

:lol:  yes indeed. i am a vegetarian and love to cook with tofu in many different variations.

Share this post


Link to post
Share on other sites

It's a bit ironic isn'it...my fairly capable gaming rig has to run a relatively old application at a reduced setting.

Not ironic at all when you understand FSX was originally designed to be run on single core CPUs running at >6GHz.

 

I doubt your "fairly capable gaming rig" meets those specs. :rolleyes:

 

regards,

Joe

Share this post


Link to post
Share on other sites

the talking about cores reminded me of something else. since we have the same CPU (4 cores)

you might want to see if you already have this in your fsx.cfg

 

[JOBSCHEDULER]
AffinityMask=14

 

for me this seems to work best. for an indepth explanation of this setting you can consult the usual tweaking guides, it basically tells fsx how to use the cores.

Share this post


Link to post
Share on other sites

Hi Olli4740, sorry for the mixed up....i though I saw your siggy with Bill something on that, but I was mistaken.  Terribly sorry for this.  Thanks for the explanation.  I will keep this in mind and will monitor the size of fsx.exe when I am back from my business trip.  It's a bit ironic isn'it...my fairly capable gaming rig has to run a relatively old application at a reduced setting.

 

(...)

regards

 

No worries, I was just kidding ...

 

the talking about cores reminded me of something else. since we have the same CPU (4 cores)

you might want to see if you already have this in your fsx.cfg

 

[JOBSCHEDULER]

AffinityMask=14

 

for me this seems to work best. for an indepth explanation of this setting you can consult the usual tweaking guides, it basically tells fsx how to use the cores.

 

W7 does a pretty good job by itself to balance load between those cores. You could give AffinityMask a try, but keep in mind that settings are different for 4core CPUs with or without hyperthreading (4coreHT adds 4 shadow cores to the equation, so the AM value must be different).

Share this post


Link to post
Share on other sites

 

 


The spiking can also come from an overloaded GPU (snip)

 

This is usually the problem.  Too high of autogen, cloud cover, water detail settings in combination can lead to these spikes.  What seems to happen is FSX floods the graphics card with too much data and the card can't keep up, resulting in spikes and other graphics artifacts such as white textures.  Try using the free MSI Afterburner tool to monitor GPU usage.

Share this post


Link to post
Share on other sites

Supporting what has been said above about the GPU, this occurs for me when using the Bufferpools tweak. I do see better performance with it, so I have learned to accept it, but if removed the spikes disappear as well.

Share this post


Link to post
Share on other sites

"Autogen spikes" can be stopped, on most computers, by locking FPS at 30 instead of unlimited. The twesks will help the stuttering.

 

Dave

Share this post


Link to post
Share on other sites

I had these on my old Core2Duo when I set my settings up too high, Autogen particularly, and AI traffic. Turning them down magically fixed everything, no tweaks needed.

 

Share this post


Link to post
Share on other sites

and by correctly tweaking you can leave your sliders at a higher setting, while eliminating the artifacts and enjoy more details!

Share this post


Link to post
Share on other sites

 

 


FSX is 32bit and 32bit applications can use a maximum of 4GB RAM - the 'default' is, they are configured to use just about half of that (2GB).

 

This is a wrong statement.  In a 32 bit version of Windows, FSX can only use 2GB unless you employ the /3GB or UserVA switch.  Then FSX can only use up to a max of 3 GB.  In a 64 bit environment, FSX can use up to a max of 4GB's.  Any additional memory installed will be used for running Windows applications and services.  So, if you only have 4GB's of memory, FSX will probably use the max of 3GB's as Windows needs the rest to run apps.  A better explanation can be found in NickN's Setting up FSX and Tuning It guide - http://www.simforums.com/forums/topic29041.html.  You were on the right track though.  Just wanted to clarify it as I think it is important that anyone using FSX should install a 64 bit version of Windows 7 or 8.

 

Best regards,

Jim

Share this post


Link to post
Share on other sites