Jump to content

Archived

This topic is now archived and is closed to further replies.

mpw8679

Microstutters? 1/2 refresh fix?

Recommended Posts

Hey guys,  Has anyone been able to apply the 1/2 refresh rate in NI with a locked 30 FPS with success?  I have tried along with all the different settings in V2 but still get the annoying stuttering I had in FSX before the 1/2 refresh rate fix.  All I have heard about V2 is how smooth and stutter free the sim is.  So far my experience with V2 is worse fps, worse stuttering, and far worse AA.  This with a 2500k at 4.5 and a 670 gtx.

Share this post


Link to post

Matt,

 

try FIBER_FRAME_TIME_FRACTION=0.1 and BUFFERPOOLS=0 in the CFG file. This made my P3D smooth without any stutter.

 

Regards,

Michael

Share this post


Link to post

Matt,

 

try FIBER_FRAME_TIME_FRACTION=0.1 and BUFFERPOOLS=0 in the CFG file. This made my P3D smooth without any stutter.

 

Regards,

Michael

Made no difference for me.  I really can't believe I am getting worse performance with a base install of p3d v2 compared to FSX with many intensive add ons.  And this is with most p3d options turned down.  Doing back to back comparisons my FSX is looking better and performing better then p3d at this time.  Something funky going on here.

Share this post


Link to post

Yeah there's an issue with Windows Desktop. Also if you are using SLI, turn it off, it causes stutters. Finally, try an older driver if you're using a newer one.

Share this post


Link to post

Yeah there's an issue with Windows Desktop. Also if you are using SLI, turn it off, it causes stutters. Finally, try an older driver if you're using a newer one.

Ya this has nothing to do with windows, drivers, or video card.  There are a few topics on the LM support forum talking about this issue.  Basically we need the 1/2 refresh rate option to get a smooth sim.  LM claims that using there in game vsync plus triple buffering fixes it, but it does not.

Share this post


Link to post

I am in the same boat with the micro stutters, it is driving me insane. I have had such a smooth experience with FSX DX10 since being able to use the 1/2 refresh rate option. To me the micro stutters are so prevalent it make the sim unusable for me.

 

Interestingly in another thread I found someone had turned off Aero and fixed the micro stutters. I tried this also and it did stop my micro stutters but obviously made the sim equally unusable due to no vsync and tearing.

 

So why is it that some people are not needing 1/2 refresh rate to achieve a smooth sim but others do.

 

I have spent countless hours trying everything to find a solution. Looks like I am going to have to park this for a while until LM & Nvidia come up with a way forward. I certainly hope this happens as I can see the potential in p3dv2.

 

Michael M

 

 

Sent from my iPad using Tapatalk HD

Share this post


Link to post

I had to go through several older Geforce drivers to find one that eliminated the stuttering. It may be wise to do so also. It may not be enough to just try one older one. I had to try about 5 different versions before I landed on 307.64 to kill the stuttering.

Share this post


Link to post

I am in the same boat with the micro stutters, it is driving me insane. I have had such a smooth experience with FSX DX10 since being able to use the 1/2 refresh rate option. To me the micro stutters are so prevalent it make the sim unusable for me.

 

Interestingly in another thread I found someone had turned off Aero and fixed the micro stutters. I tried this also and it did stop my micro stutters but obviously made the sim equally unusable due to no vsync and tearing.

 

So why is it that some people are not needing 1/2 refresh rate to achieve a smooth sim but others do.

 

I have spent countless hours trying everything to find a solution. Looks like I am going to have to park this for a while until LM & Nvidia come up with a way forward. I certainly hope this happens as I can see the potential in p3dv2.

 

Michael M

 

 

Sent from my iPad using Tapatalk HD

Make sure and post your issue at the Lockheed Martin support forum

Share this post


Link to post

I had to try about 5 different versions before I landed on 307.64 to kill the stuttering.

Would you mind to provide a d/l link for these? I didn't find them neither in the Nvidia archive nor at evga.com or guru3D...thx!

Share this post


Link to post

Exactly the same problem. I spent more than a day simply playing around with the basic setup, using only medium settings but simply couldn't get Vsync to work properly or fly smoothly. I'm back to FSX for now.

Share this post


Link to post

I've spent two weeks try every form of vsync there is.It won't/can/t work as it locked to adaptive in the program.

Share this post


Link to post

The 1/2 setting has never worked for me in FSX or Prep3d because I would get tearing so I enabled the frame limiter to 40fps and I've had no stuttering or tearing whatsoever.

Share this post


Link to post

1/2 vsyn setting would work in FSX but only in Fullscreen mode unless you disabled Aero. But, I never had much luck with that.

Share this post


Link to post

On the nVidia drivers page is a selector for older drivers. I am on 314.22 and it looks good. No limiters so I can "enjoy" FPS while I wait for the first update. I confess that I have reverted to 1.4, not because of Lockheed but ORBX, most of their stuff is not ready for 2.0 and it may be a long time before everything is updated. Of course, I will not buy more of their stuff until the final update.

 

If you look at the change list for the drivers almost all changes/updates are for blood and guts games used by kiddies to save the world and cards much newer than mine. Almost no reasons to upgrade a driver.

Share this post


Link to post

This adaptive vsync is not cutting it. However the 1/2 refresh rate one works in fsx using inspector is exactly what we need here for this too.

 

I hope LM are listening!

Share this post


Link to post

Give it some time, I'm sure they are working on it so let us have some patience.

Still remember the first weeks/months of FSX? <_<

Share this post


Link to post

You really need to tell if you run FSX/P3DV2 in fullscreen or Windowed Mode. I have so many issues in DX10/DX11 in Windowed with undocking panels

 

VSYNC or no VSYNC ,Aero=on or off (how do you check if its on or off for that matter ?)

Share this post


Link to post

If you're having microstutters try setting your refresh rate 1/2 manually.  I have a 37in LCD TV that runs at 60Hz, so I manually set it to 30Hz using Nvidia control panel.  Using Nvidia Inspector, set vertical sync tear control to standard and vertical sync to use 3D application setting, then lock FPS to 30 in P3D. 

 

This work around solved my stuttering issues in P3D, I also tested it in FSX just out curiosity and it works fine.  The only side effect I've encountered is a slower mouse speed/lag on the desktop. 

 

Hopefully LM/nvidia fixes this in the future. 

 

 

post-169914-0-43150400-1386987692.gif

Share this post


Link to post

 

 


so I manually set it to 30Hz using Nvidia control panel

 

Um, I have no option with my monitor in Nvidia Control Panel to change it to 30?

Share this post


Link to post

You can change it to 30Hz by making a custom resolution preset, or via Windows display manager in the advanced section on the monitor tab.

 

I just have no idea why anyone would manually change the refresh-rate of a 60Hz monitors to 30Hz.  That's not the intention of 1/2 refresh rate. :lol: The image quality should look terrible on top that the noticeable flickering should give you a migraine in 5 minutes

Share this post


Link to post

Like I said, only noticeable difference is mouse speed/lag on desktop.  Image quality is the same, there's no flickering at all, and my head feels fine after 2 days of testing this out.  I'm using a Samsung 37in 1080p LCD TV.

Share this post


Link to post

Simply is going to take a Vsyn incorporation and or a true fullscreen mode. ive seen 100's of this worked for mes. No goods. But its worth trying I reckon. I rather be flying than F@#@# around trying to make something work that never will beyond program changes.

Share this post


Link to post

Never heard of a monitor running that far below it's native refresh rate (let alone an LCD) and not have noticeable  side affects visually. The only time I've ever purposely set my refresh rate below 60 is when Crysis had this weird bug on Windows 7. It would run at 24p if your monitor was set at 60Hz... You had to create a custom resolution, set it to 59Hz instead and the game would run at 1080p again. 

Share this post


Link to post

Hey guys,  Has anyone been able to apply the 1/2 refresh rate in NI with a locked 30 FPS with success?  I have tried along with all the different settings in V2 but still get the annoying stuttering I had in FSX before the 1/2 refresh rate fix.  All I have heard about V2 is how smooth and stutter free the sim is.  So far my experience with V2 is worse fps, worse stuttering, and far worse AA.  This with a 2500k at 4.5 and a 670 gtx.

 

Get rid of ALL Inspector settings, set them to OFF or Application Controlled.  Get rid of the P3D profile in Inspector as well unless it's set everything to off.  Next run V2 in frames unlimited mode.  Next set VSYNC to ON, triple buffering on or off you can try, it's on for me.  I have no micro stutters whatsoever.   I will revisit Inspector for better AA settings if LM can work that piece out w/ nV.  It took me a day or two to believe Inspector settings are a bad thing for V2, even though this has been cited many times, I just had a hard time accepting it.  If you are having these sorts of issues something fundamentally is very off w/ your setup.  Are you running the latest nV drivers presumably?

Share this post


Link to post
×
×
  • Create New...