Sign in to follow this  
mvdb001

"flash" after changing view in P3D.

Recommended Posts

I'm having issues with a short "flash" just after changing views in prepar3d V2.4, this flash means that my volumetric fog is briefly switched off and then on again. This is only noticeable when I have volumetric fog enabled and some fog is present. However I also get a very short hardly noticeable bright flash in my cockpit displays but this does not annoy me.

After changing view or when selecting the same view twice, the volumetric fog is "switched off" for I guess less than half a second and then switches back on again. I tried to search the internet for a solution but haven't found anyone with the same problem. Any suggestions how to get rid of this?

I just did a fresh install of prepar3d v2.4 because I thought some of my addons were causing this "flash" but apparently they did not because still having this issues (so I guess no addons like ezdok or  any weather program is causing this problem).

Also HDR is disabled. When HDR is enabled my entire screen flashes white when changing view. Anny suggestions how to get rid of this problem are welcome. I use Ezdok fore changing views in my VC, so these "flashes" are very annoying...

 

My pc: intel I5 3750K with a Geforce GTX 680.

 

Michiel

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Hi mate

yep same here.i also use Ezdok button assignments to change views.

seems it effects the visibilty somehow.

all i can say is....you are not Alone. :smile:

 

   steve

Share this post


Link to post

Likewise.

 

I thought it may have been a key assignment "clash" but I haven't managed to track it down yet....

Share this post


Link to post

Hmm.. I am getting a slight flash with Opus cameras (set to instant change), usually near the horizon.

 

Was thinking of EZDOK as alternative but now maybe not...

 

gb.

Share this post


Link to post

Guys good to see I'm not the only one having this problem. I don't think its Ezdok causing this, but P3D. Right now I have a clean install of p3d without Ezdok installed and still have this issue. When I change view only using the P3d view-menu I'm still having the volumetric fog stops working for a second and then coming back on again. Strange to find so little information about this issue, seems to me it's a BIG bug in how de volumetric fog is rendered within P3D.

Share this post


Link to post

I have the same problem with Ezdok, and have not been able to find a fix. I will follow this thread, and will post any info if I find it. Please do the same!

Share this post


Link to post

Here is how to fix it

 

Navigate to C:\Users\Yourname\AppData\Roaming\Lockheed Martin\

 

Open up Cameras.cfg in a text editor and change the last line in [CameraDefinition.002] to read HotKeySelect=0

 

[CameraDefinition.002]
Title = Virtual Cockpit
Guid = {C95EAB58-9E4A-4E2A-A34C-D8D9D948F078}
Description = This is the description of the virtual cockpit view.
Origin = Virtual Cockpit
MomentumEffect =No
SnapPbhAdjust = Swivel
SnapPbhReturn = False
PanPbhAdjust = Swivel
PanPbhReturn = False
Track = None
ShowAxis = YES
AllowZoom = TRUE
InitialZoom = 0.7
SmoothZoomTime = 2.0
ZoomPanScalar = 1.0
ShowWeather = Yes
XyzAdjust = TRUE
ShowLensFlare=FALSE
Category = Cockpit
PitchPanRate=30
HeadingPanRate=75
PanAcceleratorTime=0
HotKeySelect=0

Share this post


Link to post

Thanks glynn i'll try this.

 

  steve

 

This worked for me..nice one glynn.

 

 steve :smile:

Share this post


Link to post

 

 


HotKeySelect=0

 

So do you know why this one works?

Thanks,

gb.

Share this post


Link to post

Wow, this has been annoying me for a long time, but Glynn's solution works!

I did not know about this. Very nice!

 

You should write a post in the P3D Tips and Tricks subforum about this.

 

Thanks, Glynn!  

Share this post


Link to post

Here is how to fix it

 

Navigate to C:\Users\Yourname\AppData\Roaming\Lockheed Martin\

 

Open up Cameras.cfg in a text editor and change the last line in [CameraDefinition.002] to read HotKeySelect=0

All this does is disable the default F9 (instant VC view) from the Control assignments in the UI.

 

By default [CameraDefinition.002] is assigned to HotKeySelect=1 which in turn is assigned to F9 in the Controls dialog.

 

By changing [CameraDefinition.002] as you suggest to HotKeySelect=0 simply assigns the view to an un-assigned key-combination in the Controls dialog.

 

One could probably achieve the same effect by simply deleting the default F9 key assignment in the Controls dialog...

Share this post


Link to post

I think your right FR Bill

so just to be sure i took the F9 key out as well

This issue was a big distraction for me,so i'm very grateful for the help in solving it.

 

  steve

Share this post


Link to post

 

 


All this does is disable the default F9 (instant VC view) from the Control assignments in the UI.

 

Bill you are correct that's all it does regarding the default FSX/P3D view system.

However the issue is with Ezdok and the way it controls the VC view.

With Hotkeyselect=1 any haze or fog is momentarily cleared as you move between different VC viewpoints.

I have just tested this again as I was curious to see it deleting F9 would also work.

with F9 removed from the FSX/P3D controls the flasing and removal of haze still happens, if I then edit the Camaras.cfg [CameraDefinition.002] section to have Hotkeyselect=0 then the haze and fog are not cleared.

Other Ezdok users can confirm this behavior, the Dev is AWOL so we are stuck with editing the Camera.cfg for now.

 

Are you an Ezdok user by any chance ?


Bill, I just tested again and you are correct, removing F9 is probably the safer way for most folks.

Share this post


Link to post

Hi Glynn,

 

I want to acknowledge that your 'HotKeySelect=0' solution indeed works.

 

Many thanks Glynn and to Michiel for asking the question.

 

JJ (a long-time user of EZdok)

Share this post


Link to post

Ha Ha! After further testing, changing the 'HotKeySelect=1 to HotKeySelect=0' does in fact work but regrettably causes EZdok's VC cameras to be corrupted after switching to Aircraft cameras and back. At least that's been my experience so far. Please provide feedback on your experience to help sort this out.

 

Thanks,

 

JJ

Share this post


Link to post
Are you an Ezdok user by any chance ?

 

Bill, I just tested again and you are correct, removing F9 is probably the safer way for most folks.

No, I have no interest in EZDok at all. I wonder if changing the camera to 0 and also reassigning the F9 key to camera 0 would accomplish both goals.

Share this post


Link to post

strange goings on.

had to update one of my aircraft and now the problem has returned.

even though i have removed the F9 key from the Controls menu and also changed the Hotkey setting to 0.

i can see the Flash once again when i change views with a key button...Grrrrr

 

 

 steve

Share this post


Link to post

This does indeed fix the flashing! Amazing. Although yeah if you click back to a cockpit view from outside the plane, there's no 'virtual cockpit' for it to revert back to. But it's simply a case of right clicking and selecting the virtual cockpit from the menu. I can live with that if it means no more flashes!

 

Thanks.

Share this post


Link to post

This does indeed fix the flashing! Amazing. Although yeah if you click back to a cockpit view from outside the plane, there's no 'virtual cockpit' for it to revert back to. But it's simply a case of right clicking and selecting the virtual cockpit from the menu. I can live with that if it means no more flashes!

 

Thanks.

 

Ah that's how you get back to VC. Thanks. Yes this fix will work for now. The flash was killing me.

Share this post


Link to post

Instead of the right click you can set a button press through FSUIPC as a shortcut to the virtual cockpit.  I set a button on my joystick.  After moving to an external view I simply press that button followed by an interior camera selection through EzDok.  One extra button press but well worth it to eliminate the flashing.  Excellent work guys and a big thank you to the contributors.

Share this post


Link to post

Isn't the flashing just a texture overload? When your switching views and you have high settings this seems to be a common problem in both FSX and P3D.

Share this post


Link to post

strange goings on.

had to update one of my aircraft and now the problem has returned.

even though i have removed the F9 key from the Controls menu and also changed the Hotkey setting to 0.

i can see the Flash once again when i change views with a key button...Grrrrr

 

 

 steve

 

Steve, look at the aircraft.cfg of the updated aircraft. There are some Hotkeyselect entries for the cameradefinitions. I have deleted them and it worked again. Don't forget to backup the aircraft.cfg before making any changes.

 

Sven

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this