Sign in to follow this  
boez

Selecting Ultra water detail setting causes P2 state lock-in on nvidia drivers?

Recommended Posts

(I intended to post this on LM’s forum but seem to be having issues logging in there).

 

Can anyone else confirm that when Ultra water detail level is selected the nvidia driver P-State drops down to P2 level - GPU-Z or Nvidia Inspector can be used to check for this.

 

On my hardware (see below) this issue exists on both my Windows 8.1u1 and Windows 10 dual boot. These were both fresh installs with no other software except Prepar3d. Zero tweaks and addons.

 

The issue is repeatable and happens either if changed when running or before starting the App after editing the config file. Dropping the setting from Ultra to any other level sees P0 restored. It seems to be independent of any other setting, tessellation level, LOD, etc. Selecting ‘Prefer Maximum Performance’ in NI has no effect either.

 

On Windows 10 the CPU usage also goes to 100% on all 4 cores although this is not the case with 8.1.

 

P-State level P2 means that the GPU is only running at around 80-90% of its potential and so is a big performance hit on top of what might be expected for clicking the slider one more position to the right. This means lower base clock speed, boost will not kick in and VRAM memory speed is limited to 3000Mhz rather than 3500Mhz. Also any GPU overclocking - which is usually setup for P0 state - will not see the benefit while in P2.

 

If you are running Ultra water may want to check this out as I have been doing so since purchasing the 980GTX and thus have not being using it to its full potential!

 

4790K @ 4.8/46

980GTX

Windows 10 - driver 352.84

Windows 8.1u1 - driver 353.06

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Whoa! I'll have to take a peek when I get back home...

Share this post


Link to post

My water setting is ultra, with all the bells and whisles enabled.

 

I cannot reproduce the issue, just checked with NI on my GTX 670, it stays in P0 state.

 

This is on Win 7 /64, driver 353.06 (latest).

Share this post


Link to post

Ditto with a GTX660Ti on Win 7/64 wit 353.12 (the actual latest, JP)

 

What other changes have you made that might have caused this? P3D .cfg by any chance?

Share this post


Link to post

He said he saw this on Windows 8.1 Update 1 and Windows 10 while you both have Windows 7, so that may be a hint there.

Share this post


Link to post

 Running GTX970 here on 353.06 in Win 7 64 and mine jumps back and forth with the water setting as well.

Share this post


Link to post

Ditto with a GTX660Ti on Win 7/64 wit 353.12 (the actual latest, JP)

Haha, sorry Louis! :)

Share this post


Link to post

Using drivers 347.52 on windows 7 and my P state remains at P0 the whole time  with no downgrade on the vram clk or the gpu overclock. Water is on ultra.

Share this post


Link to post

 

 


He said he saw this on Windows 8.1 Update 1 and Windows 10 while you both have Windows 7

 

Exactly. Can anyone with Win 8.1 or 10 weigh in?

Share this post


Link to post

Missed from my spec that it's 64 bit edition for both OS (in case that makes I difference). detail on.

 

Totally fresh install of both and no configuration file tweaks or ni tweaks as stated. I repeated this full start from blank install process several times at the weekend just to make sure and each time same result.

 

Other settings that may be relevant are full tessellation and 10m mesh, bathymetry on and terrain and cloud reflections. I did try all these on and off and same result, I.e. P2 locked with ultra selected. Weird that it looks like it's isolated to my system but thanks for checking.

Share this post


Link to post

I can confirm this happening on my system also. i was running Ultra at P2, switched to High and it switched over to P0, resulted in a huge performance increase for me too, thanks for pointing this out!

 

Running windows 8.1, latest updates and a GTX 980. 

Share this post


Link to post

Confirmed using Nvidia Inspector that this is occurring on my 980 as well (in Win 8.1). Switching water effects to High brought the P-State to P0.

 

This is a rather huge issue (which many might not even realize they're hitting!) - have you reported it on the P3D forums Boez?  

Share this post


Link to post

Maybe this is a dumb question, but is the use of the ultra water setting causing the driver to throttle the GPU back to the P2 state? BTW, I'm running Win 8.1 with water set to ultra and I am always running at the maximum power state with a GTX 980 Ti and driver 353.12. The possibilities are that the either:

  • the PCIe Link State setting under Windows Advanced Power Settings has somehow changed  from "Off" to something else.
  • the nVidia driver power setting is not set at "Prefer maximum performance"
  • or lastly, it could be a bug in the nVidia driver that only impacts some systems and graphics cards.

Share this post


Link to post

Thanks Jay - GPU load, thermal, and voltage are well below their thresholds with Ultra enabled, so it shouldn't be naturally throttling back (and to confirm this is with the power setting at "prefer maximum performance").

 

I'm running the latest 353.06 WHQL drivers; I don't see the 353.12 ones you noted for download...are those out in beta?

Share this post


Link to post

Just checked, and it's happening on my system too.

 

I'm running P3D 2.5.12945 on Windows 10 Pro Insider Preview build 10074 (slow update setting) with a Titan Black on driver 352.84 (latest driver for Windows 10).

 

The PCIe Link State setting is off and the Nvidia driver is set to "Prefer maximum performance".

 

Not sure what impact it has, but worth looking into.

Share this post


Link to post

(Edit -> Oops missed kmagelie reply which puts my theory of it being GPU architecture into doubt!).

 

 

So it looks as if a pattern maybe emerging based on GPU (at least with the limited sample population so far):

 

Dave_YVR : 970GTX - Win7 64

DylanM : 980GTX - Win 8.1

shaddyy : 980GTX - Win 8.1

myself : 980GTX - Win 8.1 / Win 10

 

Although if this is the case then it looks limited to the GM204 architecture as Jay is not seeing the anomaly with his Ti (that's with a different driver which I'll try after work).

Share this post


Link to post

Running Windows 8.1, GTX980, driver 353.06, P3D with water @ Ultra and my profile stays and never moves from P0.

 

Flying right now and monitoring.

Share this post


Link to post

Post by Beau Hollis (Prepar3D Rendering System Lead) over at LM forums:

 

http://prepar3d.com/forum-5/topic/selecting-ultra-water-detail-setting-causes-p2-state-lock-in-on-nvidia-drivers/#post-109054

 

 

----------------------------------------------------------------------------------------------------------

Quote:

When Ultra water is enabled, the 3D waves are enabled. The 3D wave simulation relies on CUDA when using NVidia hardware. My guess would be that either:

a) In the case of using CUDA and Rendering pipelines in the same app the driver drops the level to reserve resources for CUDA

b) The level drop is a because our water simulation does not build against the most current cuda libraries.

 

When last I tested, the cuda based wave simulation was faster than the Direct Compute version (which is used by any cards lacking cuda support). If you want to try using Direct Compute, you can do the following:

1) Open File: Prepar3D v2\TritonResources\Triton.cfg

2) change “disable-cuda = no” to “disable-cuda = yes”. This should be around line 128.

3) Try to fight the urge to tinker with the rest of the config options.

4) If you fail at step 3, please back up your config file first. It’s very easy to break the water or even cause crashes by changing settings in this file because we only use a small subset of the Triton library and we modified the source to disable features we’re not using.

 

----------------------------------------------------------------------------------------------------------

Share this post


Link to post

3) Try to fight the urge to tinker with the rest of the config options.

4) If you fail at step 3, please back up your config file first. It’s very easy to break the water or even cause crashes by changing settings in this file because we only use a small subset of the Triton library and we modified the source to disable features we’re not using.

 

Love the support from the Devs...and it's obvious they know their user base quite well by now :lol:

Share this post


Link to post

 I just tried the suggested fix mentioned above and can confirm that it does now set the P state to 0 with water on Ultra.

 

 Cheers to boez for linking the fix and of course to Beau for the support.

Share this post


Link to post

Not tried it myself yet but glad to hear Dave had success.

 

Curious as to what is the cause on certain PCs that are affected. One thing I remembered is that when I install nVidia drivers I always deselect everything except the graphics driver...could that be a factor?

Share this post


Link to post

Confirmed that Power State now remains at P0.

 

I've posted on LM thread asking how the performance of non-CUDA ultra water detail (i.e. the fix) is compared to the default situation of using CUDA. Even though I can now select that setting I would like to think the hit I'm getting is not too big (if at all).

Share this post


Link to post

GPU load, thermal, and voltage are well below their thresholds with Ultra enabled,

 

Certain nVidia cards drop down their clock a notch at 70°F, but only using specific drivers. For example, take a look at how  my old GTX 680 handled temperature.

 

EDIT: I should have added a link to the article, in case anyone wanted to test their GTX 980 with GPU-Z:

 

http://www.overclock.net/t/1265110/the-gtx-670-overclocking-master-guide

 

The guide is not for our generation cards, but the procedure for testing the boost clocks is pretty much the same. I would also suggest perusing the nVidia message boards, because there are a few threads about the thermal behavior of Maxwell cards with recent drivers being a bit squirrely. I didn't post any links, because the threads seemed more speculative than helpful.

34a9aeaa_clock_vs_temp.gif

Share this post


Link to post

Jay

 

Interesting graph but

I can turn every other setting completely to the left and yet still see P2 if water at ultra. I'm pretty certain it's not thermal protection kicking in. My open frame case means my Gpu temperature barely goes above 60degC even during high loads. (Scottish weather helps too!)

 

LM have provided a work around based on removing CUDA from the ultra water calculations although this doesn't explain the cause but does remove the effect with all else unchanged including average temperature.

 

Andy

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this