Sign in to follow this  
PinkJackal

Windows 10 Pro and FSX smoothness

Recommended Posts

Hi guys! 

I've upgraded my OS to Win 10, I've done a clean install of both OS and FSX, and I have a bad stutter with fsx with default plane and default scenery, fps stays locked at 30.

Does any one has this problem, I have the latest nVidia driver installed.

 

My pc

 

I7-4790K - 4.6ghz

16Gb Ram 1866mhz

GTX760 4gb Evga

1080p monitor

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Albert,

 

Jus too say your not alone! I cannot run FSX in DX9 anymore runs smooth locked at thirty then every 7to 10 seconds the scenery below judders stutters..also panning is impossible as is turning this is with the Trike at default settings.

 

I have tried everything even DX10 which actually runs better until you add say the AS AIrbus then it will s more of the same issue.

 

I have run the sims side the beginning and have never seen this and it seem to start with win 7 I cannot locate a bad part in the PC which does not mean it is not there..all is locked ar 30 fps but will not flow..this after fresh installs of everything.

 

I personally think Nvidia are messing about with the vsynch internal clock in there drivers...my system is good and has never not been able to run like this.

 

I have given up will see what P3D is like v3 and my switch or just stop alto get her as the enjoyment has gone...

 

Time will tell hope you get your sorted.

 

All the best

 

Mark

Share this post


Link to post
Share on other sites

I have upgraded operating system to Windows 10 Pro from Windows 8.1. After some tweaking I achieved somewhat smooth operation within FSX-SE. Add-ons that I'm running are ASN, PMDG 737, REX-texture direct and soft clouds. What I can tell is that recently I found out that playing around with internal weather option in FSX, particularly clout coverage density can have significant impact on the FPS. So lowering that option for me was the FPS holy grail. Besides that ASN can have significant impact on the FPS via its externally controlled weather options such as cloud coverage area. Also in my experience unleashing internal FPS limiter was a great in increasing the FPS.

 

For FSX in little tweaks lies a good chunk of FPS gains.

 

Hope this helps a little bit

Marko 

Share this post


Link to post
Share on other sites

The fact is that I love win 10 so much, I don't want to switch back to win 7, everything is so smooth in win 10.

I have the usual tweaks in FSX.cfg, the same as I had in win7.

 

If I can't sort this out I will stay with x-plane as my main sim, but I will miss my PMDG 777.

Share this post


Link to post
Share on other sites

I found FSX felt very laggy under Win 10. I rolled back to 7 with no plan to try again anytime soon.

Share this post


Link to post
Share on other sites

I want to add my $1.80 to the mix...

 

I broke down and upgraded yesterday, mainly due to upgrading a laptop I will be selling soon and after test driving it, I thought I would take the plunge to my own rig.  I was already prepared for crashes galore, not to mention the re-install of my flight sim content, but found that the basic simple upgrade to Win10 Pro was pretty quick and painless (emphasizing painless).  I checked out the basics, all working fine.  Did my runthrough of all security settings, making sure a very limited amount of privacy leaked to MS and then it was off to my apps.

 

Long story short, everything worked just as it did before, no reinstalls required.  I fired up P3D this evening and it ran just fine, no crashes, errors or otherwise.  Ran it with ASN and ORBX scenery, and everything ran...ran better than before.  Since my frames are locked in at 30, I didn't see better frames but DID see a smoother sim.  So far, I have had zero issues, and I didn't have to do a clean install.  I don't expect any other issues as I have ran everything on my machine once and it works.  I'm not going to rave and applaud, but I have a smile on my face that all the warnings, issues or otherwise that a lot of other folks had with Win10 aren't happening to me.

 

-Jim

 

I must apologize.  I totally overlooked that this thread was for FSX.  As I do have that installed on my rig (FSX:SE), I may have to fire that up to see what happens.  I'll report any issues I have but they are a bit inconsequential since I don't really use FSX much anymore.

Share this post


Link to post
Share on other sites

I have a brand new system with Win 10, Skylake 6700k (no overclock), GTX 970 card and a 1 TB SSD.  I run FSX under Vista SP2 compatibility mode with frames set as unlimited.  Maybe I'm just the lucky one, but I am having zero stutters with this setup.  The smoothness is much better than I anticipated, and I only added the highmemfix tweak along with 4096 textures.  No bufferpools, affinitymask or anything else was necessary.  I also set up my sliders exactly as Orbx recommends in their various product manuals.  My system is less powerful than overclocked pc's, but I think running in Vista mode with the large SSD is the key for me.     

Share this post


Link to post
Share on other sites

I have a brand new system with Win 10, Skylake 6700k (no overclock), GTX 970 card and a 1 TB SSD.  I run FSX under Vista SP2 compatibility mode with frames set as unlimited.  Maybe I'm just the lucky one, but I am having zero stutters with this setup.  The smoothness is much better than I anticipated, and I only added the highmemfix tweak along with 4096 textures.  No bufferpools, affinitymask or anything else was necessary.  I also set up my sliders exactly as Orbx recommends in their various product manuals.  My system is less powerful than overclocked pc's, but I think running in Vista mode with the large SSD is the key for me.     

Are you sure that compatability mode for Vista SP2 is necessary? 

Share this post


Link to post
Share on other sites

I too am running Windows 10 with Fsx (non Steam) and I don't have the stutters.

The sytem was set up from scratch rather than by upgrading.

FSX was installed on a separate partition away from the 'Program Files' folders. Tweaks to the FSX.cfg file were copied from the Win 7 install. The NVIDIA drivers are the latest and Inspector was used to tune Nvidia.

 

 

Some of the things I have done may be worth considering. ---

  • Win 10 come with loads of bloatware. Do you really need a Camera app on a Desktop? I removed all unwanted apps. Check the internet for the powershell scripts which do this
  •  For wanted apps turn OFF the live tiles.
  • Run a virus scan on your FSX folder then turn off runtime scanning of that folder. You must rescan manually for each new addon or update.
  • Keep the FSX drive defragmented. If the drive is an SSD then this is not advised.

 

 

 

 

Share this post


Link to post
Share on other sites

I also installed Win 10 PRO from scratch and FSX the same way!!

 

I have an Samsung SSD Evo 250gb just for FSX

I've turned off every option and apps in settings for win 10 as I don't need them

I've excluded FSX folder from Win antivirus

I've run FSX.exe as admin

I've set up nVidia Inspector as I did for win7

 

The problem is that I can maintain 30FPS with no problem in FSX but when I'm turning or I see the airport, stutter occurs, and I'm talking about default airport as I have vanilla FSX!!!

 

I'm waiting to see what is happening with the new P3D v3, maybe I will buy the 60$ license!

If not, I have to wait for PMDG to bring the 777 for XPX

Share this post


Link to post
Share on other sites

 

 


The problem is that I can maintain 30FPS with no problem in FSX but when I'm turning or I see the airport, stutter occurs, and I'm talking about default airport as I have vanilla FSX!!!

 

If your default airport is one of the few "detailed" airports supplied, then quite often you will get stutters when they are in your view.   When you switch to a side view with a simple background, you will probably notice that your frames will rise to normal.   Only suggestion is to turn down your settings (vehicles, global texture resolution, scenery complexity, autogen).   You can experiment with each one to see which one or more are killing your frames.   When I'm at a detailed airport or one I feel is a bit more complex than others, then I just up my Fsx frame limiter to Unlimited:  this gives me another 5-8 fps thus helping to smooth things out somewhat.   Once in the air, I back it off to 30 fps.

 

Chris

Share this post


Link to post
Share on other sites

Well in Win7 everything was fine, so I think that win10 is to blame here!

I was hoping I will embrace P3d, but then again I'm not prepar3d to spend another 500$ to buy PMDG,AES,Orbx,Aerosoft and other useful stuff just to get me started!

I'll wait and think what I can do, maybe I'll get back to win7 until win10 is more friendly with our sims, although I doubt it will ever be...

Share this post


Link to post
Share on other sites

Disable Windows Defender and install a 3rd party antivirus solution like Antivir (the free version will totally do). Defender is so slow in scanning files that FSX startup became unacceptably long and smoothness suffered.

 

No issues whatsoever running FSX on W10 with Antivir here. Performance is as good as it was on 7.

Share this post


Link to post
Share on other sites

Disable Windows Defender

 

Well I have excluded D drive all together from Windows Defender scanning and fsx.exe also.

Share this post


Link to post
Share on other sites

Are you sure that compatability mode for Vista SP2 is necessary? 

 

When I installed FSX on Win 10, I had an issue with no airplane showing in the free flight screen.  When I shut FSX down, Win 10 prompted me to allow the "compatibility troubleshooter".  I gave it permission to do so, and it settled on Vista SP2.  In summary,  I didn't select this mode, but Win 10 through the troubleshooter did it all on it's own.  It may not work for everyone, but it was pure gold for my system.  

 

EDIT:  I just double checked my FSX.exe, and it's actually set for Vista, not Vista SP2. 

Share this post


Link to post
Share on other sites

this was an nVidia driver issue which is now fixed, I didn't saw this problem, so no need for compatibility mode!

Share this post


Link to post
Share on other sites

When I installed FSX on Win 10, I had an issue with no airplane showing in the free flight screen.  When I shut FSX down, Win 10 prompted me to allow the "compatibility troubleshooter".  I gave it permission to do so, and it settled on Vista SP2.  In summary,  I didn't select this mode, but Win 10 through the troubleshooter did it all on it's own.  It may not work for everyone, but it was pure gold for my system.

I had an enquiry about this recently, deleting the fsx.cfg cured it. I'm wondering if your system had some other problem in the compatibility subsystem, preventing it interpreting the fsx.cfg correctly. Compatibility modes fiddle with stuff like commas and periods for decimal points under the hood. If you now set the compatibility mode back to off for FSX.exe, does it again exhibit the problem you described?

Share this post


Link to post
Share on other sites

I had an enquiry about this recently, deleting the fsx.cfg cured it. I'm wondering if your system had some other problem in the compatibility subsystem, preventing it interpreting the fsx.cfg correctly. Compatibility modes fiddle with stuff like commas and periods for decimal points under the hood. If you now set the compatibility mode back to off for FSX.exe, does it again exhibit the problem you described?

The black screen problem in the free flight screen was commonly reported by many using Win 10.  Since I installed FSX on a brand new pc, I had no reason to doubt a faulty fsx.cfg.  With all due respect to your request, I'm afraid to even tinker with it as you suggested....I might unknowingly cause a problem flipping modes at this point.

Share this post


Link to post
Share on other sites

Not to worry, it was only a matter of interest. I suspect it could work OK now without the compatibility mode set, which essentially isn't required on FSX in Win10 or otherwise. Changing compatibility modes for compatible apps can cause other issues, so worth bearing in mind. All the best Curt.

 

 

The black screen problem in the free flight screen was commonly reported by many using Win 10.  Since I installed FSX on a brand new pc, I had no reason to doubt a faulty fsx.cfg.

By the way, you misunderstand me, to be clear I wasn't suggesting the cfg to be faulty, only the interpretation through the compatibility subsystem, but not to worry.

 

From the enquiry I had, the PC may have been rebooted first then he thought, "I'll delete the cfg", but the problem was already cured. It could be that the machine had not finished installing updates and the error crept in during a partly updated system. I had another system which had an update, some USB drivers functioned in an unusual manner, soon after another update all went as normal.

 

In the event of the GPU drivers being updated, since I've got NVidia I always run the control panel app and use the Restore button to delete the profiles, and start new ones. I've found some problems going to certain versions in the past, and the Restore button always cured them.

Share this post


Link to post
Share on other sites

I have an Samsung SSD Evo 250gb just for FSX

I've turned off every option and apps in settings for win 10 as I don't need them

I've excluded FSX folder from Win antivirus

I've run FSX.exe as admin

I've set up nVidia Inspector as I did for win7

 

The problem is that I can maintain 30FPS with no problem in FSX but when I'm turning or I see the airport, stutter occurs, and I'm talking about default airport as I have vanilla FSX!!!

 

Hi Albert,

 

I see exactly the same stuttering now with windows 10. No problem keeping the locked 30fps but ~ every two seconds there is this small but noticeable lag - even with default aircraft in remote scenery. I must admit, I did no fresh install of windows 10 but rather chose to upgrade from windows 7 to try and find out with minimal effort.

 

I did not have the time to investigate much. I still use FSX as the problem is not a complete show stopper for me. But before on windows 7 everything was nice and smooth.

 

I used Word Not Allowed's FSX tweaking guide to setup FSX and windows 7 (and now windows 10) including all of your mentioned points from the quote above.

 

Would be nice to find out what the cause for this is...

Share this post


Link to post
Share on other sites

Have you tried my anti virus suggestion?

 

Using Defender as protection against viruses seriously impaired FSX performance. Things are much better with Antivir. It's free to boot, so why not give it a try?

Share this post


Link to post
Share on other sites

I disabled anti virus and firewall completely but it did not improve anything. My feeling is, the issue comes from video driver settings. Although they are exactly the same as before on win7. Maybe nvidia inspector works different on windows 10. I don`t know. I think about degrading back to win7.

Share this post


Link to post
Share on other sites

 I think about degrading back to win7.

I did exactly that! 

I'll wait for win10 to receive more updates and maybe I'll try it again next year.

For now I'm more into XPX, i think it's a great sim, especially with the new upcoming planes!!

Share this post


Link to post
Share on other sites

I did exactly that! 

I'll wait for win10 to receive more updates and maybe I'll try it again next year.

For now I'm more into XPX, i think it's a great sim, especially with the new upcoming planes!!

Well we have the first major upgrade from windows 10 rolling out V1511

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this