Jump to content

Sign in to follow this  
RVxSpeed

MSVCR120.dll CTD with P3D V3

Recommended Posts

Not funny. Even FSX with its OOM's are more bearable than a this 135 + 30 US dollar investment crashing on you.

 

While I appreciate that things like this can be frustrating, this is a pretty obscure issue that popped up in v3, that seems to be cured in v3.1. The curious aspect of that is we haven't changed any code since v2.5. That alludes to the idea that it wasn't likely the $135 + $30 investment that caused the issue, and other investments that might have.


Kyle Rodgers

Share this post


Link to post

I just had a MSVCR120 CTD in the 777 enroute at ET 0853 using time compression (approx 3 hr actual) KLAX-RJAA. I did use the L DU PFD 2D popup departing KLAX.  Exact same event signature as experience in v3.0, but in 3.0 it would happen every time with use of the 2D popup.

 

I guess I need to set my BIOS to HT off and see how it goes.  This was the first one in 18 sessions in P3Dv3.1, very confused and not sure where to start.


Dan Downs KCRP

Share this post


Link to post

 

 


This was the first one in 18 sessions in P3Dv3.1, very confused and not sure where to start.

 

 

Maybe it's OS related? Maybe not, just a thought..

Share this post


Link to post

Hi all,

 

1.29 hours enroute KSFO-EHAM , with v3.1 , all settings maxed out , even the autogen settings  , 1st flight in 3.1 with the 777.

This morning  tried some flights with the 737 , from 1.30 untill 3 hours flight time, clicking everywhere with no problems .

 

Settings are copied from Robs Ainscough page http://www.robainscough.com/P3DV3_Settings_Medium.html%C2'>

 

Running oc at 4.9 with HT off, no AM  , MSI gtx980 gaming with 40inch 4k monitor 3840x2160@60hz without NV insp , only nvidia control panel,

 

Best regards ,


Best regards ,

Gérard van Veldhoven

Boeing777_Banner_Pilot.jpg

18.png

Share this post


Link to post

Thanks for reply Dan. The only program running alongside is ASN. I will do some more flights but all the crashes I have with PMDG products always have no report in the app crash view program unfortunately.

 

I have no tweaks or adjustments in my cfg file. I am building my new system and will be installing W10 in the next couple weeks so I'll see how it performs then.

 

Thanks again.


Sean Green

Share this post


Link to post

Fresh install P3D v3.1 and PMDG777, flight from EGLL to KJFK, about 2400NM inbound KJFK the sim crashed hard with:

 

 

Completed a EGLL to KJFK flight in the PMDG777X without any issues yesterday, tried the  'never open a 2D DU' trick and this worked, apparently.

 

Best regards,

 

Eduard Wildknaap


Eduard Wildknaap

Share this post


Link to post

I completed a RJAA-KDFW trip in the B77W using the 2D popups and didn't get a CTD event, I have turned off HT in the BIOS and I think that is the solution for those with this problem. Running another trial now EDDF-KDFW same conditions just to make sure.  HT off does not have a noticeable effect on performance.


Dan Downs KCRP

Share this post


Link to post

Hi Dan,

 

I completed a RJAA-KDFW trip in the B77W using the 2D popups and didn't get a CTD event, I have turned off HT in the BIOS and I think that is the solution for those with this problem. Running another trial now EDDF-KDFW same conditions just to make sure.  HT off does not have a noticeable effect on performance.

 

Good to know. I've hyper-threading disabled, which is the way to go when running FSX and setting affinity mask. Affinity mask is not set on my P3D configuration. You are running v3.1? Did you overclock the CPU?

 

Best regards,

 

Eduard Wildknaap


Eduard Wildknaap

Share this post


Link to post

Hi Dan,

 

 

Good to know. I've hyper-threading disabled, which is the way to go when running FSX and setting affinity mask. Affinity mask is not set on my P3D configuration. You are running v3.1? Did you overclock the CPU?

 

Best regards,

 

Eduard Wildknaap

Affinity mask is not required with P3D.  Yes, I am running v3.1 and CTD events occur without overclocking.  At this time, however, I am running a conservative 4.5 GHz OC on my i7-4790K.


Dan Downs KCRP

Share this post


Link to post

I flew FSDT KLAX to FT KMDW; parked, shut down then continued again back to KLAX without restarting P3D; without any CTD during flight.  The only change was I never touched the PFD on the Pilot side.  So once parked and shut down at KLAX after 8 straight hours of flight I thought why not I'm done for the night, so I clicked on the PFD.  Boom!  CTD with once again no indication in the appcrash viewer of a crash.  No error messages just P3D stopped responding.

 

I uninstalled all the VC2013 runtimes; including the foreign language module, and reisntalled from a fresh download from MS both x86 and x64.  Have not tried any more flights since, hope to get one in this morning after work.

I always run with HT off so that would not be the cause of the problem on my system.  Before this flight I deleted my cfg and rebuilt my shaders files.  No tweaks just what I could change in the display options of P3D.

 

This is a fairly new Windows 7 install from October of this year


Sean Green

Share this post


Link to post

I just got the same CTD with the T7 and 3.1; I have never seen this before on 3.0. I just made the switch the other day. Have yet to complete a long haul flight. I am on W10

 

Here is my screen.

 

qkE8GBx.jpg


George Kyriazis | www.georgekonline.com

 

ELB729.png

Share this post


Link to post

Okay. wow. I just got the exact same error on a complete re-due of my last flight (including flight plan) and I got the same crash at exactly at the same point.......

 

Tried deleting all sceneries in that specific area and will re-due the long haul tonight. Will report back.

  • Upvote 1

George Kyriazis | www.georgekonline.com

 

ELB729.png

Share this post


Link to post

I just got the same CTD with the T7 and 3.1; I have never seen this before on 3.0. I just made the switch the other day. Have yet to complete a long haul flight. I am on W10

 

Here is my screen.

 

 

 

 

Are there any reason you install to the default path ? . As i recall since FSX you should put the installation outside the Programfiles(x86) folder. (administrations rights)

 

Just for the record  - i also have had that error once on a longhaul flight , fiddling with the FMC about 3hours into the flight.

 

Since then i just cross fingers

 

Michael Moe

 

 

Michael Moe 


Michael Moe

 

fs2crew_747_banner1.png

Banner_FS2Crew_Emergency.png

Share this post


Link to post
Guest

I've spent well over 25 hours trying to duplicate this problem with NO success (or should I say failure).  I've tested in Win7 and Win10 -- clean installs of P3D V3.1 AND fully loaded installs of P3D V3.0 and V3.1.

 

Here's a quick video of me going MFD/PFD crazy in the 777 - this was done on a new install of Win10 Enterprise build 1151 using the PMDG V3.x installers and running Operations updates before starting P3D and activation of PMDG.  P3D V2.5 was never on this Win10 install but was on my Win7 testbed.

 

 

Fully loaded system with ASN running.  Some things to consider:

 

1.  I disable RAAS (installs with the 777) but I highly doubt this is relevant.

2.  When installing the 777 it will install additional DirectX components, these MUST be installed correctly - suggest running DXDIAG

Beyond that I'm all out of suggestions (as you know I've listed all the things to check in many prior threads).

 

DXDIAG results:

 

1a20d82e36f3c6f310253336513d95e3.jpg

 

Cheers, Rob.

Share this post


Link to post

Thanks Rob for your efforts.  Believe me, I have much less hair on top than you LOL. I am still running trials, had an event with exact same signature as others, with HT off so that is ruled out.

 

I upgraded my GTX750Ti to a GTX980Ti and with one trial didn't have an event. Too early to draw conclusions but this problem is certainly related to individual system configuration.  I ran the dxdiag very early in this trip so yeah, pretty sure that's not it.


Dan Downs KCRP

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    30%
    $7,735.00 of $25,000.00 Donate Now
×
×
  • Create New...