Sign in to follow this  
Flapsset

New Computer: Scenery issues

Recommended Posts

Hello everyone,

 

Having been out of flight simming for several years now, I recently decided to build a new rig specifically for MFSX and get back into it.

 

Basically all scenery (autogen etc) is either blurred or not loading until the aircraft is within 1-2 nm, please see the screenshot.

 

FSX.jpg

 

I've tried tests with the sliders in MFSX (including at minimal levels) and I've tried a variety of recommended adjustments to the fsx.cfg file with no changes.

 

My specs are:

 

CPU: I7 6700K

GPU: GTX 960

RAM: 8GB

Windows 10 & MFSX installed on a SSD

 

Any ideas whats going on and how to fix it?

 

Kind regards

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Strongly recommend you check out the AVSIM FSX Configuration Guide and use the settings recommended there.  The "blurries" are associated with high settings.  Your GPU just cannot render the scenery fast enough as you are placing too many demands on it.

 

The link to the guide is in my signature.

 

Best regards,

Share this post


Link to post
Share on other sites

Strongly recommend you check out the AVSIM FSX Configuration Guide and use the settings recommended there.  The "blurries" are associated with high settings.  Your GPU just cannot render the scenery fast enough as you are placing too many demands on it.

 

The link to the guide is in my signature.

 

Best regards,

Thank you Jim,

I'm finding the autogen and blurries are occurring at the same distance even with low-moderate settings. Also frame rates are very high when settings are set high.

Lastly pausing the game doesn't see any "catching up" of loading scenery.

 

Is your advice still correct?

 

Again thank you for your time Jim.

 

Kind regards

Share this post


Link to post
Share on other sites

 

 


Is your advice still correct?

 

Yes.  What are you setting to low-moderate?  If you have LOD_Radius set at 7.0 as some recommend and other settings set to "low-moderate" then that could cause a problem too.  If you have tweaks employed, like the bufferpool tweak, you will see the blurries as it will slow down the rendering if not properly employed.  The bufferpool tweak is recommended only if you want to tweak Autogen.  Same goes with another tweak called the AffinityMask.  Whenever you put parameters in your fsx.cfg, you are asking for issues as the settings are not the same for every setup or computer system.  I do not recommend tweaks especially with systems after Sandy Bridge i7 systems.  In any case, if you cannot get your sim to render textures rapidly and clearly, then you have high settings somewhere that is causing the issue.  It could also be a setting in your display driver settings.  Page 4 of the AVSIM FSX Configuration Guide explains how to change the LOD_Radius to 6.5 which works for most.  I use it a lot and have seen no problems.  If I have it at 7.0 or higher, I'll get an occasional freeze or crash.

 

You need to make sure you also have the following parameter in the graphics section of the FSX.cfg:  highmemfix=1.  It is not a tweak but a fix to FSX that was supposed to be installed when SP2/Acceleration were released.  Like I said above, try the settings I suggested in the AVSIM FSX Configuration Guide.  They are high too but they do work for most systems.  You can try another excellent guide put out by Nick Needham called the The FSX Computer System - the Bible. 

 

Another thing that will bring down fast rendering is photoscenery.  It loads around the world whether you are flying over it or not.  This is explained in the AVSIM FSX Configuration Guide.  When you have programs like this that are loading textures whether you are using the textures or not, then that taxes the fsx configuration/display driver settings and any high settings will be emphasized thus slowing down the loading time.

 

Hope this helps.

 

Best regards,

Share this post


Link to post
Share on other sites

Some "scenery" won't load until you are close.  That's just the nature of FSX since they removed alpha fade.  Kinda ruined it IMO. 

 

Anyhow, with my new build I had the same problem.  I tweaked the computer pretty good and started with lower settings in FSX (Steam).  Even going back and lower it more didn't help.  I was getting aggravated considering my settings are kinda low considering what other people seem to be running.  I just wanted it to look good and run smooth.  I realized my payware aircraft and other add ons were going to bring things down, but I never had such horrible looking textures, even in FS9. 

 

Anyhow, I finally went and increased LOD to 6.5 and it's like a new sim now.  Strange.  Still runs smooth and looks great.  Weird.  It's often that one tweak that changes everything.

Share this post


Link to post
Share on other sites

Many good points here, with regards to the issue with photoscenery, that applies to all scenery with photoscenery bgl's that covers smaller areas, not only large scenery packs with "photoareas".

 

I use the freeware Scenery Config Editor to group and switfly disable groups of areas that I don't need for a certain flight. Makes all the difference in my setup.

Share this post


Link to post
Share on other sites

Thank you everyone, all fixed

 

Kind regards

Might I ask you how you managed to fixed this horrific plague that's been haunting me for a while now. I've tried many tweaks and I also lowered my settings none of which helped me.

Share this post


Link to post
Share on other sites

Thank you everyone, all fixed

 

Kind regards

Please don't leave us hanging.

Share this post


Link to post
Share on other sites

I'd pay someone for a solution to this. My FSX is running great and has almost none stutters, but damn the slow terrain loading is killing all the joy fOR me. If only more addon developers would start developing their addons for X-plane :sad:

Share this post


Link to post
Share on other sites

I have had this issue as well..... any feedback to the fix you found would be helpful.

 

 

LW

Share this post


Link to post
Share on other sites

I think I answered it in my post (although every computer system and FSX is setup differently).  Use the settings in the AVSIM FSX Configuration Guide for your video card and FSX settings.  You must not be using any tweaks.  Tweaks bad.  Go fly. 

 

The OP's issue was the blurries.  The AVSIM Conf Guide fixes the blurries.  The blurries and slow rendering is solely caused by high settings and/or tweaks improperly employed.  If you are flying around commercial airports like KORD/KJFK/KIAD, all the airports in England, etc., then you need to reduce the settings.  Just too much eye-candy and you probably will never get rid of it totally.  I have instant rendering BUT, when looking out the pilots left window at 200 mph, the scenery seems to have a hard time catching up and it looks like it might be stuttering but I know of no solution to this problem other than slowing down your aircraft or don't look out the side windows at high speeds.  Look at your gauges instead.  With the aged programming of FSX/FSX-SE/and P3D (FSX-SE and P3D are based off of the FSX programming), I doubt we will see much improvement. 

 

I do love flying my iFly747 or PMDG777 into St Louis (Taxi2Gate) and there, as I slow down for the approach to around 170, the aircraft seems to be just hovering as I turn into the final approach.  Absolutely stunning stuff!  It doesn't look all that good near the final landing phase looking out the side windows as the scenery seems to be trying to catch up (not blurry) but in the final phase no pilot should be looking at the eye-candy out the side windows.

 

Finally, did I mention no tweaks in the FSX.cfg?  I know I did but no tweaks.  Your system is about 5 times more powerful than when FSX was first released if you have a Sandy Bridge or higher CPU.  The latest video cards are absolutely more powerful too.  We don't need those tweaks that were needed prior to Sandy Bridge.  Try even lower settings than what is in the AVSIM FSX Config guide, especially mesh and texture resolutions.  You will not see much difference in quality by bring them down a little more and always running FSX with two fsx mods.  Change the LOD_Radius to 6.5 and the Texture_Max_Load to 2048 (HD) or 4096 (also HD).  Keep all other settings at the default.  For instance, a lot of so-called "experts" say to raise the Texture_Bandwidth_Multi to 120 or higher (default is 40).  It should never go higher than 60.  Never.  The default is fine and it will let your sim breath a little more.  The LOD_Radius and Texture_Max_Load settings are the magic tweaks if you are going to use any tweaks.

 

Best regards,

  • Upvote 1

Share this post


Link to post
Share on other sites

Thanks Jim,

 

I used the Basic FSX Conf. guide as a baseline and found setting the LOD RADIUS to 6.5 and adjusting the Scenery Complexity to Very Dense and the Autogen Complexity to Normal/Dense has corrected my issue with the loading.

 

Further investigation leads me to believe as stated in the guide and elsewhere, that with all of my ORBX add-ons installed (Global, Vector, OpenLC....) I see no need in running the Autogen density very high, in fact Normal appears to suffice.  I also adjust the Water effects to Low 2x.  I have always kept the setting Texture_Max_Load to 2048.  I am running the DX10 Fixer but no other tweaks to my cfg file.  As for the Texture_Bandwidth_Multi, I don't believe that is set to 120, however I will have to go back and double check.  After a couple short test I am happy with the results, just need to make a couple of long flights to ensure stability, however my FPS is 40+ and holding. 

 

Thanks again Jim for the insight.

 

 

 

Cheers,

LW

Share this post


Link to post
Share on other sites

I have the following specs: 6700k CPU, nVidia 970, 16Gb Ram and FSX on SSD.  I had the exact same issue with my new computer and solved it with a graphics card setting.  First, as Jim said, NO tweaks to the fsx.cfg, because Skylake systems don't benefit from them.  What fixed the blurries for me was going into nVidia Inspector and adjusting two settings under "Texture Filtering".  Anisotropic filtering mode to OFF; and Anisotropic filtering to 16x.  That took me from very blurry to crystal clear.

Share this post


Link to post
Share on other sites

I have the following specs: 6700k CPU, nVidia 970, 16Gb Ram and FSX on SSD.  I had the exact same issue with my new computer and solved it with a graphics card setting.  First, as Jim said, NO tweaks to the fsx.cfg, because Skylake systems don't benefit from them.  What fixed the blurries for me was going into nVidia Inspector and adjusting two settings under "Texture Filtering".  Anisotropic filtering mode to OFF; and Anisotropic filtering to 16x.  That took me from very blurry to crystal clear.

 

What is you filtering setting in FSX under the Grapics tab?

Share this post


Link to post
Share on other sites

What is you filtering setting in FSX under the Grapics tab?

I have Anisotropic filtering set in the graphics tab.    

Share this post


Link to post
Share on other sites

Hi Luftwulf, I see you have Steve's DX10 Fixer running, but in his PDF guide he does include a host of cfg tweaks to go with it. Did you implement them? Or leave your cfg 'bare'.

Sorry, my mistake ... I must have been following another DX10 guide ... I might try a fresh FSX.cfg build then and clean out all those fixes.

Share this post


Link to post
Share on other sites

I have Anisotropic filtering set in the graphics tab.    

 

Thanks..

Share this post


Link to post
Share on other sites

Hi Luftwulf, I see you have Steve's DX10 Fixer running, but in his PDF guide he does include a host of cfg tweaks to go with it. Did you implement them? Or leave your cfg 'bare'.

Sorry, my mistake ... I must have been following another DX10 guide ... I might try a fresh FSX.cfg build then and clean out all those fixes.

 

Firstly, Great Avatar!  

 

My settings are as follows:

 

Poolsize = 0

Display Texture MaxLoad =

Swap Wait Timeout = 2

Graphic Texture Max Load =  2048

 

Texture Bandwidth Multiplier = 60

Missing Texture Alert (not checked)

LOD Radius = 6.5

 

Max Sync Batching Jobs = 3

Fiber Time Fraction = 

 

Process Affinity/Mask = Checked

Core2

Core4

Core6

 

Force VC Shadows = Checked

 

 

Cheers,

LW

Share this post


Link to post
Share on other sites

For instance, a lot of so-called "experts" say to raise the Texture_Bandwidth_Multi to 120 or higher (default is 40).  It should never go higher than 60.

 

Best regards,

I would just like to add that this is not the case for FSX Steam Edition. The default Texture_Bandwidth_Multi is set to 160 and should be left as it is. The bufferpools shouldn't be touched ( added ) either since dovtail made some improvements to it. But this only apply's to FSX SE not MS FSX.

Share this post


Link to post
Share on other sites

Interesting.  The default TBM for P3D is 30 and no bufferpool tweak.  I suspect the fact Dovetail uses dotnet 4.0 to run their application is the reason for this.  FSX uses dotnet 1.1 or 2.0.  Otherwise I see no advantage.  They could not change any of the code in FSX.

 

Best regards,

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this