Sign in to follow this  
hychewright

My Traffic 6

Recommended Posts

Hello pilots, I have read good reviews here about MT6. Decided to give it a try. I am using P3DV3.1 and I noticed on the Sim Market site that it is compatible through v2.5.  I was thinking that I saw a post here the other day that stated MT6 is compatible with V3.1? I think it was posted by Bob. Just would like to know if MT6 is indeed compatible with V3.1 and has the installers as well.......  Thanks

 

 

On a different subject,  I just won't thank all the wonderful people that make up this community who helps everyone with problems.  You all deserve a big THANKS !!  From all over the Globe we all share this wonderful hobby of flying. I have been with  AVSIM a long time and you all are the nicest people.  Thanks again for making this hobby more fun.  Happy flying.

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Just would like to know if MT6 is indeed compatible with V3.1 and has the installers as well.

 

It is and the one installer works for all versions.

 

 

Here is a quote from the MT6 manual: "So MyTraffic 6 brings you support for Windows XP, Vista, Windows 7, Windows 8, Windows 8.1, and Windows 10, and can be used as addon to Microsoft Flight Simulator X, Flight Simulator X Steam Edition, Lockheed Martin Prepar3D V1 and Lockheed Martin Prepar3D V2., as well 2.0-2-4 as 2.5. and Lockheed Martin Prepar3D V3.0. "

Share this post


Link to post

I just bought it too because of the recommendations here of it being V3 compatible and indeed read me does say it is as well.

 

HOWEVER, I have a problem though and the official forums aren't helping me because I can't post a topic without "approval" because I am a new member and it's been several hours since I posted it... Oh well so thought I'd try here (hope you don't mind).

 

I bought it, seemed to install fine following the instructions and sure enough I have AI traffic at airports. However, P3D now crashes on me after a couple minutes. Doesn't seem to be any real rhyme or reason.

 

Fresh install of P3D (just bought it actually) so absolutely no other add-ons and hence no 3rd party conflicts, not even aircraft. I would appreciate any insight as to how/why this could be happening.

 

i7-6700k, 980ti, 32GB RAM, fresh Win 8.1 install in addition to the fresh software installs.

 

Z4waS9B.jpg

Share this post


Link to post

 

 


However, P3D now crashes on me after a couple minutes. Doesn't seem to be any real rhyme or reason.

 

Did you try P3D3 without MT6 installed?  Does P3D crash then?

 

I flew from KRDU to KMCO and also KDTW to KORD last night with MT6 installed.  No crashes whatsoever.

Share this post


Link to post

Did you try P3D3 without MT6 installed?  Does P3D crash then?

 

I flew from KRDU to KMCO and also KDTW to KORD last night with MT6 installed.  No crashes whatsoever.

Yep, played it for a few hours when I first installed it (P3D) Sunday. No issues whatsoever. Smooth as silk and flew out of various North American airports with no problems at all. Rock solid. Installed MT6 this AM and that's when the problems started.

 

Here is their support forum if anyone needs it! I just bought it myself last night but haven't had time to install it yet?

 

http://forum.simflight.com/forum/7-mytraffic-support-forum/

 

Cheers

Martin

 

Yeah, that's the forum where they have to approve posts for new users.. and have been sitting on mine for hours :sad:

Share this post


Link to post

Lamar,

 

MyTraffic 6 does function in P3D 3.1. Perhaps the Simmarket info is out of date. The program does not require installation inside the main simulator folder. In fact, it is recommended it be installed elsewhere.

 

After installation, there are some manual steps required. I should point out that MyTraffic can do these steps using the communicator, but the user interfsce is a bit cryptic. Therefore, I prefer to do it manually. There's not much to it.

 

-if you haven't already done so, go to the Prepar3D website and download and install the latest SDK.

 

-open the SDK folder and search for TrafficDatabaseBuilder.exe. Copy (do not move) the file to your MyTraffic folder.

 

-open the ...\ProgramData\Lockheed Martin\Prepar3D v3 folder. Open SimObjects.cfg. Make a note of the last entry number. Create a new entry (eg if the last entry is 10, make the new entry 11). It should look something like this:

 

[Entry.11]

Path=\MyTraffic\Aircraft

 

-add an entry to the scenery library. The entry entry should be above the default world scenery; and below any default cities and/or 3rd party scenery.

 

-disable the default Prepar3D AI aircraft. Go to your main Prepar3D folder drill down to Scenery\World\Scenery. Search for trafficAircraft.bgl. Change it to trafficAircraft.bgl.off, or something similar.

 

You should be good to go.

  • Upvote 1

Share this post


Link to post

You will also need to add the MyTraffic directory to your scenery.cfg preferably between the propeller objects and addon sceney entries in order to take advantage of the updated afcads with more parking spaces ect.

Share this post


Link to post

Hi do you have a crash report? (use event viewer).

 

I use MyT6 in P3D v3.1 with almost no issues. 

 

Couple of things to try:  start with ga traffic only at 10%, no hdr lighting very modest graphical settings only add other traffic/graphic options if you get no crashes. Also try different schedules, (you'll need to set up the communicator with traffic builder.)

 

The only real problem I've had with MyT is the odd corrupted ai model and schedule that caused the ai.dll crash. A reinstall fixed it. 

 

Let us know what the faulting module is from the crash report. 

 

Matt Attwell

Share this post


Link to post

You will also need to add the MyTraffic directory to your scenery.cfg preferably between the propeller objects and addon sceney entries in order to take advantage of the updated afcads with more parking spaces ect.

Hey Glynn,

 

Do you have propeller objects in your setup? I have 3.1 and there is no propeller objects entry in scenery. Sorry to hijack the thread.

Share this post


Link to post

 

 


Installed MT6 this AM and that's when the problems started.

 

I spoke too soon.  I just crashed also.

Share this post


Link to post

Yes My Traffic 6 works perfect in V3 .  

 

Now this is probably not accurate advice  But it worked for me.  Regarding the Crash  Prepar3D exe has stopped working ,  I also got this several times,  I deleted my Prepar3D.cfg and the Crashes stopped.   If you delete your Prepar3D.cfg be sure to adjust your Traffic settings again,  if you dont, you will not see any Traffic

Share this post


Link to post

I installed it into P3Dv3.1 but found it very demanding on fps.  You should also consider the freeware traffic optimizer utility as well with MT6. 

Share this post


Link to post

I installed it into P3Dv3.1 but found it very demanding on fps.  You should also consider the freeware traffic optimizer utility as well with MT6.

 

+1

Share this post


Link to post

I installed it into P3Dv3.1 but found it very demanding on fps.  You should also consider the freeware traffic optimizer utility as well with MT6. 

 

I have had no FPS problem with MY traffic 6. What do you have your traffic settings on, 100% ?  

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this