Sign in to follow this  
Richard Sennett

Hawker High Above

Recommended Posts

Help AVSIM continue to serve you!
Please donate today!

Very nice artistic shot...  looks kind of  surreal.  Very cool, looks like a trailer shot from a futuristic movie, love the shine  Did you post edit it?

 

...but it's a Carenado,  good luck  getting it to navigate you home....  but you can always follow the road lights.   

Share this post


Link to post
Share on other sites

Shine is from new P3D V3 - dont have to edit anything - its very nice - i get it home - just have to figure out Carenados way of getting it home  :wink: Thanks

Share this post


Link to post
Share on other sites

just have to figure out Carenados way of getting it home  :wink:

 

LOL! Gotta fly it down like a 60's Cessna because nothing else works! 

 

Beautiful shot btw. 

Share this post


Link to post
Share on other sites

One awesome- blended pic with plane, clouds and environment below.

Share this post


Link to post
Share on other sites

Looks like it could be on a model airplane box cover! Awesome

 

Thank you much guys - carenado make my job pretty easy actually - hope all is well

:smile: !!!

 

Thank you much guys - carenado make my job pretty easy actually - hope all is well

Share this post


Link to post
Share on other sites

Happy to admit to be a Carenado pilot as well, although the Mustang for Prepar3D is really nice :-). Some developers should join forces.

Share this post


Link to post
Share on other sites

Hallow Sorry Iam new n this forum so I would like if someone can help me, I fly the Hawker 850 from from Carenado, I installed the the Telluride Orbx airport but I have a problem. Whenever i land the cabin altitude alarm goes off, this also happens when I turn on the batteries before taking off from Telluride. The avionics alarm also goes off and there is no way to turn it off. I’ve tried everything, activating and deactivating the MAIN AIR VALV or deactivating the PRESSN OVRD switch from auto to manual. Also try with Citation CJ 2 was perfect but the Hawker no working and There´s is no way to turn off the alarm, could someone please tell me if there is a glitch with the plane or the airport? Thanks 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this