Sign in to follow this  
Martin Scott

Whats going on with Milviz?

Recommended Posts

Hi All,

I am hoping that someone can advise me as to the way forward, as I am getting absolutely no customer service from Milviz.

 

On the 27th May 2016 I purchased the Milviz F4 Phantom Bundle for $89.99 using PayPal.The purchase went through and I imediatley receved a link to download the product from PayPal. In my enthusiasm I didnt disable my anti virus software as advised in the manaual (Simple mistake and not a henious crime I'm sure).

 

Upon reading the Milviz forums (Cannot Register as yet!) I found that I am supposed to receive an Email from Milviz which will provide links to the latest version of the product and any upgrades. At the moment I have an unusable product with so many issues, too many to mention. To date I have recieved absolutely nothing!!!

 

To add insult to injury I have sent an email to (info@milviz.com) with a copy of my receipt and referencing my order number on 31st May - NIL RESPONSE!

 

I sent an email to (kat@milviz.com) on the 1st June explaining the situation plus copies of receipt and order number - NIL RESPONSE!

 

I sent an email to (roadburner440@milviz.com) ON 4th June with much the same. - NIL RESPONSE!

 

I have also tried to contact them through their own" CONTACT US" link on their website - NIL RESPONSE!

 

Now I see a lot of references in Milviz's own forums as to how wonderful they are at customer service but I'm begining to feel that I have been well and truley duped.!

 

Has anyone else had the same or similar exprience with Milviz and if so how was it resolved (if at all)??

 

Thanks,

Martin Scott 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Martin,

 

No idea why you can't get register for an account on their forums - have you tried? In my experience Kat is usually responsive and helpful and you should have received regular emails like the one below.

 

This is the latest info I can find on the Phantom:

 

vA1.160114_E is the latest installer. You will be notified of the next iteration by your vendor or by following the McDonnell Douglas F-4 Phantom II Support Phorum

 

 

The Phantom support forum is another account which I can't log onto it either, so can understand your frustration.

 

Not sure if this helps. 

 

Did you quote your order no and details etc when you sent them emails?

 

 

Ray

Share this post


Link to post
Share on other sites

Thanks Ray, I did provide as much information as I have including order number and receipt of payment.

 

Judging by the generally good feedback relating to Milviz and as you say they are responsive and helpful, and I can only assume this is a one off glitch.

 

On reflection I,m of the mind to sit and wait a little longer.

 

Thanks for the link, I'll check it out at the soonest.

Regards,

Martin

Share this post


Link to post
Share on other sites

 

 


o date I have recieved absolutely nothing!!!

 

Have you checked all your Email Box's for a reply.  For some reason a lot of my Email goes straight to either my Trash box Or Spam box

Share this post


Link to post
Share on other sites

Monty.  Show me your proof of purchase please.

 

As for the OP, if you've contacted Kat (at milviz dot com) and not gotten a response that is strange because she ALWAYS responds within 24 hours or less.  Always.  Even to people like Monty up here...

 

So, if you didn't get a response, then mail or pm me with your info and I will get you sorted.

 

FYI, there is no "new Milviz" behavior.  We ALWAYS provide support for all of our products (the ones we did) and that's not going to stop.  

 

As per the F-4 (which Monty has so far refused to show his purchase info for), yes, it's true that the gear/flap markers are non functional at this time.  However, we ARE testing a new build right now and hope to release it as soon as P3D 3.3 is solid.   Until then we can't because the risk of P3D customers not having a working product at all is far greater than a "fail" on the gear/flap markers.

 

Next up... if ANYONE has issues with our support (which is a surprise) feel free to post on our support forums.  You WILL get an answer and we will attempt to fix your issue(s).

  • Upvote 3

Share this post


Link to post
Share on other sites

Dear Commercial Member,

This is the "OP" or at least I presume that you are addressing Monty's post and not mine?

 

Thank you for your offer to get my issue sorted thats much appreciated and I would like to email you the emails that I have previously sent which do indeed include my ordering number and payment reciept.

 

As for ANYONE having issues regarding your support.  Well I do, however I was unable to post in the Milviz forums as you suggest because to do that you have to receive an email from Milviz in the first instance which is precisely what is letting the support down.

 

My first port of call was to attempt to solve the issue through the forum and the Milviz website but no email received means no opportunity to register onto the forums then subsequently log in and post! 

 

Hence the frustration.

Kindest Regards,

Martin

Share this post


Link to post
Share on other sites

Got it.  PM me and I'll get you sorted.

  • Upvote 1

Share this post


Link to post
Share on other sites

Welcome to the 'new' Milviz.     I'm afraid the lack of response and support you're currently experiencing is very much 'par for the course' these days and it's unfortunate.  

 

What a load of rubbish Monty!

 

Milviz is one of the most professional developers out there and their support is second to none.

 

Cheers,

 

Jerome

  • Upvote 2

Share this post


Link to post
Share on other sites

Welcome to the 'new' Milviz. I'm afraid the lack of response and support you're currently experiencing is very much 'par for the course' these days and it's unfortunate. Quite frankly, posting the issue publicly here at Avsim was the best thing you could do in terms of eliciting a response from Milviz as they are quite sensitive about any and all kinds of negative publicity.

 

It didn't always used to be like this. I hope you are able to get the problem situated

"Monty"

 

This is the second snarky post I have seen you make regarding Milviz support, and I have to wonder why - as my experience has been just the opposite. I have only been a Milviz customer for a few months, and have found their support to be first rate for my two products, the Baron and the C310. I had one purchase problem, and an issue gaining access to the Baron support forum. In both cases, my email requests were answered almost immediately.

 

Can you give some specific instances of bad or non-existent support that have affected you personally? Easy to make unsupported accusations.

 

In the OP's case, I would think the issue is almost certainly a case of incoming or outgoing emails being blocked or misdirected. My own ISP mis-identifies legitimate email as SPAM all the time.

  • Upvote 3

Share this post


Link to post
Share on other sites

 

 


she ALWAYS responds within 24 hours or less.

Fully agree.

Share this post


Link to post
Share on other sites

Thanks, I have PM'd the text from the previous sent emails, you will get the gist when you read them. By the way, I have checked my junk/spam emails theres nothing related in them.

Thanks again

The OP :)

Share this post


Link to post
Share on other sites

Welcome to the 'new' Milviz.     I'm afraid the lack of response and support you're currently experiencing is very much 'par for the course' these days and it's unfortunate.      Quite frankly, posting the issue publicly here at Avsim was the best thing you could do in terms of eliciting a response from Milviz as they are quite sensitive about any and all kinds of negative publicity.     

 

It didn't always used to be like this.    I hope you are able to get the problem situated (maybe sometime this summer?).      

 

 

Actually, the latest 'E' installer is 1.160409.     If your landing gear indicator lights are not functioning properly, you already have the latest version installed.   (sigh)    

 

Purchaser of many Milviz products here...based on the documents that came with those products and the website, you have to have proof of purchase to get support. Having trouble finding yours? Kat and Roadburner have helped many people who made legitimate purchases. Occam's razor is not being kind for you on the question of legitimate purchase. Best you get that out of the way and then you can provide feedback.

Share this post


Link to post
Share on other sites

Fully agree.

That's also been my experience. Thank you Kat for the excellent service.

 

JJ

Share this post


Link to post
Share on other sites

I have banned MontyPreston from this topic as his comments were off topic and without basis.

  • Upvote 3

Share this post


Link to post
Share on other sites

Dear Martin,

I have searched our email accounts and cannot find any of the emails you sent but Colin forwarded me your email address and I have emailed you. If for some reason you do not receive my email, please PM me via the forum or this thread.

 

Best wishes - Kat

Share this post


Link to post
Share on other sites

Thanks Kat,

All is good with the world now :)

 

Registered on the forums and have downloaded and installed the product correctly this time.

 

Thanks again.

Martin

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this