Sign in to follow this  
hjsmuc

10.50 FPS Drop

Recommended Posts

I see this issue reported at the X-Plane FAQ http://questions.x-plane.com/3400/frame-rate-issue

 

I wonder if users here experience the same. I do. After upgrading to RC3 the fps drop to single digit after a few minutes. No changes to the config, preferences or scenery, 

 

Could this be related to the latest Win 10 update?

 

I disabled all plugins, sceneries but to no avail. 

 

Kind of sad, XP was at its best before this happened. 

 

There may well be an error on the user's side but I am out of ideas on this. 

 

Any suggestions appreciated.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

If you have installed windows update KB3176938 your problem is surely related to windows as happened to a lot of people on the past few days.

 

Check on your windows app if it is installed and remove it.

  • Upvote 1

Share this post


Link to post
Share on other sites

I am pretty sure it's the Windows update, I mean what on earth should Laminar have done to cause this. It's been happening the past few days, long after RC3 has been released.

 

I had a drop to single digits today at 42000 feet - I didn't get around yet to check if I got this malware injected from Microsoft.

Share this post


Link to post
Share on other sites

Thanks for the heads up, gonna check it out. I did not think that this was on LR's side. 

Share this post


Link to post
Share on other sites

I have the win10 update mentioned as well.  Apart from one instance where something similar happened, but disappeared with a restart of the sim, I've been unaffected.

Share this post


Link to post
Share on other sites

Deleted this Windows update and so far no fps drop. Not saying that this is compelling evidence but it worked for me so far. 

Share this post


Link to post
Share on other sites

Deleted this Windows update and so far no fps drop. Not saying that this is compelling evidence but it worked for me so far. 

 

 

you are welcome  :wink:

Share this post


Link to post
Share on other sites

It happens to me since I updated Windows 10 (I think it was the Anniversary Update) some weeks ago. But only If lost focus of the X-Plane window. 

If I open X-Plane 10.50 on full screen or do not open more windows, like i.e. Firefox, while flying, its ok. If I open another program or window and X-Plane window looses focus, massive fps drop. And I mean 1-2 fps drop.

 

I will try to delete that KB3176938.  Maybe it will solve the problem.

Share this post


Link to post
Share on other sites

As expected Windows wanted to reinstall this update. I let it do that and guess what, the fps drop is also back. Must not be valid for everyone installation but worth a try if performance suddenly goes south. 

Share this post


Link to post
Share on other sites

Hi,

 

I had a major drop in FPS after a Windows 10 update, probably KB3176938 on 31 August. I checked nvidia for a video card update and they had a 372.70 driver. After that install, the FPS went back to normal. So, you may also try a video card update and see if that helps. My card is a GTX970.

Share this post


Link to post
Share on other sites

Funnily enough I got the Steam update to 10.50 on Friday and first thing I did was delete everything inside the preferences folder. So far I am very happy with the new update. My beloved is out of town this weekend so lots of time to test :)

 

Will have to check if I got the Win 10 update

Share this post


Link to post
Share on other sites

I am pretty sure it's the Windows update, I mean what on earth should Laminar have done to cause this. It's been happening the past few days, long after RC3 has been released.

 

I had a drop to single digits today at 42000 feet - I didn't get around yet to check if I got this malware injected from Microsoft.

This might explain 2 instances of a drop to single digits on a flight from egcc to eddf, I recently flew. I can't remember it happening before so I'll check the updates. Great info.

 

Jon

Share this post


Link to post
Share on other sites

 

 


As expected Windows wanted to reinstall this update.

Just right click on the update when offered and choose "hide update".  It will not come back.

 

John

Share this post


Link to post
Share on other sites

Just right click on the update when offered and choose "hide update".  It will not come back.

 

Does this work in Windows 10? AFAIK not. Instead you need to force Windows to hide this update by download a small tool (a troubleshooter package) from Microsoft which allows to hide updates:

 

https://support.microsoft.com/en-us/kb/3073930

 

But I'm not sure if this works. I hid the update yesterday, but today it nevertheless wanted to download.

Share this post


Link to post
Share on other sites

 

 


Does this work in Windows 10?

 

Maybe not... I have used it on some non-microsoft (like drivers) and it worked.  Found this:

 

Windows 10 Home edition is the only version that is required to perform updates automatically in the background. Windows 10 Pro and Enterprise both allow deferment of updates.

If you're running Windows 10 Home edition, updates flow down from Microsoft automatically and install. There's nothing else you need to do. For some, though, this could cause a bit of trouble, particularly if driver updates are reported to cause problems.

Microsoft has made a tool available that allows all Windows 10 users to "hide" specific updates from the updating mechanism.

It's downloadable from here: https://support.microsoft.com/en-us/kb/3073930

Share this post


Link to post
Share on other sites

I was getting 1 frame every 5 seconds but only above 14,000ft. Uninstalling KB3176938 solved the problem.

  • Upvote 1

Share this post


Link to post
Share on other sites

 

 


I was getting 1 frame every 5 seconds but only above 14,000ft. Uninstalling KB3176938 solved the problem

 

Maybe the altitude was just a coincidence. Did you switch windows while flying? Because for me the issue occured only after I left the X-Plane windows and returned to it later.

Share this post


Link to post
Share on other sites

I was having the same problem with 10.50 - 3fps before I even got off the ground. Removing KB3176938 brought my frame rates back to normal.

 

Thanks to everyone for the heads up on this problem!

Share this post


Link to post
Share on other sites

vFlyteAir, yes, you could be right. I used my other monitor monitor while letting the aircraft climb then came back to switch off the landing lights and passenger signs. The problem is the same in 10.45 and 10.50 so it's related to the Windows 10 and not X -Plane.

Share this post


Link to post
Share on other sites

Yesterday a new update was issued (KB3189866), but the issue persists. Many users of other OpenGL games (RuneScape, D&D Online, even WoW in OpenGL mode) as well as viewers for Second Life (such as Firestorm) are affected. KB3189866 still includes the problem, because updates are cumulative.

 

So we have to hide both updates now. *sigh*

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this