Jump to content

Sign in to follow this  
Pe11e

URP v1.1 for P3D v4 released

Recommended Posts

18 hours ago, aerobird said:

Yes, I have tried.


Applying preset E:\PTA 2.50\URP v1.1 High Contrast (no Reshade).ini...
   Applying [Reduce cloud brightness at dawn/dusk/night] to E:\Lockheed Martin\Prepar3D v4\ShadersHLSL\Cloud.fx
ERROR applying tweak [Reduce cloud brightness at dawn/dusk/night]  Problem with patch #0 - Null original block.
   Applying [Alternate lighting for clouds groups] to E:\Lockheed Martin\Prepar3D v4\ShadersHLSL\Cloud.fx
ERROR applying tweak [Alternate lighting for clouds groups]  Problem with patch #0 - Null original block.
   Applying [Clouds lighting tuning] to E:\Lockheed Martin\Prepar3D v4\ShadersHLSL\Cloud.fx
ERROR applying tweak [Clouds lighting tuning]  Problem with patch #0 - Null original block.
   Applying [Clouds saturation] to E:\Lockheed Martin\Prepar3D v4\ShadersHLSL\Cloud.fx
ERROR applying tweak [Clouds saturation]  Problem with patch #0 - Null original block.
   Applying [Clouds light scattering] to E:\Lockheed Martin\Prepar3D v4\ShadersHLSL\Cloud.fx
ERROR applying tweak [Clouds light scattering]  Problem with patch #0 - Null original block.
   Applying [Clouds Fog tuning] to E:\Lockheed Martin\Prepar3D v4\ShadersHLSL\Cloud.fx
ERROR applying tweak [Clouds Fog tuning]  Problem with patch #0 - Null original block.
   Applying [Reduce top layer cirrus clouds brightness at dawn/dusk/night] to E:\Lockheed Martin\Prepar3D v4\ShadersHLSL\General.fx
ERROR applying tweak [Reduce top layer cirrus clouds brightness at dawn/dusk/night]  Problem with patch #0 - Null original block.
   Applying [Cirrus lighting] to E:\Lockheed Martin\Prepar3D v4\ShadersHLSL\General.fx
ERROR applying tweak [Cirrus lighting]  Problem with patch #0 - Null original block.
   Applying [Objects lighting] to E:\Lockheed Martin\Prepar3D v4\ShadersHLSL\General.fx
ERROR applying tweak [Objects lighting]  Problem with patch #0 - Null original block.
   Applying [Aircraft lighting & saturation] to E:\Lockheed Martin\Prepar3D v4\ShadersHLSL\General.fx
ERROR applying tweak [Aircraft lighting & saturation]  Problem with patch #0 - Null original block.
   Applying [Autogen emissive lighting] to E:\Lockheed Martin\Prepar3D v4\ShadersHLSL\General.fx
ERROR applying tweak [Autogen emissive lighting]  Problem with patch #0 - Null original block.
   Applying [Terrain lighting] to E:\Lockheed Martin\Prepar3D v4\ShadersHLSL\GPUTerrain.fx
ERROR applying tweak [Terrain lighting]  Problem with patch #0 - Null original block.
   Applying [Urban areas lighting at night] to E:\Lockheed Martin\Prepar3D v4\ShadersHLSL\GPUTerrain.fx
ERROR applying tweak [Urban areas lighting at night]  Problem with patch #0 - Null original block.
   Applying [Terrain saturation] to E:\Lockheed Martin\Prepar3D v4\ShadersHLSL\GPUTerrain.fx
ERROR applying tweak [Terrain saturation]  Problem with patch #0 - Null original block.
   Applying [Water surface tuning] to E:\Lockheed Martin\Prepar3D v4\ShadersHLSL\GPUTerrain.fx
ERROR applying tweak [Water surface tuning]  Problem with patch #0 - Null original block.
   Applying [Waves size] to E:\Lockheed Martin\Prepar3D v4\ShadersHLSL\GPUTerrain.fx
ERROR applying tweak [Waves size]  Problem with patch #0 - Null original block.
   Applying [Water saturation] to E:\Lockheed Martin\Prepar3D v4\ShadersHLSL\GPUTerrain.fx
ERROR applying tweak [Water saturation]  Problem with patch #0 - Null original block.
   Applying [Specular lighting] to E:\Lockheed Martin\Prepar3D v4\ShadersHLSL\FuncLibrary.fxh
ERROR applying tweak [Specular lighting]  Problem with patch #0 - Null original block.
   Applying [Rayleigh scattering effect] to E:\Lockheed Martin\Prepar3D v4\ShadersHLSL\FuncLibrary.fxh
ERROR applying tweak [Rayleigh scattering effect]  Problem with patch #0 - Null original block.
   Applying [Haze effect] to E:\Lockheed Martin\Prepar3D v4\ShadersHLSL\FuncLibrary.fxh
ERROR applying tweak [Haze effect]  Problem with patch #0 - Null original block.
   Applying [Turn off HDR luminance adaptation effect] to E:\Lockheed Martin\Prepar3D v4\ShadersHLSL\PostProcess\HDR.hlsl
ERROR applying tweak [Turn off HDR luminance adaptation effect]  Problem with patch #0 - Null original block.
   Applying [Alternate tonemap adjustment] to E:\Lockheed Martin\Prepar3D v4\ShadersHLSL\PostProcess\HDR.hlsl
ERROR applying tweak [Alternate tonemap adjustment]  Problem with patch #0 - Null original block.
   Applying [Contrast tuning] to E:\Lockheed Martin\Prepar3D v4\ShadersHLSL\PostProcess\HDR.hlsl
ERROR applying tweak [Contrast tuning]  Problem with patch #0 - Null original block.
   Applying [Custom post-processing] to E:\Lockheed Martin\Prepar3D v4\ShadersHLSL\PostProcess\HDR.hlsl
         Activating post-process [DPX]
         Activating post-process [Sepia]
Preset has been applied with errors. See log above
Shaders cache cleared

 

Hi Aerobird,

Instead of making out that my software is broken, try actually buying it :) You have a pirated version, hence all of the errors.

Thanks,


Matt.

  • Upvote 1

Matt Davies

Founder/CEO - Mettar Simulations

=====
Prepar3D Tweak Assistant (PTA) available here: https://www.simtweaks.com
projectFLY - one of the most used virtual aviation platforms (now with GLOBAL schedules):  https://www.projectfly.co.uk

Share this post


Link to post
Share on other sites
35 minutes ago, MattDavies said:

Hi Aerobird,

Instead of making out that my software is broken, try actually buying it :) You have a pirated version, hence all of the errors.

Thanks,


Matt.

 

Share this post


Link to post
Share on other sites

I am new to using URP, but I believe I have found a bug in the new 1.1 config tool. It doesn't seem to update the add-on.xml for the sky texture. Toggling on and off the sky textures in the tool seems to do nothing in the sim. When I manually added a block in add-on.xml pointing at Sky\Texture I ended up with a much nicer sky.

Hope this helps and thanks for the great addon.

Share this post


Link to post
Share on other sites
6 hours ago, gprguy said:

I am new to using URP, but I believe I have found a bug in the new 1.1 config tool. It doesn't seem to update the add-on.xml for the sky texture. Toggling on and off the sky textures in the tool seems to do nothing in the sim. When I manually added a block in add-on.xml pointing at Sky\Texture I ended up with a much nicer sky.

Hope this helps and thanks for the great addon.

 

Can you post here the block you added in the add-on.xml?

Thanks.


Alvega

Share this post


Link to post
Share on other sites

I added this:

  <AddOn.Component>
    <Category>Texture</Category>
    <Path>Sky\Texture</Path>
    <Type>GLOBAL</Type>
  </AddOn.Component>

If I make any changes with the URP tool, that block gets wiped out again. Add it back, and the sky textures load in properly.

  • Upvote 1

Share this post


Link to post
Share on other sites
6 hours ago, gprguy said:

I added this:

  <AddOn.Component>
    <Category>Texture</Category>
    <Path>Sky\Texture</Path>
    <Type>GLOBAL</Type>
  </AddOn.Component>

If I make any changes with the URP tool, that block gets wiped out again. Add it back, and the sky textures load in properly.

Currently, the URP tool puts the path directly into Texture.cfg in %pgoramdata%. This was because (for some reason) add-on.xml didn't update the sky textures, and I was too tired to figure it out. I'll test some more and include this in the next update :D


Thanks,

Prithvi Shivaraman

 

Pilot at Royal Dutch Virtual

Share this post


Link to post
Share on other sites
8 hours ago, gprguy said:

I added this:

  <AddOn.Component>
    <Category>Texture</Category>
    <Path>Sky\Texture</Path>
    <Type>GLOBAL</Type>
  </AddOn.Component>

If I make any changes with the URP tool, that block gets wiped out again. Add it back, and the sky textures load in properly.

 

Thanks, my sky texture didn't change too without adding this block.


Alvega

Share this post


Link to post
Share on other sites
On ‎10‎/‎06‎/‎2017 at 7:50 AM, MattDavies said:

Hi Aerobird,

Instead of making out that my software is broken, try actually buying it :) You have a pirated version, hence all of the errors.

Thanks,


Matt.

That's pretty low @aerobird.  It's bad enough stealing the software, then you come and ask the person you stole it from for help????? :angry:


Matt Webb

Share this post


Link to post
Share on other sites

I'm glad I found this thread. I was having some issues with the sky textures and now I know why? Is there a PTA preset for URP or how do I import setting to PTA?

Thanks in advance.

Share this post


Link to post
Share on other sites

Can urp be used with pta.  I have both installed at moment. Looks ok but wondering if I may be asking the software to do the same thing twice.

Thanks

S


Systems: XP-11 System: I7 8700K 4.8Ghz,32GB 3000 DDR4 RAM,1x1TB SSD,Geforce GTX1080ti 11GB,Windows 10.

Utilities System: Surface Book 2, I7, GTX1050, 16GBRAM, 500GB SSD, Windows 10.

signature-dark.png

Share this post


Link to post
Share on other sites

Would.also like to know the answer tothat question stephen.

Also how can we turn down Raleigh scattering effect in urp 1.1 installer for v4??

Without pta??

Thanks 

Mike 

Share this post


Link to post
Share on other sites

And here's another one who would like to know if/how PTA and URP are meant to be used together?

I'm on latest version of both P3Dv4, PTA and URP and to make things even more complicated I also have ENVTEX installed :biggrin:


Richard Åsberg
Beta tester for FS2Crew and HiFi Simulation Technologies

Share this post


Link to post
Share on other sites
On 6/11/2017 at 5:11 AM, 997R8V10 said:

Currently, the URP tool puts the path directly into Texture.cfg in %pgoramdata%. This was because (for some reason) add-on.xml didn't update the sky textures, and I was too tired to figure it out. I'll test some more and include this in the next update :D

Thanks for the explanation!

Still wondering though why some people are reporting they need to add the missing block to add-on-xml in order to see the new sky textures? Doing that would mean you're trying to load the same URP sky textures twice in two different ways?

Guess I'll have to play around with this a bit and see what's true on my machine.

Edited to add I just noticed how the entry in texture.cfg has the Required parameter set to False. Is that how it should be or could that be the reason why people also need to add a block to add-on.xml to have the URP sky textures loaded?

For scenery you would use the scenery library option in P3D to manage your installed scenery but what about textures and the entries listed in texture.cfg? Is there a UI for that as well I overlooked or is the only way managing these entries by manually editing texture.cfg?


Richard Åsberg
Beta tester for FS2Crew and HiFi Simulation Technologies

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    27%
    $6,985.00 of $25,000.00 Donate Now
×
×
  • Create New...