edpatino

SODE new version 1.5.2

Recommended Posts

Hi:

Now that a new version of the SODE module (v1.5.2) has been released, and according to the changes included in this version, SODE is now installing following the LM suggested procedure for installing addons in P3Dv3.4 and P3Dv4.

Taking this into account:

1. Which is the detailed correct procedure for updating a existing SODE installation to v1.5.2 in P3Dv3.4?. I fear the SODE manual is not covering this procedure in detail (it only refers to running the .msi installer and then register it into the simulator version). There is no mention about the need of uninstalling and/or unregistering the existing version and how.

2. Will all the existing SimObjects from the different scenery developers be re-located or preserved as they are in their current directory locations (C:\ProgramData\12bPilot\SODE\SimObjects) by the new installer?. I have at least 20 different simobjects already installed and do not want to re-install them.

Thanks in advance for any help.

Cheers, Ed

 

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Ask the developer?

Share this post


Link to post
19 minutes ago, WarpD said:

Ask the developer?

Done, but no answer so far.

Cheers, Ed

Share this post


Link to post

Well, they do live on a different part of the giant marble... 

Share this post


Link to post

1. Don't worry. The installer takes care of it. I upgraded SODE 1.5.2 from 1.4.x and no issues in V3 or V4. I did no deinstall. 

In V4, the installer makes the entry for the SODE exe into the add-on.xml. 

Make sure to activate SODE for the platforms that you intend to use. 

2.  The simobjects remain at their place and are not touched. As such they comply with the new installation convention that was introduced in V3

Share this post


Link to post
3 hours ago, edpatino said:

Hi:

Now that a new version of the SODE module (v1.5.2) has been released, and according to the changes included in this version, SODE is now installing following the LM suggested procedure for installing addons in P3Dv3.4 and P3Dv4.

Taking this into account:

1. Which is the detailed correct procedure for updating a existing SODE installation to v1.5.2 in P3Dv3.4?. I fear the SODE manual is not covering this procedure in detail (it only refers to running the .msi installer and then register it into the simulator version). There is no mention about the need of uninstalling and/or unregistering the existing version and how.

2. Will all the existing SimObjects from the different scenery developers be re-located or preserved as they are in their current directory locations (C:\ProgramData\12bPilot\SODE\SimObjects) by the new installer?. I have at least 20 different simobjects already installed and do not want to re-install them.

Thanks in advance for any help.

Cheers, Ed

 

I can only speak for myself here. What I do is just uninstalling it from the Programs and Features list. No issue whatsoever.

Share this post


Link to post
1 hour ago, Cargostorm said:

The simobjects remain at their place and are not touched. As such they comply with the new installation convention that was introduced in V3

Hi Chris, thanks for your input. On my setup (still P3Dv3.4), the simobjects were placed into the folders the previous SODE (v1.4.x) did install them, using the previous convention ("old method", not the new one suggested/recommended by LM with everything outside the sim), so if I understand you correcly, their current location (in C:\ProgramData\etc...) according to your experience, will not be touched by the new v1.5.2 installer?. Please confirm and thanks in advance. This is what concerns me the most.

Cheers, Ed

 

Share this post


Link to post
4 hours ago, edpatino said:

no answer so far

Ed, Jeffrey - the developer of SODE - is an airline pilot busy flying around the world.
Give him some time! :wink:
He will finaly reply. He is a very helpful man.

Share this post


Link to post

For what it's worth I can't get the latest version to read my p3d v3 path, only v4.  Consequently, I can't register it in v3.  Tried to reinstall, same problem. 

Share this post


Link to post
48 minutes ago, Rafal said:

Ed, Jeffrey - the developer of SODE - is an airline pilot busy flying around the world.
Give him some time! :wink:
He will finaly reply. He is a very helpful man.

+1 He sure is. Very helpful, and won't see you stuck.

Share this post


Link to post
2 hours ago, Rafal said:

Ed, Jeffrey - the developer of SODE - is an airline pilot busy flying around the world.
Give him some time! :wink:
He will finaly reply. He is a very helpful man.

 

1 hour ago, Travelling_Wilbury said:

+1 He sure is. Very helpful, and won't see you stuck.

Thanks for the info. I'll be waiting, no rush here.

Cheers, Ed

 

  • Upvote 1

Share this post


Link to post

[UPDATE]

Thanks to Jeffrey, the SODE developer, who responded to all the enquiries concerning the correct procedure for uninstalling any previous version of SODE and installing the newest v1.5.2. If anyone is interested I'll suggest writing an email to him.

Cheers, Ed

 

  • Upvote 2

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now