bberish

Horrible Experience with New 4K Monitor @30hz

Recommended Posts

I just bought a brand new 4K Samsung 28' monitor today in hopes of getting some buttery smooth frames at a higher resolution... 

My PC Specs, i7 6700 4.0, and Nvidia 1080, 32gigs DDR4 memory, liquid cooling etc. the good stuff :)

I had some problems with micro stutters, and I heard that a 4k 30hz refresh rate monitor would make P3D Beautiful and smooth.

Unfortunately, total opposite case for me... I load up the default F-22, at add on scenery KSEA... I have Vsync, and Triple buffering on.

Smooth for a few seconds 30fps,

then I switch views to spot plane and my frames hit 5fps OR LOWER, and they stay that way... 

So i turn off Vsync a triple buffer, same thing, 5fps or lower in any view, almost as if the sim is freezing momentarily. 

 

After trying a lot of different things, I'm basically using the same resolution as my old monitor, but on my new 4K capable monitor, which is depressing... I'd love to be able to take full advantage of high resolution. 

 

Any suggestions, or thoughts on why this might be happening? My system is totally capable, but I'm not sure why i'm having this issue?

 

Any system or P3D settings you need, just ask.

I feel like this can't be a P3D issue, but a system issue... Is my GPU overloading? I've used task manager to monitor CPU while experiencing 5fps or lower, and CPU usage is very low... surprisingly low actually.

 

Thanks for your help!

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

It's very possible you are exhausting your video memory. Are you running MSAA or SSAA? At 4K resolution with a 1080 I wouldn't go higher than about 2x MSAA.

Share this post


Link to post

Try setting frame rates to unlimited  in SIM and VSYNC on. I don’t use triple buffering coz I can’t see any difference and feel it’s not quite as smooth. (Hard to tell)

Make sure your Nvidia settings are default, delete your shaders and Check your FPS. It should be at 30 if your monitor is set to 30hz.

You need to be holding 30 FPS for smooth stutter free fly’n.

Ive dropped my 4k 65”tv to 25hz to eliminate stutters at big 3rd party airports where I could’nt hold 30FPS.

If you’re still getting lower than 30FPS at a default airport in a default aircraft then you’ll need to have a look at other settings and drop them back. Dynamic lighting and speed trees or high autogen and shadows are big hogs.

As an example I have a Titan X (pascal) similar to your 1080 and have textures set at 4k and most slides maxed out. I use Dynamic Lighting (no speed trees) only MSAA and hold a constant 25 FPS most of the time. My CPU is an old 6800k but OC’d to 4.6.

Im guessing, but your machine should see similar results.

Share this post


Link to post

I don't care what you do, you're going to have heck of a time getting a 28 foot monitor to run smoothly. :biggrin: 

  • Upvote 5

Share this post


Link to post

I have a Samsung 4k monitor tho I use a 1080Ti I have regularly seen between 8 and 10 GBs of the Vram in use at 4k with a terrain setting of 10, all the important sliders to the right and 8xMSAA (flying either the Twin Otter or the PMDG 737. I suspect if you are trying to run the same visual performance levels of 1920x1080 res now at 4k that is the strain for the 1080 Vram which I believe is 8GBs? I know my 980Ti was struggling with much lower sliders because of the 6Gbs in it. I moved to a 1080Ti from it with my old CPU (3930k @4.4Mhz) and the stutters and loading issues disappeared.

Share this post


Link to post
1 hour ago, wckorb said:

It's very possible you are exhausting your video memory. Are you running MSAA or SSAA? At 4K resolution with a 1080 I wouldn't go higher than about 2x MSAA.

Beat me too it. I'm using 2x 980Ti in sli with a 4K monitor.   I use 4x msaa.  If I use ssaa it kills the system 

Share this post


Link to post

I'm running a old 4690k and a gtx 1070 and have 0 issues maintaining a stable 30 fps with my 4k display.  I would venture to say you have an issue in your PC config somewhere or the sim isn't configured properly.

Share this post


Link to post
1 hour ago, Chuck Nance said:

I don't care what you do, you're going to have heck of a time getting a 28 foot monitor to run smoothly. :biggrin: 

I missed that. A 28’ (foot) monitor might work if you have all slides to the left and no AI traffic. Not sure about SLI in P3Dv4.1 but try a minimum of 6 1080’s in SLI.

😂

Share this post


Link to post
3 hours ago, bberish said:

I just bought a brand new 4K Samsung 28' monitor today in hopes of getting some buttery smooth frames at a higher resolution... 

 

Not sure the buttery smooth silver bullet has been found yet.  You don't have a bad setup but everything is still a trade-off. 

Share this post


Link to post

The only problem you will get with GPU Vram is when you use Texture_exp mod. 

 

@bberish Install some tools to monitor your PC and see what's going on. Sounds like you hit some kind of limit somewhere.

Share this post


Link to post
7 hours ago, Chuck Nance said:

I don't care what you do, you're going to have heck of a time getting a 28 foot monitor to run smoothly. :biggrin: 

I got it for a steal! 

Share this post


Link to post
7 hours ago, wckorb said:

It's very possible you are exhausting your video memory. Are you running MSAA or SSAA? At 4K resolution with a 1080 I wouldn't go higher than about 2x MSAA.

I went down to 4xMSAA. 

 

I also reset my Nvidia Inspector and NVC to defaults, but immediately changed to "Prefer Maximum Performance"

 

I run Texture exp at 10. Does 9 make much of a visual difference at a 4k resolution on a 28foot monitor?

Share this post


Link to post
7 hours ago, Iceman2 said:

Try setting frame rates to unlimited  in SIM and VSYNC on. I don’t use triple buffering coz I can’t see any difference and feel it’s not quite as smooth. (Hard to tell)

Make sure your Nvidia settings are default, delete your shaders and Check your FPS. It should be at 30 if your monitor is set to 30hz.

You need to be holding 30 FPS for smooth stutter free fly’n.

Ive dropped my 4k 65”tv to 25hz to eliminate stutters at big 3rd party airports where I could’nt hold 30FPS.

If you’re still getting lower than 30FPS at a default airport in a default aircraft then you’ll need to have a look at other settings and drop them back. Dynamic lighting and speed trees or high autogen and shadows are big hogs.

As an example I have a Titan X (pascal) similar to your 1080 and have textures set at 4k and most slides maxed out. I use Dynamic Lighting (no speed trees) only MSAA and hold a constant 25 FPS most of the time. My CPU is an old 6800k but OC’d to 4.6.

Im guessing, but your machine should see similar results.

Tried the above, set frames to unlimited, VSYNC but NO triple buffer... same issue

Nvidia was set to default except for "Prefer Maximum Performance" - Same issue, frames hover around 30 for a few moments then drop to less than 5fps, whenever I change external views or start flying

 

Share this post


Link to post
7 hours ago, Uteman said:

I have a Samsung 4k monitor tho I use a 1080Ti I have regularly seen between 8 and 10 GBs of the Vram in use at 4k with a terrain setting of 10, all the important sliders to the right and 8xMSAA (flying either the Twin Otter or the PMDG 737. I suspect if you are trying to run the same visual performance levels of 1920x1080 res now at 4k that is the strain for the 1080 Vram which I believe is 8GBs? I know my 980Ti was struggling with much lower sliders because of the 6Gbs in it. I moved to a 1080Ti from it with my old CPU (3930k @4.4Mhz) and the stutters and loading issues disappeared.

A 1080TI makes a huge difference from the 1080? 

What are heaviest hitters on the GPU? Shaders, Texture_EXP? What else can I try adjusting. I want good visuals, as well as a smooth experience.

Share this post


Link to post

I'm running a 4k monitor on a 3770k with a 3gb VRAM GTX 780 just fine. I do have to run the graphics sliders at medium settings. Your hardware is fine, something is messed up with your configuration.

I suggest to start:

1) Disable Nvidia Inspector.

2) Then delete your P3D.cfg and your sliders folder, start p3d, let them rebuild, and then run P3D with the default settings. If it runs fine, bump your settings up slowly one by one.

3) If that hasn't cured it, reinstall your Nvidia drivers doing a clean install then repeat step 2.

Almost make sure your monitor has the correct settings and you are connected to the correct input port, this is especially important if your monitor is a TV.

A lot of people have made good suggestions, however you have not provided enough information on your system configuration and addons. Your problem could be either of those.

If you are using Windows 10....well then it could also be a bad forced update from Microsoft.

What I have suggested is just basics to try and clean up your setup. If they don't work you will need to provide more information and dig deeper. The reason you are getting 5 fps is not due to your video card unless it is faulty or has a bad driver or physical install.

Ted

Share this post


Link to post

This thread might help you out:

In a nutshell, here's what hits the GPU

- Shadows
- Dynamic Reflections
- SSAA
- Dynamic Lighting
- 3D Water (water set to ultra)
- New 3D rain/snow effects (set weather to storm theme to test)

I run a 6600k and 1060 and have decent performance even wtih 4x SSAA.  At some of the bigger/less optimized airports I have to drop it to 8x MSAA though.  I run my monitor at 25 hz and it usually holds that.  I do sacrifice a lot in other areas though (ie low cloud draw distance, water dropped, no dynamic lighting or reflections, middle of the road autogen, etc).

Share this post


Link to post
44 minutes ago, Ted Striker said:

I'm running a 4k monitor on a 3770k with a 3gb VRAM GTX 780 just fine. I do have to run the graphics sliders at medium settings. Your hardware is fine, something is messed up with your configuration.

I suggest to start:

1) Disable Nvidia Inspector.

2) Then delete your P3D.cfg and your sliders folder, start p3d, let them rebuild, and then run P3D with the default settings. If it runs fine, bump your settings up slowly one by one.

3) If that hasn't cured it, reinstall your Nvidia drivers doing a clean install then repeat step 2.

Almost make sure your monitor has the correct settings and you are connected to the correct input port, this is especially important if your monitor is a TV.

A lot of people have made good suggestions, however you have not provided enough information on your system configuration and addons. Your problem could be either of those.

If you are using Windows 10....well then it could also be a bad forced update from Microsoft.

What I have suggested is just basics to try and clean up your setup. If they don't work you will need to provide more information and dig deeper. The reason you are getting 5 fps is not due to your video card unless it is faulty or has a bad driver or physical install.

Ted

Here is what I will try tonight:

  • Nvidia Inspector Disabled
  • Nvidia Control - "Prefer Maximum Performance"
  • Texture_EXP set to 9, NOT 10 (See if this is still visually appealing at 4k)
  • Untick "Use High Resolution Terrain Textures" in P3d World Settings
  • Vsync On - Tripple Buffer On - Unlimited Frames
  • 4xMSAA
  • FXAA OFF
  • Anisotropic 8x Filtering
  • Resolution 2048-2048
  • Water Detail Medium

 

From there, I'll adjust scenery settings. I would like to keep Dynamic Lighting, however, I've always kept dynamic reflections off

 

 

Share this post


Link to post

Texture EXP set to 10 uses 9-10GB VRAM on my system (1080Ti SLI), so it's another likely culprit. Setting it to 9 will probably solve your issue and cut your load times in half without noticeably affecting visuals. As far as I remember, ticking the "High Resolution Terrain Textures" box will set this to 9 for you.

You will also see better performance at 2xMSAA. Any more than that just isn't necessary on a 28" monitor. 

Share this post


Link to post
55 minutes ago, bberish said:
  • Texture_EXP set to 9, NOT 10 (See if this is still visually appealing at 4k)
  • Untick "Use High Resolution Terrain Textures" in P3d World Settings

LOL When you TICK the High Res option you will be using EXP at 9. If I were you I'd either remove that option completely from the cfg or simply tick the option. Adding it manually to the cfg and then unticking it in P3D makes no sense.

BTW EXP 10 isn't worth it at all imho: huge increase in loading times and you can hardly see the difference. In fact, if I were you I'd untick that option and use the default setting for a while: if there is a difference, you will hardly notice it anyway. The same goes for other settings btw: a lot of people seem to feel the need to pull as much sliders right as possible just because they can while using more moderate settings hardly makes the overal experience less worth it.

Anyway, one more tip: why would you want to set Anisotropic to 8x...?! That setting should be set at the max of 16 on EVERY computer because even 10 year old hardware can use it without any problems. I am surprised this is even an option. Don't expect setting it to 8 to make any difference: it won't. While a low setting actually DOES have a clear influence on what you see, unlike that EXP setting. So don't even try it. :happy:

Share this post


Link to post
4 minutes ago, J van E said:

LOL When you TICK the High Res option you will be using EXP at 9. If I were you I'd either remove that option completely from the cfg or simply tick the option. Adding it manually to the cfg and then unticking it in P3D makes no sense.

 

Negative Sir! At least on my system with High Res ticked and no exp i have a lot of problems with the autogen distance, loading almost below my plane, with exp 9 the problem is gonne, but i get a longer loading time.

Share this post


Link to post

I have a 32 inch 4K monitor powered by a Nvidia 1070. If  I run monitor at 30 hz flight sim and mouse on screen are not smooth, but running monitor at 60 hz resolves the situation.

Is you monitor capable of 60 hz ?

 

Regards Brian

Share this post


Link to post
1 hour ago, dmarques69 said:

Negative Sir! At least on my system with High Res ticked and no exp i have a lot of problems with the autogen distance, loading almost below my plane, with exp 9 the problem is gonne, but i get a longer loading time.

Ok, well, then this is clearly one of those YMMV things. :happy:

Share this post


Link to post
1 hour ago, SpaceMonkey said:

I have a 32 inch 4K monitor powered by a Nvidia 1070. If  I run monitor at 30 hz flight sim and mouse on screen are not smooth, but running monitor at 60 hz resolves the situation.

Is you monitor capable of 60 hz ?

 

Regards Brian

The option isn't on Nvidia Control Center to go to 60hz at the 4k resolutions, only the lower 1080p resolutions. I think I am currently running 1920x1080, at 59hz. 60hz give me stutters. 

 

Share this post


Link to post
On ‎10‎/‎26‎/‎2017 at 0:38 AM, bberish said:

I just bought a brand new 4K Samsung 28' monitor today in hopes of getting some buttery smooth frames at a higher resolution... 

My PC Specs, i7 6700 4.0, and Nvidia 1080, 32gigs DDR4 memory, liquid cooling etc. the good stuff :)

I had some problems with micro stutters, and I heard that a 4k 30hz refresh rate monitor would make P3D Beautiful and smooth.

Unfortunately, total opposite case for me... I load up the default F-22, at add on scenery KSEA... I have Vsync, and Triple buffering on.

Smooth for a few seconds 30fps,

then I switch views to spot plane and my frames hit 5fps OR LOWER, and they stay that way... 

So i turn off Vsync a triple buffer, same thing, 5fps or lower in any view, almost as if the sim is freezing momentarily. 

 

After trying a lot of different things, I'm basically using the same resolution as my old monitor, but on my new 4K capable monitor, which is depressing... I'd love to be able to take full advantage of high resolution. 

 

Any suggestions, or thoughts on why this might be happening? My system is totally capable, but I'm not sure why i'm having this issue?

 

Any system or P3D settings you need, just ask.

I feel like this can't be a P3D issue, but a system issue... Is my GPU overloading? I've used task manager to monitor CPU while experiencing 5fps or lower, and CPU usage is very low... surprisingly low actually.

 

Thanks for your help!

Bberrish

There are a number of settings in common addons that greatly affect performance, besides the settings in P3dV4 itself.  Here's a link to a very good video setting up P3d, AS16, Envtex, ASCA, ORBX and more.  https://www.youtube.com/watch?v=epD8EHwBT5kI  You may also wish to review Rob Ainscough's excellent written P3D setup guide found in AVSIM through this link. https://www.avsim.com/files/file/87-avsim-prepar3d-guide/

My suggestion is to delete your config and shaders, rebuild them, and then follow the suggestions in the video first (18minutes) and then review Rob's instructions if that doesn't work.

Good luck.

Jay

Share this post


Link to post
15 hours ago, bberish said:

Smooth for a few seconds 30fps,

then I switch views to spot plane and my frames hit 5fps OR LOWER, and they stay that way... 

Typically switching from VC to external view will increase your FPS, not reduce it so I'd look elsewhere for your FPS reduction issue.

As a start I'd recommend you backup your Prepar3d.cfg, delete it (a new one will get created on P3D start) and then delete your shaders folder.  If you have any nVidia profiles (via NCP, delete them for Prepar3d.exe).  Be sure to do all this while P3D is NOT running (sorry that I have to mention that, but I found many end users do this type of diagnostics while P3D is still running).

It would be helpful to also provide the detail specifications on your monitor (brand and model number) if it's this monitor: 

https://www.samsung.com/us/computing/monitors/uhd-and-wqhd/samsung-uhd-28-monitor-with-high-glossy-black-finish-lu28e590ds-za/

Then you'll want to disable FreeSync.

Make sure Windows scaling is at 100%  (that will make icons/text very small but you don't want to run P3D with any scaling, stay at 1:1).

Per documentation for that monitor: http://downloadcenter.samsung.com/content/UM/201510/20151030173012594/BN46-00481B-Eng.pdf

"An HDMI cable that supports 3840 x 2160 at 30 Hz will work when connect with HDMI 1. An HDMI cable that supports 3840 x 2160 at 60 Hz will work when connect with HDMI 2."

So if you're operating at 30Hz make sure your HDMI cable is plugged into HDMI 1 port on the TV/monitor.

Cheers, Rob.

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now