Jump to content

Sign in to follow this  
craig_read

P3Dv4 Pause (Not Responding) Then Back

Recommended Posts

I always experience these pauses or hangs approaching certain scenery.  My last flight was into KLGA arriving on the MIT I flew the same track as displayed by Flightaware from my AA380 flight, from Jersey up over Brooklyn and overfly LGA on 045 track until about 5 N field then turn Southeast for downwind, Southwest for base then Northwest final for landing 31.  I started getting multiple "long frames" (as I call them) on base and had maybe three of them by the time I landed.  In other sessions I noticed that during the long frame scenery objects about 5 nm away get loaded and pop into sight, so I've always believed long frames are caused by P3D not being able to render new scenery objects within a normal frame period.  On this track P3D had to load scenery objects for both FSDT JFK and Imaginesim LGA.

I keep hoping that the next version will have enough multithreading to allow this task to get accomplished within a frame period, but until that happens I think we are stuck with long frames.


Dan Downs KCRP

Share this post


Link to post

Anyone find a solution to this yet?


All the best,

-John

Milviz Team (posts are of my own opinion)

Share this post


Link to post
2 hours ago, Milton Waddams said:

Anyone find a solution to this yet?

Don't use scenery addon?  Wait for a version of P3D that overcomes the long frame problem?


Dan Downs KCRP

Share this post


Link to post
4 hours ago, downscc said:

Don't use scenery addon?  Wait for a version of P3D that overcomes the long frame problem?

I seemed to have solved it by disabling FSUIPC’s time sync option, haven’t tested I with the aircraft that I was experiencing the problem in, though. 


All the best,

-John

Milviz Team (posts are of my own opinion)

Share this post


Link to post

Funny I was about to make a thread about it. Guess we are a lot in the same boat. 

Can't say the time after the latest windows10 1709 update has bin a walk in the park. Suddenly my network pc's are not allowed to share allthough ASP4 still works over network.

I had a lot of those 5-10 seconds pauses without the responding thing and the sound keeps going in the background around KLGA,KJFK,KEWR and KDCW with D D New York as well. 

Maybe 16 GB DDR is not enough? no HRT. 

Thanks Michael Moe 


Michael Moe

 

fs2crew_747_banner1.png

Banner_FS2Crew_Emergency.png

Share this post


Link to post

Nope, problem still exists. It never used to do this before, weird.


All the best,

-John

Milviz Team (posts are of my own opinion)

Share this post


Link to post

I had this happening to me last flight into UK2000 EGLL where it started during the descent.

I read somewhere it could be because SODE Safe Docks used by the UK2000 EGLL scenery where disabling these should fix the problem. That didn't work in my case though so must be something else.

Very annoying (and scary since it feels like you're on the edge having a CTD) so let's hope the real culprit will be found soon looking at the number of people seeing this lately.

In my case it seems to be mostly (or even exclusively) in the UK area and more specifically in the London area. Haven't seen this elsewhere a far as I can recall.


Richard Åsberg
Beta tester for FS2Crew and HiFi Simulation Technologies

Share this post


Link to post
4 hours ago, WebMaximus said:

Very annoying (and scary since it feels like you're on the edge having a CTD) so let's hope the real culprit will be found soon looking at the number of people seeing this lately.

Hi Richard,

Don't know about 'lately', I experienced these pauses in 3.4, 4.0 and now 4.1.   I've mentioned it a few times but never get any responses or reassurance that I am not alone. Perhaps this thread will help to reverse that trend and encourage a drive to identify what might be responsible.

If we are assuming that the software is not responsible then what else could be implicated? In each case I have found these pauses to be at the same spot, reproduceable and in each case it seems to have something to do with delayed loading of an unidentified element or elements of scenery. For example, I recently installed ORBX's NZWR Whangarei Airport, which I can heartily recommend. Performance is excellent, but I was disappointed to experience one of those irritating pauses during takeoff. I reloaded and prior to takeoff I slewed back and forth along the length of the runway several times before trying again. Result: pause gone! This workaround is also effective elsewhere.

Again, in the past, I mentioned having helped troubleshoot similar pauses associated with a number of custom airports in the excellent product, 'Scotflight for Orbx'. At first my observations were met with some skepticism but, in time, my findings were accepted and the causes identified. Very little was divulged by the Developer but I am assuming there were issues with certain scenery elements. These were corrected and the pauses are now history.

I experience several brief pauses during takeoff along the runway in the Raptor at Elgin KVPS. I head west on a heading of 270 and as I approach Hurlburt (HRT) there is a long 4-5sec pause before the sim continues. As stated above, this too is reproduceable on my system and these pauses, brief and extended, can be worked around using the slew dodge or flying back and forth over the area. I have a friend who lives nearby and he says he does not see these pauses. His is a virgin installation of 4.1. However, it should be noted that I experienced this in 4.0 and a virgin 4.1 before reinstating all my Add-ons. Maybe a 3rd Party Add-on is in some way responsible, but the variety of diverse situations where these pauses occur suggests something other than a scenery element may be responsible, but what? Also what circumstance make these (extended pauses) reproduceable at each situation where they occur. Fortunately for me it's more an irritant than an issue of the show stopping kind as >80% of my simming time remains entirely pause free. I imagine your experience and those of others is likely to be similar.

Regards,

Mike


My rig: ASUS ROG Rampage V Extreme, i7-5960X (Dynamic OC 4.6 GHz - all cores, HT=ON, AM=21845), Corsair Hydro Series H110i GT Cooler with 2xNoctua NF-A14 PWM 140mm fans, G.SKILL Ripjaws 4 series 16GB (4 x 4GB) DDR4 3000, ASUS GTX 1080Ti ROG STRIX 11GB, GDDR5X (Driver versions: 441.66 (Win7), 452.06 (Win10)), Samsung 850 EVO 1TB SSD x4, Samsung 970 EVO 2TB V-NAND M.2, LG BH16NS40 16x SATA Internal BDRW, EVGA 1200 P2 Watt PSU, Cooler Master HAF X, ASUS ROG Swift PG278Q (G-Sync) monitor at 120Hz. Oculus Rift. Dual Boot: Windows 10 Pro 64bit (2004) / Prepar3D v5.0.31.35253, Windows 7 Pro 64bit / Prepar3D v4.5.12.30293.

Share this post


Link to post

I’ve only just recently started having this problem, after adding a bunch of Black Friday scenery: Orbx OpenLC, Vector, DD Washington X, and Flightbeam KIAD.  So, in my case, it definitely appears to be scenery related.

i was also able to induce the pause by looking back over my shoulder in the F-22, which also makes me think that it’s related to loading complex scenery, since P3D now has to render stuff behind me.  At least, that’s my uneducated guess.

Share this post


Link to post

Same here, haven't seen this before but looking at this thread as well as some other places more people seem to have this problem now for some reason. Or maybe just a coincidence more people are reporting about it at the same time.

In my case I don't think I could reproduce the issue. At least not with 100% certainty. What I do know is I've seen this issue for the last couple of weeks and only when flying in the UK area.


Richard Åsberg
Beta tester for FS2Crew and HiFi Simulation Technologies

Share this post


Link to post
5 minutes ago, WebMaximus said:

What I do know is I've seen this issue for the last couple of weeks and only when flying in the UK area.

Do you own payware versions of EGKK and EGLL at the same time?

The UK area is very overloaded with London and these airports, so perhaps you are seeing a symptom of the problem which manifest easier on this area.

Simbol 

Share this post


Link to post

Good idea but in the London area I only own EGLL.

I do own other UK airports though such as EGBB, EGPH and EGCC and all of them from UK2000.

What I found strange is how the pauses in my case were worse when I was somewhere between FL100-FL200. Luckily they disappeared when I got below FL100 during final approach and even more luckily during final.


Richard Åsberg
Beta tester for FS2Crew and HiFi Simulation Technologies

Share this post


Link to post

I get these pauses on approach into busy hubs usually about 10-15nm out which coincides with the sim loading the scenery in.  At this point I can only assume the engine can't deal with it and it pauses briefly to catchup. On further testing at the exact time these pauses occurs I have 100% CPU usage on 1 core so again it appears the sim is loading scenery into memory and briefly struggles to keep up.

Funnily enough I never had this problem using FSX SE and I have a more powerful PC for P3D so that's strange.


Thomas Derbyshire

Share this post


Link to post

Also, doesn't it seem strange that the circumstances surrounding our experiences often differ? Yet one thing is now beyond dIspute. The occurrence of these extended pauses (4-5 seconds in my case) is indeed an established fact and this alone suggests that a common factor is involved.

I'm assuming (since there have been no similar reports) that others are not seeing what I'm seeing while approaching HRT from the east, yet I have no logical explanation for these occurrences. Actually, I've experienced similar pauses elsewhere in this general area, but they are less predictable. Scenery-wise this area is not particularly dense and, when run unlimited (which I don't), frame rates are high. ORBX Global Base, Global Vector and Landclass are involved and there is minimal involvement of terrain elevation mesh as the area is flat as far as the eye can see. Otherwise performance is generally very smooth throughout.

It does seem unlikely that our hardware setups are implicated as our platforms are all very capable. In many cases the 1080Ti (which is never overstressed) is the active GPU and such pauses are not seen in other sims and games, at least that's my experience. 

When I encounter a pause I can reproduce it until I fly or slew linearly back and forward a few times through that exact same geographical situation. I'm gathering from posts to date that this may not be so for other users. 

This is both intriguing and, yes, a little frustrating! Perhaps, in some way, the P3D engine is implicated in some way and we will just have to live with it until an answer can be found. It seems a brief halt in processing occurs on encountering a particular, as yet, undefined set of circumstances. However, if the Developers are not seeing these pauses then there may not be much of an incentive to troubleshoot the issue.

Mike

 

 


My rig: ASUS ROG Rampage V Extreme, i7-5960X (Dynamic OC 4.6 GHz - all cores, HT=ON, AM=21845), Corsair Hydro Series H110i GT Cooler with 2xNoctua NF-A14 PWM 140mm fans, G.SKILL Ripjaws 4 series 16GB (4 x 4GB) DDR4 3000, ASUS GTX 1080Ti ROG STRIX 11GB, GDDR5X (Driver versions: 441.66 (Win7), 452.06 (Win10)), Samsung 850 EVO 1TB SSD x4, Samsung 970 EVO 2TB V-NAND M.2, LG BH16NS40 16x SATA Internal BDRW, EVGA 1200 P2 Watt PSU, Cooler Master HAF X, ASUS ROG Swift PG278Q (G-Sync) monitor at 120Hz. Oculus Rift. Dual Boot: Windows 10 Pro 64bit (2004) / Prepar3D v5.0.31.35253, Windows 7 Pro 64bit / Prepar3D v4.5.12.30293.

Share this post


Link to post

Ahhh.... 
I,m not the only one having this....
I only have it once during approach (or shortly before) and thought it was related to scenery loading of the (complex) airport and in combination with my processor affinity settings.
I had it both at FlyTampa's Athens and Corfu.

 

 


Location: Vleuten, The Netherlands, 15.7dme EHAM
System: P3D V4 - 80386 DX2 - 4MB RAM - 3dfx Voodoo5 - Windows 3.11

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    31%
    $7,775.00 of $25,000.00 Donate Now
×
×
  • Create New...