Anxu00

Is P3D Anti Alias hopeless?

Recommended Posts

Yesterday night, I finally got the MilViz Beaver up and running, and I don't know whether it's this bird, but some of the instruments look horrible with ragged edges.  My AA setting is FXAA: Off and MSAAx8, nothing else.  It's acceptable if DL was to be enabled for PMDG.  But boys, it's bad.  My GTX980 is OK, not great, but plunking down a 1000 bucks for GTX1080Ti with not really great results as reported by others is really not smart.  I know P3D has an inherent AA problem.  So the option is to bite it and bear, or do something else.  It's really is hopeless.

What's work for you?

  • Upvote 1

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

I'm running a 1080ti gpu and finding the cockpit detail is ok in the C310r (don't have the Beaver)

have   you tried increasing this in the .cfg file

[PANELS]
MAX_VC_TEXTURE_RESOLUTION=4096

 

J37Lhra.jpg

Share this post


Link to post

I've just upgraded to P3Dv4.1 using same settings as you on the same graphics card and I have no issues with the anti-aliasing. I've got a 24" monitor running 1080p.

Share this post


Link to post
2 hours ago, onebob said:

I'm running a 1080ti gpu and finding the cockpit detail is ok in the C310r (don't have the Beaver)

have   you tried increasing this in the .cfg file

[PANELS]
MAX_VC_TEXTURE_RESOLUTION=4096

 

J37Lhra.jpg

Thanks I was not aware of that.  That's just texture resolution.  what's your AA settings?  No shimmering at the instruments? What's your monitor resolution?  The C310R cockpit looks good.  AA shimmering may be as well depending on aircraft.  With my setting the PMDG 777 cockpit also looks good.

Share this post


Link to post
3 hours ago, Anxu00 said:

What's work for you?

If you run 1080p then you might want to use SSAA rather than MSAA.  But sounds like you might have other issues, have you check that your don't have an NI profile setup for your 980 that might be conflicting with your in-sim settings?  Also, if you have "widescreen" enabled, I suggest you disable it.

Cheers, Rob.

Share this post


Link to post
20 minutes ago, Anxu00 said:

  what's your AA settings?  No shimmering at the instruments? What's your monitor resolution

Using 8xmsaa, no shimmering, and the monitor resolution is 2560x1440x32,

bob

Share this post


Link to post

Umm I have a asus rog 1080ti and it doesn't let me run the ngx at night with DL on so don't buy one  because you think it will. Its not even close if you're using msaa.

 

I go from like 40 fps down to 16 if I use.l 8xmsaa

Share this post


Link to post

Sorry, I misread the OP. Yeah the MSAA is poor and it caught me out to start with, switch to 4xSSAA with FSAA disabled and it looks nice and run better than the default settings.

Share this post


Link to post
[GRAPHICS]
TEXTURE_MAX_LOAD=2048
TEXTURE_MAX_LOAD=2048
NUM_LIGHTS=4
COCKPIT_HIGH_LOD=1
AIRCRAFT_REFLECTIONS=1
LANDING_LIGHTS=1
DYNAMIC_LIGHTING=1
DAWN_DUSK_SMOOTHING=1
LENSFLARE=1
HDR=1
DYNAMIC_REFLECTIONS=1
SHADOW_QUALITY=1
SHADOW_DRAW_DISTANCE=3
CONTENT_NO_SHADOW=0
INTERIOR_SHADOWS_CAST=1
EXTERIOR_SHADOWS_CAST=1
SIMOBJECT_SHADOWS_CAST=0
TERRAIN_SHADOWS_CAST=1
VEGETATION_SHADOWS_CAST=0
BUILDING_SHADOWS_CAST=0
CLOUD_SHADOWS_CAST=1
PARTICLES_SHADOWS_CAST=0
INTERIOR_SHADOWS_RECEIVE=1
EXTERIOR_SHADOWS_RECEIVE=1
SIMOBJECT_SHADOWS_RECEIVE=0
TERRAIN_SHADOWS_RECEIVE=1
VEGETATION_SHADOWS_RECEIVE=0
BUILDING_SHADOWS_RECEIVE=0
SHADOW_NUM_CASCADES_LOW=4
SHADOW_NUM_CASCADES_MID=5
SHADOW_NUM_CASCADES_HIGH=7
SHADOW_NUM_CASCADES_ULTRA=12
OPAQUE_SHADOW_TEXTURE_SIZE=2048
TRANSLUCENT_SHADOW_TEXTURE_SIZE=512
OPAQUE_SHADOW_DRAW_DISTANCE=2000
TRANSLUCENT_SHADOW_DRAW_DISTANCE=2000
EFFECTS_QUALITY=1
EFFECTS_DISTANCE=1
TEXTURE_QUALITY=3
IMAGE_QUALITY=0

[DISPLAY]
ChangeTime=0.200000
TEXTURE_FILTERING=8
MSAA=0
SSAA=4
VSYNC=0
TRIPLE_BUFFER=0

[SCENERY]
AUTOGEN_DRAW_DISTANCE=24000.000000
AUTOGEN_TREE_DRAW_DISTANCE_PERCENT=0.900000
AUTOGEN_TREE_MIN_DISTANCE_TO_LOD=2500.000000
MaxRegionsPurgePerFrame=16
POP_FREE_AUTOGEN=1
AUTOGEN_BATCH_LOD=2
AUTOGEN_VEGETATION_TYPE=0
IMAGE_COMPLEXITY=4

[TERRAIN]
LOD_RADIUS=9.500000
TESSELLATION_FACTOR=85
MESH_RESOLUTION=23
TEXTURE_RESOLUTION=28
AUTOGEN_VEGETATION_DENSITY=4
AUTOGEN_BUILDING_DENSITY=4
DETAIL_TEXTURE=1
HIGH_RESOLUTION_TERRAIN_TEXTURES=1

Excerpts of the keys bits of my prepar3d.cfg. It's looking nice and running smooth even in ORBX regions although I haven't thrown anything heavier than Majestic Q400 at it yet.

Share this post


Link to post

Age old problem of using 4xSSAA at night with dynamic lighting brings most cards down.  You can’t NOT use DL in the PMDG or else the landing lights don’t illuminate ground.  This is the position I’m in using a 1070.  I think it’s ridiculous if even a 1080ti can’t handle 4xSSAA with DL on because those cards aren’t cheap.  Anything less than 4xSSAA produces horrible ORBX night light shimmering as well so you are getting double shafted.  

  • Upvote 1

Share this post


Link to post

@sidfadcI'm doing exactly that on my GTX980 without issue but I only run 1080p and have no PMDG. I don't think the Majestic has dynamic landing lights yet but I do have them in my addon scenery.

Share this post


Link to post
20 hours ago, Rob Ainscough said:

If you run 1080p then you might want to use SSAA rather than MSAA.  But sounds like you might have other issues, have you check that your don't have an NI profile setup for your 980 that might be conflicting with your in-sim settings?  Also, if you have "widescreen" enabled, I suggest you disable it.

Cheers, Rob.

Disable Widescreen helped Thx.  I have a Dell 30" monitor: 2560x1600 (I think) so SSAA kills the PMDG performance with DL.  Right now I am settled with FXAA: On, 8xMSAA which seems to maintain reasonable performance for PMDG.  I am hoping PMDG will provide an option to switch back to legacy lights, as DL as a feature is just horrible for the average HW.  Knowing that Volta is around the corner, I decide to wait rather than getting the 1080Ti now.  And to be honest, I don't see evidence of that card help hugely either.

Share this post


Link to post
21 hours ago, Rob Ainscough said:

Also, if you have "widescreen" enabled, I suggest you disable it.

Why this? I use widescreen enabled in the config since years, now also in P3Dv4.1. Is there any disadvantage from using this?

BTW: I use 4xSSAA and have absolutely crisp panels and gauges. I guess 4xSSAA should be possible in daytime also for a 980 on 1080p. In night time, I only use 4xMSAA due to the enormous performance loss when combining DL and SSAA...

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now