vgbaron

Caution from LM re Texture_Size_Exp

Recommended Posts

Relating to the discussion about Texture_Size_Exp and High Resolution textures here:

LM has discovered a potential bug which could cause issues per this:

Re: Confusion about High Resolution Terrain textures setting

post by Beau Hollis » 

Thanks for bringing this to our attention. There are actually two places, and one of them does not override the TSE value based on the HRTT setting. As a result, mismatched settings may have some negative side effects. Until we can fix this, please limit your combination of these options to these three combinations:

For default 256:
HIGH_RESOLUTION_TERRAIN_TEXTURES=0
TEXTURE_SIZE_EXP=8 (or not set)

For 512:
HIGH_RESOLUTION_TERRAIN_TEXTURES=1
TEXTURE_SIZE_EXP=9 (or not set)

For 1024:
HIGH_RESOLUTION_TERRAIN_TEXTURES=1
TEXTURE_SIZE_EXP=10

Please do not use these setting combinations as they may cause problems:

HIGH_RESOLUTION_TERRAIN_TEXTURES=0
TEXTURE_SIZE_EXP=9

HIGH_RESOLUTION_TERRAIN_TEXTURES=0
TEXTURE_SIZE_EXP=10

HIGH_RESOLUTION_TERRAIN_TEXTURES=1
TEXTURE_SIZE_EXP=8

Thanks

Beau Hollis
Prepar3D Rendering System Lead

  

  • Upvote 4

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

I've been using this one:


HIGH_RESOLUTION_TERRAIN_TEXTURES=0
TEXTURE_SIZE_EXP=9

Guess I need to click on HHTT. Doesn't HHTT on and TSE=9 the same thing?

Share this post


Link to post

Yes - but as LM said... try to use the documented settings (only)..

I was using the same settings as you, but have now switched to

HIGH_RESOLUTION_TERRAIN_TEXTURES=1   only.

I see no difference..

Share this post


Link to post

I do not tweak anything in P3D4.  I don't see the point.  A lot of pain for little gain?

  • Like 1
  • Upvote 7

Share this post


Link to post
5 hours ago, Greggy_D said:

I do not tweak anything in P3D4.  I don't see the point.  A lot of pain for little gain?

HIGH_RESOLUTION_TERRAIN_TEXTURES=1  or better put HIGH RESOLUTION TERRAIN TEXTURES is a tick box in the setting not a tweak. 

The only real "tweak" there is a manual entry for people with 12GB gtx TEXTURE_SIZE_EXP=10

It just pointing out that people should not mix/add both.

These do the same thing.

HIGH_RESOLUTION_TERRAIN_TEXTURES=0 <<< A tick box
TEXTURE_SIZE_EXP=9

 

Share this post


Link to post

Interesting, is this related to the blurries some (including me) have been experiencing with v4.1?  I’ll have to check my settings when I get home.

Share this post


Link to post

i don't get it, so using 

HIGH_RESOLUTION_TERRAIN_TEXTURES=1

TEXTURE_SIZE_EXP=9 or 10 is wrong? i use 4096 texture resolution

 

 

Share this post


Link to post
1 hour ago, Lbt564 said:

i don't get it, so using 

HIGH_RESOLUTION_TERRAIN_TEXTURES=1

TEXTURE_SIZE_EXP=9 or 10 is wrong? i use 4096 texture resolution

 

 

HIGH_RESOLUTION_TERRAIN_TEXTURES=1

is the same as

TEXTURE_SIZE_EXP=9

I would suggest not using the TEXTURE_SIZE_EXP line at all, just set HIGH RESOLUTION TERRAIN TEXTURES in the UI.

4096 texture resolution is separate and has nothing to do with this.

 

  • Upvote 1

Share this post


Link to post
1 hour ago, Lbt564 said:

i don't get it, so using 

HIGH_RESOLUTION_TERRAIN_TEXTURES=1

TEXTURE_SIZE_EXP=9 or 10 is wrong? i use 4096 texture resolution

 

 

Not wrong but exactly the LM recommendation as stated above.  They said HRT=0 and TSE=9 may cause issues.

Share this post


Link to post

What Beau basically said is that there are specific designed settings. Setting HRTT=0 and TSE=9 is NOT a designed setting. Normally the HRTT=0 would be ignored as the TSE=9 would take precedence - the problem is that the "wrong" settings are NOT being ignored and may cause issues because P3D is trying to set TSE=9 with HRTT=0.

They are working to correct this - so just stick to the designed settings.

Vic

Share this post


Link to post
Posted (edited)

Hey guys 

sorry to bring this topic up again.

I am a little confused

Thou I am wanting to try texture_size_exp=9

i currently have HRT ticked.

now is that the same?

or shall I untick HRT and insert 

TSP =9 only in cfg?

at the moment I am running 2 titans sc 6gb.

cheers

mike

Edited by mikeymike

Share this post


Link to post

HRT set = TSP 9 so you are already using it. You could try 10 with hrt set though.

 

Vic

Share this post


Link to post
On 12/20/2017 at 7:23 AM, Lbt564 said:

i don't get it, so using 

HIGH_RESOLUTION_TERRAIN_TEXTURES=1

TEXTURE_SIZE_EXP=9 or 10 is wrong? i use 4096 texture resolution

 

 

No...that's the right way to do things....

Share this post


Link to post
7 hours ago, vgbaron said:

HRT set = TSP 9 so you are already using it. You could try 10 with hrt set though.

 

Vic

Ok,

thanks mate.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now