Jump to content
Sign in to follow this  
Skywolf

Mega Addons with Amazing Performance in 4K - Part 2

Recommended Posts

5 hours ago, julian2 said:

Ah thanks I havent seen it. In this case the 245 does not make it worse but also not better. I also tried the vsync tutorial from simmershome for v4. But also with that the stutter remains. FPS go down to 1FPS for one second around every 30 seconds. 

As Skywolf mentions check your power profile on the vidcard in the nvidia control panel.

Monitor your cpu usage during one of those 30 second pauses.  Task Manager might tell you what app is eating cycles during those times, but, I'd suggest a utility like ProcessExplorer or Filemon to determine exactly what is running at those times.   A regular pause with that time interval makes me think it is an external app or process.


Rhett

i7-8700k @ 5.0 ghz, 32 GB G.Skill TridentZ, 1080Ti, 32" BenQ, 4K res

Share this post


Link to post
12 hours ago, Skywolf said:

Maybe P3Dv5 wants more cores.  Can you try with LoD 2.5 as you have 4 Core - see what happens.  Do the stutters go away? 

 

P3Dv5 is 

Hitting these cores fully

Core 0

Core 1

Core 2 (Not full)

Core  3 

Core 4 (Not full)

Core 5 

 

3 Cores full and 2 cores way less 

 

What you are seeing with Core2 and Core4 seems to be normal for P3Dv5.  Those seem to be overflow cores or mirror cores of Core0. 

Since v5's behavior isn't fully understood, I would be cautious about using any AffinityMask right now.

  • Like 1

Rhett

i7-8700k @ 5.0 ghz, 32 GB G.Skill TridentZ, 1080Ti, 32" BenQ, 4K res

Share this post


Link to post

Unfortunately your settings didn't hold up for me. My machine keeps BSOD after awhile. I've ran a memory test and it's not my ram. It's probably my overclock, but it has been stable up until now. Seems like Prepar3D is a good stress test for your CPU.


ASUS ROG Maximus Hero XII ▪︎ Intel i9-10900K ▪︎ NVIDIA RTX 3090 FE ▪︎ 64GB Corsair Vengeance RGB Pro ▪︎ Windows 10 Pro (21H1) ▪︎ Samsung 970 EVO Pro 1TB NVME SSD (OS Drive) ▪︎ Samsung 860 EVO 2TB SATA SSD ▪︎ Seagate 4TB SATA HDD ▪︎ Corsair RMx 850W PSU

Share this post


Link to post
On 5/12/2020 at 6:44 AM, Skywolf said:

Hi guys,

Looks like I have finally achieved on what I have been wanting to do for a while with my hardware.  I figured out the trick for people with 8GB video cards and having at minimum 30fps with the following addons installed - including one of the most fps hit area that has plagued almost all of us for ages.

Finally pulled off Slick FPS at 30fps with 30hz 4K monitor (TL/DR - see also pics) - My VRAM stayed around 5.2GB in SoCaL area with all that autogen and flying.  AT KORD area it jumped to 6gb but still tons left.

with 

Set the following in P3Dv5 and CPU - My tweaks are even less in the second round but the addons complexity increased insanely.

1) Disable HT and No Affinity Mask - I tried them all.  Let P3Dv5 do its thing.

2) MAX_TEXTURE_REQUEST_DISTANCE=300000 (Default is 1000)

3) Enable HIGH_RESOLUTION_TERRAIN_TEXTURES=1 in Settings

3) TEXTURE_SIZE_EXP=10  - this goes in [TERRAIN]

4) LOD_RADIUS=3.500000   

 

(Yes, put LOD to 3.5 with Texture Size ExP to 10, and hi res textures - all 3 go hand in hand) - If these are not like this - 8GB Video Card will get vrOOM!!! 4.5 LOD will straight up OOM with that high texture exp)

 

These settings Do the Magic with High Resolution Terrain enabled for 8GB Video Cards.  I am on Windows 2004 Final Build for May 20H1 (19041.208) - this mandatory for VRAM management - See my other thread

 

Enter The Addons

1) Orbx Socal (yes LA area)

2) FSDT KLAX

3) AIG planes

4) PMDG 747

5) FS Pilots 2020 NG Mesh

6) Chaseplane

7) AS P3D and TrueSky Enabled in P3Dv5

 

My hardware CPU is slightly older i7-5820K, 16GB DDR Quad Channel 2400, SSDs, Nvidia 2070 Super RTX, 3- 4k Monitors, Rift S

 

I am flying at 2500 FT at 355 Knots (yes, b/c I can)  with the PMDG 747 over Orbx SoCal and taking off from FSDT KLAX with few AIG birds.  All shots are in 4K monitor with AS P3D Hotfix 2 Beta and TrueSky enabled.

 

For some LA shots - Screen shots were taken in Time Preview Mode for dusk/dawn shots.  Main flight is at late evening.  This is way you all will see the graphics are super sharp - 30 fps outside and inside was ranging from 26-30fps at sometimes even more - though monitor is at 30hz 4K.

 

JNieoFF.jpg

UbsLlp5.jpg

ZNr0Kks.jpg

AblMf0L.jpg

NCyQ93T.jpg

I09qJpm.jpg

E6sje3r.jpg

HvRAlMc.jpg

DolUaYw.jpg

SIJdXUq.jpg


Mission Accomplished - Kick A ** Graphics Finally - So slick, So smooth with Orbx Regions and PMDG

CysnFXC.jpg


ATWCMkR.jpg

Extra - Same Settings - 

Global+OpenLC NA+FSDT KORD+AIG+FS2020 NG Mesh

5tENpgw.jpg
 

bJkNtUl.jpg


Who Says the Sun doesn't move - It moves when I play in Time Preview mode

v0TNziM.jpg


eRgMp42.jpg


lzEurIh.jpg


Quick Recap of Settings

tw1ClYD.png

L5OgMG8.png

5xorQwA.png
 

 

Enjoy and be safe everyone.

 

 

Hi. Thanks for you contribute to the community. I have the card as you, and i tried you settings, but with 2xMSAA, the shimmering and aliasing are really bad, if i switch to 4xMSAA,i have CTD, so my question is, how his your DPI in windows display settings? 150%? 125 or even 100%?

Thanks 

Paulo Morais 

Share this post


Link to post
5 hours ago, Skywolf said:

Is your video card running at Maximum power and is your pc set to Maximum power profile?

For video card it is the Nvidia Control Panel - and pc is well your windows power setting.

Your cpu is newer than mine, and you have more system ram.  You should get good improvements

Also - Did you exclude your sim directory in your Antivirus?

All my addons are inside one directory including Prepar3d v5.  So I have entire folder excluded along with Chase plane (it even comes with instructions during install automatically).  Followed by Prepar3d Addons directories 

 

So I finally found out what is causing the stutters. It seems it is the Antimalware Service Executable. CPU Usage goes up to around 10% every 30 seconds at the Antimalware Service Executable. I turned off Real-Time Protection at the Virus & Threat Protection Windows Menu and stutters are gone. 

I have P3D installed on a separate SSD and made an exclusion for the whole drive but the Real-Time Protection seems to affect P3D anyways.

So I will test a bit further but it looks like this is causing the problems.

  • Like 1

Intel i7-6700K @ 4.00GHz, 32GB RAM, NVIDIA GeForce GTX 1080, Windows 10 Home 64bit with 2004 Update

Share this post


Link to post

@Skywolf so i have put these settings in my config and my SIM still runs absolutely smooth on stable 30 FPS (because of the VSync). I´ve made a testflight from EDDH to EDDF (Aerosoft) and from LOWG to EDDH. Always with TS aktive and AS plus PFE, MCE, etc. I´ve had a very very beautiful and realistic sunset departure out of EDDH with real live weather, wich was actually very gray and cloudy in northern Germany these days. It was really cool because on ground everything was gray and rainy and after departure i went into the thick cloudlayer and on the Cloud top the sky got blue and the sun broke thru as it is in reallife. (i even thought i could feel the sun warming my face when suddenly the sunrays hitting me)

And all that without any kind of stutters, just wow. But i noticed that with your settings the loading time of the terrain data at startup is increased. It seems that now much more data are loaded into my RAM to have this far out wide view of the terrain. But it really looks like the real world, and no popping up scenery anymore. 

👍 from my side 

Edited by BerndB

Bernd

P3D V5.2 -  PC spec: Intel i9-9900 overclocked 5 GHz HT off, 32 GB RAM, GPU Nvidia RTX2080, 2xM2 SSD, Skalarki HomeCockpit and Jeehell FMGS on a dedicated Server, PF3 for ATC, MCE, GSX, EFB, AS+ASCA and OrbXpf3-supporter.gif

Share this post


Link to post
3 hours ago, PauloMorais said:

Hi. Thanks for you contribute to the community. I have the card as you, and i tried you settings, but with 2xMSAA, the shimmering and aliasing are really bad, if i switch to 4xMSAA,i have CTD, so my question is, how his your DPI in windows display settings? 150%? 125 or even 100%?

Thanks 

Paulo Morais 

Hi @PauloMorais my windows is set to 100 DPI on my 4K.  It is small for some at that high resolution.  I do see some flashes here and there but to be honest it is quite rare on my end.  The fidelity these settings bring, has blown me away.  I have never simmed this good.

 

3 hours ago, BerndB said:

so i have put these settings in my config and my SIM still runs absolutely smooth on stable 30 FPS (because of the VSync). I´ve made a testflight from EDDH to EDDF (Aerosoft) and from LOWG to EDDH. Always with TS aktive and AS plus PFE, MCE, etc. I´ve had a very very beautiful and realistic sunset departure out of EDDH with real live weather, wich was actually very gray and cloudy in northern Germany these days. It was really cool because on ground everything was gray and rainy and after departure i went into the thick cloudlayer and on the Cloud top the sky got blue and the sun broke thru as it is in reallife. (i even thought i could feel the sun warming my face when suddenly the sunrays hitting me)

And all that without any kind of stutters, just wow. But i noticed that with your settings the loading time of the terrain data at startup is increased. It seems that now much more data are loaded into my RAM to have this far out wide view of the terrain. But it really looks like the real world, and no popping up scenery anymore. 

👍 from my side 

 

Amazing!!!! I am so glad that this is working for you.  Now I have insane amounts of addons being loaded (pretty much all Orbx FTX regions except for Australia V2, New Zealand) with FS2020 NG Mesh, - total time it takes to boot is around 1 min 50 seconds to 2 min - up to Scenario window. 

Well graphics is what we want with smooth stability 😊

 

Share this post


Link to post
4 hours ago, julian2 said:

So I finally found out what is causing the stutters. It seems it is the Antimalware Service Executable. CPU Usage goes up to around 10% every 30 seconds at the Antimalware Service Executable. I turned off Real-Time Protection at the Virus & Threat Protection Windows Menu and stutters are gone. 

I have P3D installed on a separate SSD and made an exclusion for the whole drive but the Real-Time Protection seems to affect P3D anyways.

So I will test a bit further but it looks like this is causing the problems.

Looking forward on hearing your results.  I am glad you found on what was causing the stutters

  • Like 1

Share this post


Link to post

Thanks for the reply. The problem is, when i select 100% DPI and start P3D , i found that the resolution of the sim, is the same as if i started with 150%. The only change that i notice is when i have DPI at 150%, then start P3D and change to 125%. Even then , the shimmering is intense, and if i try 100%, it crashes all the time. As i said it before, i have the same card as you, and the same settings.

Need some help

 

Thanks 

 

Paulo Morais

Share this post


Link to post
21 minutes ago, PauloMorais said:

Thanks for the reply. The problem is, when i select 100% DPI and start P3D , i found that the resolution of the sim, is the same as if i started with 150%. The only change that i notice is when i have DPI at 150%, then start P3D and change to 125%. Even then , the shimmering is intense, and if i try 100%, it crashes all the time. As i said it before, i have the same card as you, and the same settings.

Need some help

 

Thanks 

 

Paulo Morais

Have you tried with 2xSSAA?

Share this post


Link to post
36 minutes ago, Skywolf said:

Have you tried with 2xSSAA?

Hi Skywolf,,,,any idea about night flying...? To dark, unreal, no moon, stars are "weak". Salden gave me idea about moon to change in .cfg, but V5 .cfg doesn't have MOONPHASE. So far tried everything. Should I add in V5 even though it doesn't have it? Anyone tried....? Has to be some moonlight to shine some light...LOL..any idea...?

Edited by cyyzrwy24

Virtual Air Canada - Alex Luzajic

Share this post


Link to post
21 minutes ago, cyyzrwy24 said:

Hi Skywolf,,,,any idea for night flying...? To dark, no moon, stars are "weak". Salden gave me idea about moon to change in .cfg, but V5 .cfg doesn't have MOONPHASE. So far tried everything. Has to be some moonlight to shine some light...LOL..any idea...?

no idea about moonphase.  I just like light autogen and I get tons of that now for my night flying.

Edited by Skywolf

Share this post


Link to post
2 minutes ago, Skywolf said:

no idea about moonphase.  I just like light autogen and I get tons of that now for my night flying.

So with autogen you can increase a light for night flying...? I see moon_phase in V4.5 and it is really realistic so I can only assume that I could add to V5 under GRAPHICS....

It is odd than V5 doesn't even have that...wonder why came out of box that way or they forgot....LOL

Edited by cyyzrwy24

Virtual Air Canada - Alex Luzajic

Share this post


Link to post
8 hours ago, Skywolf said:

Looking forward on hearing your results.  I am glad you found on what was causing the stutters

What size is your 4k monitor?

and are you using any shaders? Like envshade?

thanks

mike

Share this post


Link to post

I’m confused. What is this setting? TEXTURE_SIZE_EXP= 

should it be at 9 or 10? I have a RTX 2080ti 

also, is it related to the LOD setting in the UI? 
And finally, does it affect autogen setting in the Ui or should we leave that at medium? 

Edited by Ianrivaldosmith

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    53%
    $13,405.00 of $25,000.00 Donate Now
×
×
  • Create New...