Jump to content
Sign in to follow this  
verbal

v5.4 starts normally but minimises to task manager

Recommended Posts

As per thread title, P3D v5.4 starts with the splash screen, automatically loads chaseplane and AIGTC, splash screen disappears and sim minimises to task manager, unable to fly 😞

The only thing I've changed in the past month or so is updated GSX, updated AIG, and uninstalled FSRealtime (yes, it worked with v5), until I got a random runtime error that I could not fix. 

Anyone else with experience with this issue? 


i9-13900K | 6400MHz DDR5 (32GB) | GeForce RTX 4090 24GB | ViewSonic 27in QHD VA 165Hz Curved | Windows 10

Marc

Share this post


Link to post

First I would copy the P3D Config file to desktop to keep your settings. Then delete the Config file in P3D then start P3D and let it rebuild the default settings. Then use AddonOrganizer to disable not delete the addon you mention to track the problem. 


 

Raymond Fry.

PMDG_Banner_747_Enthusiast.jpg

Share this post


Link to post

I have zero experience with AddonOrganizer but gave it a go, disabled all addons and problem persists. 

 


i9-13900K | 6400MHz DDR5 (32GB) | GeForce RTX 4090 24GB | ViewSonic 27in QHD VA 165Hz Curved | Windows 10

Marc

Share this post


Link to post
4 hours ago, verbal said:

I have zero experience with AddonOrganizer but gave it a go, disabled all addons and problem persists. 

 

Can you right click on the prepar3d.exe, select properties and check if its selected to run minimized? It should be normal window.


OS=WIN11 Home, Sim=P3D5 5.4 (P3D4 and FSX for install reasons)
Addons=ORBX, ASCA, AS, TOGA and tons of sceneries, aircraft

MB=Gigabyte AORUS Z790 Elite AX, CPU=i13900K, Cooling=Be quiet! Pure Loop II FX
GPU=KFA2 RTX3090 24 GB, RAM=64 GB DDR5-5600, HOTAS=Logitech G Saitek X52 Pro

Visit my website for fixes and addons: https://sites.google.com/view/dans-p3d-mods

Share this post


Link to post

I've had that happen to me before in the distant past, and the solution was always to restore the last config file backup I made with AddonOrganizer's one-click backup.


Bob Scott | President and CEO, AVSIM Inc
ATP Gulfstream II-III-IV-V

System1 (P3Dv5/v4/XP12): i9-13900KS @ 6.0GHz, water 2x360mm, ASUS Z790 Hero, 32GB GSkill 7800MHz CAS36, ASUS RTX4090
Samsung 55" JS8500 4K TV@30Hz,
3x 2TB WD SN850X 1x 4TB Crucial P3 M.2 NVME SSD, EVGA 1600T2 PSU, 1.2Gbps internet
Fiber link to Yamaha RX-V467 Home Theater Receiver, Polk/Klipsch 6" bookshelf speakers, Polk 12" subwoofer, 12.9" iPad Pro
PFC yoke/throttle quad/pedals with custom Hall sensor retrofit, Thermaltake View 71 case, Stream Deck XL button box

Sys2 (MSFS/XP11): i9-10900K @ 5.1GHz, 32GB 3600/15, nVidia RTX4090FE, Alienware AW3821DW 38" 21:9 GSync, EVGA 1000P2
Thrustmaster TCA Boeing Yoke, TCA Airbus Sidestick, 2x TCA Airbus Throttle quads, PFC Cirrus Pedals, Coolermaster HAF932 case

Portable Sys3 (P3Dv4/FSX/DCS): i9-9900K @ 5.0 Ghz, Noctua NH-D15, 32GB 3200/16, EVGA RTX3090, Dell S2417DG 24" GSync
Corsair RM850x PSU, TM TCA Officer Pack, Saitek combat pedals, TM Warthog HOTAS, Coolermaster HAF XB case

Share this post


Link to post

I have had this as well, and it was caused by the locked RAASPro that comes with the PMDG 777. It requires the 2016 Access Database Engine to run properly and mine had become corrupted causing P3D to launch into the background. Removing and reinstalling the Access Database fixed it. There was a thread on a website that lead me to the fix (it may have been on the PMDG forum, I can’t remember now). However I took screenshots of the fix and labelled it so it took me two seconds to find it for this thread! Also run repair on the 777.

https://www.microsoft.com/en-us/download/details.aspx?id=54920

 

 

Share this post


Link to post

Yet again, the more addons you have that interact with the sim, the greater the chances of a problem.

GSX and AIGTC can easily be culprits, as can the RAAS, among other things, that are used in PMDG planes.

The more complexity, the more that can, and will, go wrong.

I keep my sim as simple as possible and rarely have problems - freeware planes, Active Sky weather, and Radar Contact - that's all.

Dave

  • Like 2

Simulator: P3Dv5.4

System Specs: Intel i7 13700K CPU, MSI Mag Z790 Tomahawk Motherboard, 32GB DDR5 6000MHz RAM, Nvidia GeForce RTX 4070 Video Card, 3x 1TB Samsung 980 Pro M.2 2280 SSDs, Windows 11 Home OS

 

Share this post


Link to post

In prepar3d.cfg section [USERINTERFACE] look for  SHOW_SCENARIO_WINDOW=1 shoul be 1

prepar3d.cfg is in     C:\Users\YOUR_USER_ID\AppData\Roaming\Lockheed Martin\Prepar3D v6

that changes with the tick in the initial scenario window...

Jorge

Edited by aeronauta

Share this post


Link to post

Had that too and it was caused after install of the PMDG and as others have pointed out above, by RAAS that comes with it...

After disabling RAAS it started working fine.

I had actually posted a similar topic a while ago here at the forum.


Main Simulation Rig:

Ryzen 5600x, 32GB RAM, Nvidia RTX 3060 Ti, 1 TB & 500 GB M.2 nvme disks, Win11.

Glider pilot since October 1980...

Avid simmer since 1992...

Share this post


Link to post

No problems with PMDG loading or RAAS on my  PC setup.

PMDG777 /  PMDG747

P3D4.5.14.34698  / P3D5.4.9.28482

 

Edited by vonmar

Best Regards,

Vaughan Martell - PP-ASEL KDTW

Share this post


Link to post

The RAAS problem only seems to be an issue if you have Microsoft Access (or the full MS Office that includes Access) installed, as the database engine versions conflict.

I use Apache OpenOffice and have never experienced problems with the RAAS companion software that ships with some PMDG acft.

  • Like 1

Bob Scott | President and CEO, AVSIM Inc
ATP Gulfstream II-III-IV-V

System1 (P3Dv5/v4/XP12): i9-13900KS @ 6.0GHz, water 2x360mm, ASUS Z790 Hero, 32GB GSkill 7800MHz CAS36, ASUS RTX4090
Samsung 55" JS8500 4K TV@30Hz,
3x 2TB WD SN850X 1x 4TB Crucial P3 M.2 NVME SSD, EVGA 1600T2 PSU, 1.2Gbps internet
Fiber link to Yamaha RX-V467 Home Theater Receiver, Polk/Klipsch 6" bookshelf speakers, Polk 12" subwoofer, 12.9" iPad Pro
PFC yoke/throttle quad/pedals with custom Hall sensor retrofit, Thermaltake View 71 case, Stream Deck XL button box

Sys2 (MSFS/XP11): i9-10900K @ 5.1GHz, 32GB 3600/15, nVidia RTX4090FE, Alienware AW3821DW 38" 21:9 GSync, EVGA 1000P2
Thrustmaster TCA Boeing Yoke, TCA Airbus Sidestick, 2x TCA Airbus Throttle quads, PFC Cirrus Pedals, Coolermaster HAF932 case

Portable Sys3 (P3Dv4/FSX/DCS): i9-9900K @ 5.0 Ghz, Noctua NH-D15, 32GB 3200/16, EVGA RTX3090, Dell S2417DG 24" GSync
Corsair RM850x PSU, TM TCA Officer Pack, Saitek combat pedals, TM Warthog HOTAS, Coolermaster HAF XB case

Share this post


Link to post
On 12/28/2023 at 11:51 PM, Bob Scott said:

The RAAS problem only seems to be an issue if you have Microsoft Access (or the full MS Office that includes Access) installed, as the database engine versions conflict.

I use Apache OpenOffice and have never experienced problems with the RAAS companion software that ships with some PMDG acft.

Good hint.

I use OpenOffice too since a couple months, but probably when I got my problem with RAAS I was still using a full install of Office 2016, including the Access components, not to mention that certain addons also install a version of Access which could also rise the incompatibility state.

Edited by jcomm

Main Simulation Rig:

Ryzen 5600x, 32GB RAM, Nvidia RTX 3060 Ti, 1 TB & 500 GB M.2 nvme disks, Win11.

Glider pilot since October 1980...

Avid simmer since 1992...

Share this post


Link to post

The fact that it uses the Microsoft Access Database components is a problem overall.

 

For example I ran RAAS in FSX which being 32 bit meant the 32 bit version of the Microsoft Access Database components was required, all fine and good in this case as I had a 32 bit version of Office installed.

However for P3D being x64, the 64 bit version of Microsoft Access Database components was required, but you cannot have both bitness types installed, just one or the other.

This was a problem as I had other 32 bit programs that needed the 32 bit version of Microsoft Access Database components.

It was a bit of an undertaking to update all applications to 64 bit where they would then use the 64 bit version of Microsoft Access Database components. Of course for some programs (like FSX) there was no x64 upgrade path in itself, so some things had to be uninstalled.

 

At work we also came across similar issues with Enterprise level software, where many orgs were running thousands of licenses with many customisations and 3rd party integrations and were unable to just change the bitness of the Microsoft Access Database components they were using, plus we found a long standing bug in Microsoft Access Database components x64 that would seemingly randomly result in a heavy CTD of the sort where a complete machine restart was needed to recover properly.

So if you're using RAAS x64 and getting some unexplained CTD's see if disabling RAAS resolves the problem.

In the QA we peformed we found the MS Access bug was a rare occurance, it might not happen, it might occur immediately, or it might function fine for 200~1000 times and then trigger, the one consistant thing was it would occur eventually.

Unfortunately we found MS to be unresponsive despite MS having sample code to cause the CTD and many 3rd party reports of the issue, we assumed they had their own agenda in play.

For our company's software we migrated away from Microsoft Access Database components to SQLite so as to not be beholdant to Microsoft for embedded database components and while replacing the internal embedded database was relatively simple from a code design perspective, at the customer end there was a ton of SQL rewrites required to bring their customised systems over to SQLite due to the different SQL syntax between the two systems.

Cheers

 

 


Ryzen 5800X clocked to 4.7 Ghz (SMT off), 32 GB ram, Samsung 1 x 1 TB NVMe 970, 2 x 1 TB SSD 850 Pro raided, Asus Tuf 3080Ti

P3D 4.5.14, Orbx Global, Vector and more, lotsa planes too.

Catch my vids on Oz Sim Pilot, catch my screen pics @ Screenshots and Prepar3D

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
×
×
  • Create New...