Archived

This topic is now archived and is closed to further replies.

captain420

P3D v2 and EZDok Cam compatibility

Recommended Posts

Before buying P3D v2.0, I would like to know if EZdok 1.17 or whatever the latest version is will work under P3D v2.0? I recall seeing a thread on here that some people were able to get it to work. It's been awhile since I've been on here so would like some help. 

 

Thanks!

 

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Funny you should ask, I just visited a friend who was installing P3D2 and he installed Ezdock without a hassle using the EMT. Seemed to work really well. Not sure if you can get it to work without the migrator, maybe someone else can advise?

 

Sent from my Mobile thing

 

 

Share this post


Link to post

There is a version available for P3D V2 in a forum thread (flight1 simforums, EZCA and Prepar 3d)

 

I installed it without the migration tool. At the moment I have my basic setup including FSUIPC, SPAD, EZCA working well with P3D without relying to migration software.

 

I had some compatibility problem trying to use the latest Track IR software with EZCA. I reverted to a previous version and it worked fine after.

 

 

 

 

Share this post


Link to post

That gets it "working" but without the migration tool you can't run the configurator that configures your airplanes so you don't see only a cockpit in the external view.

 

Use the migration tool, enable virtual FSX, run the configurator then turn virtual FSX back off. You need to do this every time you add a new aircraft.

 

Don't forget to also rename the 2 simconnect files in the TrackIR folder as well or EZdok will not work( same procedure as per the install instructions for ezdok)

Share this post


Link to post

Mine worked but every time you changed the camera the screen flickered once.. Really annoying.. 

Share this post


Link to post

Fellows,

I can run mine fine w/or/wo EMT running - and I used the configurator and it built aircraft data base fine.

What I found that I initially had to do, was import existing camera sets for each plane I brought up...but only once.

It's been working fine for almost a month, well, since P3d v2 came out.

 

Tom

Share this post


Link to post

Fellows,

I can run mine fine w/or/wo EMT running - and I used the configurator and it built aircraft data base fine.

What I found that I initially had to do, was import existing camera sets for each plane I brought up...but only once.

It's been working fine for almost a month, well, since P3d v2 came out.

 

Tom

 

Are you getting screen flash every time you change a camera also? Wondering if mine was caused by my sli/surround setup. Or if others got it also. 

Share this post


Link to post

Are you getting screen flash every time you change a camera also? Wondering if mine was caused by my sli/surround setup. Or if others got it also. 

 

Are you sure this isn't because your camera views have a different Zoom value?  If I have one camera at zoom 85 and switch to another set to zoom 90, it will definitely give the impression of a "flash", because the new zoom is applied instantaneously, unlike the camera position change, so I always try to keep it consistent. 

Share this post


Link to post

Are you sure this isn't because your camera views have a different Zoom value?  If I have one camera at zoom 85 and switch to another set to zoom 90, it will definitely give the impression of a "flash", because the new zoom is applied instantaneously, unlike the camera position change, so I always try to keep it consistent. 

 

Yeah because it's using the same cameras I setup for FSX.. I'll re-install it at some other time and explore it further..  At this point I'm just trying to divide and conquer my addons into four piles

 

Works 100% and stable

Works with the lose of features but stable

Works or works with lose of features and unstable 

Works somewhat and don't trust it yet

 

EZCA falls into the last category for me right now.. 

Share this post


Link to post

styckx,

KingGhidorah is correct.  I have only one camera with a different zoom value, and I also get a ???? flash or whatever we need to call it.  All of my other cameras are same

zoom and are very fluid.

 

Tom

Share this post


Link to post

It works great on my P3D V2 setup, without any problems or flashes.

Share this post


Link to post

Thanks Pierre, is this the thread you're referring to?

http://www.simforums.com/Forums/ezdok-and-p3d_topic47802.html

 

Are using EZdok 1.17?

Not this on, there is another thread labeled EZCA an Prepar3d that contains the link...

 

 

Sent from my iPad using Tapatalk HD

That gets it "working" but without the migration tool you can't run the configurator that configures your airplanes so you don't see only a cockpit in the external view.

 

Use the migration tool, enable virtual FSX, run the configurator then turn virtual FSX back off. You need to do this every time you add a new aircraft.

 

Don't forget to also rename the 2 simconnect files in the TrackIR folder as well or EZdok will not work( same procedure as per the install instructions for ezdok)

Yes, you're right. But it works also by copying the ezca camera section from any fsx plane and adding it to the end of each aircraft.cfg IN P3d. Could be long if you have a large hangar but in my case it is managable. I anyway always modify the aircraft.cfg to hide the plane default views and to change the aircraft id for ATC.

 

Sent from my iPad using Tapatalk HD

Share this post


Link to post

If EZCA is already installed with your FSX...

 

http://forum.avsim.net/topic/429386-p3dv2-ezca-setup-tutorial/

 

Thanks for the explanation, but can I get away without having to buy Estonia Migration Tool? From my understanding, EMT allows you to run EZdok's configurator so that it can add the necessary entries into each airplane's cfg file. But if I were to manually do this by opening the airplane.cfg file that I have for FSX, copying the necessary lines and pasting it into my P3D's airplane setting, would yield the same results? I don't have that many planes, so this should be an alternative solution for those who do not wish to go the EMT route.

Share this post


Link to post

Okay, I followed the instructions in that link but EZdok doesnt show up under my P3D menu. How can I edit/modify camera settings then?

Share this post


Link to post

Thanks for the explanation, but can I get away without having to buy Estonia Migration Tool? From my understanding, EMT allows you to run EZdok's configurator so that it can add the necessary entries into each airplane's cfg file. But if I were to manually do this by opening the airplane.cfg file that I have for FSX, copying the necessary lines and pasting it into my P3D's airplane setting, would yield the same results? I don't have that many planes, so this should be an alternative solution for those who do not wish to go the EMT route.

Yes you can copy ezca camera lines manually. In fact, my cockpit views work without adjustmemt. The ezca camera are required for external views.

 

I don't use migratipn tool.

Share this post


Link to post

Strange I installed it per instructions and it doesnt seem to work. I cant use my mouse to pan around the vc like in FSX. Usually you would hear a click noise and be able to pan. This should work for any plane, since its using EZCA to pan. I'm not trying to change views by holding shift+x or anything. I guess this means EZCA isn't even loaded for me.

 

What version of EZCA are you guys using?

Share this post


Link to post

Don't forget to also rename the 2 simconnect files in the TrackIR folder as well or EZdok will not work( same procedure as per the install instructions for ezdok)

 

I don't use TrackIR so is this step necessary? I can't seem to find that folder. If EZCA is working, should it show up under my p3d addon's menu?

 

Update: Okay I finally manage to get it to work, well sort of. However I can't seem to pan around while in the virtual cockpit view? Any ideas? I press the middle mouse button and here it "click" to signify that EZCA is active and accepting the press and while holding it down I try to move the mouse to pan around but nothing? Any ideas?

Share this post


Link to post

That step I posted was in reference to TIR+EZCA so they will not be present in your setup. Not sure why the middle mouse button isn't working for you it seems to work fine here.

Share this post


Link to post

slayer does your says 1.17 P3D in red in the EZCA setup window?

Share this post


Link to post