Sign in to follow this  
FransKes

My P3D v2.3 Crashes

Recommended Posts

After the 2.3 patch caused P3D to crash repeatedly, I downloaded the full version and re-installed (after uninstalling the patched 2.3) P3D. I restored my flights and controls files, as well as my scenery and aircraft addons. All worked well.

 

Next on my list was all of the ORBX stuff (Global, Vector, LCEurope, free airports, and Libs). This all took quite a while.

 

However, now P3D again crashes (without ASN running). The Event Viewer states that clr.dll in .NET faulted (exit code 80131506). I have no idea what to do about this (apparently the patch crashes were caused by exactly the same error).

 

Does anyone have a clue what the root cause of these errors might be?

 

Needless to say, I have yet to see any improvements :huh: !

 

Frans

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

With me P3D kept crashing after ASN had run one time, even after I disabled it in the DLL.xml

I had to remove it from the system before P3D stopped crashing.

Share this post


Link to post

I have the same CTD: clr.dll. Every time.

Share this post


Link to post

That's interesting, Maarten. I did have ASN running the first time I executed P3D after I had installed all of the ORBX stuff; P3D crashed. The next time (and all following times), when I did not have ASN running, P3D still crashed; can I assume then that "as_srv" in the dll.xml file belongs to ASN?  If so, this is consistent with your case. So you actually had to uninstall ASN to get P3D to work? This sounds very encouraging, although I really love ASN.

 

Frans


Maarten, you are a genius. I disabled "as_srv" in the dll.xml file and also renamed the "as_srv" folder in the P3D folder, and behold P3D 2.3 WORKED for the first time.

 

Frans

Share this post


Link to post

Yes, I did follow Rob's instructions, and I have not yet installed FSUIPC.

 

Frans

Share this post


Link to post

Thank god I found this thread. I was about to rebuild my entire system. 

Share this post


Link to post

I've solved it by deleting the ASBOOTRSTRAP entry in the dll.xml file

There was no need to 'delete' the entry. Simply change the line:

<Disabled>False</Disabled>

to

<Disabled>True</Disabled>

Share this post


Link to post

Just a little added info:

 

I got CTD every time after scenery loaded until I figured out that I had "fiddled" with the FSUIPC weather options !

After reinstall of FSUIPC and deleting the ticks in its weather options (Wind and Clouds) P3D worked OK.

 

I have ASN, all ORBX (FTX) addons as well as 100 GB of addon airport scenery + FSGS2010 and Pilots Ultimate.

Those does not caus P3D CTD:s.

 

( ASN is reinstalled with a new beta for P3D v.2.3 and works OK. )

 

Best,

Bjorn

Share this post


Link to post

if you are using the ASN for P3D v2.2 it is not compatible with P3D v2.3 you have to do a complete uninstall or even though you don't use it it will still crash P3D get the beta 2 of ASN SP1 that works fine.

 

Well that happened to me.

Share this post


Link to post

Hi Guys,

 

I've read Rob's advice, patched 2.2 (after uninstalling the hotfix), got CTD, and restored 2.2.

 

Can I uninstall 2.2, do a full install of 2.3, then add in the backed up files Rob specifies, thereby avoiding a full re-install of all my addons, from mesh, thro' Orbx, to airports and aircraft?

 

Thanks, Jim

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this