Jump to content

Sign in to follow this  
DylanM

New Orbx/FTX installers required for P3DV2.5?

Recommended Posts

Given the updated folder structure, could anyone confirm if we need to wait for new installers with 2.5 (ORBX, FSGlobal, etc.)?

Share this post


Link to post
Guest

Given the updated folder structure, could anyone confirm if we need to wait for new installers with 2.5 (ORBX, FSGlobal, etc.)?

 

Yes, you'll have to wait .. for any third party that might be bound to v2.5 versions and/or affected by the directory structure changes.

 

Cheers, Rob.

Share this post


Link to post

Yes, you'll have to wait .. for any third party that might be bound to v2.5 versions and/or affected by the directory structure changes.

 

Cheers, Rob.

 

Appreciate it (and all the insights along the way...!) Rob.

 

And thanks for the official note from ORBX Skywolf. Missed that announcement.

 

Dylan

Share this post


Link to post

Anyone know if FTX Global + Vectors and the PMDG 777 all work with 2.5 right off the bat?

 

 

If you can fool Orbx into thinking that the terrain.cfg file is still in the root folder of P3D, it will install and function correctly. You can do this by creating a symbolic link in your root folder, pointing to the new location of the file (not at my computer but I think it's ProgramData). The are a lot of references to symbolic links and utilities that will create links for you. I installed all of my Orbx scenery and it is functional.

 

Also, the current versions of objectflow don't work with 2.5. When you start up P3D, you'll get a warning about objectflow, with an option not to load it/them. Don't load it/them. If you do, very nasty things could happen to your setup. Don't delete, move, rename, or otherwise modify the files referred to in the warnings. Just don't load them. I renamed them the first time I did this, and P3D would no longer start. Had to restore my system.

 

Two things: back up your computer first. Second, back up your computer first. I use a disk imaging program and backup before each action I take.

 

There have been excellent, sober comments to just wait til Orbx updates their software. That would be good advice. I just did this as an experiment.

Share this post


Link to post
Guest

I really do recommend waiting for Orbx, sounds like John V. wasn't too happy about me posting a video of v2.5 in Norway ... no ill was intended, but I can understand his reservations.  Orbx does have a few things to sort out beyond just the Terrain.cfg relocation.  But as I understand it from John's post in his forum, it'll not be that much longer.

 

Cheers, Rob.

Share this post


Link to post

I didn't get the impression that he was unhappy,  just frustrated because he kept telling ORBX's users to be patient. If even a modest percentage of them try to use ORBX products with P3d  2.5 via some kind of unofficial workaround, one has to believe that at least a few of them will botch it up and then go crying for help. This makes the product itself look bad.

 

I'm still waiting and will install P3d 2.5 when the key add-ons that I use have supported installers. This is the best course of action in the short term. Besides, its not like version 2.4 isn't still the best flight sim out there.

Share this post


Link to post
Guest

 

 


one has to believe that at least a few of them will botch it up and then go crying for help. This makes the product itself look bad.

 

Agree, that's why I understand his position.

 

Cheers, Rob.

Share this post


Link to post

    Why wait, at all? There is soo much more to P3D, than Orbx or PMDG. The lighting, alone, made P3D, my sim of choice. It's just a matter of time before 3rd parties catch up. Of course, this is just my personal opinion, my choice. Everyone has the choice.

 

regards, Craig

Share this post


Link to post

Agree, that's why I understand his position.

 

Cheers, Rob.

 

I don't advocate setting up Orbx at this point. Yes there are potential issues. I just put forward an option. Before I do anything, I make an image of my drives.

 

Having said that, I'm sure we'll all be happily sailing along in Orbx land shortly. I do agree that Venema wouldn't have cautioned users if there were no risks involved.

 

Orbx has stated that no support will be offered as a result of messing up a system using non standard methods. That's fair.

Share this post


Link to post

Have you seen that Orbx have a new update as of 18 feb.

 

Anybody tried this and how to do it? Do I have to install all my Orbx (global and vector) first and then exe the new update from Orbx?

Share this post


Link to post
Guest

Yes, Orbx have released updated libraries for use with v2.5.  I'm in old PC to new PC transition, so I haven't been able to test it yet.

 

Cheers, Rob.

Share this post


Link to post

1. Install all your Orbx global stuff but don't install any the patches yet. Ignore any errors caused by old ftx central.

 

2. Install the updated Orbxlib. Run the updated ftx central and pick a region and press apply.

 

3. Install the patches.

Share this post


Link to post

Ditto stook2005.  I've installed global, vector, NA and stuff like PNW, NRM and KPSP.  All working well with the NGX I am beta testing and ASN open beta.  Be sure to read instructions for Orbxlib from here: https://www.fullterrain.com/support  bottom of page ver 150215.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  
×
×
  • Create New...