Sign in to follow this  
Chri

OPTIMIZE_PARTS=1

Recommended Posts

Hello,

today while inspecting my Prepar3D.cfg I came across the setting OPTIMIZE_PARTS under the [sIM] section. The default setting is OPTIMIZE_PARTS=0 and out of interest I canged this to OPTIMIZE_PARTS=1 to see what happens.
To my surprise it really does optimize something in the sim. I have about 10 FPS more in the PMDG NGX afterwards. I did some testflights with this and couldn't see any other visual differences, but I haven't found any explanations on this option in the net. Does anyone know what it actually does?

OPTIMIZE_PARTS=0
http://fs2.directupload.net/images/150314/yck5696m.jpg

OPTIMIZE_PARTS=1
http://fs2.directupload.net/images/150314/g3xnlgrg.jpg


Best regards

Christian

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

hello, what type of cpu do you use?! nice FPS !

Intel Core i7 4790K

GTX 980

Share this post


Link to post

Man it's unbelievable! Just changed the value from 0 to 1. I was suffering around 20 fps in PMDG's aircrafts and I couldn't find a tweak makes a major difference until now. My frames up to 30 (locked) and still I can not believe it. I was struggling with this for a long time. Thank you so much!

Share this post


Link to post

I have an i7 3930k ant GTX 980 and just scrape past 30 FPS as long as I don't turn on AI traffic.  I turn that on I drop into the mid-20's.  I want 44.3 FPS tooooooo!  T_T    I assume this is a default airport and not a payware airport which is much more taxing on the frames.

 

I'm gonna see if this has any impact on my game performance too and confirm.

 

 

EDIT:  Tested.    Added 1-6 FPS at payware KAUS-Austin.  My frames are locked.   A little smoother performance with 40 AI aircraft around me.   I don't know what this does but it works.  I don't see any loss of quality in my cockpit or on the exterior plane model.

Share this post


Link to post

Same here too. At least another 10fps for the PMDG 777. It would be good to know exactly how this quantum leap occurs. But for me with my modest system, this is life-changing in terms of what P3D can do for me now.

 

 

Paul Hermon

Share this post


Link to post

The screenshots were taken at default ESGG. I don't have many P3D compatible airports so far. On Aerosoft EDDL I get around 43 FPS with OPTIMIZE_PARTS=1 and 36 with OPTIMIZE_PARTS=0

Share this post


Link to post

Much thanks for that tip, first time I come across it. Will need to try it on different systems at the office!

Share this post


Link to post

The screenshots were taken at default ESGG. I don't have many P3D compatible airports so far. On Aerosoft EDDL I get around 43 FPS with OPTIMIZE_PARTS=1 and 36 with OPTIMIZE_PARTS=0

 

You are making me want to upgrade my processor.  XD    The only time I get that much FPS is when I clear about 10000 feet and AI is off.    Would you mind sharing your P3D settings and did you do any other weird tweaks apart from the usual?

Share this post


Link to post

You are making me want to upgrade my processor. XD The only time I get that much FPS is when I clear about 10000 feet and AI is off. Would you mind sharing your P3D settings and did you do any other weird tweaks apart from the usual?

No, nothing unusual, just moderate settings. I have the bufferpools 0 tweak and my autogen is set to normal. LOD 4.5. Textures at 1024. The system is not overclocked. Btw, AI is off. I still need to get Ultimate Traffic to work.

Share this post


Link to post

Bufferpools 0.  Hmmmm... I don't have that in my CFG and I run 2048 textures as most payware airports are done in this resolution.   I shall see what happens.

Share this post


Link to post

Nice find. I can also confirm that I can see a slight improvement in fps on my system. Around 5-6 fps I would say.

Share this post


Link to post

This sounds interesting - have to try it out - thanks - downloading .43 full version of P3D and will only have to use .44 patch on a fresh install

Share this post


Link to post

I to am getting 10 more frames at lax with 30% ut2 in  a pmdg 777. Went from 35 to 45 fps with that setting.

 

Maybe Rob can ex-plane this.

 

Regards Ted Kiser

Share this post


Link to post

Confirmed before I install fresh install of P3D I had to try this - was 30 fps in vc now 40 in T777 - tweak of the year award - not sure what its doing but its doing it like I just bought a new cpu - well done Christian 

Share this post


Link to post

HAHA thats working for real with PMDG product!! usualy i get 19-20 fps in FLY TAMPA MONTREAL with the PMDG 777 now i get between 26 and 30 fps . im impressed!! something must go wrong somewhere else if we get those extra fps lol

Share this post


Link to post

Just read this at LM forums

 

Don’t quote me on this as its just a guess but LM introduced their own affinity masking technology and its probably that which is being applied.

Share this post


Link to post

Check the cfg file in your current version to see if its listed in the file if not then there's your answer

Share this post


Link to post

No, nothing unusual, just moderate settings. I have the bufferpools 0 tweak and my autogen is set to normal. LOD 4.5. Textures at 1024. The system is not overclocked. Btw, AI is off. I still need to get Ultimate Traffic to work.

 

The bufferpools gave me another 4-5 FPS.  :)    I can now go on with my life.   No stutters, no blurries and almost a full 10 FPS more.   Today was a good day in simming history.

Share this post


Link to post

Check the cfg file in your current version to see if its listed in the file if not then there's your answer

Not if I'm running 2.5 so the question still stands.

Share this post


Link to post

Wow,

UK2000 ENGX Airport RWY 28

PMDG NG 738 WL

 

Without=42

With     =54

 

12fps, what a find, great job.

 

Just tried

[bufferPools]
PoolSize=0
 
same as last time I tested it 0 fps increase.

Share this post


Link to post

There's another one called OPTIMIZE_DENSE_CLOUDS under the [Weather] section.

Does anyone know what this one does? I tried it and it didn't seem to change anything but who knows...

Share this post


Link to post

Had to check this out when more and more people in here seem to get positive results from this tweak. I am way to tired (I blame that on our 2 month-old baby boy...) to sit and do any lengthy testing so I've just done som quick-and-dirty tests with the PMDG 777.

 

It sure seems like it works! I can't wait to do some more testing after some sleep. Really nice find!

 

 

Share this post


Link to post

There is one for clouds too. I haven't tested it.

Share this post


Link to post
Guest
This topic is now closed to further replies.
Sign in to follow this