Sign in to follow this  
warbirds

I must be doing something wrong

Recommended Posts

I really wanted to like XPlane. I had the demo and it worked great but now that I have the full version it runs much slower and stops every 2 or 3 minutes. Sometimes when it stops it loses about 5 or more frame rates when it gets going again. 

 

I have all settings at medium and have all Skymax settings on low or off and in cloudy or overcast weather I get about 15 to 22 fps with the payware Challenger 300 jet. 

 

I am running a GTX 980 full bore and overclocked i 7 5930 k and should be getting much better performance from this sim. I get twice the performance in FSX SE that I do in XPlane. 

 

Does this take a certain version OpenGL Nvidia driver or is there maybe some setting or something I am missing?

 

If this is normal than I have already invested way too much in this sim.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

your system is a lot better than mine and I have no issues. What add ons are you using? How much RAM have you got?

 

I have seen the pauses before, and they appeared when I had the synchronisation to real time option ticked. Problem went away when I unticked it.

 

Also, if using any of the w2xp photo sceneries, you need over 8G of RAM to avoid bottlenecking your system (learnt this the hard way)...I have been running the JARDesign A300 and the FJS 727 in and out of Frankfurt, Aerosoft Heathrow, etc and my framerates are over 50.

 

Hope you can find the culprit.

Share this post


Link to post
Share on other sites

Something seems wrong.  You should be getting much better performance than you are reporting according to your system specs.

 

I have a slower CPU and video card than you and get close to 2x the performance.  My advice is to go to your rendering settings and set everything to the lowest. Take a short flight around your favorite airport and make sure everything is running smooth(but ugly). Then up the settings one at a time and try it each time you make a change. Make note of what setting you changed each time. At some point you may hit whatever is causing your system to bog down. At that point, we may be able to zero it down. 

 

Also, if you have any addon scenery in this area, take it out and see if it is causing this issue.  Since you have Skymaxx, Go to plugins and uncheck silverlining (I think that's what its called) which should deactivate skymax. Then see it that has any effect. 

You have to do a little detective work. Hopefully you will find out what's going on.

 

Rob  

Share this post


Link to post
Share on other sites

I have uninstalled Skymax a couple times to check it against the stock clouds and it comes out about even with all things on low. 

 

I know something is not right but finding it might be impossible, or at this time seems that way because I have tried all the tricks I know of. 

 

I have 16 gig of fast ram and the gtx 980 has 4 gig so I have enough memory. No scenery installed yet, just one plane.

 

By synchronisation to real time option do you mean the set to real time check in the time and date section? If so I do have that off, unchecked. 

 

I have clouds as low as they go, 10 I think is the number. No deer or birds or ballons and no HDR. 

 

It must take a certain system to make this sim sing and mine is not doing it. I just went back into FSX SE and set up an ASN stormy weather with a similar jet that was using in XPlane and was getting over 60 fps. 

 

Keep the ideas coming and maybe I can solve this.

 

Thanks

Share this post


Link to post
Share on other sites

That's very odd.  Hopefully someone can chime in here with some new ideas.

I have read where some people said they had experienced poor performance and after a reboot, its running great. X-plane can be strange in that way.

 

You said you had the demo running well. The full version should run the same. I cant figure out why it wouldn't. Very odd

.

Hope you get it worked out!

 

Rob

Share this post


Link to post
Share on other sites

Can you provide a screenshot of the rendering settings? Also, what fps do you get with the default C172?

Share this post


Link to post
Share on other sites

Hi Warbirds.

 

Before doing anything else I would advise temporarily disabling SkyMaxxPro until you get everything running nicely.

Go to your X-Plane 10\Resources\plugins\SilverLining\64 folder and rename the win.xpl file to something else like win.xpl.OFF

 

Now run X-Plane and go to Settings / Rendering Options and use the preset Set to Minimum to start from zero. Work your way through the options keeping an eye on your frames. You can do this by going to the Settings / Data Input & Output menu and checking the 4th box of the 1st line (frame rate), you will then see your fps in the top-left of the main screen.

 

As a guide here are my current settings. Please note I'm an airliner guy so I keep shadows and water reflections down to save fps. I'm also using the latest NVidia Win 10 driver and running X-Plane v10.40b11, but 10.36 should still have the Set to Minimum option.

 

 

2sb0rvp.jpg

 

Let us know how you get on.

Stick at it mate, when you get it running well it looks awesome! :wink:

Share this post


Link to post
Share on other sites

And, since you're on Nvidia, please post your NI settings.

 

Make sure on the Common section of Nvidia Inspector you set Threaded Optimization to OFF

 

I will try to find my settings and post them here.

 

You should really get it running super smooth.  I am on an i5 2500 @ 3,3 GHz, and have a GTC 960, and get, with HDR on, from 30 to 60 easily on most parts of the World, using SkyMaxx Pro v2. Even with default clouds things are very acceptable.

 

Also give a look along this thread, because it may give you some suggestions for NI settings.

Share this post


Link to post
Share on other sites

 

 


And, since you're on Nvidia, please post your NI settings.
 
Make sure on the Common section of Nvidia Inspector you set Threaded Optimization to OFF
Good point Jose I forgot about Threaded optimization. Worth trying.

Share this post


Link to post
Share on other sites

My NI settings are:

 

Frame rate limited to 30

1/2 refresh rate

Antialiasing set to  8xS  [Combined 1x2 SS + 4x MS]

Threaded Opt to Off

Prefer maximum performance set

 

My X Plane settings are already at minimum or close. Running 1080p rez and high for textures. No HDR, no dear or birds or balloons, clouds at 10, shadows at minimum, roads at low, cars at low. Should I really have to do this with my system?

 

Stock Cessna gets 30 (fps set to 30) but will drop down to 21 and lower in overcast.

 

Check my pc stats on my page here at Avsim and although I have three GTX 980's I have X Plane set to use only one. (this is something they really should fix as SLI would make this sim run the way it should). 

Share this post


Link to post
Share on other sites

Check my pc stats on my page here at Avsim and although I have three GTX 980's I have X Plane set to use only one. (this is something they really should fix as SLI would make this sim run the way it should). 

 

Three GTX 980s??? Wow, that's one powerful computer... *cries away in corner with my puny GTX 860M*

 

Jokes aside, try unplugging the extra GPUs, and see how it runs. Also check your CPU and GPU clock speeds as X-Plane is running; there might be something that's throttling your performance. My laptop is easily ten times less powerful than your tri-SLI system, but I can get 45 FPS with fairly high settings. 

 

Also, try deleting all the files in <Your X-Plane directory>/Output/Preferences, as this will effectively reset all of X-Plane's preferences and start you back from scratch. 

Share this post


Link to post
Share on other sites

Don't run nvidia inspector for XP10

 

You do need the threaded optimization off but only do that in nvidia control panel.

 

We'll get it figured out

Share this post


Link to post
Share on other sites

I'm away from my home PC... Tonight I'll try to post my settings.

Share this post


Link to post
Share on other sites

I can shut off my other gpu's with a switch on the mb and tried that but no change. I know it is all on my end and not the sims fault. 

 

I hope something works because I have seen what this sim can do and so far I am really liking it. Coming from a long ling of FS editions I am amazed at the easy joystick or whatever you want input setup, also the weather section where you can paint your own weather with your mouse (REX just released something like this but X Plane already has it). I think there is a detailed setting for almost anything you can think of. Plus the nights (from dusk till dawn) really mesmerize and just force me to just sit back and let the auto pilot fly while I watch.

 

Thanks for all the help guys,

Share this post


Link to post
Share on other sites

Paul did you see the part about NOT using nvidia inspector?  You'll want to run everything in XP10 EXCEPT for the threaded optimization = OFF using nvidia control panel.

 

right click desktop, nvidia control panel ->manage 3d settings-> program settings, go to xplane.exe and turn off TO per^.

Share this post


Link to post
Share on other sites

Thanks, yes I saw that but not sure about it because I have seen threads on here about using it with NI. What is the reason I should not use NI?

 

Also I know about the Nvidia control panel,,,been doing this for almost twenty years :)

Share this post


Link to post
Share on other sites

Paul,

 

you can send me two of your GTX 980 cards. I wont mind at all, you don't have to thank me !  I guess X-Plane 10 will work better that way ( in my system... Shhhhhh!!!!! )

 

Ok?

 

Is it a deal ?

 

Now, again, as soon as I arrive home, in a few hours, I'll post my NI settings for you to try.

 

;-)

Share this post


Link to post
Share on other sites

Ha, I could send you two but first send me the cash :)

 

Open to try anything at this point so keep ideas coming guys.

 

Thanks,

Share this post


Link to post
Share on other sites

Your NI settings for antialiasing are those you use for FSX. For X-Plane or any other modern graphics engine this is an overkill even with a GTX 980. I would try, for a start, to use only the X-Plane internal antialiasing options...

Share this post


Link to post
Share on other sites

Might not apply in this case, but I know sometimes I have big fps difference if I run X-Plane in full screen or in window mode not sure why sometimes it have no effect and other time fps drops a lot in window mode.

Share this post


Link to post
Share on other sites

Your worl detail distance is too high but you can increase the texture resolution to very high. And forget the inspector in the beginning. This is not the FSX.X-Plane (and the OpenGL drivers) knows how modern graphic cards work.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this