Sign in to follow this  
swissa340

P3D v3 crashes on startup

Recommended Posts

Hello,

 

I use P3D v3 since last november and it ran fine until today. When I start it, it loads for a while and then an error message appears: Prepar 3D stopped working.

I tried everything (appart of reinstalling). Can someone help me?

 

Wish you all a nice weekend

Alex

 

My system:

i7 4790k, GTX980Ti, 16 Gb Ram (2400mhz), 250GB SSD (System), 2x 1TB HDD (Stuff), 500GB SSD (P3D only)

 

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Hello Swiss. Welcome to the Forums.   You have probably tried this but just in case, have you tried deleting your Prepar3D.cfg and see if that helps.    

 

Follow this link.  Scroll down to   (6)  Where is my Prepar3D.cfg located   Right Click and Delete Prepar3D.cfg    When you start Prepar3D again it will rebuild itself 

 

http://www.avsim.com/topic/481623-my-link-thread/

Share this post


Link to post

Hello Swiss. Welcome to the Forums.   You have probably tried this but just in case, have you tried deleting your Prepar3D.cfg and see if that helps.    

 

Follow this link.  Scroll down to   (6)  Where is my Prepar3D.cfg located   Right Click and Delete Prepar3D.cfg    When you start Prepar3D again it will rebuild itself 

 

http://www.avsim.com/topic/481623-my-link-thread/

First Thank you very much for your quick answer.

Unfortunately I already tried deleting the prepar3d.cfg file but it didn't work :(

 

swissa340

Share this post


Link to post

Try deleting these files and letting P3D rebuild them -

Prepar3D_Default.fxml & Prepar3D_Default.wx located in %LOCALAPPDATA%\Lockheed Martin\Prepar3D v3

Prepar3D.cfg located in %APPDATA%\Lockheed Martin\Prepar3D v3

 

Vic

  • Upvote 2

Share this post


Link to post

Oh very good Vic,   i will be adding that to my knowledge base 

Share this post


Link to post

Sometimes the default flight file gets corrupt and crashes on startup Elaine. If this is the case for the OP, rebuilding the file will help. f not, no harm done.

 

 

Vic

Share this post


Link to post

Prepar 3D stopped working

 

Do you get a pop up on its own or does it seem frozen and not loading?

 

Are you starting a flight from where Night Environment is installed? There is an issue with P3D V3.1 and NE. You need to start from an area outside NE and then  fly into the zone where NE is installed.. if you start from an Airport withing the NE area, it would take a long time to load.. yes it would load eventually but it takes a long time you may think P3D is frozen... 

 

Chris from NE is working with LM (its a LM issue with the 3.1 update)

 

IF its not that, then yeah..try what others are suggesting 

Share this post


Link to post

Have you just started using the Estonia Migration Tool by any chance?

Share this post


Link to post

Try deleting these files and letting P3D rebuild them -

 

Prepar3D_Default.fxml & Prepar3D_Default.wx located in %LOCALAPPDATA%\Lockheed Martin\Prepar3D v3

Prepar3D.cfg located in %APPDATA%\Lockheed Martin\Prepar3D v3

 

Vic

 

Thank you but I think I found the issue. Today I bought Aerosoft's Rome and installed it. That was the moment when P3D didn't start anymore. I uninstalled Rome but it still crashes.

Do you get a pop up on its own or does it seem frozen and not loading?

 

Are you starting a flight from where Night Environment is installed? There is an issue with P3D V3.1 and NE. You need to start from an area outside NE and then  fly into the zone where NE is installed.. if you start from an Airport withing the NE area, it would take a long time to load.. yes it would load eventually but it takes a long time you may think P3D is frozen... 

 

Chris from NE is working with LM (its a LM issue with the 3.1 update)

 

IF its not that, then yeah..try what others are suggesting 

I don't even get to the scenario page. I crashes on the strtup screen, where the P3D logo is.

I don't use Night Environment, I just use the ORBX night lighting. (from FTX global)

 

Have you just started using the Estonia Migration Tool by any chance?

I have had the Migration Tool since I switched from FSX to P3D v2.5, and then v3. I had no issues with this tool.

Had the same issue before Xmas (solved).

 

http://www.avsim.com/topic/480273-weird-p3dexe-has-stopping-working-with-win10/?hl=%2Bstopped#entry3343472

 

Don't know if it may help. Cheers,

Thank you, but it didn't help. I think Aerosoft Rome makes P3D to crash. I unistalled it now but it still cashes.

Share this post


Link to post

Try to delete the scenery.cfg in C:\ProgramData\Lockheed Martin\Prepar3D v3. I had a issue like that and I solve this way.

Share this post


Link to post

Try to delete the scenery.cfg in C:\ProgramData\Lockheed Martin\Prepar3D v3. I had a issue like that and I solve this way.

Ok, I will try. Thank you

Try to delete the scenery.cfg in C:\ProgramData\Lockheed Martin\Prepar3D v3. I had a issue like that and I solve this way.

No, did not work. It still says: Prepar 3D stopped working

Share this post


Link to post

Ok, I will try. Thank you

No, did not work. It still says: Prepar 3D stopped working

 

Look in View Event log from windows for you see the crash in p3d.

Share this post


Link to post
Faulting application name: Prepar3D.exe, version: 3.1.2.15831, time stamp: 0x5672b60a

Faulting module name: VMCX_AP.dll, version: 10.0.0.14, time stamp: 0x4ab4b581

Exception code: 0xc0000409

Fault offset: 0x00003c5a

Faulting process id: 0x1054

Faulting application start time: 0x01d150a737f3fb99

Faulting application path: Z:\P3D V3.1\Prepar3D.exe

Faulting module path: Z:\P3D V3.1\VistaMare\bin\VMCX_AP.dll

Report Id: ee3b0384-e7e0-4b58-b19a-a3b7fa48aa6e

Faulting package full name: 

Faulting package-relative application ID: 

 

This is from my Event Viewer, if it helps.

Share this post


Link to post

 

Faulting application name: Prepar3D.exe, version: 3.1.2.15831, time stamp: 0x5672b60a
Faulting module name: VMCX_AP.dll, version: 10.0.0.14, time stamp: 0x4ab4b581
Exception code: 0xc0000409
Fault offset: 0x00003c5a
Faulting process id: 0x1054
Faulting application start time: 0x01d150a737f3fb99
Faulting application path: Z:\P3D V3.1\Prepar3D.exe
Faulting module path: Z:\P3D V3.1\VistaMare\bin\VMCX_AP.dll
Report Id: ee3b0384-e7e0-4b58-b19a-a3b7fa48aa6e
Faulting package full name: 
Faulting package-relative application ID: 
 
This is from my Event Viewer, if it helps.

 

 

I think could you help:

 

http://www.avsim.com/topic/405316-ctd-fault-module-namevmcx-apdll-unloaded/

 

Same issue but in FSX.

Share this post


Link to post

Hi

 

I solved the problem  :lol: . I simply deleted the VMCX_AP.dll file. The file is located in the P3D folder/Vistamare/bin/ VMCX_AP.dll

 

Thank you all for your support.

 

Good night and have a nice weekend.

 

swissa340

Share this post


Link to post

could it have been installed with Aerosoft Rome??

glad you have solved it anyway.i know how frustrating these sort of things can be.

 

  steve :smile:

Share this post


Link to post

Sometimes the default flight file gets corrupt and crashes on startup Elaine. If this is the case for the OP, rebuilding the file will help. f not, no harm done.

 

 

Vic

 

Very good,  i never thought of that,  its good to know 

Share this post


Link to post

could it have been installed with Aerosoft Rome??

glad you have solved it anyway.i know how frustrating these sort of things can be.

 

  steve :smile:

Yes it was installed with the MA Rome. I installed it again and deleted the .dll file and it works flawless now.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this