Sign in to follow this  
chrisal

Windows 10 Anniversary Update broke P3D

Recommended Posts

I couldn't work out what was happening. After this "automatic" update yesterday P3D froze on the splash screen with no further activity - disc or cpu. I tried everything I could think of - rebootng, turning off Defender, running as admin (which I do anyway), re-installing v3.4 client, googling the problem - you name it, I tried it. Again and again.

So in desperation I uninstalled the Windows update.

Problem solved - for now. It's working as before.

 

Has anyone else had this problem?

 

Cheers

Chris

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Haven't done the update yet, but in such a case, when P3D does not want to start up properly anymore, usually deleting the prepar3d.cfg fixes most of the issues.

Share this post


Link to post
Share on other sites

I updated some time ago with no issues fortunately. I'm sorry but I don't have any suggestions really, apart from, are all your drivers up to date?


 


So far Win10 has been very kind and given me no major cause for concern, but I know not everyone has been so lucky.


Share this post


Link to post
Share on other sites

Updated last week to win10 UA:

 

I only had a frightening "P3D client: This app is no longer available"  notification on first 2-3 reboots, but nevertheless everything was working normally.

Let's see what happens when I'll update to 3.4 (still on 3.3 here).

 

Cheers,

Share this post


Link to post
Share on other sites

I see a few windows update posts but mostly quiet on this subject.  My own update finally happened two days ago without incident, other than the annoyance of Microsoft not having the manners to tell me an update was going to take 10 min..., I could have taken care of it at a different time given the opportunity.... Oh Wait!! I am sorry, we are talking about Microsoft here, I forgot. The software giant that wants you to use your high performance workstation like a cell phone LOL, or the big company that is too big to give any consideration at all to it's customers because we have enormous barriers to leaving.

Share this post


Link to post
Share on other sites

My windows got updated by accident but guess what P3D works fine on my end.  Zero breakage, You need to install all the drivers, I was having some USB drivers and native windows driver didn't cut it

Share this post


Link to post
Share on other sites

You still can set Win10 not to automatically update, having said that running several weeks on the anniversary update and all is fine :-)

Share this post


Link to post
Share on other sites

On P3D 3.3.5 and a recent Anniversary update and everything is A.O K...except I lost Kaspersky anti virus! P3D is working perfectly!!

Share this post


Link to post
Share on other sites

Only issue I had was with USB drivers, like alot of people.

 

Now when p3d is running if I plug or unplug any USB devices. My headset or my phone to charge it, for example then p3d will ctd never did that before the w10 update.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this