Sign in to follow this  
twiggys

pb9 is out

Recommended Posts

Go get it; see release notes.

 

Ben:

"Clouds: I am still fighting with cloud performance, so this work is not in a public beta yet, because it’s not quite ready for prime-time".

 

Interesting!!!!

 

http://developer.x-plane.com

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

It sounds like Alaska and other northern areas (Norway?) won't be available until the final release. You should be able to just use the installer to load them at that point.

 

Note: There is HDv3 terrain mesh available for those areas in higher resolution than you'll get in the final XP11 release, although not quite as recent OSM data. Check out the map here:

http://www.alpilotx.net/downloads/x-plane-10-hd-mesh-scenery-v3/

 

You can install that right now if you want those areas. That's what I've done with Alaska. You might get a notice that X-Plane can't find terrain, but when that popup menu goes away, the HD mesh loads just fine.

  • Upvote 2

Share this post


Link to post
Share on other sites

Thanks for the info!  :smile:

PB9 seems to be stable and i did notice good and stable performance.

Share this post


Link to post
Share on other sites

No real difference, performance wise, for me and I guess that's good. I did have a strange bug on my very first start after install where the mouse cursor wasn't changing over click spots, but on subsequent restarts I could not reproduce.

 

For some reason the 'standard' XP shimmering seems a bit worse? Might just be me tonight however.

 

I sure do wish they'd get around to fixing that awful ground texture shaking though. The airport I picked to fly from tonight was a Gateway airport (CYQD) that I'm just putting the finishing touches on, and the default concrete apron texture was shaking so hard I could barely look at it.  There are times when I'm not sure how these things go unaddressed for so long.

 

The one thing I've noticed (and this was present in PB8 but I didn't have a chance to seriously look at it) is that I get a *very* bad stutter when my framerate is floating in the 40's with Vsync on. It happen when the load is too much for VSync to keep 60fps, but not so much that it's getting bumped down to 30fps. My solution thus far has been to ensure that there's enough of a load to make sure VSync is bumping the framerate down to 30fps. Which gets hard out in the middle of nowhere.

Share this post


Link to post
Share on other sites

My first flight...am amazed...in the stock Baron 58

 

First off...I am in a flight through heavy scud, and just broke out above it...in the Great Lakes area...and am popping 43 FPS!

 

I have never achieved that rate, from the day that I have run with v10 (whatever).  For the v11.x beta runs, (and with the sim, as I like it, maxed out on the sliders...) my mean average has always been (with a better beta version than others...) around 27-33 FPS, and that was max...that 33.

 

Same area...over Detroit, flight path down from KFNT (Bishop-Flint), with some pretty heavy cloud formations, and am getting as stated, 43 FPS!

 

No crashes, first time running B9.  Things are starting to solidify, towards possibly an RTM?  Who knows...but don't hesitate to update to B9, from B8 or earlier.  

 

Back to the flight...

Share this post


Link to post
Share on other sites

I did notice one thing that PB9 seems to show much reduced GPU time.

 

Say on default KSEA with max settings (relection=LOW), both PB8 and PB9 gave similar 30fps. In PB8, CPU and GPU always show exactly same time fraction like 0.033. In PB9 the CPU time is 0.033 but GPU time is much reduced to like 0.020. 

 

Does this mean that PB9 somehow greatly improved the GPU efficiency? If so unfortunately that didn't translate into higher FPS for me probably b/c things remain CPU-limited. 

Share this post


Link to post
Share on other sites

Just had a great B9 flight.

 

Flew the Baron 58, on a flight plan, between KFNT and KMYR.  MPHgs kept to 239 for the flight at cruise. 160 knots indicated.

 

Just landed, and shut XP11 down.

 

Flew at 9,000 just above heavy overcast for the most part to the numbers at Myrtle Beach, South Carolina, with xEnviro.   Worked flawlessly, xEnviro, XP11 B9 itself, and had the best XP FPS performance, EVER!

 

Lows of 29, to highs of 43-44 FPS for the entire trip, with heavy input from xEnviro 1.06.

 

Very satisfied to see where XP11 is heading, on its way to R.C. and finally----->RTM.

 

Happy B9 camper...

Share this post


Link to post
Share on other sites

Finally some love to AMD cards. Improved my performance by more than 50% on average on my R9 390. Sitting at the runway at ESMS with the default C172, clear weather, 13:00 in the beginning of January now gives about 35 FPS instead of 22 FPS as I had in previous betas.

 

Edit: Most things at high, textures max, reflections minimal, no ground shadows. Taking a huge FPS hit (roughly 30-50%) if I increase reflections to low, a bit unexpected considering I have a 4960X @ 4.3 GHz.

Edited by sweoggy

Share this post


Link to post
Share on other sites

PB9 seems to be running much better on my test rig: i5-2500K @ 3.4GHz / 16GB/AMD Radeon HD 5700/1024MB with rendering options set to medium or high, running stock scenery with only xenviro as addon.

 

With PB8 I was getting FPS anywhere from 16 to around 22; FPS are now 26 to 34 on the ground, 32 to 38 while air borne with XE doing it's wonders.

 

The AMD performance improvement works.

Share this post


Link to post
Share on other sites

I had to delete the preferences folder again like with the previous release as it kept crashing on loading. All seems fine now though.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this