Dane Watson

FSX Problem When Minimized

Recommended Posts

I have noticed sometimes when I minimize FSX to the taskbar and then go back to the taskbar to reopen it FSX refuses to open, I then have no choice but to force a close.

I read somewhere that this is a known problem with Win. 7 and 10.
Does anyone have any fixes for this?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I have this problem to but after enough clicks on the taskbar's FSX icon as on the screen it reopens again. I use opusFSI for the weather and the latest version4 opens a little window sometimes causing FSX to minimize, I have W7 and didn't find a solution nowhere yet, it has to do with the focus being drawn away from a window to another and it looks like W7 can't multitask. I asked the dev from Opus to change the window back to in game to get rid of the problem, he promised me an update this week.

Herman

Share this post


Link to post
Share on other sites

I have the issue occasionally and found, at least for me, the best solution was to open Process Explorer, right click on  FSX, select 'Window' then 'maximize'.

Ernie

 

 

Share this post


Link to post
Share on other sites

HI Dane,   I am not at home at the moment,  but I think its something like Press CTRL & ENTER together, or SHIFT & ENTER    that normally sorts for me. (Or clicking on it in the task window about 10 times!)

If that's not the solution let me know, I have it written down somewhere at home.  Might even be CTRL ALT and ENTER  or CTRL SHIFT ENTER,  I am almost certain ENTER is one of the Keys !

 

Cheers

 

Share this post


Link to post
Share on other sites
12 hours ago, Bozdog said:

HI Dane,   I am not at home at the moment,  but I think its something like Press CTRL & ENTER together, or SHIFT & ENTER    that normally sorts for me. (Or clicking on it in the task window about 10 times!)

If that's not the solution let me know, I have it written down somewhere at home.  Might even be CTRL ALT and ENTER  or CTRL SHIFT ENTER,  I am almost certain ENTER is one of the Keys !

 

Cheers

 

Thanks Bozdog, whenever it happens again I will try out your suggestions - but it doesn't  happen that often, just that when it does happen it is really annoying.

Share this post


Link to post
Share on other sites
14 hours ago, airernie said:

I have the issue occasionally and found, at least for me, the best solution was to open Process Explorer, right click on  FSX, select 'Window' then 'maximize'.

Ernie

 

 

Thanks Ernie, I'll check that out.

Share this post


Link to post
Share on other sites
16 hours ago, airernie said:

I have the issue occasionally and found, at least for me, the best solution was to open Process Explorer, right click on  FSX, select 'Window' then 'maximize'.

Ernie

 

 

It just now happened - I was prepared with Process Explorer. Did what you suggested and yes, it worked.

But the question is why does this happen?

Share this post


Link to post
Share on other sites

Can you please post your system specs?

You didn't mention it, but are you running in the Full Screen or Windowed Mode?  I remember this issue with Windows 7 in Full Screen, but I've never seen it using the Windowed Mode under Windows 7 and Windows 10.  Due to working development and Beta Testing many products, I averaged 4 to 8 full flights (2 or 3 hours) per week for about 12 years and as I said I've never seen this in Windowed Mode.

Running FSX in the Windowed Mode is highly recommended, and there is a tweak to get rid of most if not all of the surrounding border.

If you're having this in the Windowed Mode, here are a few things to try:

- Update your graphics drivers.

- Ensure you're running FSX "As Admin".

- Ensure you have the HIGHMEMFIX=1 in your FSX.CFG file.

- Chage your Sound LOD to 1 in your FSX.CFG.

- Monitor you Frame Rate just before minimizing and see if it's in the single digits. If so, you probably need to groom your system/simulator and/or reduce graphic settings.

- You might also try using Alt-Enter to see if that works for you.

 

Share this post


Link to post
Share on other sites

Dane, I too had this problem - using fullscreen mode with Windows 10 (and 7 prior to that) -, but found that Alt+Ent, eventually having to repeat it, would do the job each time rather than using the "Maximise" command which would never work.

Now Dave, you raised an interesting point given your IT background, without hijacking Dane's topic, could you shed some light on the benefits of using Windowed mode, I read several threads here and elsewhere regarding this and realised that opinions were about 50/50, no clear advantage (I for one could not see any but I am no IT guru...)

Many thanks and good luck Dane.

Share this post


Link to post
Share on other sites

It always happens in full screen mode, windowed mode is difficult to apply since Vsync doesn't work anymore then. I have a 60hz refresh rate on my monitor and use 1/2 vsync in NVidia inspector and therefore limit frames to 30 in FSX, that would be all for nothing then?

Herman

Share this post


Link to post
Share on other sites

When in fullscreen (Exclusive Mode) another app disturbing the windows z order can leave FSX missing from the desktop as it is hidden in fullscreen mode. Pressing ALT+ENTER is the switch between fullscreen and windowed mode. Pressing the combination twice (or thrice) is the operating system way of "measuring the available fullscreen space" and should bring back the missing FSX window as it goes through windowed mode and back.

Share this post


Link to post
Share on other sites
7 hours ago, DaveCT2003 said:

but I've never seen it using the Windowed Mode under Windows 7 and Windows 10. 

Windowed is all I ever use and it probably happens every couple of weeks or so.

Fortunately in my case it usually happens during the loading sequence, so it doesn't interrupt my flight.

Share this post


Link to post
Share on other sites

That seems more like the window cords off screen which can also happen again from another app altering the z order. The ALT+ENTER combination pressed twice should always bring it back.

Share this post


Link to post
Share on other sites

Thanks Steve,

I'll give the key sequence a try the next time it happens.

Ernie

Share this post


Link to post
Share on other sites
15 hours ago, airernie said:

Windowed is all I ever use and it probably happens every couple of weeks or so.

Fortunately in my case it usually happens during the loading sequence, so it doesn't interrupt my flight.

Ernie, that's when it happens to me as well - just as the loading process is completing

Share this post


Link to post
Share on other sites
23 hours ago, DaveCT2003 said:

Can you please post your system specs?

You didn't mention it, but are you running in the Full Screen or Windowed Mode?  I remember this issue with Windows 7 in Full Screen, but I've never seen it using the Windowed Mode under Windows 7 and Windows 10.  Due to working development and Beta Testing many products, I averaged 4 to 8 full flights (2 or 3 hours) per week for about 12 years and as I said I've never seen this in Windowed Mode.

Running FSX in the Windowed Mode is highly recommended, and there is a tweak to get rid of most if not all of the surrounding border.

If you're having this in the Windowed Mode, here are a few things to try: - WINDOWED MODE

- Update your graphics drivers.- LATEST NVIDIA DRIVERS

- Ensure you're running FSX "As Admin". ALWAYS RUN IN ADMIN MODE

- Ensure you have the HIGHMEMFIX=1 in your FSX.CFG file. YES TO HIGHMEMFIX=1

- Chage your Sound LOD to 1 in your FSX.CFG. SOUND_LOD=1 ALREADY IN PLACE

- Monitor you Frame Rate just before minimizing and see if it's in the single digits. If so, you probably need to groom your system/simulator and/or reduce graphic settings. MY FPS IS ALWAYS BETWEEN 30 AND OVER 100 DEPENDING ON THE AIRPORT SCENERY

- You might also try using Alt-Enter to see if that works for you.

 

Thanks Dave for your reply.

See above (your post) for my responses to your questions/suggestions. Also, by the way as Ernie mentioned in a recent post, it only seems to happen just as the Fly Now is loading the flight.

Yes, I should have posted my specs:

MSI GP62 6QF, Windows 10, 64bit, i7 6700HQ (8 CPU's), 16GB Ram, Nvidia GTX960M.

 

Share this post


Link to post
Share on other sites

Ah, I see you're running on a laptop (4 core).  Your running on the laptop with an integrated graphics card is likely the reason you're suffering this problem.  FSX/P3D are notorious for not running well on laptops unless it's a rig that has an actual graphics card rather than an integrated card (chip).  As I mentioned before, I've never seen this issue reported in Windows mode (on desktops systems).

I recommend you try using "Pause on Task" switch setting or otherwise pausing your flight before minimizing your screen in order to reduce the re-rendering that is done when you maximize the display.  If that doesn't work or is not something you're keen on doing then you might try reducing your graphics settings to see if that helps.  Probably what is needed is a second monitor so that you don't have to minimize your display.

Thinking on this, you might also try disabling Hyperthreading and running on your 4 physical cores.  This may help more than the advice I've given above!

My very best wishes.

 

 

 

 

Share this post


Link to post
Share on other sites
On 4/3/2017 at 11:59 PM, Jean-Claude said:

Dane, I too had this problem - using fullscreen mode with Windows 10 (and 7 prior to that) -, but found that Alt+Ent, eventually having to repeat it, would do the job each time rather than using the "Maximise" command which would never work.

Now Dave, you raised an interesting point given your IT background, without hijacking Dane's topic, could you shed some light on the benefits of using Windowed mode, I read several threads here and elsewhere regarding this and realised that opinions were about 50/50, no clear advantage (I for one could not see any but I am no IT guru...)

Many thanks and good luck Dane.

 

I'd have been happy to, but Steve got to it first and did a great job (he's likely better qualified that I am in this area).

 

Share this post


Link to post
Share on other sites
On 4/3/2017 at 7:08 AM, airernie said:

 the best solution was to open Process Explorer, right click on  FSX, select 'Window' then 'maximize'.

 

 

 

I'm all of a sudden having this issue where FSX loads Minimized 90% of the time, rather annoying.

The above solution works but has ANYONE ever been able to track down why this happens?

I recently installed GSX and wonder if it has something to do with that?

Share this post


Link to post
Share on other sites

It can also be caused by FSX failing to close fully and that can leave certain settings broken. Do the ALT+ENTER routine and also check addons and dlls for proper operation when exiting the sim.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now