gasher9999

Middle Mouse Button not working.

Recommended Posts

After V0.2.23 update MMB does not work. When pressed the camera slews sideways and upside down. No UI visible either. MB View Selector works if it is selected by itself. MB Zoom works by itself. MB Pan and Tilt is the problem.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

hmm. oh noes.. non-experimental version has the issue too

i'm showing version 2.24 ..  this must have been a recent change, i was using cp last night without troubles. ah well good luck to the bug fixes

cheers,-andy crosby

Share this post


Link to post
Share on other sites

I've been having problems with the last few version & the latest alpha ver 2.24 seems to be worse for me.

I can get the MMB pan only to work in windowed mode but not in full screen at all. Also the hold MMB to get the CP view menu isn't working at all & click the MMB place the camera looking straight down in the Captain's seat.

I'm thinking of disabling the experimental version or maybe reinstalling CP to see if that helps at all. Any idea's guys?

 

Steven

Share this post


Link to post
Share on other sites

Yup, same here. Especially if you put your mouse over a button on the aircraft and press the middle mouse, it will view down right away, every single time.
Hoang Le

  • Upvote 2

Share this post


Link to post
Share on other sites

Trying to figure that one out, sorry for the inconvenience, as always.

Do you guys have multiple monitors? If so, how are they positioned?

Regards,
Keven

Share this post


Link to post
Share on other sites

Single monitor, 4k. Same issue as all of the above. Thanks for helping quickly :).

Share this post


Link to post
Share on other sites

Single 27'' monitor, fullHD, this annoying bug is back again and even worse after it was sorted out in the latest releases.

CHPL now is nearly unserviceable with the MMB, no matter if you set to windowed or full window mode.

In any case thanks again for your prompt commitment Keven.

Share this post


Link to post
Share on other sites

After the last update, when I press the mouse middle button the view goes sideway also on my side, usually I use the middle mouse button for the Pan&Tilt, now is really annoying because I want to pan and it goes easily sideways first, only if I manage to keep it longer pressed and move the mouse works.

If I press it several times, it makes circling of the view around a fixed point.

The problem is with the short press of the button.

Hopefully it can be fixed cause is very annoying.

Share this post


Link to post
Share on other sites

I have the same issue.

I use 3 monitors, but P3D is only running on the middle one.

Share this post


Link to post
Share on other sites

Also here problems with the new mouse detection system (from v0.2.24), using two monitors, but P3D window only on one. Also Mouse Look (Hold), which I have assigned to space, does not work anymore as it should, as it locks in and even when space is released.

No issues before the last update (last flight was on Friday).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now